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1 Welcome to MAESTRO 11.0.0

Welcome to MAESTRO 11.0.0, a comprehensive program that
leverages the power of Finite Element Analysis and Structural
Evaluation for the naval architect.

MAESTRO is a finite element tool providing powerful structural design and analysis
capabilities for naval architects.

A robust application, backed up by first class support.

MAESTRO has been designed and created by a group of naval architects that care
about your experience with the software.  Simply put, we feel successful when our
software can leverage your design talents to create better vessels. If you have
questions that can't be answered through this Help File or the forum, feel free to contact
us at support@maestromarine.com. We enjoy hearing about your projects, your
application of MAESTRO, and your challenges, and will do our best to help.

http://orca3d.com/forum/index.php?PHPSESSID=mp2cmfsm18hmn53l7a2a90ult5&board=15.0
mailto:support@maestromarine.com
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2 Latest Updates

Updates and changes to MAESTRO will be described here, listed by release number. You
can also read the Release Notes, which are included as part of the installation, to see a
complete history of the releases and changes to MAESTRO.

2.1 Version 11.0.0

MAESTRO Release Notes
MAESTRO is a finite element analysis program for rationally-based analysis, evaluation, and
structural optimization of ships, offshore structures, and other large complex thin-walled
structures.

MAESTRO Requirements

· Operating Systems tested: 32-bit Windows XP and Vista, 32-bit and 64-bit
Windows 7

· Operating Systems not supported: Windows ME, 98, 95, NT 

· Mac: The Intel Mac with Bootcamp or Parallels has not been tested 

· Microsoft .NET Framework 3.5, SP1.

· Valid license (without this, MAESTRO will operate in the demonstration mode)

· Installation of Sentinel System Driver and Sentinel Protection Server 7.6.6.
(Automatically installed with MAESTRO).

Version 11.0

New and Enhanced Modules
The following is a list of the new and enhanced modules found in MAESTRO v11.0.  A copy
of this list of features can be found in the Release Notes.

· New Ultimate Limit State (ULS) Heuristic-based Optimization Module: A new
optimization method which uses a variety of heuristic-based optimization methods
(i.e., Simulated Annealing, Genetic Algorithms) and MAESTRO’s ULS evaluation
paradigm has been added to the existing Optimization module.  

· MAESTRO-Wave:  A new time-domain MAESTRO-Wave module has been added.
In addition, new wet panel discretization options have been added for the frequency
and time domain MAESTRO-Wave calculations including: 2D strip theory using the
free surface Green’s Function, a high-speed 2.5D Rankine Source Method with
forward speed correction, and the Universal RAO method.  A new option to speed up
computation time has been added to allow MAESTRO to calculate the velocity
potential (thus radiation and diffraction pressure) as a constant value for all elements
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within the hydrodynamic panel instead of the standard method which calculates them
on each FE element individually.

New and Enhanced Features
The following is a list of the new and enhanced features found in MAESTRO v11.0.  A copy
of this list of features can be found in the Release Notes.

· Design Wave Creation: The design wave dialog now allows the user to use a
custom sea spectrum definition and also select which wave frequencies to use in
determining the extreme design wave.  

· Operating Profiles and Wave Spectra: A number of pre-defined operating profiles
and wave spectra are now available with the MAESTRO distribution.

· Mean and Extreme Stress Calculations: A new capability has been added to
compute mean stress and extreme stress from a computed RAO database.

· RAO and Response Spectrum Calculations: MAESTRO can now calculate motion
and stress RAOs at specific locations/elements.

· Inertia Relief Restraint Method: A new automatic restraint method has been added
in which the user does not have to apply traditional restraints to the model.  Instead,
MAESTRO automatically creates a fixed node at the model center of gravity which is
attached to surrounding structure using soft spring elements.  Inertia relief is required
to be run prior to solving the model.

· ABS High Speed Naval Craft Rules Added: The stress and buckling checks from
the ABS High Speed Naval Craft (ABS HSNC) guide have been added to MAESTRO
’s limit state framework.

· Import Mass Distribution from MAESTRO .wet File: A MAESTRO .wet file can be
re-imported into MAESTRO and used for a mass distribution.  This allows a user to
import a hydrodynamic mesh and full FE model mass distribution to run
MAESTRO-Wave for motion and hull girder load RAOs.

· Hide Elements: A new command has been added under the View menu that allows
a user to hide elements using a variety of selection options.

· Group Operations and Group Manager: Two new dialogs have been added
allowing the user to more easily manipulate existing groups or create new ones.  The
Group Operations allows a user to create new groups by copying, adding,
subtracting, or finding common elements between one or more existing groups.  The
Group Manager allows a user to move one or more groups into a new category or
subfolder within the groups tree.

· Bending Moment without Axial Force Contribution: MAESTRO can now plot the
longitudinal bending moment without axial force contributions which makes it easier
to compare results to other tools that do not account for the axial force (e.g., section
based calculations).

· Merge Hydrodynamic Panel: An option has been added to automatically merge
evaluation panels into large panels to be used in hydrodynamic (MAESTRO-Wave)
calculations.

· Map Hydrodynamic Patch:  Allows the user to run MAESTRO-Wave with a custom
hydrodynamic mesh of a structural model and map the source strengths from the
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hydrodynamic mesh to the structural model.

· Level 1 Evaluation Patch Search:  A new evaluation patch search method has
been added allowing the user to define the beam elements representing the patch
boundary supports.  The patch search/creation can now be performed on the current
view part, in addition to the entire model.  Also, the patch search functionality has
been optimized to reduce computation time.

· Negative Adequacy Parameter Reporting: A new feature has been added to report
the number of elements and corresponding structural weight of failing structure.  All
negative adequacy parameters, including minimum adequacy parameter, are now
reported from the list elements command. 

· Weight Distribution Load Pattern: The weight distribution algorithm has been
improved to be more efficient.

· Tank Load Reader: A new import option allows the user to import a text file of tank
loads to create one or more new load case definitions.  Sample sources of this data
include weight reports, spreadsheets, or a GHS tank load export script.

· Polygon Mesh File Format Extended: The polygon mesh file format has been
extended to allow users to also import endpoint and strake definitions.

· Beam Shapes Added: The following beam shapes have been added: tube, box, and
I.

· Group Selection Options:  A variety of group selection options have been added
including selecting by evaluation patches and adding by seed, attached properties,
and attached beams.

· Nastran Import Additions:  MAESTRO now imports concentrated masses and
forces from NASTRAN models as well as preserves property names created in
FEMAP.  FEMAP Neutral (.neu) files can also be imported which preserve FEMAP
group information.

· MAESTRO-Wave Liquid Tank Loads: New options have been added to the
MAESTRO-Wave module to account for tank sloshing loads.

· Directional Spring and GAP Element Added:  The existing spring element has
been expanded to include directional springs and GAP elements.

· Copy Elements:  A new feature has been added to quickly create one or more new
elements in a selected direction by copying existing elements in the model.

· Split Strake: A new refinement option has been added allowing the user to “split” a
strake into multiple strakes so that all stiffeners are now defined as girders.

· ALPS/HULL Report:  A new option has been added to the ALPS/HULL results menu
allowing the user to create a report of the ALPS/HULL results.

· Multiple ALPS/HULL Results:  The ability to run and store ALPS/HULL results for
more than one ALPS/HULL model has been added.

· Design Pressure:  The design pressure option has been added back to the
evaluation patch dialog allowing a user to specify an additional design pressure to be
used for adequacy parameter calculations.

· SN Curve Added:  The Eurocode 9 SN curve for aluminum has been added for
spectral fatigue calculations.
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· Mass Distribution CG Calculator: A new feature has been added to calculate a
mass distribution’s VCG and TCG in order to reach a target VCG and TCG for the
full load case.

Bug Fixes:

· Element Directional Display: This was feature was not working correctly in version
10.

· Boundary Modules: Bending moment and shear force loads for boundary modules
were previously being applied as full value for a half model.  Half models now use the
half load value.

· 64-bit Cutting Plane Selection: A bug with selecting cutting planes in the 64-bit
version has been resolved.

· Inertia Relief All Load Cases: A bug was fixed that reset the static waterplane to
the first load case when running inertia relief balance for all load cases.

Version 10.0.5

· SFA Analysis with Top-Down Model:  The spectral fatigue analysis can now be run with

top-down fine mesh models.

· Operating Profile Enhancement: The operating profile used with the ELA and SFA

modules can now have unequal probabilities.

· S-N Curve Parameters Now Visible:  The user is now able to view the parameters for

the available S-N curves in MAESTRO.

· Bug Fix:  MAESTRO now allows multiple SFA groups to be created.

Version 10.0

New and Enhanced Features:

· MAESTRO-Wave:  New module which provides the ship designer with an integrated
frequency-domain computational tool to predict the motions and wave loads of any
vessel.  To compute these hydrodynamic motions and loads, MAESTRO-Wave first
calculates the velocity potentials, source strengths, and flow velocities at the
centroids of the hydrodynamic panels for each speed, heading, and frequency
requested, and then maps the source strength to the structural panels. The
equations of motion are formulated using the structural mesh rather than the
hydrodynamic mesh. This approach results in a perfect equilibrium for the structural
model. Bending moments, shear forces and torsional moments are automatically in
closure. No inertia relief and artificial loads are needed to balance the model. The
computation of these hydrodynamic forces is based on 3D potential theory using the
zero speed Green’s function with a speed correction parameter.  A variety of
visualizations and output data are available for purposes of post-processing.
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· Extreme Load Analysis (ELA):  New module which imports unit wave load data
from a hydrodynamic analysis (MAESTRO-Wave or other) via *.smn file format. It
then allows the user to calculate hull girder load response RAOs, and provides the
necessary short-term and long-term statistical computations to predict extreme
values of the maximum loads for a given vessel.

· Spectral Fatigue Analysis (SFA):  New module which provides the ability to perform
global fatigue screening of the vessel.  The SFA module introduces additional
functionality to the ELA module to compute Stress RAOs, displacement RAOs,
define and associate structural groups to SN curves and Stress Concentration
Factors (SCFs), and compute fatigue damage based on the Miner cumulative
damage principle.

· MAESTRO/NAPA Steel Interface:  New module which allows the designer to import
a NAPA/NAPA Steel 3D model, which includes the finite element model (geometry,
scantling properties, and finite elements), loading information (longitudinal weight
and bending moment distributions, tank boundary/content/fill definitions, and
hydrostatic equilibrium definition), and model hierarchy definitions such as
MAESTRO module group.  This interface enables shorter design cycle times by
using a single 3D structural design model (from NAPA) that can be re-used as the
design matures and is ready for analysis in a matter of minutes.

· VERES Export:  Allows user to export MAESTRO model information to *.MGF,
*.M3D, and *.M2D files to support VERES analyses.

· PRECAL Export:  Allows user to export MAESTRO model information to *.HUL,
*.HIN, and *.CND files to support PRECAL analyses.

· 64-bit Version:  Now available in a 64-bit version.

· ALPS/ULSAP Update:  This module has been updated to version 2011.2.

· Results View Updates:  When user-defined range is set, elements below that range
are set to blue and elements above that range are set to red.

· Expanded Group Organization Feature: Allows subfolders to be created
underneath the default group types in the groups tree.  

· Drag and Drop Group Creation: Groups may now be dragged and dropped from
one type to another to automatically extract certain elements from an existing group. 
For example, nodal groups can be created from plate or general group and shell
elements may be recovered from node groups or a general group.

· New Tank Features: Allows volume groups to be defined as flooded to model
flooded or damaged conditions.  User can adjust tank permeability and apply
deballast pressure.

· Hull Girder Load Target: The hull girder load target is a new load pattern that can
be used to ensure that either a minimum shear force envelope or a minimum
bending moment envelope is met or to add an additional shear force or bending
moment on top of all other load patterns.

· Create Boundary Modules: Option to assist in applying end moments.  A master
node is automatically created and joined by RBE2 elements to all nodes at modules
ends to ensure that plane sections remain plane.  End Moment load is then applied
at this master node.

· Weight and Buoyancy Density Plot: Option to plot weight and buoyancy per unit
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length for easier comparison to other hydrostatic programs.

· Create Module from General Group: Right-click menu option to create a new
module consisting of the elements defined in the selected general group.  These
elements are removed from their original module.

· Extract Module: Option to create a new module by “extracting” elements from an
existing module by defining a bounding box.  This allows large or full ship imported
models to be easily separated into more manageable modules.

· Define General Group from List of Nodes or Elements: Select multiple
elements/nodes from the grid tab and create a general group using the right-click
menu.

· Mass Distribution Exclude Nodal Groups: The mass distribution load pattern now
allows selected nodal groups to be excluded from receiving the loading.

· Speed Enhancements: MAESTRO’s loading speed has been increased for models
with large numbers of groups defined.  The auto-creation of evaluation patches has
also been increased to handle larger and finer meshed models.

· Displacement Direction Plot Added:  Option to select single direction (i.e. X, Y, Z)
only to plot deformation.  Also added option to plot “true” scale deformation.

· Cutting Planes added to Right-Click Menu:  The same cutting planes menu that
appears in the Tools menu is now added to the menu when you right-click the mouse
in the modeling space.

Bug Fixes: A number of minor bugs have been fixed.

Version 9.1.0

New and Enhanced Features:

· User Defined Extreme Design Wave:  Capability to facilitate Extreme Load
Analysis has been added to the MAESTRO main menu.  This includes the ability
to graphically review an imported load database (via complex Ship Motion file)
and the creation of extreme design loads.

· Ship Motion File Complex Form:  The Ship Motion file has been expanded to
allow the importing of Complex displacement, acceleration, and pressure data
calculated by 3rd party seakeeping software.  This file is backward compatible
with the legacy Ship Motion file.

· Weight Distribution Load Pattern:  Added the ability generate a weight
distribution by either entering weights or weight densities at their  corresponding
longitudinal locations.  This load patter can be combined with other existing load
patterns.

· New Midship Section Design Tutorial:  This tutorial will walk through the
complete process of creating and analyzing a midship section given a basic set
of design parameters and hull geometry.

· Group Creation & Modification: 

o Added a method to facilitate the identification of wetted elements
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o Added several methods for creating General groups and Volume groups
including an automatic search algorithm

o Added methods to automatically generate consistent normals within a
group

o Ability to add elements during group creation from the groups view

· Nastran Import/Export:  The following functionality has been added to the
Nastran import/export capability:

o Significantly improved the importing speed

o Import Spherical and Cylindrical coordinate

o Import/Export PBARL/PBEAML cards

o Export "boundary only" data file (filename.nas.spcd)

o Import Nastran model as a Group

· Hull Girder Cross Section Property Calculation:  A new method for defining
cross section locations has been added.  This functionality allows you to recover
hull girder section properties outside of the traditional endpoint locations.  This
includes recovering hull girder properties from an imported Nastran finite
element model.

· Equation Solver Method:  The mechanism to choose a different Equation
Solver method (Sparse, Iterative, or Skyline) has been moved to the
File/Preferences dialog.  Previously, this mechanism was located in the
Analysis/Evaluation dialog.

· Longitudinal Effectiveness: Added the ability to assign longitudinal
effectiveness to finemesh models and General groups.

· ALPS/ULSAP:  This module has been significantly updated to the version
2010.4.  Additional reference papers have been added to the Help system as
well as updated verification models.

· ALPS/HULL:  This module has been updated to allow the user to impose
pressures (i.e., hydrostatic, volume, linpress, etc.) on the defined ALPS/HULL
analysis model.

· Simple Object Mesh Template:  Added the ability to auto-generate the
following MAESTRO models:

o Stiffened Panel with Initial Deflection

o Sphere

o Cylinder with/without rings

· Sample Models:  Security changes have been made in Windows 7.  Therefore,
if MAESTRO is installed on a Windows 7 OS, the Models and Samples directory
will be located in C:\ProgramData\MAESTRO directory.

· Ply-Polygon File Format Import:  MAESTRO now has the ability to import
ply-polygon mesh geometry files (*.ply).  This feature will create a new module of
the quad and triangle elements in the mesh, all with the same plate and material
property.
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Bug Fixes: A number of minor bugs have been fixed.

Known Issues:

· Cutting Planes: Cutting planes deleted when user chooses View/Refresh.
· Quick Create: The creation of additional nodes via Quick Create fails on the first attempt

in some cases.
· Color Legend: In some plotting scenarios, the titles and/or values are cutoff.   The user

can use the View/Options to change the font if necessary.
· Default  Material:  The default  material  property is deleted when the user  creates a new

model (via the File/New menu item) in one running instance of MAESTRO.
· View Refresh:  In  plotting  different  views,  MAESTRO will  hang  on  the  current  view.   In

most  cases  this  can  be  resolved  by  the  user  choosing  View/Element  Type  followed  by
View/Refresh.

· Cylindrical  Coordinates:  The  cylindrical  coordinates  were  intended  for  purposes  of
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inputting the data but not modifying existing Endpoints/Additional Nodes.
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Version 9.0.8

New and Enhanced Features:

· Sparse Out-Of-Core (OOC) Solver:  Added Sparse Out-Of-Core (OOC) solver  that  can
solve very large models.  The limitation of the solver is based on the computer’s hard disk
space.  Models up to 700,000 degrees of freedom have been tested.

· Inertia  Balance:  Added  automated  inertia  balancing  for  models  having  hydrostatic
loading.  Previously, automated inertia balance was only available for models not having
hydrostatic  loading.   The  details  of  the  load  balance  methodology  are  available  under
Load Balance in the Verification and Validation section of the manual.

· Longitudinal  Bending  Moments:   Axial  forces  for  longitudinal  bending  moment
calculations are now included.  Previously, the bending moment distribution was based on
the  classical  beam  theory,  where  the  contributions  from  axial  forces  were  ignored.   In
some cases, this resulted in bending moment distributions that did not close at the ends. 
This only affects the bending moment distribution plot and does not change the model’s
loads; therefore, this will not change previous model response results.  The details of the
longitudinal  bending  moment  calculations  are  available  under  Load  Balance  in  the
Verification and Validation section of the manual.

· Bending Moment/Shear Plots: Bending moment and shear force are now plotted at the
base line.  Previously, these plots were located at the waterline.

· Load Balancing Verification Documentation: An extensive explanation and verification
of the load balancing methodology is presented in the Help file.

Bug Fixes:

· Legacy Solver: Fixed a few synchronization bugs for the legacy solver.
· Load Creation: Fixed a bug related to the numbering of load cases.  If the user only had

two load cases, ID 2 and ID 3, but missing ID 1, a third load case could not be created
unless ID 3 was renumber to 1 or 4.

· Fine  Mesh  Models  and  Corrosion:  Fixed  a  bug  when  solving  un-corroded  fine  mesh
models of a corroded global model.

· ALPS/HULL: Fixed a bug that did not allow the user to execute an ALPS/HULL analysis a
second time in a given session.

· RSpline:  Fixed  an  RSpline  display  bug  that  caused  computer  crashing  when
creating/deleting RSplines

Graphical Bugs Fixed:

· Stress Reporting: A bug when reporting stress for transversely stiffened elements.

· Group View Deformation: Deformation plots when viewing groups were not correct.

· Adequacy Plots: Fixed a bug when displaying adequacy parameters of irregular
evaluation patches.
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Version 9.0.7

New and Enhanced Features:

· Layout  Organization:  Many  of  the  menu  items  and  icons  have  been  reorganized,
renamed  or  changed  to  provide  the  user  with  a  more  consistent  and  effortless
experience.   Please  see  the  documentation  for  a  complete  description  of  menus  and
icons.

· RBE3: A new element, RBE3 has been added to MAESTRO.  The intended use of the
RBE3 is to transmit forces and moments from a primary node to one or more secondary
nodes without adding any stiffness to the structure.

· Transverse Bending Moments: A newly designed Hull Menu includes options to view
transverse plots of bending moments.  This is especially useful when designing
multi-hulls.

· Transparency: This new feature allows the user to choose to set a module or
substructure as transparent for easier viewing of the model.

· Groups Creation/Operation: New functionality has been added to allow a user to create
a new group from existing groups using the Group Operation dialog.  Also, a new feature
has been added within the groups dialog to add additional elements that are similar to an
already selected element.  Combined, these features provide the user with a more robust
way to create groups.

· Wetted Group:  To assist in exporting “wetted” elements to FEMAP, new functionality in
the  Groups  menu  was  added  that  will  automatically  create  a  general  group  of  "wetted"
elements.

· Select  by  Box:  To  expedite  the  selection  of  elements,  a  select-by-box  capability  has
been added.

· Directional Stress: A new feature has been added which allows the user to align all
element local stress vectors to a global direction.  This functionality will enable the
presentation of stress in a uniform manner to the analyst can better assess the stress
patch in a given direction.

· Export Stiffness Matrix: MAESTRO can now export the stiffness matrix in Nastran
format through the export Nastran options.  This feature will allow advanced users to
process analysis runs in Nastran by using the MAESTRO generated stiffness matrix.

· Batch Execution: MAESTRO has the ability to perform batch processing, which allows
the user to sequentially solve any number of models, each of which may have any
number of load cases without having to manually launch each model.

· AutoSave: A new auto save feature has been added to MAESTRO.  The user can select
the number of executed commands in between auto saves from File > AutoSave
Frequency...

· Recover Model: A new feature has been added under File > Recover, which
automatically recovers a model after an unexpected closing of MAESTRO.

· Documentation: The documentation has been completely overhauled with a focus more
on “how to.”  Additionally, all of the documentation is now in a single location, which can
be found via the Help menu or help icon.

· Sentinel  Security  Drivers/Servers:  The  Sentinel  System  Driver  (both  for  USB)  and
Sentinel  Protection  Server  (for  Network  locks)  are  now  integrated  into  the  MAESTRO
installation  process.   Therefore,  there  is  no  need  for  the  user  to  install  security
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drivers/servers separately.  The integrated installation checks to determine the necessity
of installing the Sentinel Driver/Sentinel Protection Server.

· Help Menu: The new Help menu now includes links to the website, forum, support email,
and FAQ.

· FAQ: Updated FAQ section in the help file and on the website.
· "Null" Beam and Stiffener Properties: There are now predefined "null" beam and

stiffener layouts when creating a new model.  This eliminates the need to define these for
an unstiffened panel or unframed strake.

· Set Current & View Part: There is now an icon  and a right-click menu option in the parts
tree to set the current and view part for a module or substructure at the same time.  There
is also a new icon to set current part  and set view part .

· Background Color: The new MAESTRO default background color is light gray with
gradient north.  To change back to a black background, or another color, open the
Preferences dialog from File > Preferences.

· Capture View: A new feature has been added under the File menu which allows the user
to copy a screenshot of the modeling space to their clipboard which can then be pasted
into another program.

· Importing Legacy Results: A new mechanism has been added to facilitate the
importing, i.e. opening *.PLG files, of legacy MAESTRO results.

· Hull Menu: A newly designed Hull Menu with options to view horizontal and transverse
plots.

· Solving Fine Mesh Models: Multiple top down Fine Mesh models can be solved at once
from the File > Analysis/Evaluation menu or Analysis/Evaluation dialog.

· Groups: A new feature has been added within the groups dialog to add additional
elements that are similar to an already selected element.

· Check & Merge Dialog:  The functionality found in the Check & Merge Dialog (namely
Update: FE Tags, Free Edges and Evaluation Patches) has been moved to the Tools >
Renumber FE-Tag, View > Edges > Free Edges and Model > Evaluation Patch >
Auto-Generate menu items respectively.

· Model Summary:  Functionality used to report number of elements and nodes has been
moved to the Model > Summary menu item.

Bug Fixes:

· Update  FE  Tags:  Fixed  a  bug  so  that  FE  Tags  are  updated  when  a  module  or
substructure is moved or rotated.

· Collapsed Quad: Fixed a bug so that a quad collapsed to a triangular element correctly
distributes mass and force to the appropriate nodes.

· Sort Volume Table: Fixed a bug so the Volume Table can now be sorted by the Volume
Group Name.

· Deletions  Dialog:  Fixed  a  bug  that  would  cause  a  hard  crash  when  deleting  large
amounts of elements from the deletions dialog.

· Sort Element List by ID: Fixed a bug that allows elements to be sorted in the Grid tab
without information disappearing.

· Sort Nodes List by ID: Fixed a bug that caused a hard crash when trying to sorted listed
nodes by ID in Grid tab.

· Warped Quad: Fixed a bug to take the average face normal of the two triangles making
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up a warped quad for area, weight, volume, etc. calculations.
· Trochoidal Wave: Fixed a bug so that the trochoidal wave profile definition now uses the

formulas provided in DDS-100-6 i.2.
· Parts Tree in Parts Dialog:  Fixed  a  bug so  that  the parts  tree  within  the Modules  and

Substructures dialog is consistent with the main parts tree.
· Brackets:  Fixed  a  bug  so  that  leg  lengths  are  automatically  populated  for  the  listed

property, and are returned to the automatic lengths if “user defined” is unchecked.
· Find FE-Tag: Fixed a bug so a search can now be performed for  a  nodal  or  elemental

FE-Tag.
· Deletions Filters: Fixed a bug so that the filters in the deletions dialog work as expected.
· Saving/Loading Results: Fixed a bug so results consistently save and load with a .mdl

file.
· ULSAP Results: Fixed a bug so that ULSAP results are automatically saved and loaded

with a .mdl file.
· ULSAP Adequacy Parameters: Fixed a bug so only ULSAP Adequacy parameters  are

shown in an ULSAP analysis.

Graphical Bugs Fixed:

· "Show This Thickness Only": Fixed a bug that allows user to switch back to all
"thicknesses" using the dynamic query once the "Show this thickness only" option is
selected.

· Corner Stress: Fixed a bug so now the check box for "Corner Stress" changes the stress
contour plot between nodal and elemental contour plots.

· Compound  Element  Effectiveness:  Fixed  a  bug  so  now  non-transverse  compound
elements can be defined as longitudinally effective using the dynamic query.

· Bending  Moment  when  Switching  Load  Cases:  Fixed  a  bug  so  the  hull  bending
moment plot updates when different load cases are selected.

· Load Case Selection: Fixed a bug to  make  sure  queried loads are  consistent  with  the
load case from the load case selection drop-down menu.

· Pressure Plots when Switching Load Cases: Fixed a bug so the color plot and legend
updates each time a different load case is selected from the load case drop-down menu.

· Deformed Model Changes: Fixed a bug that prevented model from being undeformed if
structure was changed in the "deformed" mode.

· Contour Stress Plot:  Fixed a bug so that  the stress  legend updates  correctly  between
load cases when viewing a contoured stress plot.

· Hide Elements Outside Range: Fixed a bug that now has Hide Elements Outside Range
icon   functionally  properly.   This  option  will  now  hide  elements  that  are  not  within  the
range of displayed values.

· Stiffeners on Wetted Elements View: Fixed a bug so that when stiffeners are turned on,
they remain in view on the wetted elements when selecting View > Wetted Elements.

· Mirrored  Wetted  Elements:  Fixed  a  bug  so  the  wetted  faces  of  wetted  elements  in  a
mirrored module or substructure are shown correct graphically.

· Adequacy “User Defined” Range Plot: Fixed a bug so results update correctly when
switching between load cases.
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3 Introduction

The topics in this section provide some basic information about MAESTRO, what it is for,
and what you can do with it.

3.1 About MAESTRO

MAESTRO is a design tool specifically tailored to suit naval architects and their finite
element analysis and limit-state (failure mode) evaluation needs.  The objective of any
structural finite element analysis is to accurately determine the response of a structural
system that is modeled with finite elements and subjected to given loads.  MAESTRO
accomplishes this objective through a single Windows-based graphical user interface that
completely encompasses the structural modeling (preprocessing), the ship-based loading,
the finite element analysis, the limit-state evaluation, and the post-processing.

3.1.1 The Software System

MAESTRO (Method for Analysis, Evaluation, and STRuctural Optimization) is a design,
analysis, and evaluation tool specifically tailored for floating structures and has been fielded
as a commercial product for over 20 years and has a world-wide user base.  MAESTRO’s
history is rooted in rationally-based structural design, which is defined as a design directly
and entirely based on structural theory and computer-based methods of structural analysis
(e.g., finite element analysis). MAESTRO core components are: rapid coarse-mesh finite
element modeling, ship-based loading, finite element analysis, limit state analysis (e.g., at
the hull girder level, stiffened panel level, and local member level), and design evaluation
(shown below).

 

The core capability of MAESTRO is part of a larger open product model framework as
shown below.  This open framework allows the interfacing (i.e., data input and data output)
of MAESTRO with a variety of ship structural design and life-cycle assessment technologies
for several technical domains including, but not limited to: Structural Life-cycle Assessment,
Underwater Shock Assessment, Fatigue Analysis and Assessment, Hydrodynamic Loads
Analysis, Ultimate Hull Girder Strength Assessment, and Ship Salvage Assessment.  The
implementation of the NVR Strength Criteria (i.e., the objective of this panel project) is one
example of a particular US Navy toolset or methodology that can be interfaced with this
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open product model framework.

The overall FEA process in MAESTRO can be decomposed into key activities and
individually examined. These activities are introduced in the figure below and discussed in
detail in the following sections.



Introduction 27

© 2014 Optimum Structural Design, Inc.

The MAESTRO system is composed of many modules that address particular aspects of the
ship structural design process.  

They are described in the following sections:

Modeling/Analysis/Evaluation

Finemesh Analysis

Natural Frequency

ALPS/ULSAP

ALPS/HULL

Naval Vessel Rules (NVR) Assessment

Nastran Translator

ANSYS Translator

NAPA/MAESTRO Interface

MAESTRO-Wave

Extreme Load Analysis (ELA)
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Spectral Fatigue Analysis (SFA)

Optimization

3.1.1.1 Modeling Analysis & Evaluation

This module includes the graphical modeler for developing MAESTRO structural models and
full post-processing capability.  This includes full model viewing capability and generation of
loads for input to the MAESTRO Analysis/Evaluation Solver.  Post-processing includes such
features as graphical display of loads, deflections, stresses, and failure evaluation results
from the MAESTRO Analysis/Solver.

MAESTRO’s two central operations, analysis and evaluation, are also performed by this
module.  This module completes a finite element analysis and structural integrity evaluation
(failure modes and other limit states) of every member and every load case.

The solver performs three integrated tasks:

· finite element analysis to obtain the actual stresses and deflections throughout the model
for all load cases. 

· calculation of the failure stresses for all relevant modes of failure, for every member and
every load case. 

· a complete evaluation of the structural adequacy of every member under each load case,
and thereby obtaining a rigorous assessment of the current design of the structure, which
includes identifying the most critical failure mode and load case for each member. 

3.1.1.2 Finemesh Analysis

The MAESTRO Fine Mesh module allows the user to create refined 3-D FEA models of any
portion of the MAESTRO model quickly.  The user creates a group made up of elements
from the "area of interest" then refines the group based on two options.  The first option is
called the Top-down mode.  In this mode, Fine Mesh Analysis applies displacements from
the global analysis to the fine mesh model for boundary conditions.  In the Embedded mode
(the second option), Fine Mesh Analysis replaces the coarse mesh portion of the model with
the fine mesh.

3.1.1.3 Natural Frequency

MAESTRO can compute the natural frequency of the ship in either air or water. When the
analysis is done in water, the added mass of the water is automatically applied to the wetted
elements.

3.1.1.4 ALPS ULSAP

The features of ALPS/ULSAP include:

· Ultimate limit state evaluation of unstiffened uni-axially stiffened panels and cross-stiffened
panels.
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· Any combination of load components, namely longitudinal axial compression or tension,
transverse axial compression or tension, edge shear, longitudinal in-plane bending,
transverse-in-plane bending-and lateral pressure can be applied.

· Either steel or aluminum alloy material can be dealt with, considering the softening effect
in heat affected zone caused by welding.

· Initial imperfections in form of initial deflections and welding residual stresses are dealt
with as parameters of influence.

· Various types of structural degradation such as corrosion wastage (general or pitting),
fatigue cracking-and local denting are dealt with as parameters of influence.

· Impact pressure action arising from sloshing, slamming and green water can be analyzed
for providing permanent set in terms of panel deflection.

3.1.1.5 ALPS HULL

The features of ALPS/HULL include:

· Progressive collapse analysis of ship hulls until and after the ultimate limit state is
reached, using simplified nonlinear finite element method (idealized structural unit
method).

· Any combination of hull girder load components, namely vertical bending, horizontal
bending, sectional shear and torsion can be applied.

· Either steel or aluminum alloy ship hulls can be dealt with, considering the softening effect
in heat affected zone caused by welding. 

· Initial imperfections in form of initial deflections and welding residual stresses are dealt
with as parameters of influence.

· Various types of structural degradation, e.g., corrosion wastage (general or pitting), fatigue
cracking-and local denting are dealt with as parameters of influence.

3.1.1.6 Naval Vessel Rules Assessment

The NVR Assessment module provides structural assessment based on the direct analysis
methodologies described in the ABS Rules for Building and Classing Naval Vessels.  The
NVRs are governed by a “DISTRIBUTION STATEMENT D” statement, which authorizes
only U.S. Department of Defense (DoD) and U.S. DoD contractors the ability to gain access
to the NVRs and their implementation into MAESTRO.  Please contact
support@maestromarine.com for guidance regarding proper DoD authorization.

3.1.1.7 Nastran Translator

This module translates either the entire MAESTRO finite element model or a portion thereof
into Nastran, including loads.  Alternatively, Nastran models can be translated into
MAESTRO (only Nastran geometry).
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3.1.1.8 ANSYS Translator

This module automatically translates either the entire MAESTRO finite element model or a
portion thereof into ANSYS.

3.1.1.9 NAPA MAESTRO Interface

The NAPA/MAESTRO Interface (NMI) module allows the designer to import a NAPA/NAPA
Steel 3D model, which includes the finite element model (geometry, scantling properties,
and finite elements), loading information (longitudinal weight and bending moment
distributions, tank boundary/content/fill definitions, and hydrostatic equilibrium definition),
and model hierarchy definitions such as MAESTRO module group.  This interface enables
shorter design cycle times by using a single 3D structural design model (from NAPA) that
can be re-used as the design matures and is ready for analysis in a matter of minutes.

3.1.1.10 MAESTRO-Wave

The MAESTRO-Wave module provides the ship designer with an integrated
frequency-domain and time-domain computational tool to predict the motions and wave
loads of any vessel.  To compute these hydrodynamic motions and loads, MAESTRO-Wave
first calculates the velocity potentials, source strengths, and flow velocities at the centroids
of the hydrodynamic panels for each speed, heading, and frequency requested, and then
maps the source strength to the structural panels. The equations of motion are formulated
using the structural mesh rather than the hydrodynamic mesh. This approach results in a
perfect equilibrium for the structural model. Bending moments, shear forces and torsional
moments are automatically in closure. No inertia relief and artificial loads are needed to
balance the model. The computation of these hydrodynamic forces is based on 3D potential
theory using the zero speed Green’s function with a speed correction parameter.  A variety
of visualizations and output data are available for purposes of post-processing.

3.1.1.11 Extreme Load Analysis

The Extreme Load Analysis (ELA) module imports unit wave load data from a hydrodynamic
analysis (MAESTRO-Wave or other) via *.smn file format. It then allows the user to calculate
hull girder load response RAOs, and provides the necessary short-term and long-term
statistical computations to predict extreme values of the maximum loads for a given vessel. 
This includes the ability to define or import wave scatter diagrams, operational profiles, and
wave spectra as well as compute hull girder RAOs for user-defined dominant load
parameters (e.g., vertical bending moment).  Finally, extreme equivalent regular waves
(equivalent design waves) are internally computed and selected for assessment of extreme
global loads.  The user has a variety of options to add still water loads to the wave-induced
wave loads and re-balance these components.

3.1.1.12 Spectral Fatigue Analysis

The Spectral Fatigue Analysis (SFA) module provides the ability to perform global fatigue
screening of the vessel.  The SFA module introduces additional functionality to the ELA
module to compute Stress RAOs, displacement RAOs, define and associate structural
groups to SN curves and Stress Concentration Factors (SCFs), and compute fatigue
damage based on the Miner cumulative damage principle.
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3.1.1.13 Optimization

The MAESTRO Optimization module uses sequential linear programming to redesign the
structure.  This optimization eliminates any structural inadequacies while achieving an
optimum design based on user specified objectives (goals), which may be least weight or
least cost or even both of these, in a weighted non-dimensional combination.  In its
optimization mode MAESTRO iterates the structure through design cycles in which it revises
scantlings, reruns the finite element analysis, and reevaluates the structural adequacy of
each member for all failure modes and load cases.  This iterative process continues until the
structure has converged to an optimum design that has no structural inadequacies.

3.1.2 Finite Element Modeling

The first step in the FEA process is creating the model, which consist of nodes and finite
elements.  In the design of large structures such as ships, it is usually advisable to divide the
task into a few distinct subtasks in order to maintain a good overview and control of the
model generation.  Most large structures can be reduced to several levels of component
structures for which the design and analysis is relatively independent.  Such a structure can
best be modeled by subdividing it into a hierarchy of parts, down to the module level, and
then constructing each module using a three-dimensional mesh of nodes and appropriate
groupings of finite elements.  As shown in the figure below, the MAESTRO structural
modeling is organized in two levels: modules and substructures.

Of particular interest in this model hierarchy, is the composition of the module.  The module
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typically consists of a distinct segment of the ship (e.g., cargo holds in commercial ships or
watertight subdivisions in naval ships).  The definition of the module is helpful for this
because they are ideal high-level building blocks and, in the parallel midbody of a tanker,
bulker, or submarine, only one module (i.e., one cargo hold or compartment) needs to be
built and then copied.  Finally, within this module, the definition of the strake (see the figure
below) is used to capture and retain critical information (e.g., breadth between stiffeners,
span of longitudinals, frames, or girders) for the process of strength assessment.  This
concept of a strake, and the recovery/retaining of the strength assessment parameters are
further extended to the concept of a MAESTRO Evaluation Patch.

The Evaluation Patch (E-patch) is a collection of elements with its boundary supported by
bulkheads or beams.  An E-patch can also be a single element.  In traditional MAESTRO, an
E-patch was a lengthwise strake panel or a few strake panels, if the section per bay was
defined as greater than one.  The evolution of the E-patch in MAESTRO eliminated this strict
definition, freeing the analyst to create more refined FEMs, as sometimes is required. 
These E-patches are defined automatically (see the quilted colors in the figure below; each
color represents an automatically generated E-patch) by MAESTRO or can be defined
manually by the user.
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Each E-patch can be subsequently reviewed for the recovered strength assessment
parameters (see the figure below).  Later sections will discuss how stresses are utilized in
this E-patch paradigm.
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3.1.3 Applying Loads (Ship-based)

The next step in the FEA process is the application of loads.  Loads are a prerequisite to
structural response analysis and design.  The correct application of loads is a critical factor
to sound structural design assessment.  In some ways, the correct application of loads is
most important. In ship design, there are several common load “patterns” that need to be
considered (e.g., Basic Loads-Live Loads/Dead Loads/Liquid Tank Loads, Sea
Environment-Hull Girder Loads/Sea Loads/Ship Motion Loads, Operational
Loads-Slamming/Flooding/Docking, and Combat Environment-Shock/Air blast/Weapons
Effects).  Although MAESTRO has the capability to accurately model these different load
patterns, it should be noted that the analyst must use sound engineering judgment to
determine what loads (e.g., “rule based” versus “first-principle based”) can be combined in a
particular load case.  Rule based loads must be distinguished as such and not combined
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with first-principle loads.  Loads that are not generated  within (e.g., computed hydrodynamic
loads) MAESTRO can be imported and used for analyzing extreme global load structural
responses.

3.1.4 Checking Your Model

At each stage of the FEA process, you receive graphical verification of your progress. 
MAESTRO provides tools for checking your model before and after analysis, which gives
you confidence that you have correctly modeled the structure.

MAESTRO makes extensive use of dynamic querying, which allows the user to make
changes graphically while checking the model.  Dynamic query is a powerful tool that is used
in all phases of the FEA process.  The dynamic query functionality is intended to be used in
conjunction with particular MAESTRO menus, e.g. the View, Loads, Hull, and Results
menus.  In combination with these particular menus, the user can make changes ("on the
fly") while modeling (i.e., thickness, material, pressure sides, etc.).
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In addition to graphically presenting model properties such as element thickness (plate,
beam web and beam flange), positive pressure sides and beam properties (to name a few),
MAESTRO provides built in integrity checks for element aspect ratios, disconnected
elements, warped (twisted) quads, element internal angles and overlapped elements.  These
integrity checks can be executed at any stage of the process.

3.1.5 Analyzing Your Model

When the modeling stage is complete, MAESTRO provides interfaces to solvers to perform
both finite element analysis and structural evaluation.  Regarding structural evaluation,
MAESTRO provides three failure mode strength assessments, which are discussed briefly.  

MAESTRO Failure Evaluation

The first is the MAESTRO failure evaluation, which is based on the theory presented in Ship
Structural Design (Hughes).  The following are the modes of failure examined by the
MAESTRO evaluation method:

Panels

§ Panel Collapse (stiffener flexure, combined buckling, membrane yield and stiffener
bucking)

§ Panel Yield (tension/compression in the stiffener flange and tension/compression in
the plate)

§ Panel Serviceability due to local plate bending longitudinal/transverse

§ Panel Failure due to local plate buckling;

Girders

§ Girder Collapse (tripping and tension/compression in flange)

§ Girder Yield (tension/compression in the plate/flange)

Frames

§ Frame Collapse (plastic hinge)

§ Frame Yield (tension/compression in the plate/flange)

ALPS/ULSAP Failure Evaluation

The second is the ALPS/ULSAP failure evaluation, which is based heavily on the theory
presented in Ultimate Limit State Design of Steel-Plated Structures (Paik and Thayamballi).
The following are the modes of failure examined by the ALPS/ULSAP evaluation method:
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· Overall collapse of plating and stiffeners as a unit

· Collapse under predominantly biaxial compression

· Beam-column type collapse

· Local buckling of stiffener web

· Tripping of stiffener

· Gross

ALPS/HULL Strength Assessment

Finally, the progressive collapse analysis of ships under hull girder loads can be assessed in
MAESTRO, using the optional ALPS/HULL module.  The theory behind ALPS/HULL is
presented in Ultimate Limit State Design of Steel-Plated Structures (Paik and Thayamballi).

3.1.6 Post-processing

After the analysis (structural response and/or structural evaluation), MAESTRO provides
visualization features that enable you to quickly interpret the results, verify loading
conditions, and record results.  Deformation plots, stress plots, contour plots, and
animations of each loading condition are available in MAESTRO.

As previously mentioned, MAESTRO makes extensive use of dynamic querying not only in
the model stage of the FEA process, but the post-processing stage as well.  For example,
while the user is graphically post-processing with dynamic query turned on, a pop-up window
displays the exact information that is being used to create the graphics (i.e., stresses,
deformations, structural adequacy).  Also, this information can be echoed, in text format, to
the output window located at the bottom of the GUI.

3.2 Getting Help

Using this help file:

This help is designed to be used on-screen. It is extensively cross-linked so that you can find
more relevant information to any subject from any location. If you prefer reading printed
manuals a PDF version of the entire help is installed in the \Help subdirectory, located in the
directory where you installed MAESTRO (by default, ...\MAESTRO\Help). This may be
useful as a reference but you will probably find that the active hyperlinks, cross-references
and active index make the on-screen electronic version of the help much more useful.

Getting Started

Start by studying the About MAESTRO and General sections.

Using the help while you're working

As far as possible the help is separated by the basic steps of finite element
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modeling and analysis. This makes easier to find the answer to your question
based on your stage of the finite element analysis process.

· To find information on a specific topic, navigate to the appropriate section:

General

Geometry/Finite Element Modeling

Checking The Model

Importing and Exporting

Loading The Model

Analyzing and Post-Processing

Advanced Processing and Programming

Extreme Load Analysis

NAPA-MAESTRO Interface

Verification and Validation

· When you're frustrated, use the Index and Search functions as well as check
out the Frequently Asked Questions section.

Tutorials:

· See the Tutorials section for some basic tutorials to get you started with using MAESTRO.

· You will find some of the models used in the tutorials in the MAESTRO/Models &
Samples/Tutorial Models folder.

· Full ship sample models can be found in MAESTRO/Models & Samples/Full Ship Models
folder.

Getting a printed user manual:

Please don't try to print the HTML Help version of the help from the Microsoft help viewer; it
would look terrible. You will find a formatted PDF version of the entire documentation
designed for printing in the MAESTRO\Help folder or from Start > All Programs >
MAESTRO 

Email Support:

support@maestromarine.com 

mailto:support@maestromarine.com
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Telephone Support:

(410) 604-8000

Website:

www.maestromarine.com 

Forum:

MAESTRO Forum

Other MAESTRO Representatives:

In addition to the options above, you may also contact a local representative from the list
below for MAESTRO technical support:

Europe/Middle East/Russia 

Design Systems & Technologies

Phone: +33-4-92-91-13-24

Fax: +33-4-92-91-13-38

ds-t@ds-t.com

3.3 How to buy MAESTRO

MAESTRO can be purchased by visiting the online purchasing page and filling out the
required information and submitting the form.  Once the form is received, you will be
contacted by a MAESTRO sales representative and a quote will be generated for the
requested modules or maintenance and support extension.  You may also contact the DRS
AMTC directly:

160 Sallitt Drive, Suite 200

Stevensville, MD 21666

Phone: 410-604-8000

Fax: 410-643-5370

http://www.maestromarine.com
http://www.maestromarine.com/forum/
http://www.ds-t.com/
mailto:ds-t@ds-t.com
http://www.maestromarine.com/purchase.php
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Email: support@maestromarine.com 

3.4 Software Maintenance and Support

STANDARD MAINTENANCE SERVICES

Scope of Service: During the Period of Performance, M&S services for MAESTRO (“the

Software”) include:

· Periodic updates of the Software that may incorporate (i) correction of any

substantial defects, (ii) fixes of any minor bugs, and (iii) at the sole discretion of

AMTC, enhancements to the Software. These updates will be available

electronically or via CD.

· Ten (10) hours technical support consisting of telephone, fax, and electronic mail

consultation, during AMTC normal business hours, and frequently asked

questions (FAQ) through the MAESTRO website, to assist Customer in the

operation and application of the Software. Additional customized technical

support during the Period of Performance will be billed to Customer at the AMTC’

s current billing rates. This ten hour limit does not apply to technical support

related to software bug fixes. This allotted time amount of customized technical

support will expire at the end of the Period of Performance.

· Maintenance at AMTC offices of a test version, for the three most recent versions

of the Software.

Services Not Included: M&S services do not include:

· Charged-for-Enhancements that are offered, at AMTC’s sole discretion, to

Customers upon payment of a license fee;

· Custom programming services;

· On-site support;

· Training; and

· Hardware and related supplies

mailto:support@maestromarine.com
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Maintenance and Support (M&S) Period of Performance Expiration and

Re-Establishing M&S

· A 12 month M&S fee is required to be purchased at the time of purchasing

MAESTRO software.  M&S is priced at 20% of the price of the software per year.

After 12 months, the Software licensee has the option to purchase an additional

12 months of M&S for the next year.  If the M&S agreement has expired, the

licensee will no longer receive or have access to the services described in the

Annual M&S Scope of Services.  To re-establish MAESTRO M&S, the licensee

must first pay for any lapsed M&S period, in order to become current.  In addition

to any lapsed M&S, M&S would also be due for the current year. Lapsed M&S is

capped at 2-1/2 years (30 months); therefore, a user whose license is 2-1/2 years

or more out of M&S would pay 50% (20% * 2.5 years) of the list price of the

software, plus M&S for the current year.  

Software License and Terms: The MAESTRO Software License Agreement governs the

terms and conditions of use of the Software.

Reprogramming the Hardware Lock: Please execute the following steps:

1. Remove all other hardware locks from your computer.  The MAESTRO hardware

lock should be the only device attached to your computer for this operation.  

2. Select Start > All Programs > MAESTRO x.x.x> MAESTRO Fast Lock (where 

x.x.x is the current version number)

3. Select:  Edit/Set Passwords. 

4. Enter the new passwords which are shown above. The new Support Date will be

shown.  

Downloading the Latest Version of the Software: The most recent MAESTRO software

can be downloaded from our website, at http://www.maestromarine.com.  Please follow

the MAESTRO software installation instructions as noted below:

1. Download the self-extracting zip file into a temporary folder or your desktop,

using the "MAESTRO Installation File" link.

2. Double-click on the file to run it; this will automatically extract the files and run

setup.exe and install the necessary security drives. 

3. Follow additional instructions provided on-screen to complete the installation. 

Support Contact:Please contact us with any questions or concerns at:

support@maestromarine.com.  
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3.5 Getting Started

The current release of MAESTRO can be downloaded by sending an email to 
sales@maestromarine.com requesting a download link.

Once the download is complete, double-click the self-extracting file to start the installation
process.

Follow the on-screen instructions to complete the installation.  With MAESTRO version 9.0
and later, the installation will automatically ensure the appropriate drivers and servers (for
network licenses) are installed.

Once the MAESTRO installation is complete, verify that the license dongle (USB or parallel
port) is attached to the local machine where MAESTRO is installed, or if it is a network
license that the dongle is attached to the host computer and the Sentinel Protection Service
is started on the host computer.  This can be verified by opening the Control Panel, clicking
on Administrative Tools, and then Services.  If the service is not already started, start the
service before launching MAESTRO to ensure the network lock is found.

If you do not have a license or your current license is expired, MAESTRO will run in Demo
mode with limited functionality.  If you would like to purchase a license, or renew an
existing license, you can go to http://www.maestromarine.com/purchase.php to fill
out a form for a quotation or email directly to support@maestromarine.com with your
inquiry.

If you experience any problems during or after the installation, click Help > Technical
Support from the menu to send an email to support@maestromarine.com.

Note for Network Locks

If you are troubleshooting issues with a network lock, you may refer to the ReadMe.pdf file
located in the MAESTRO installation directory under MAESTRO/System/Sentinel or see the
Security Devices section of the help manual.

mailto:sales@maestromarine.com
http://www.maestromarine.com/purchase.php
mailto:support@maestromarine.com
mailto:support@maestromarine.com
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4 General

The topics in this section provide an overview of the MAESTRO program user interface.

4.1 Workspace Layout

The MAESTRO Modeler is a tool for creating a structural model through a graphical user
interface (GUI). With the help of various menu options and toolbars, the user can rapidly
generate a large, yet accurate model. The layout of the MAESTRO GUI is shown below.

The main display area contains the graphical representation of the model geometry. It is
used for viewing either the entire or a portion of the current structural model, and is often
used to make interactive selections. The main display can have several layouts including
one, two, or four viewports. The number in the upper right corner of each viewport indicates
the ID of that viewport, and the current view part is displayed in the window border of each
viewport. The active viewport’s window border is highlighted in dark blue.
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The user can control how and what is seen in the main display through the commands in
the View menu.  Commands to rotate the current view can also be accessed with a single
mouse click via the Viewing toolbar. Several more commonly used viewing commands can
be accessed by clicking the right mouse button anywhere in the main display area. This
results in a pop-up menu being displayed from which the user can perform operations such
as zooming in or out, fitting the view, panning the view, toggling to the previous view, setting
any of the five standard views, and toggling perspective projection on and off.

Single View
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Split Vertical View
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Split Horizontal View
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4 Views

4.2 File Menu

The File menu provides several common functions within MAESTRO.  A brief description of
each option is discussed below.
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New

This option will open and new MAESTRO file.

Open...

This option allows the user to select and open a previously saved MAESTRO .mdl file.

Save

This option will save the current MAESTRO model file.

Save As...

This option will allow the user to choose the location and save the current MAESTRO model
file under a new file name.
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Import >

This option will open a fly-out menu of file types for MAESTRO to import.

See Importing Geometry for details of the DXF, GHS, PLY and IDF import options.

See Importing an Analysis Model for details of the MAESTRO (*.dat), MAESTRO (*.mdl),
and Nastran import options.

See Importing Hydro Loads for details of the Ship Motion (*.smn), Wave Scatter (*.sea), and
the Operating Profile (*.opf) import options.

See NAPA-MAESTRO Interface for details of the MAESTRO Neutral File (*.mnf).

See Tank Loader for details on importing tank loads (*.txt).

Export >

This option will open a fly-out menu of file types for MAESTRO to export.
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Job Information...

This option will open the Job Information dialog.

Preferences

This option will open the preferences dialog where background settings and DXF Import
settings can be changed.  The Equation Solver Method section allows the user to choose
the Equation Solver Method: Sparse, Iterative, Skyline.  The Results section allows the user
to export the results file into XML format.  

The Hull Longitudinal Section Cut allows the user to select whether the cross section
properties are recovered at the MAESTRO endpoints or at the exact longitudinal location
specified in the Job Information dialog.  For more information, please see the Hull  > View
Longitudinal >  Properties section.
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Units...

This option will open the Units dialog.

Print...

This option will open the Print dialog.

Print Setup...

This option will open the Print Setup dialog.
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Quick Reference Files

The next section of the File menu provides the previously opened model files for quick
reference.

Autosave Frequency...

This option allows the autosave frequency to be changed.

Recover Model

This option will recover the model if a crash or other error occurs.

Exit

This option will exit MAESTRO.

4.3 Tools Menu

The tools menu provides several options to assist the user throughout the finite element
analysis process.  A brief description of each option is discussed below.

Toolbars >
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This option allows the user to toggle on and off the view of the MAESTRO toolbars.

Construction Geometry >

This option opens the Construction Geometry menu which allows the user to create and
delete construction lines and markers.

Cutting Planes >

This option allows the user to define a cutting plane or delete an existing one.

Set Current Part

This option allows the user to click a part in the model space to set as the current part.  This

is the same as clicking the Set Current Part icon .
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Set View Part

This option allows the user to click a part in the model space to set as the view part, which

will zoom fit the window to this part.  This is the same as clicking the Set View Part icon .

Set Current & View Part

This option allows the user to click a part in the model space to set  as the current and view
part.  This combines the function of the Set Current Part and Set View Part options.  This

can also be done by clicking the Set Current & View Part icon .

Integrity Check >

This option opens the integrity check options menu allowing the user to choose one of the
functions to check the model.

Find FE-Tag

This option will launch the Find FE-Tag to locate a node or element by it's FETag. 

Click the radio button to choose between "Nodal" and "Element" and type the FeTag to
search.  A dialog will list the node or element location for the enter FeTag.  This location will
be echoed to the Output tab.
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Renumber FE-Tag

This option will renumber all Nodal and Element FE-Tags in the model to remove any gaps
in FE-Tag numbers.  

Renumber FE-Tag (Advanced)

This option is similar to the "Renumber FE-Tag" functionality except is provides the user with
the ability to specify the "starting" value of the FE-Tag.

Edit Nastran Data

This option allows the user to open and edit the Nastran *.nas file (if applicable) in the
MAESTRO Output tab or a separate editor program if the Use Non-MAESTRO Editor option
is checked.

Select Alternate Editor

This option allows the user to select a text editor program to use for *.nas files outside of
MAESTRO.

Use Alternate Editor

This option allows the user to toggle on or off the option to use an alternate editor for
Nastran data.  A check mark will appear next to the option in the menu if an alternate editor
is to be used, otherwise the Nastran data will open in the Output tab.

4.4 View Menu

The View menu provides several options for viewing the model that help in the FEA modeling process.  A brief description of each option is discussed below.
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Undo View Change

This option will undo the last change to the model view made.  For example, if the model is
being viewed in the profile view and is changed to body plan, choosing this option will return
the view to profile.

Pan

This option allows the user to pan the model with the mouse.  This can also be done by
holding the Shift key and clicking and holding the mouse wheel button and moving the
mouse to pan the model.
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Rotate

This option allows the user to rotate the model with the mouse.  This can also be done by
clicking and holding the mouse wheel button and moving the model as desired.

Zoom >

Zoom Window (In)

This option will allow the user to select an area of the model by a user-defined box and
zoom in.  This can also be done by right-clicking in the model space and selecting Zoom In.

Zoom Window (Out)

This option will allow the user to select an area of the model by a user-defined box and
zoom out.  This can also be done by right-clicking in the model space and selecting Zoom
Out.

Zoom Extents

This option allows the user to select to zoom to the extents of the model.  This can also be
done by right-clicking in the model space and selecting Fit.

Set View >
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This option allows the user to select from the standard views or a named view.

Specify

This option will turn on the rotate function allowing the user to click the left mouse button and
spin the model interactively.

Store

This option allows the user to "store" the current view to be recalled at a later time.

Recall

This option allows the user to "recall" the last stored view.

Set View Style >

This allows the user to change the view between a black or white background (if current
background is black or white), show nodes on or off, shrink or unshrink elements, and solid
or wireframe view.  These options can also be set in the View Options dialog or from the
View Toolbar.

Set Visibility >

This option allows the user to set a module display on or off and transparent or not
transparent.  These options can also be set in the Parts Tree.

Set Window >
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This option allows the user to show or hide the parts/groups tree, the output section and the
status bar. 

Element Type

This option is the default MAESTRO view where each type of element has a different color.

In conjunction with the Element Type view, the user can dynamically query and element to
change it from "wetted" to "unwetted" and vice-versa, reverse the element normal, and
rotate the local x-axis of the element. To use this functionality, the user must first change to
the Element Type view, toggle the Dynamic Query icon, move the mouse cursor over a
particular element, right-click the mouse, and finally select the menu item.

Wettable Elements

This option will change the view to display on the elements that are defined as "wettable".

In conjunction with the Wettable Elements view, the user can dynamically query an element
to change it from "wettable" to "unwettable" and vice versa. To use this functionality, the
user must first change to the Element Type view, toggle the Dynamic Query icon, move the
mouse cursor over a particular element, right-click the mouse, and finally select the menu
item.

To return to viewing all elements, you must select View > Wettable Elements to uncheck
the option.



General 61

© 2014 Optimum Structural Design, Inc.

By ID

This option allows the user to view the model by material ID, plate property ID, beam
property ID, rod property ID, or stiffener layout ID.

The dynamic query function can be used to highlight an element and change the beam, rod,
or stiffener layout property by right-clicking on the element in the corresponding view.
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Groups

Corrosion Side

This option allows the user to view the side of the element which corrosion is applied to,
shown as pink, if a corrosion group is defined.

User-defined Color

This option will display the currently viewed groups as the user-defined color set in the 
groups dialog.  
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Volume/Plate Pressure Side

As mentioned above, MAESTRO distinguishes between a positive and negative pressure
face by a pink and gray face respectively. The pink face of the element will receive the
positive pressure. As seen below, a typical tank will have the pressure side on the "inside" of
the tank. This is very important when defining tanks. 
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In conjunction with the Volume/Plate Pressure Side view, the user can use the Dynamic

Query tool, which can be initiated via the  icon, to Flip Pressure Side, define the
volume group as a Centerline Group, and Remove an element associated with the group.
When using this functionality, the user can also choose to switch between the Element
Pressure Side view or the Tank/Group Pressure Side view. This aids in the building of tanks.
To use this functionality the user must first change to the Volume/Plate Pressure Side view,
toggle the Dynamic Query icon, move the mouse cursor over a particular element, right-click
the mouse, and finally select the menu item.

Restraints

This option displays the model in wireframe view showing the nodes that are constrained
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and in which direction.

Edges

Free Edges

This option will check the model for free edges and can create a group of potential free edge
errors if desired.  It is easiest to see the free edges in red when the model is in wireframe
view.
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3 Edges

This option checks the model for edges where 3 elements meet and can create a general
group of the 3 edge elements if desired.  It is easiest to see the edges in red when the
model is in wireframe view.

4 or More

This option checks the model for edges where 4 or more elements meet and can create a
general group of the 4 or more edge elements if desired.  It is easiest to see the edges in
red when the model is in wireframe view.

Evaluation Patches

Included Elements

This option will display the elements that make up the evaluation patches that will be
analyzed.  This includes single panel elements that are bordered by beam elements on all
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edges.  The dynamic query icon  (with patch option checked) can be used to highlight
an element or patch and select Evaluation Off.

Patch

This option will display the defined patches for the model.  They dynamic query icon 
can be used to highlight a patch and retrieve information about it by clicking the icon and
selecting Patch from the drop down menu.

Plate

Element Normal Side
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The figure below shows how MAESTRO distinguishes between a positive normal and
negative normal face. The pink face of the element will receive the positive normal side.

In conjunction with the Element Normal Side view, the user can use the Dynamic Query tool,

which can be initiated via the icon, to reverse the element normal and consequently
flip the pressure side. To use this functionality the user must first change to the Element
Normal Side view, toggle the Dynamic Query icon, move the mouse cursor over a particular
element, right-click the mouse, and finally select the menu item.

NOTE: Element Normal Side cannot be flipped for Strake Elements. Only the flipping of the
pressure side can occur for strakes resulting in the flipping of the Strake Frame web
orientation.

Element Pressure Side

The figure below shows how MAESTRO distinguishes between a positive and negative
pressure face. The pink face of the element will receive the positive pressure. 

In conjunction with the Element Pressure Side view, the user can use the Dynamic Query

tool, which can be initiated via the  icon, to reverse the element pressure side. This
will flip the element pressure side. To use this functionality the user must first change to the
Element Pressure Side view, toggle the Dynamic Query icon, move the mouse cursor over a
particular element, right-click the mouse, and finally select the menu item.
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The pressure side is plotted in pink on the side of the element a pressure load would be
applied in order to have the net force vector pointing in the direction of the elements positive
normal using the right-hand rule.  The pressure side of a quad or tri element is the same as
the normal side, whereas the pressure side of a strake is always opposite to the frame side.

Stiffener Side

The pink face designates the stiffener side of the plate element.

In conjunction with the Stiffener Side view, the user can use the Dynamic Query tool, which

can be initiated via the  icon, to Flip Stiffener Side. With this view displaying, toggle
the Dynamic Query icon, move the mouse cursor over a particular element, right-click the
mouse, and finally select Flip Stiffener Side.
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Thickness

With Corrosion Net

This option is used to toggle the view to display the thickness of Plate, Beam Web, or Beam
Flange with or without net corrosion and is used in conjunction with the Plate, Beam Web, or
Beam Flange menu option.

With % Corroded
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This option is used to toggle the view to display the thickness of Plate, Beam Web, or Beam
Flange with or without % corroded and is used in conjunction with the Plate, Beam Web, or
Beam Flange menu option.

Beam Flange

The Beam Flange view, under the Thickness menu, displays the flange thickness of all
beam elements in the model. This helps the user to identify mistakes in the model.

In conjunction with the Beam Flange thickness view, the user can use the Dynamic Query

tool, which can be initiated via the  icon, to change the thickness in a particular
element. To use this functionality the user must first change to the Beam Flange view,
toggle the Dynamic Query icon, move the mouse cursor over a particular element, right-click
the mouse, and finally select the thickness of choice.

Beam Web

The Beam Web view, under the Thickness menu, displays the web thickness of all beam
elements in the model. This helps the user to identify mistakes in the model. 
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In conjunction with the Beam Web thickness view, the user can use the Dynamic Query tool

, which can be initiated via the  icon, to change the thickness in a particular element.
To use this functionality the user must first change to the Beam Web view, toggle the
Dynamic Query icon, move the mouse cursor over a particular element, right-click the
mouse, and finally select the thickness of choice.

Plate

The Plate view, under the Thickness menu, displays the plate element thickness in the
model. This helps the user to identify mistakes in the model. 
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In conjunction with the Plate thickness view, the user can use the Dynamic Query tool, which

can be initiated via the  icon, to change the thickness in a particular element. To use
this functionality the user must first change to the Plate view, toggle the Dynamic Query
icon, move the mouse cursor over a particular element, right-click the mouse, and finally
select the thickness of choice.

Composite Layers

The Composite Layers view displays the number of layers associated with all composite
elements in the model.

Parent/Child

This option will display the master and secondary nodes of a fine mesh model.  The nodes
that correspond to global nodes will be shown in pink and the fine mesh secondary nodes
will be shown in yellow.  In other words this option will display the master(pink) and
secondary(yellow) nodes for the R-Spline elements that translate the displacements
between the global and fine mesh models.
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All Modules

This option is used to view the global, coarse mesh model with the fine mesh model(s)
shown on top of the coarse mesh elements.
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Element X Axis &

Global X

This option will color the elements corresponding to the angle that the element's local x-axis
makes with the global x-axis.
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Global Y

This option will color the elements corresponding to the angle that the element's local x-axis
makes with the global y-axis.
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Global Z

This option will color the elements corresponding to the angle that the element's local x-axis
makes with the global z-axis.
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Hide Elements

This option will open a dialog allowing the user to select elements to hide from the current
view.  There are a number of right-click selection options after an element is added to the
dialog.  
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Options...

This option will launch the View Options dialog.

Refresh

This option will allow the user to refresh the graphics.  

4.5 Model Menu

The Model menu provides options to build, constrain and balance the model.  A brief
description of each option is discussed below.
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Parts >

Create/Modify

This option will open the Parts dialog, where a structure or module can be created or

modified.  This is the same as clicking the parts icon .

Combine

This option will move the selected module beneath the substructure that is set as the current
part.  The module is selecting by clicking on it with the mouse in the modeling space.  Note:
a substructure must be set as the current part for this option to be allowed since a module
cannot be added beneath another module.
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Copy

This option will create a copy of the selected part and allow the user to name and set the
location of the new part.  The part is selected by clicking on it in the modeling space.

Delete

This option is used to select a part in the modeling space to delete.  This can also be done
by right-clicking on a part in the parts tree and selecting Delete.

Mirror > 

Model

This option will open the Mirror dialog which is used to mirror the model or add a mirror.

Parts >

This menu is used to mirror or add mirror a specific part.  Once the option is selected from
the menu, click on the part to mirror or add mirror and follow the prompts in the command
tab. 

XYZ Scale

This option allows one or more modules to be scaled in the X, Y, Z, or a combination of
directions.  This option will not affect material and element properties, it will simply scale the
node locations in the direction(s) specified.  Note: if the module or modules has a rotation
defined, the scaled results may not be correct; this scaling is only performed in the
translational directions.
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The tree on the left side of the dialog allows the user to select the module, substructure or
full model to scale.  The X, Y and Z boxes are the scale factors for the selected part. 
Leaving the scale factor "1" will not affect the model in that direction.

Extract Module

The Extract Module command will enable a module to be split into multiple pieces. The user
must first define a bounding box in which the enclosed elements will be extracted. For more
information see the section on extracting a module with the Extract Module command from
imported NASTRAN geometry.  

Materials...

This option will open the Materials dialog where materials can be created, modified and
deleted.

Properties >

Beam

This option will open the properties dialog to the beam properties tab.

Plate

This option will open the properties dialog to the plate properties tab.
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Rod

This option will open the properties dialog to the rod properties tab.

Spring

This option will open the properties dialog to the spring properties tab.

ULSAP Parameters

This option will open the Ultimate Strength Parameters dialog where sets of parameters can
be created, modified and deleted.
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Nodes > 

Create/Modify >

This menu option is used to create or modify endpoints or additional nodes by opening the
appropriate dialog box.
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Delete >

This menu option is used to delete endpoints and additional nodes.  Note: a module must be
set as the current part in order to use this functionality.  Once endpoint or additional node is
selected, the user will be prompted to specify the ID of the endpoint or additional node to
delete.  Selecting unused nodes will delete any endpoints or additional nodes not being used
to define an element.

Renumber IDs

This option is used to renumber the node ID of the current modules endpoints and additional
nodes.  This will eliminate any gaps in ID numbers if nodes are deleted.

Elements > 

Create/Modify >

This menu is used to create or modify an additional element, compound, or strake and will
open the appropriate dialog.

Delete > 

Select

This option will open the Deletions dialog.
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All Visible >

This option allows the user to delete all visible elements of a specific type by choosing the
desired element from the menu.

Simple Object Mesh

Stiffened Panel
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This option allows the user to define and auto generate a stiffened panel.  Options allow for
the length, width, thickness and material of the plate as well as the stiffener property and
number in each primary direction.  Mesh controls also allow the user to define the number of
elements between stiffeners as well as the number of elements to define the stiffener webs
and flanges.

Sphere
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This option allows the user to create a full, half, 1/4 or 1/8 sphere mesh with a given radius,
material property and number of elements defining the mesh shape.

Cylinder

This option allows the user to create a cylinder mesh with a given property, top and bottom
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radii, length and mesh controls.  The user can also add rings on the inside or outside of the
cylinder at a given spacing.

Stiffener Layout...

This option will open the Stiffener Layout dialog where stiffener layouts can be created,
modified and deleted.

Evaluation Patch >

Auto-Generate

This option will automatically create evaluation patches from the model's elements.

Create/Evaluate

This option will launch the Evaluation Patch dialog.

Delete All

This option will delete all evaluation patches defined for the model.

Create Boundary Modules

This option allows the user to automatically create a master node at the neutral axis
connected to all the module's end nodes by RBE2 elements in support of End Moment load
patterns.  This will ensure that the plane sections remain plane.  The End Moment load is
now applied at the master node versus spreading the imposed forces and moments to the
existing nodes.  Note: this option is only valid with a "Cut" model.

Create CG Restraint

This option will automatically create a fixed restraint at the model's CG connected to
surrounding structure with soft springs.

Define Restraints...

This option opens the Restraints dialog.
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Balance...

This option opens the Balance dialog.

Optimization...

This option will open the ULS Optimization dialog.

Design Selection...

This option will show the list of optimized design results and allow the user to select one, if
available.

Summary...

This options opens the Model Summary dialog providing the total number of nodes and
elements as well as the total modeled length, width, and height.

4.6 Groups Menu

The Groups menu provides options to create, modify and delete groups as well as perform
operations on existing groups.
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General...

This option opens the groups dialog to the General tab.

Volume...

This option opens the groups dialog to the Volume tab.

Plate...

This option opens the groups dialog to the Plate tab.

Nodal...

This option opens the groups dialog to the Node tab.

Module...

This option opens the groups dialog to the Module tab.

Section...
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This option opens the groups dialog to the Section tab.

Bay...

This option opens the groups dialog to the Bay tab.

Corrosion...

This option opens the groups dialog to the Corrosion tab.

Manager...

This option will open the Group Manager dialog.

The Group Manager will list all of the groups and their type in the left hand side.  Groups can
be moved into new subgroups or have their type changed by selecting options from the new
group section and moving the existing groups to the right-hand side of the dialog.

Operations...

This option will open the Group Operation dialog.
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Existing groups can be combined and subtracted to create new groups using this dialog.  A
new group of shared elements between existing groups can also be created. 

1.  Move the groups of interest into the right column by clicking the group and then clicking
the >> button.

2.  Select the operator for each group added.

+: this will add the elements of the selected group to the new group (no elements will be
double counted)

-: this will exclude the elements of the selected group from the new group

&: this will add the common elements of the selected groups to the new group

Note: The "-" sign should not be taken literally as a subtraction. If a group is subtracted from
the new group and then a group containing elements that were previously subtracted is
added, the elements originally excluded by selecting the "-" operator will not be added
subsequently.

3.  Select the group type from the drop-down menu.

4.  Give the new group a name.

5.  Click Create.
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Example: Creating Group of Parallel Midbody Stripped of Transverse Structure

Say, for example, a general group consists of all parallel midbody and the goal is to
preserve the inner bottom and inner hull ballast tanks but to strip the module entirely of
transverse framing and bulkheads. The initial module group looks like the following, which is
a half hull with deck removed to show transverse structure:

Again, the goal is to remove web frames, transverse frames, and the transverse bulkhead.
As opposed to deleting all compound elements from the general group, it would be easier to
create a general group or a plate group of all transverse structure. This can be done simply
by entering the groups dialog and checking the "Full Strake/Full Compound" option in either
the general groups tab or the plate groups tab. Click an element of the transverse structure
which will be indicated by green elements. Right-click in the dialog and select "Add By
Type". All compound elements, including the transverse frames and web frames should be
included in this new group with type "cmpd". Set the current view to the group containing all
modules that make up the parallel mid-body. The aft-most station contains a transverse
bulkhead that needs to be eliminated. Create either a plate group or general group
consisting of the quad elements which can be all selected using the right-click "Add By
Type" option. Since all of the shell plating and inner bottom is modeled with quad strakes,
only the true quad elements of the bulkhead will be selected. Individually select any
remaining bar elements or tri elements that are part of the bulkhead. 
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The group operations dialog can now be used to exclude all transverse structure from the
above picture. Select Groups > Operations... and the Group Operation dialog will appear.
The left hand column lists all groups that are eligible for group operations. The right hand
column will be populated with the groups and operations explained in the Operations
section. The main group group containing all structure in the midbody should be given a "+"
sign to add it to the operations. The transverse bulkhead and structure groups should be
excluded by assigning a "-" to each of them. The dialog should appear as the following. The
final group, devoid of all transverse structure, should appear as the following.

Example: Create a Nodal Group of Nodes Associated with a Plate Group

The group operations dialog can be used to add groups together or exclude selected
elements of compatible group types (ie. plate group and general group addition). The
operations dialog can alternatively be used to gather nodes from elements into a group. Say,
there exists a plate group or a general group of some elements. The goal is to extract the
nodes that are associated with the vertices of each element into a separate nodal group.
This can be done simply by adding the plate or general group to the right hand column and
giving it a plus sign. ID the group as type "Nodal" and the result will be a nodal group of all
nodes associated with those elements. This can be leveraged to assist the loading of the
model.
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Extract Group...

This option allows the user to define a region in space in which all elements will be extracted
into a general group called "extract". The extract group option will only extract elements from
the current view and visible elements. The default is to extract all visible elements and can
be selected by entering nothing in the range for extraction and then clicking "OK". The
extract group dialog where bounds for extraction are defined looks like the following:

Wetted Elements

This option will create a general group named "wetted#lcx" (where x is the load case
number) of all shell elements defined as wettable that will receive hydrostatic pressure from
the given load case's load pattern.

Wettable Elements

This option will create a general group named "wettable" of all the shell elements that are
defined as wettable.

Vertical Elements

This option will automatically create a general group of the "vertical" plate elements defined
as being within the threshold value of the vertical, or MAESTRO Y-axis.  This option
provides a quick way to select well supported ship structure that can be loaded using the
Target Load loading pattern.  This is especially useful with finer mesh models that may have
several plate elements between frames.

Extract By Property

This option will automatically create general groups of all the element properties defined and
those elements which are assigned that property.
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Create by FeTag

This option will open a dialog allowing a user to create a group by element or nodal FE Tag.
Multiple FE Tags can be entered at once separated by commas.

4.7 Loads Menu

The Loads menu allows the user to create or modify a load case, as well as view the
resulting pressure and forces for the selected load case.  A brief description of each option
is discussed below.
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Create/Modify...

This option will launch the Loads dialog where load cases can be created, modified, and
deleted.

Compute >

The Compute menu has two options to calculate parameters of the modeled structure.   A
detailed description of each of these options is below:

Center of Flotation & CG

This option will calculate and output the center of flotation and center of gravity to the output
tab as well as graphically display the waterplane and CG and CF locations.
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Gyradius

This option will compute the radius of gyration about the user-defined center of rotation. 
Once selected a dialog will launch prompting the user to input the center of rotation.

After the center of rotation is defined, click OK.  The results will be displayed in a new dialog
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box as well as be echoed to the Output tab.

View Pressure >

The sub-menu allows the user to choose to view the pressure due to various loading
options, or all, for the currently selected load case.  Note:  the scale for the graphical
representation of pressure will remain the same if switching between load cases, unless the
maximum pressure value is higher than the current scale's maximum value.  To view the
load case specific legend, turn off the pressure view and then turn it on again.

Immersion

This option will display the pressure on the "wetted" panel elements based on the initial
location of the model's waterplane for the currently selected load case.
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The dynamic query icon  can be used to query an element to recover the pressure
and double-clicked to echo the information to the output tab. (Note: While quad elements
are defined with nodes 1, 2, 3, and 4, the dynamic query will present Pressure[0], Pressure
[1], Pressure[2], and Pressure[4]. Node 1 corresponds to Pressure[0] and so forth.)

Note well that if the pressure is zero at a node, then the query will not display the pressure
value for that node.

Volume (Inverse)

This option will display the pressure due to all volume loads for the active load case on the
inverse side of the plate so that the pressure display can be seen easily.  The dynamic query

icon  can be used to query an element to recover the pressure and double-clicked to
echo the information to the output tab.

Linear Pressure

This option will display the pressure of the panel elements for which a linear pressure is

defined for the currently selected load case.  The dynamic query icon  can be used to
query an element to recover the pressure and double-clicked to echo the information to the
output tab.
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Surface Head

This option will display the pressure of the panel elements for which a surface head is

defined for the currently selected load case.  The dynamic query icon  can be used to
query an element to recover the pressure and double-clicked to echo the information to the
output tab.

Surface Zero

This option will display the pressure of the panel elements for which a surface zero is

defined for the currently selected load case.  The dynamic query icon  can be used to
query an element to recover the pressure and double-clicked to echo the information to the
output tab.

Additional Beam

This option will display the pressure of the additional beam elements for which a pressure is

imposed for the currently selected load case.  The dynamic query icon  can be used
to query a beam element to recover the pressure and double-clicked to echo the information
to the output tab.

Edge

This option will highlight the edge of elements where an additional stress is applied.  Similar
to the free edges view, the edges where a stress is applied will show up in red.

All  

This option will display the net pressure on the elements for the currently selected load case.

 The dynamic query icon  can be used to query an element to recover the pressure
and double-clicked to echo the information to the output tab.

View Mass >

This sub-menu allows the user to view the different mass loads that may be imposed on the
model for the currently selected load case.  
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Volume

This option will display the volume groups that are loaded for the currently selected load
case.

Module

This option will show the modules and their corresponding elements which are added to the
load case either as a structural weight or a scaled weight for the currently selected load
case.

Nodal

This option will display the nodes which are applied a mass in the currently selected load
case.

View Point Load

This option will give a graphic representation of the directional load applied at each node(s).

The dynamic query  icon can be used to query the force in each direction at the
selected node.
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View Boundary

Note: this option is for cut models only.

Vertical Bending

This option will graphically display the boundary nodal forces and moments applied to

simulate the user-defined vertical end moments.  The dynamic query  icon can be
used to query the force and moments at individual nodes.  

Vertical Shear

This option will graphically display the boundary nodal forces and moments applied to
simulate the user-defined vertical shear force or the vertical shear force calculated by

MAESTRO to balance the model.  The dynamic query  icon can be used to query the
force and moments at individual nodes.

Horizontal Bending

This option will graphically display the boundary nodal forces and moments applied to

simulate the user-defined horizontal end moments.  The dynamic query  icon can be
used to query the force and moments at individual nodes.  Note: this is only applicable if 
transverse symmetry is not checked in the Job Information dialog.

Horizontal Shear

This option will graphically display the boundary nodal forces and moments applied to
simulate the user-defined horizontal shear force or the horizontal shear force calculated by

MAESTRO to balance the model.  The dynamic query  icon can be used to query the
force and moments at individual nodes.  Note: this is only applicable if transverse symmetry
is not checked in the Job Information dialog.

Torsion
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This option will graphically display the boundary nodal forces and moments applied to

simulate the user-defined torsional moments.  The dynamic query  icon can be used
to query the force and moments at individual nodes.  Note: this is only applicable if 
transverse symmetry is not checked in the Job Information dialog.

All

This option will graphically display all the boundary nodal forces and moments applied to the
model representing the vertical bending, vertical shear, horizontal bending, horizontal shear,

and torsion.  The dynamic query  icon can be used to query the force and moments
at individual nodes.  

Total Point Force

This option provides a graphical representation of the equivalent nodal force for the currently

selected load case.  The dynamic query  icon can be used to query a specific node
and that node can be double-clicked to echo the information to the Output tab.

Total  Force Summary

This option will print out the total combined point loads for the current view part in the Output
tab.

4.8 Hull Menu

The Hull menu is used to display various model properties, which can then be queried. This
provides the user with a graphical method to quickly and accurately identify trends. Because
graphics alone are not sufficient, a majority of these menu items produce distribution data, in
the form of text in the Output window for further scrutiny.  A brief description of each option
is discussed below.

Note: 

If transverse symmetry is checked in the Job Information dialog, the results shown
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will be for the full model, not just the half modeled.

In conjunction with the Hull menu, the user can use the Dynamic Query tool, which can be

initiated via the  icon, to query the distribution graph. To use this functionality the user
must select the Hull menu item of choice, toggle the Dynamic Query icon, and move the
mouse cursor over a particular portion of the graph. This will produce a text box with data for
the highlighted section of the distribution. Further, the user can echo this information to the
Output window by double-clicking the left mouse button while hovering over the graph entity
of interest.  

View Self Weight

View Gross Weight

View Gross Weight Density

View Buoyancy

View Buoyancy Density

View Net Force

View Longitudinal >

View Horizontal >

View Transverse >

Weight Summary

View Self Weight

The View Self Weight command under the the Hull menu is used to display the MAESTRO
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calculated "modeled" weight. The term "modeled" weight refers to the weight calculated by
MAESTRO based on the materials and elements that make up the FE model. As shown
below, MAESTRO produces a display of this weight distribution. Further, MAESTRO echoes
this distribution to the Output window, which is found at the bottom of the MAESTRO GUI. 

In conjunction with the View Self Weight command, the user can use the Dynamic Query

tool, which can be initiated via the icon, to query the distribution graph. To use this
functionality the user must select the View Self Weight command, toggle the Dynamic Query
icon, and move the mouse cursor over a particular portion of the graph. This will produce a
text box with graph data. The user can echo this information to the Output window by
double-clicking the left mouse button while hovering over the graph entity of interest.

View Gross Weight

The View Gross Weight command under the the Hull menu is used to display the FE
model's gross weight for the selected load case. As shown below, MAESTRO produces a
display of this weight distribution. Further, MAESTRO echoes this distribution to the Output
window, which is found at the bottom of the MAESTRO GUI. 

In conjunction with the View Gross Weight command, the user can use the Dynamic Query
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tool, which can be initiated via the  icon, to query the distribution graph. To use this
functionality the user must select the View Gross Weight command, toggle the Dynamic
Query icon, and move the mouse cursor over a particular portion of the graph. This will
produce a text box with graph data. The user can echo this information to the Output window
by double-clicking the left mouse button while hovering over the graph entity of interest.

View Gross Weight Density

The View Gross Weight Density command under the Hull menu is used to show the weight
per unit length. The output in the output tab looks like the following with a weight density at
each station:
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View Buoyancy

The View Buoyancy command under the the Hull menu is used to display the FE model's
buoyancy distribution for the selected load case, as shown below. Further, MAESTRO
echoes this distribution to the Output window, which is found at the bottom of the MAESTRO
GUI. 

In conjunction with the View Buoyancy command, the user can use the Dynamic Query tool,

which can be initiated via the  icon, to query the distribution graph. To use this
functionality the user must select the View Buoyancy command, toggle the Dynamic Query
icon, and move the mouse cursor over a particular portion of the graph. This will produce a
text box with graph data. The user can echo this information to the Output window by
double-clicking the left mouse button while hovering over the graph entity of interest.
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View Buoyancy Density

The View Buoyancy Density command under the Hull menu is used to show the buoyancy
per linear distance. The output in the output tab looks like the following with a buoyancy
density at each station:
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View Net Force

The View Net Force command under the the Hull menu is used to display the FE model's
net force distribution for the selected load case, as shown below. MAESTRO also echoes
this distribution to the Output window, which is found at the bottom of the MAESTRO GUI. 

In conjunction with the View Net Force command, the user can use the Dynamic Query tool,

which can be initiated via the  icon, to query the distribution graph. To use this
functionality the user must select the View Net Force command, toggle the Dynamic Query
icon, and move the mouse cursor over a particular portion of the graph. This will produce a
text box with graph data. The user can echo this information to the Output window by
double-clicking the left mouse button while hovering over the graph entity of interest.
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View Longitudinal >

The View Longitudinal menu has several options to display the longitudinal properties of the
modeled structure.   A detailed description of each of these options is below:
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Shear Force

Bending Moment

Bending Moment w/o Axial Force Contribution

Torsional Moment

Element Effectiveness

All Sections

Properties

Izz

Iyy

Cross Sectional Area

Neutral Axis

Shear Center

Warping Constant

Torsional Rigidity

Shear Force



MAESTRO 11.0.0114

© 2014 Optimum Structural Design, Inc.

The View Longitudinal > Shear Force command under the the Hull menu is used to
display the FE model's longitudinal shear force distribution, as shown below. MAESTRO
also echoes this distribution to the Output window, which is found at the bottom of the
MAESTRO GUI. 

In conjunction with the View Longitudinal Shear Force command, the user can use the

Dynamic Query, which can be initiated via the  icon, to query the distribution graph.
To use this functionality the user must select the View Shear Force command, toggle the
Dynamic Query icon, and move the mouse cursor over a particular portion of the graph. This
will produce a text box with graph data. Further, the user can echo this information to the
Output window by double-clicking the left mouse button while hovering over the graph entity
of interest.

Bending Moment

The View Longitudinal > Bending Moment command under the the Hull menu is used to
display the FE model's longitudinal bending moment distribution, as shown below.
MAESTRO also echoes this distribution to the Output window, which is found at the bottom
of the MAESTRO GUI. 

In conjunction with the View Longitudinal Bending Moment command, the user can use the



General 115

© 2014 Optimum Structural Design, Inc.

Dynamic Query, which can be initiated via the  icon, to query the distribution graph.
To use this functionality the user must select the View Bending Moment command, toggle
the Dynamic Query icon, and move the mouse cursor over a particular portion of the graph.
This will produce a text box with graph data. Further, the user can echo this information to
the Output window by double-clicking the left mouse button while hovering over the graph
entity of interest.

Bending Moment w/o Axial Force Contribution

The View Longitudinal > Bending Moment w/o Axial Force Contribution command
under the the Hull menu is used to display the FE model's longitudinal bending moment
distribution ignoring the contribution from axial forces (e.g., hydrostatic forces on a flat
stern). MAESTRO also echoes this distribution to the Output window, which is found at the
bottom of the MAESTRO GUI. 

In conjunction with the View Longitudinal Bending Moment w/o Axial Force Contribution

command, the user can use the Dynamic Query, which can be initiated via the  icon,
to query the distribution graph. To use this functionality the user must select the View
Bending Moment command, toggle the Dynamic Query icon, and move the mouse cursor
over a particular portion of the graph. This will produce a text box with graph data. Further,
the user can echo this information to the Output window by double-clicking the left mouse
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button while hovering over the graph entity of interest.

Torsional Moment

The View Longitudinal > Torsional Moment command under the the Hull menu is used to
display the FE model's longitudinal torsional moment distribution, as shown below.
MAESTRO also echoes this distribution to the Output window, which is found at the bottom
of the MAESTRO GUI. 

In conjunction with the View Longitudinal Torsional Moment command, the user can use the

Dynamic Query, which can be initiated via the  icon, to query the distribution graph.
To use this functionality the user must select the View Longitudinal Torsional Moment
command, toggle the Dynamic Query icon, and move the mouse cursor over a particular
portion of the graph. This will produce a text box with graph data. Further, the user can echo
this information to the Output window by double-clicking the left mouse button while hovering
over the graph entity of interest.

Element Effectiveness

The View Longitudinal > Element Effectiveness command under the hull menu shows a
graphical representation of which elements have  longitudinal effectiveness.
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The Dynamic Query  function can be used to highlight an element and toggle on or
off whether the element is longitudinally effective.

All Sections

The View Longitudinal > All Sections command under the Hull menu will display all the
sections of the model.  This is helpful if you are viewing specific sections and would like to
return to the full model view.
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Properties

The View Longitudinal > Properties command under the Hull menu displays the hull girder
properties for each section in table form in the Grid tab.  Within the grid, the user can select
individual sections to view, or copy the results and paste them into another program such as
Microsoft Excel.
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This data can be copied and pasted into a program such as Excel by following these steps:

1.  Right-click inside the grid and select "Change to Fixed Rows."

2.  Change fixed row number from 1 to 0.

3.  Copy the data.

4.  Paste the data into the desired program.

If the "Slice" option is selected in the Hull Longitudinal Section Cut area of the Preferences
dialog, the defined sections will be displayed as below:
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The sections shown in red represent longitudinally effective elements while the green
sections represent longitudinally ineffective elements.

The same properties will be recovered in the Grid tab, but the user can now right-click and
select "Show this Section" will show just the section cut selected.  (Selecting "Show all
Sections" will return to the full ship sections view.)

Right-clicking and selecting "Export this Section" or "Export All Sections" will display the
section node IDs (note: this is not the finite element node ID) and their locations on the
Output tab.  This will also list the thickness of the plate for each edge defined between two
section nodes.  The "smeared thickness" includes any defined stiffeners between those two
nodes.  The longitudinal and shear effectiveness columns list whether that edge is
associated with a longitudinally effective element.  The last section of the output lists the
section nodes and their total area which includes the rod, beam and bar area contributions.

Izz

The View Longitudinal > Izz command under the the Hull menu is used to display the FE
model's inertia properties about the z-axis for each section, as shown below.

In conjunction with the View Longitudinal Izz command, the user can use the Dynamic

Query, which can be initiated via the  icon, to query the distribution graph. To use this
functionality the user must select the View Izz command, toggle the Dynamic Query icon,
and move the mouse cursor over a particular portion of the graph. This will produce a text
box with graph data. Further, the user can echo this information to the Output window by
double-clicking the left mouse button while hovering over the graph entity of interest.
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Iyy

The View Longitudinal > Iyy command under the the Hull menu is used to display the FE
model's inertia properties about the y-axis for each section, as shown below.

In conjunction with the View Longitudinal Iyy command, the user can use the Dynamic

Query, which can be initiated via the  icon, to query the distribution graph. To use this
functionality the user must select the View Iyy command, toggle the Dynamic Query icon,
and move the mouse cursor over a particular portion of the graph. This will produce a text
box with graph data. Further, the user can echo this information to the Output window by
double-clicking the left mouse button while hovering over the graph entity of interest.
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Cross Sectional Area

The View Longitudinal > Cross Sectional Area command under the the Hull menu is used
to display the FE model's cross sectional area properties, as shown below.

In conjunction with the View Longitudinal Cross Sectional Area command, the user can use

the Dynamic Query, which can be initiated via the  icon, to query the distribution
graph. To use this functionality the user must select the View Cross Sectional Area
command, toggle the Dynamic Query icon, and move the mouse cursor over a particular
portion of the graph. This will produce a text box with graph data. Further, the user can echo
this information to the Output window by double-clicking the left mouse button while hovering
over the graph entity of interest.
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Neutral Axis

The View Longitudinal > Neutral Axis command under the the Hull menu is used to
display the FE model's neutral center, as shown below.

In conjunction with the View Longitudinal Neutral Axis command, the user can use the

Dynamic Query, which can be initiated via the  icon, to query the graph. To use this
functionality the user must select the View Neutral Axis command, toggle the Dynamic
Query icon, and move the mouse cursor over a particular portion of the graph. This will
produce a text box with graph data. Further, the user can echo this information to the Output
window by double-clicking the left mouse button while hovering over the graph entity of
interest.
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Shear Center

The View Longitudinal > Shear Center command under the the Hull menu is used to
display the FE model's shear center, as shown below.

In conjunction with the View Shear Center command, the user can use the Dynamic Query,

which can be initiated via the  icon, to query the graph. To use this functionality the
user must select the View Shear Center command, toggle the Dynamic Query icon, and
move the mouse cursor over a particular portion of the graph. This will produce a text box
with graph data. Further, the user can echo this information to the Output window by
double-clicking the left mouse button while hovering over the graph entity of interest.
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Warping Constant

The View Longitudinal > Warping Constant command under the the Hull menu is used to
display the FE model's warping properties, as shown below.

In conjunction with the View Longitudinal Warping Constant command, the user can use the

Dynamic Query, which can be initiated via the  icon, to query the distribution graph.
To use this functionality the user must select the View Warping Constant command, toggle
the Dynamic Query icon, and move the mouse cursor over a particular portion of the graph.
This will produce a text box with graph data. Further, the user can echo this information to
the Output window by double-clicking the left mouse button while hovering over the graph
entity of interest.
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Torsional Rigidity

The View Longitudinal > Torsional Rigidity command under the the Hull menu is used to
display the FE model's torsional rigidity properties, as shown below.

In conjunction with the View Longitudinal Torsional Rigidity command, the user can use the

Dynamic Query, which can be initiated via the  icon, to query the distribution graph.
To use this functionality the user must select the View Longitudinal Torsional Rigidity
command, toggle the Dynamic Query icon, and move the mouse cursor over a particular
portion of the graph. This will produce a text box with graph data. Further, the user can echo
this information to the Output window by double-clicking the left mouse button while hovering
over the graph entity of interest.



General 127

© 2014 Optimum Structural Design, Inc.

View Horizontal > 

The View Horizontal menu has several options to display the horizontal properties of the
modeled structure.   A detailed description of each of these options is below:

Net Force

Shear Force

Bending Moment
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Net Force

The View Horizontal > Net Force option is used to display the FE Model's horizontal net
force distribution.   Further, MAESTRO echoes this distribution to the Output window, which
is found at the bottom of the MAESTRO GUI. 

In conjunction with the View Horizontal Net Force command, the user can use the Dynamic

Query, which can be initiated via the  icon, to query the distribution graph. To use this
functionality the user must select the View Horizontal Net Force command, toggle the
Dynamic Query icon, and move the mouse cursor over a particular portion of the graph. This
will produce a text box with graph data. Further, the user can echo this information to the
Output window by double-clicking the left mouse button while hovering over the graph entity
of interest.

Shear Force

The View Horizontal > Shear Force option is used to display the FE Model's horizontal
shear force distribution.   Further, MAESTRO echoes this distribution to the Output window,
which is found at the bottom of the MAESTRO GUI. 

In conjunction with the View Horizontal Shear Force command, the user can use the

Dynamic Query, which can be initiated via the  icon, to query the distribution graph.
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To use this functionality the user must select the View Horizontal Shear Force command,
toggle the Dynamic Query icon, and move the mouse cursor over a particular portion of the
graph. This will produce a text box with graph data. Further, the user can echo this
information to the Output window by double-clicking the left mouse button while hovering
over the graph entity of interest.

Bending Moment

The View Horizontal > Bending Moment option is used to display the FE Model's
horizontal bending moment distribution.   Further, MAESTRO echoes this distribution to the
Output window, which is found at the bottom of the MAESTRO GUI. 

In conjunction with the View Horizontal Bending Moment command, the user can use the

Dynamic Query, which can be initiated via the  icon, to query the distribution graph.
To use this functionality the user must select the View Horizontal Bending Moment
command, toggle the Dynamic Query icon, and move the mouse cursor over a particular
portion of the graph. This will produce a text box with graph data. Further, the user can echo
this information to the Output window by double-clicking the left mouse button while hovering
over the graph entity of interest.
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View Transverse >

Shear Force

Bending Moment

Torsional Moment

Shear Force

The View Transverse > Shear Force option is used to display the FE Model's transverse
shear force distribution.   Further, MAESTRO echoes this distribution to the Output window,
which is found at the bottom of the MAESTRO GUI. 

In conjunction with the View Transverse Shear Force command, the user can use the

Dynamic Query, which can be initiated via the  icon, to query the distribution graph.
To use this functionality the user must select the View Transverse Shear Force command,
toggle the Dynamic Query icon, and move the mouse cursor over a particular portion of the
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graph. This will produce a text box with graph data. Further, the user can echo this
information to the Output window by double-clicking the left mouse button while hovering
over the graph entity of interest.

Bending Moment

The View Transverse > Bending Moment option is used to display the FE Model's
transverse bending moment distribution.   Further, MAESTRO echoes this distribution to the
Output window, which is found at the bottom of the MAESTRO GUI. 

In conjunction with the View Transverse Bending Moment command, the user can use the

Dynamic Query, which can be initiated via the  icon, to query the distribution graph.
To use this functionality the user must select the View Trasnverse Bending Moment
command, toggle the Dynamic Query icon, and move the mouse cursor over a particular
portion of the graph. This will produce a text box with graph data. Further, the user can echo
this information to the Output window by double-clicking the left mouse button while hovering
over the graph entity of interest.

Torsional Moment

The View Transverse > Torsional Moment command under the the Hull menu is used to
display the FE model's transverse torsional moment distribution, as shown below.
MAESTRO also echoes this distribution to the Output window, which is found at the bottom
of the MAESTRO GUI. 

In conjunction with the View Transverse Torsional Moment command, the user can use the

Dynamic Query, which can be initiated via the  icon, to query the distribution graph.
To use this functionality the user must select the View Transverse Torsional Moment
command, toggle the Dynamic Query icon, and move the mouse cursor over a particular
portion of the graph. This will produce a text box with graph data. Further, the user can echo
this information to the Output window by double-clicking the left mouse button while hovering
over the graph entity of interest.

Weight Summary

The Weight Summary command under the the Hull menu is used to produce weight
summary tables in the Output window, as shown below.
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4.9 Wave Menu

The Wave Menu is used to exercise the MAESTRO-Wave, Extreme Load Analysis, and
Spectral Fatigue Analysis modules and all of their options.
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MAESTRO-Wave

This option will open the MAESTRO-Wave dialog to create and run MAESTRO-Wave cases.

Regular Wave Database

This option will open the regular wave database and show results from any imported
MAESTRO-Wave .bmn/.smn files.

Wave Spectrum

This option allows the user to create new theoretical or user defined wave spectra.

Wave Scatter Diagrams

This option allows users to view and modify wave scatter diagrams.

Base Operational Profiles

This option allows users to view and modify operational profiles.
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SN Curves

This option allows users to view, modify, and create new SN curves.

Compute RAOs

This option allows users to compute RAOs from any imported .bmn/.smn files.

View RAOs/Statistics/Time Series

This option allows users to view results from any imported .bmn/.smn files.

Compute Design Wave

This option allows users to compute a design wave using short or long term statistics from
any  .bmn/.smn files.

Define Design Wave

This option allows users to define a custom design wave from any  .bmn/.smn files.

Clear RAO Plots

This option will clear any current RAO plots from the MAESTRO modeling space.

Define Spectral Fatigue Analysis

This option allows the user to define a wave spectral fatigue analysis or slamming fatigue
analysis load case. 

View Damage Ratio

This option allows the user to view the damage ratio results after running a fatigue load
case.

View Fatigue Life ( < 500 Years)

This option allows the user to view the fatigue life results after running a fatigue load case.

Define Extreme Stress Analysis

This option allows the user to calculate mean and extreme stress load cases from any
imported .bmn/.smn files and computed stress RAOs.
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4.10 Analyze Menu

The Analyze Menu is used to run global and local finite element analysis, limit state analysis,
and hull girder ultimate strength.

Global & Local FEA

This option will launch the Analysis/Evaluation dialog with the "Solve All Fine Mesh Models"
checked.

Global FEA

This option will launch the Analysis/Evaluation dialog.

Local FEA

This option will analyze any fine mesh models that exist in the current file.

Limit State Evaluation (Post FEA) >

These options will run only the limit state analysis for the selected limit states.  Note: finite
element analysis results are required to run just the limit state calculations.
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Individual Panel Evaluation

This option will launch the standalone panel evaluation dialog.

Hull Girder Collapse

This option will run the ALPS/HULL analysis if an ALPS/HULL model exists in the current
file.

Legacy Version of MAESTRO >

These menu options are for legacy users of MAESTRO and should only be accessed by
experienced users.

4.11 Results Menu

The Results menu allows the user several options to display and post-process the results
from the finite element analysis.

Deformed Model

This option will toggle on and off whether the model is displayed as deformed or
undeformed.  A check mark will appear next to this option in the menu if the model is in the
deformed view.  The Deformation Scale can be adjusted in the View Options dialog under
the Post-Processing section.

Stress >

For each load condition, MAESTRO calculates stresses for all finite elements.  The menu
items below provide access to recovering stresses in rods, beams, bare plates and stiffened
panels.  An important distinction between each element type's stress recovery will be
discussed in the Stress Results  sections, as well as additional details for each of the stress

recovery options.  The dynamic query icon  can be used to highlight and recover a
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specific element's analysis results.  Double-clicking the element will echo the results to the
Output tab.

Note:  the scale for the graphical representation of stress will remain the same if switching
between load cases, unless the maximum stress value is higher than the current scale's
maximum value.  To view the load case specific legend, turn off the stress view and then
turn it on again.

Directional

This option will toggle on or off the directional stress option.

Define Direction...

This option will launch the Define Stress Direction dialog.  

Show Direction

This option will toggle on or off whether small quills are placed on each element defining the
element's local X-direction.

Adequacy >

This option will provide the menu for the particular failure mode evaluation chosen during the
analysis.  For more information on each adequacy parameter and how to perform a failure
mode evaluation, please see the Failure Mode Evaluation section.

List >



MAESTRO 11.0.0138

© 2014 Optimum Structural Design, Inc.

Elements

This option will populate the Grid tab with a list of elements, their stresses, and adequacy
parameter results (if applicable).  The cells can be copied and pasted into a database
program, like Microsoft Excel, if desired.

Nodes

This option will populate the Grid tab with a list of the element nodes, their location, and their
displacement.  The cells can be copied and pasted into a database program, like Microsoft
Excel, if desired.

Reaction Forces

This option will list the reaction forces and moments in the Output tab for each constrained
node and total each force and moment direction at the bottom.

Negative Adequacy

This option will list the number of elements with a negative adequacy parameter and those
elements percentage of the total structural weight for the selected load case.

Optimization

This option will list the results of the previous optimization run, if available.

Export Output >

MS Excel

This option will open the Output dialog so the user can select which properties and results to
output.  MAESTRO will then automatically create a Microsoft Excel file of the selected output
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data.

Text File

This option will open a dialog allowing the user to save a text file of the elements, materials,
and results.

Contour

This option toggles on the stress contour view.  A check mark will appear next to the option
in the menu when contour plot is turned on.

4.12 Help Menu

The Help menu provides several resources to the user for help with MAESTRO.  A brief
description of each option is discussed below.
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MAESTRO Help

This option will launch the MAESTRO help file.  This can also be done by clicking the

MAESTRO Help icon .

FAQ

This option will launch the MAESTRO website FAQ section.  These FAQ are the same as
the ones found in the MAESTRO help file.

Forum

This option will launch the MAESTRO forum where MAESTRO users and technical support
personnel post tips, tricks, and technical support questions and responses.

Release Notes

This option will open the MAESTRO release notes providing a summary of new features and
fixed bugs.

Technical Support

This option will launch your desktop email program with an email pre-addressed to 
support@maestro.com.  

About...

This option will open the About MAESTRO dialog providing the currently installed version of
MAESTRO and copyright information.

mailto:support@maestro.com.
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4.13 Toolbars

The MAESTRO interface contains five toolbars to allow the user to access often used
commands with a single mouse click. These include the Standard  toolbar, the
Pre-Processing toolbar, the View toolbar, the Post-Processing toolbar, and the Refine
Element toolbar.  All commands associated with toolbar buttons can also be accessed via
the main menu.  

Please see the GUI Interface figure to see the toolbar layout.

Standard Toolbar

Pre-Processing Toolbar

Viewing Toolbar

Post-Processing Toolbar

Refine Element Toolbar

 Standard Toolbar

The Standard toolbar which is located at the upper left part of the interface just below the
main menu provides a fast and easy means of performing some common tasks.  Most of the
icons on the toolbar correspond to a specific file menu command. A brief description of the
action performed by each toolbar icon is given below:

 This icon creates a new modeler file.
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 This icon launches a dialog prompting the user to select the existing modeler file they
wish to open.

 This icon will save the current modeler file over the existing file name.  If no file name is
defined, it will prompt the user to name the file and then save.

 This icon will launch the print dialog allowing the user to print the a hardcopy of the
contents of the main display.

 This icon will launch the MAESTRO help file.

Pre-Processing Toolbar

The Pre-Processing toolbar which is located on the left side of the interface provides fast
and easy means of accessing the functions necessary to construct and load a finite element
model.

 This icon launches the Job Information dialog.  It is the same as selecting File > Job
Information... from the menu.

 This icon launches the Parts dialog.  It is the same as selecting Model > Parts >
Create/Modify from the menu.

 This icon launches the Materials dialog.  It is the same as selecting Model > Materials...
from the menu.

 This icon launches the Properties dialog.  It is the same as selecting Model >
Properties from the menu.

 This icon launches the Stiffener Layout dialog.  It is the same as selecting Model >
Stiffener Layout... from the menu.

 This icon launches the Reference Points dialog.  It is the same as selecting Model >
Nodes > Create/Modify > EndPoint from the menu.

 This icon launches the Additional Nodes dialog.  It is the same as selecting Model >
Nodes > Create/Modify > Additional Node from the menu.

 This icon launches the Strakes dialog.  It is the same as selecting Model > Elements >
Create/Modify > Strake from the menu.

 This icon launches the Compounds dialog.  It is the same as selecting Model >
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Elements > Create/Modify > Compound from the menu.

 This icon launches the Finite Element Quad dialog.  It is the same as selecting Model >
Elements > Create/Modify > Quad from the menu.

 This icon launches the Finite Element Triangle dialog.  It is the same as selecting Model
> Elements > Create/Modify > Triangle from the menu.

 This icon launches the Finite Element Beam dialog.  It is the same as selecting Model >
Elements > Create/Modify > Beam from the menu.

 This icon launches the Finite Element Rod dialog.  It is the same as selecting Model >
Elements > Create/Modify > Rod from the menu.

 This icon launches the Finite Element Spring dialog.  It is the same as selecting Model
> Elements > Create/Modify > Spring from the menu.

 This icon launches the Finite Element RSpline dialog.  It is the same as selecting Model
> Elements > Create/Modify > RSpline from the menu.

 This icon launches the Finite Element Bracket dialog.  It is the same as selecting Model
> Elements > Create/Modify > Bracket from the menu.

 This icon launches the Deletion dialog.  It is the same as selecting Tools > Deletions >
Select from the menu.

 This icon launches the Groups dialog.  It is the same as selecting one of the group types
from the Groups menu.

 This icon launches the Restraints dialog.  It is the same as selecting Model > Define
Restraints... from the menu.

 This icon launches the Loads dialog.  It is the same as selecting Loads >
Create/Modify... from the menu.

 This icon launches the Evaluation Patch dialog.  It is the same as selecting Model >
Evaluation Patch > Create/Evaluate from the menu.

Viewing Toolbar

The Viewing toolbar which is located at the top of the modeling space provides the various
viewing options for the model.  These options can be helpful from constructing the model all
the way through post processing.



MAESTRO 11.0.0144

© 2014 Optimum Structural Design, Inc.

 This icon launches the View Options dialog.  It is the same as selecting View >
Options... from the menu.

 This icon allows the user to click a part in the model space to set it as the current part.
It is the same as highlighting a part in the parts tree and right-clicking and selecting Set
Current Part or selecting Tools > Set Current Part from the menu.

 This icon allows the user to click a part in the model space to set it as the current view.
It is the same as highlighting a part in the parts tree and right-clicking and selecting Set View
Part or selecting Tools > Set View Part from the menu.

 This icon allows the user to click a part in the model space to set it as the current part
and current view.  It is the same as highlighting a part in the parts tree and right-clicking and
selecting Set Current & View Part or selecting Tools > Set Current & View Part from the
menu.

 This icon allows the user to click a module in the model space and set it as a
Transparent view.  It is the same as highlighting a part in the parts tree and right-clicking
and selecting Set Transparency On.

 This icon allows the user to click a transparent view module and return it to the standard
element type view.  It is the same as highlighting a part in the parts tree and right-clicking
and selecting Set Transparency Off.

 This icon toggles the view between solid and wireframe.

 This icon toggles node visibility as on or off.

 This icon will toggle on and off stiffeners.  This is the same as opening the View Options
dialog and checking "Stiffeners".

 This icon will toggle on and off the water plane.  This is the same as opening the View
Options dialog and checking "Water Plane".  Note, to turn on the CG and CF markers, you
must still open the View Options dialog.

 This icon toggles the background color between black and white.

 This icon will hide the elements outside of the defined range for the current plot.

 This icon will toggle shrink elements on or off.

 This icon enables dynamic rotation of the model. After selecting this toolbar button, use
the left mouse button to rotate the model. Use a left down-click to rotate the model, and
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release the mouse button to set the new view angle. The command equivalent of this item is
Set-View-Angles.

NOTE: The user also has the choice of using the wheel button (if available) to invoke the
dynamic rotation functionality. Simply move the mouse while simultaneously holding the
wheel button down.

 This icon rotates the model about the global X-axis each time it is clicked.

 This icon rotates the model about the global Z-axis each time it is clicked.

 This icon rotates the model about the global Y-axis each time it is clicked.

 This icon will toggle the direction of any sign sensitive command. Rotations will occur in
a positive direction and zoom command will magnify views when the "+" is enabled and
conversely, rotations will be in a negative sense and zooming will zoom out when the "-" is
enabled.

NOTE: Icons only flip/rotate the model in constant increments of 15 degrees. To rotate the
model to a specific angle, execute View > Set View > Specify from the menu. The user is
then prompted to supply the angle of rotation as an argument in the Command Line. Specific
angles can also be achieved dynamically through the dynamic rotation toolbar button.

 This icon will toggle the view of the Parts Tree on or off.

 This icon allows the user to select an element type to apply the Quick Create
functionality to.

 This icon is for the "Cancel" command. Clicking on this toolbar button will cancel any
action that is currently being executed and also clears the command stack.  This is the same
as pressing the Esc key.

 This icon allows the user to query the model, dependent on the current view, by
moving the mouse cursor over an element. To see more uses, read about the view options
in the View Menu, the Loads Menu, and the dynamic query's ability with Creating and
Evaluating Evaluation Patches, and Post-Processing of Failure Mode Analysis.

Post-Processing Toolbar

The Post-Processing toolbar which is located at the top of the modeling space provides
quick access to functions to balance, analyze and post-process the model.

 This drop-down menu allows the user to quickly switch between defined
load cases and also shows which load case the current results shown are for.
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 This icon launches the Balance dialog.  It is the same as selecting Model > Balance...
from the menu.

 This icon toggles the Contour results plot on and off.

 This icon is used with composite layers analysis.

 This icon launches the Animation dialog.  It is then used to toggle the animation on or
off.

  This icon will force any animation that is running to stop.

 This icon launches the Analysis dialog.  Clicking the drop-down arrow allows the user
to select the analysis type.

Refine Element Toolbar

The Refine Element toolbar which is located on the right side of the modeling space is used
to quickly and easily convert coarse mesh elements into finer mesh elements.

 This icon allows the user to double-click a strake panel and MAESTRO will automatically
convert it to a quad element.

  This icon allows the user to double-click a full strake and split it into two identical
strakes.

 This icon allows the user to double-click a quad element and MAESTRO will
automatically split the quad into two quads.

 This icon allows the user to double-click a quad element and MAESTRO will
automatically split the quad into three quads.

 This icon allows the user to double-click a quad element and MAESTRO will
automatically split the quad into four quads.

 This icon allows the user to double-click a quad element and MAESTRO will
automatically split the quad into a quad and a triangle.

 This icon allows the user to double-click a quad element and MAESTRO will
automatically split the quad into two quads and a triangle.
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 This icon allows the user to double-click a quad element and MAESTRO will
automatically split the quad into two triangles.

 This icon allows the user to double-click a quad element and MAESTRO will
automatically split the quad into three triangles.

 This icon allows the user to double-click a triangle element and MAESTRO will
automatically split the triangle into two triangles.

 This icon allows the user to double-click a triangle element and MAESTRO will
automatically split the triangle into a triangle and a quad.

 This icon allows the user to double-click a triangle element and MAESTRO will
automatically split the triangle into four triangles.

 This icon allows the user to double-click a triangle element and MAESTRO will
automatically split the triangle into three quads.

 This icon allows the user to double-click a rod or beam element and MAESTRO will
automatically split the rod or beam into two elements.

 This icon allows the user to double--click a beam element and MAESTRO will
automatically split the beam element into two quads for the beam web and 2 quads for the
beam flange (if applicable).

 This icon allows the user to double-click a beam element and MAESTRO will
automatically split the beam element into two quads for the beam web and 2 rods for the
beam flange (if applicable).

 This icon allows the user to double-click a beam element and MAESTRO will
automatically convert the beam web to a quad and the flange to a quad (if applicable).

 This icon allows the user to double-click a beam element and MAESTRO will
automatically convert the beam web to a quad and the flange to a rod (if applicable).

  This icon allows the user to double-click a stiffened strake or quad element and
MAESTRO will automatically convert the internal stiffeners to beam elements and split the
plate element into multiple elements.

 This icon allows the user to merge two elements into one by clicking the first element
and then double-clicking the second element to be merged.

 This icon allows the user to double-click a bracket element and MAESTRO will
automatically convert the bracket to a triangle and a rod.
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4.14 Standard Views

MAESTRO has several default views that will automatically orient the model for viewing. 
These views can be accessed from the View > Set View > menu, or by right-clicking in the
modeling space and selecting from the menu.  MAESTRO also allows the user to create 
Named View, which can be saved and called up like a default view.

Body Plan

Profile View

Plan View

Isometric Views

Body Plan
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Profile View

Plan View
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Isometric Views (SouthEast, SouthWest, NorthEast, NorthWest)

SouthEast
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SouthWest
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NorthEast
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NorthWest
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4.15 Named Views

MAESTRO allows the user to create their own model orientation view and save this view to
be loaded later.  In addition to saving the model orientation, the Named View will save the
View Options, user-defined range, and view type (plate thickness, stress plot, element type).

The Named View menu can be launched from the View > Set View > Named View... menu
or by right-clicking in the modeling space and selecting Named View.
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Creating a New Named View

1.  Set the model to the orientation and options desired.

2.  Open the Named View dialog.

3.  Type a name into the drop-down menu.

4.  Click the Create/Modify button.

Modifying a Named View

1.   Set the model to the new orientation and options desired.

2.  Open the Named View dialog.

3.  Select the Named View from the drop-down menu to modify.

4.  Click the Create/Modify button.

Selecting a Named View

1.  Open the Named View dialog.

2.  Select the desired view from the drop-down menu.

3.  Click the Select button.

Deleting a Named View

1.  Open the Named View dialog.

2.  Select the desired view from the drop-down menu.

3.  Click the Delete button.
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4.16 Using the Mouse & Shortcut Keys

Left Mouse Button

Right Mouse Button

Mouse Wheel

Keyboard Shortcuts

Left Mouse Button

The left button is used to select any menu item, toolbar item, parts tree item, and groups
tree item. The left button is also used to interact with MAESTRO's many dialog boxes. In
conjunction with Finite Element, Reference Points, Compounds, and Strakes dialog boxes,
the user can select the closest entity. It is important to note that the user must first click in
the ID field of the dialog box to select the entity of interest. 
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Right Mouse Button

The right button is used to invoke various quick access menus. The quick access menu will
differ depending on where the cursor is located in the GUI.

Main Display Area

When the mouse cursor is located in the main display area, the user, with the click of the
right button, will access the menu shown below. This menu item allows the user to set the
current view projection. Here, the user can choose from a list of viewing operations and
standard views. This menu also allows the user to toggle a perspective projection on or off
as well as copy the current display. 

Parts Tree Area

When the cursor is located in the Parts Tree area, the user can access a parts quick menu.
This menu allows the user to set part attributes, modify parts, and query parts, as shown
below. 
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Groups Tree Area

When the cursor is located in the Groups area, the user can access a groups quick menu.
This menu allows the user to set group attributes, modify groups, and query groups, as
shown below. 

Command Line, Output Window, and Grid Window

When the cursor is inside the area of one of these tabs, which are located at the bottom of
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the MAESTRO GUI, the right-click will access various quick menus. These quick menus are
shown below.

Mouse Wheel

The wheel button is used to zoom and pan in your modeling space without using any
MAESTRO commands.

Roll Wheel

Rotate the wheel forward to zoom in and backwards to zoom out. Use the Shift and CTRL
key to accelerate zooming.

Hold Wheel

Hold down the wheel button and drag the mouse to dynamically spin the model around.

Hold Wheel + Hold Shift
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Hold down the Shift key and the wheel button, then drag the mouse to dynamically pan the
model.

Hold CTRL + Single Click Wheel

Hold the CTRL key down and then single click the wheel button, this combination invokes
the Cutting Planes command.

Keyboard Shortcuts:

· <Esc>        =  key invokes the cancel command
· <Ctrl + n>  =  Endpoints and Additional Nodes dialog
· <Ctrl + e>  =  Finite Element dialog
· <Ctrl + k>  =  Strake dialog
· <Ctrl + d>  =  Deletion dialog
· <Ctrl + g>  =  Groups dialog
· <Ctrl + r>   =  Restraints dialog
· <Ctrl + l>   =  Loads dialog

4.17 Dialog Box Conventions

The MAESTRO interface makes extensive use of dialog boxes to guide the user in
developing the structural model. Detailed descriptions of how to use these dialog boxes are
provided in later sections.

Dialog boxes in MAESTRO are one of two types; modal or modeless. Modal dialog boxes
require the user to complete interaction within the dialog and close it before continuing with
any further interaction with the program. They are used for operations that are performed
infrequently and which can be completed in a single train of thought. Examples of operations
in MAESTRO which employ modal dialogs include setting the units system, setting
MAESTRO job information, and setting viewing options. Modeless dialog boxes, on the other
hand, allow the user to interact with the any part of the program while they are open. They
are used for repetitive operations and for operations where the user needs to interact with
the display area while the dialog box is open. For example, when creating many structural
elements, the user would not want to open the Finite Elements dialog box to create each
element. Furthermore, while the Finite Elements dialog is open, the user might like to select
a node in the Main Display area. This is only possible with a modeless dialog box. Most of
MAESTRO's dialog boxes are modeless including the node dialog, element dialog, strake
dialog, compound dialog, materials dialog, properties dialog, and stiffener layout dialog. In
addition to the aforementioned benefits, modeless dialog boxes allow the user to switch
between creating nodes, elements, and strakes without having to individually open and close
each dialog.



General 161

© 2014 Optimum Structural Design, Inc.

Modeless dialog boxes that contain references to other data (e.g., material and/or scantling
properties) have buttons that provide quick access to the dialogs used to define this data.
For example, the dialog for creating Quadrilateral elements contains buttons labeled
Property and Layout, which relate to the plating and the stiffeners, respectively. Clicking
these buttons will invoke the appropriate dialog box to allow the user to review the values
associated with a particular data item, modify that item if desired, or define a new item. For
example, plating has two properties: thickness and material type. If the user was creating a
new quad element and found that the desired combination of thickness and material type
was not in the Property drop-down list because it had not yet been defined, he/she could
click the Property button to define the new combination.

4.18 GUI Conventions

MAESTRO's graphical user interface is compatible with Microsoft’s Windows® operating
systems. As such, most of the interface conventions will already be familiar to the user. The
purpose of this section is to document those interface conventions which are peculiar to
MAESTRO such as initiating interactive agents and getting the next available ID.

The first convention worth noting relates to use of the mouse. It is assumed that a
two-button + "wheel" Windows-compatible mouse is available. In practically all instances
where a reference is made to a mouse click or a selection with the mouse, it is intended that
the user click the left mouse button. In any case where it is necessary to deviate from this
convention, a special note will be made.

Part of the power of MAESTRO lies in its ability to link complex descriptions of structural
items to a simple visual description in the graphics display. Take the simple case of a strake.
Strakes contain a multitude of data describing their behavior in the structure as a whole. It is
useful for the user to simply point at a strake of interest in the graphical display in order to
query that element for its structural data. Once the user has selected the strake of interest,
he/she may want to change one of the strake’s defining endpoints by clicking on a new
endpoint in the display. Performing these operations involves initiating an interactive agent
which informs the program that you are about to select something in the graphics display
and you wish the program to do something in response. In MAESTRO the mechanism used
to initiate interactive agents from a dialog box is to set the focus in the field in question. For
the strake example, the user clicks (with the left mouse button) in the ID field to initiate the
agent and then clicks in the graphics display on the strake of interest. If the selection is
successful, all of the fields in the strake dialog box will be updated with the data for the
selected strake. If the user now wishes to define this strake’s endpoint 1, click in the
endpoint 1 field to initiate the agent then select the desired endpoint in the graphics display.
This convention of setting the cursor focus to a field to initiate an interactive agent occurs in
all of the dialog boxes where such operations are logical.

Another consistent interface convention in MAESTRO relates to specifying item identification
numbers (ID’s) for various structural items. Many of the data items found in MAESTRO
occur in large lists such as elements, nodes, properties, materials, etc. It is therefore
necessary to have a unique means of identifying these items for them to be useful. In
MAESTRO this unique identification takes the form of a numerical ID. ID values must be
positive integers. Most times when creating a new item from a dialog box the user is not
concerned with what ID an item has but simply wishes to get a unique ID. To accomplish this
in any of MAESTRO’s dialog boxes the user merely clicks the ID button. This will get the
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next available ID in the particular list in question. Note that any numbering holes will be
ignored. If the user has 10 properties defined numbered 1 through 10, deletes property
number 5, then clicks the ID button, the ID field is filled with 11 not 5.

Although all structural items in MAESTRO must have an ID many of them can also have a
name. Named items include materials, properties, stiffener layouts, strakes, compounds,
and of course modules and substructures. In each of these cases (with the exception of
modules and substructures) the names are optional, meaning that they can be left blank.
However, it is often very convenient to name items for easy reference later. The clearest
example of this is material names. It might be difficult for the user to remember that material
13 was supposed to be aluminum, but by naming this material it would be obvious later,
when specifying a plate’s material, which material was to be selected. The names of like
items must be unique within a particular list. The user could not have two materials named
aluminum with slightly different properties. In general the user should make item names as
detailed as necessary to avoid future confusion about what is contained in that item.

4.19 View Options

Toolbar  

Menu  View > Options...

The View Options dialog allows the user to control a wide variety of viewing options including
element/node visibility, rendering algorithms, viewport layout, etc. 

The View Options dialog can be launched from the toolbar, or from the View > Options... 
menu.
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Labels & Entities Visibility

The view of the elements listed in the dialog can be toggled On and Off by clicking the check
box.  Several of the elements can also be toggled to On w/label which will show element
IDs, Water Plane CGs, or Strake IDs.

Scale

The Scale section of the View Options dialog allows the user to scale the graphic view of
several entities.  For example, the Restraints scale can be used to lengthen the graphic
representation of the restraints from the View > Restraints menu option.

Tools & View Style



MAESTRO 11.0.0164

© 2014 Optimum Structural Design, Inc.

Viewports

This section of the View Options dialog allows the user to switch between a single, split, or
four view workspace.  For more detailed information on these views, please see the 
Workspace Layout section.

Video Driver Options

The recommend settings in the View Options dialog are:

Rendering Options: Hardware Z-buffer

Video Driver: OpenGL Driver

Driver Options: Double Buffering

The Video Driver and Driver Options can be found by clicking the Advanced... tab in the
View Options dialog.

The Tools & View Style sections also allows the user to select between a variety of viewing
options and whether construction geometry, cutting planes and the world axes are visible.

Plot Legend

This section allows the user to change the default settings of the legend when plots are
shown.

Pre/Post-processing
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Deformation 

Direction: The direction option allows the user to plot the deformation in all or only one
direction (i.e. X, Y, Z) at a time.

Scale: The deformation scale allows the user to adjust the magnitude (e.g. "1" is the true
deformation scale) of the deformed model view.  Note: the model must be in a deformed
view to adjust the deformation scale.

Range

When a view is selected with a legend of values, this range is automatically populated with
the maximum and minimum values.  The Min and Max can be overridden with user-defined
values by checking the Apply Defined Range box and inputting new numbers.

Corner Stress

When this option is checked, the stress contour plot is based on elemental nodal stress.  If it
is unchecked, the stress contour plot is based on the average elemental centroidal stress.

ALPS/HULL

When ALPS/HULL results are available, this option allows the user to turn on results, turn on
results with the moment curve displayed, or turn off the results.

4.20 Auto Save and Recover Model

Auto Save

MAESTRO has an auto save function, which will automatically backup the model after a set
number of hard commands.  A "hard" command is any command where something in the
model is created, modified, or deleted.  For example, creating a strake or modifying a
material property is considered a "hard" command.  Changes to the graphics view, i.e.
model view orientation, is not considered a "hard" command.

To set the frequency of the automatic backup, select File > Autosave... from the menu.
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This will open the AutoSave Frequency dialog box.

Input the number of "hard" commands before each auto backup and click OK to save.  An
#autosav.rcv file will automatically be generated in the MAESTRO/System directory.

Model Recovery

Option #1

In the event that MAESTRO does not respond, or the program crashes, you can  recover
your model by selecting File > Recover Model from the menu.  This will access the
#autosav.rcv file automatically generated during Auto Save (as described above).  The
#autosav.rcv file is created based on the user-defined AutoSave Frequency and is stored in
the MAESTRO/System directory.

Option #2

Alternatively, a filename.bck file is created and saved in the location of the current .mdl file.
 Open the location where the original model was saved.  You will see a filename.mdl and
filename.bck.  The filename.bck file can be opened directly by MAESTRO; this is your
recovered modeler file.

4.21 Cutting Planes

The cutting plane functionality can be found under the Tools > Cutting Planes. Cutting
planes can also be found by right clicking and selecting  Cutting Planes.
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Cutting planes are planes in space which delineate visible and invisible regions of space. A
user can insert a cutting plane into the model and specify which side is visible and which is
invisible.  This can be very useful at times, such as when wishing to view only the interior of
a full hull model. By placing a longitudinal cutting plane at the origin and hiding the port side,
the interior of the starboard model is made visible. The user can create cutting planes
aligned with any of the principal axes or define a cutting plane with arbitrary orientation. In
addition, the user can specify a cutting slice in which two closely spaced cutting planes are
placed in the model with their visible side being the region between them. 

As with all of the View commands, Cutting Planes only alters the view on the display; it does
not actually change the model. The user can add any number of cutting planes to the model
and they are stored with the particular part in which they are defined. Cutting planes do not
persist in the model if it is saved and retrieved.

YZ Plane

Places a cutting plane in the YZ plane. YZ Plane issues a prompt to specify
first a point on the cutting plane and second a point on the visible side of the
cutting plane. These points may be specified by clicking on a point in the
modeling space or entering the coordinates in the form of (x, y, z), at the
command line.

ZX Plane

Places a cutting plane in the ZX plane. ZX Plane issues a prompt to specify
first a point on the cutting plane and second a point on the visible side of the
cutting plane. These points may be specified by clicking on a point in the
modeling space or entering the coordinates in the form of (x, y, z), at the
command line.
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XY Plane

Places a cutting plane in the XY plane. XY Plane issues a prompt to specify
first a point on the cutting plane and second a point on the visible side of the
cutting plane. These points may be specified by clicking on a point in the
modeling space or entering the coordinates in the form of (x, y, z), at the
command line.

YZ Slice

Erases everything from the display not lying in the specified YZ plane (plus the
thickness of the slice). YZ Slice issues a prompt to specify a point on the
desired plane. This point may be specified by clicking on a point in the
modeling space or entering the coordinates in the form of (x, y, z), at the
command line. The default slice thickness is defined internally in the Modeler
as 10 cm.

ZX Slice

Erases everything from the display not lying in the specified ZX plane (plus the
thickness of the slice). ZX Slice issues a prompt to specify a point on the
desired plane. This point may be specified by clicking on a point in the
modeling space or entering the coordinates in the form of (x, y, z), at the
command line. The default slice thickness is defined internally in the Modeler
as 10 cm.

XY Slice

Erases everything from the display not lying in the specified XY plane (plus the
thickness of the slice). XY Slice issues a prompt to specify a point on the
desired plane. This point may be specified by clicking on a point in the
modeling space or entering the coordinates in the form of (x, y, z), at the
command line. The default slice thickness is defined internally in the Modeler
as 10 cm.

Specify

Cutting planes can have any arbitrary orientation in space. This command
places a cutting plane with a user-specified orientation. The user is prompted
to specify a vector normal to the plane, a point on the plane, and a point on the
visible side of the plane. These points may be specified by clicking on a point
in the modeling space or entering the coordinates in the form of (x, y, z) at the
command line. For example, to generate a cutting plane that is parallel to the Y
axis, but is at a 45° angle to both the X and Z axes, specify a normal vector of
(1,0,1), an origin of (0,0,0), and the visible side by clicking on a point on the
model.

Delete Removes all cutting planes from the model and restores the active viewport.

Dynamic XY

A dynamic XY cutting plane allows for the user to click and dynamically cut into
the hull, starting at centerline and cutting into either port or starboard by
dragging the mouse in the respective direction.

Dynamic YZ

The dynamic YZ plane cuts longitudinally from the x position that the user
clicks along the vessel. For most accurate results for initial cut point try cutting
in profile view.

Dynamic ZX

The dynamic ZX plane cuts vertically from the y position that the user clicks
above the baseline. For most accurate results for initial cut point try cutting in
body plan view.
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4.22 Security Devices

The topics in this section provide details of how to updated the security device, the Fast
Lock utility and details regarding the use of network security devices.

4.22.1 Updating Security Device

It is very important you first have the two passwords available that were provided by the
distributors. If you do not have these passwords, you should contact the distributors before
continuing. These passwords will allow the proper operation of MAESTRO and other
optional modules.

If you are experiencing any problems with your security device please contact 
support@maestromarine.com. 

Procedure for Updating the Security Device

To update your security device, perform the following steps:

1.  Locate passwords that have been provide by the distributors or your MAESTRO dealer. 
If you do not have passwords, you will only be able to view the security device information. 
Please contact support@maestromarine.com regarding passwords.

2.  Attach the security device to the USB port.

NOTE: PARALLEL PRINTER PORT SECURITY DEVICES ARE NO LONGER
SUPPORTED.

3.  Click MAESTRO Fast Lock from the Start > Program Files > MAESTRO menu.  The
dialog below will appear.

mailto:maestrosupport@orca3d.com
mailto:support@maestromarine.com.
mailto:support@maestromarine.com
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4.  Choose Read Lock from the File menu.  At this point the Fast-Lock utility will report your
current options.

5.  Choose Set Passwords... from the Edit menu.  The dialog below will appear.
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6.  Enter both Password 1 and Password 2.

7.  Click OK.  The lock is now updated.

4.22.2 Fast Lock - Security Device Utility

Fast Lock is a utility that allows the user to update and maintain their MAESTRO security
device. This utility provides the capability to remotely update the user's maintenance and
support as well as update the user's optional modules. Outside of updating the security
device, the Fast Lock utility is used to inform the user of the device's current configuration. If
you are experiencing any problems with your security device please contact technical
support at support@maestromarine.com. 

Interface

The Fast Lock interface is very easy to use and understand (nearly self-explanatory); a brief
description follows.

File Menu

Using the File menu, the user can execute the Read Lock, Print, Print Setup, and Exit
commands.

Edit Menu

The user can execute the Set Passwords... command using this menu item.  The Set
Passwords dialog, seen below, will then prompt the user to enter two passwords, which is
provided by the distributors or your local MAESTRO dealer.

mailto:support@maestromarine.com.
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View Menu

Using this menu, the user can toggle on/off the Toolbar an Status bar.

Help Menu

This menu provides Fast Lock version information.

Current Lock Settings

This area of the Fast Lock interface displays security device information. This information
includes Lock Type, Number of Users, License Number, Expiration Date, Support Due Date,
and Last Run Date.

Enabled Modules

This area of the Fast Lock interface displays modules that are enabled.

4.22.3 SafeNet Network Lock

MAESTRO relies on a hardware lock to provide license security. MAESTRO can be run in a
network environment in which MAESTRO is installed and used on many client workstations
with security handled by a single hardware lock installed on a central server machine.
Interaction between MAESTRO and the hardware lock is handled by a security server
program that must be running on the server machine where the lock is installed. The system
that handles network security is known as Sentinel Protection Server and is developed by 
SafeNet, Inc.

http://www.safenet-inc.com/
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The installation of all security components, including the Sentinel Protection Server, is
bundled into the installation of MAESTRO.  Please refer to the SafeNet ReadMe.pdf file,
which can be found in the following directory: ...\MAESTRO\System\Sentinel

NOTE:

MAESTRO has a mechanism to release a network license 10 minutes after a crash occurs. 
Alternatively, a user with Administrator computer privileges can Restart the Sentinel
Protection Server manually via the MS Windows Services dialog.  See the About Sentinel
License Monitor section of the SafeNet ReadMe.pdf for further troubleshooting tips.

4.23 Installation Directory and Sample Files

By default, MAESTRO is installed in a MAESTRO directory located in the user's Program
Files.  Upon a successful installation of MAESTRO, the following two directories will be
created: Help and System.  A third directory Models and Samples will be created in the
user's ProgramData folder.

Help Directory

The Help directory contains the electronic manual in both Compiled HTML Help File (*.chm)
and Adobe Acrobat (*.pdf) formats.  Supporting manuals, i.e. MAESTRO Basic Features
Tutorial, Legacy Data Prep Manual, and MAESTRO Release Notes, are also included in this
directory.

System Directory

The System directory contains all of the necessary files that allow MAESTRO to function
properly.  These files should not be removed or modified.  The System directory also
includes support files and documentation for the Sentinel security device in the event
troubleshooting is required.

Models and Samples Directory

The Models and Samples directory contains a variety of MAESTRO example models,
verification models, sample programs (C++/C#) and other data to assist the user in learning
and understanding MAESTRO.  All of the data found in this directory is appropriately
referenced throughout the documentation.  If you are running Windows Vista or Windows 7,
your Models and Samples directory will be installed under the user's Program Data folder.
Note: this folder's view may be set to "hidden."
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5 Geometry/Finite Element Modeling

The topics in this section provide detailed information on the MAESTRO functionality used
during the Finite Element Modeling stage of an analysis.

5.1 Model Organization

Elements

Strakes and Modules

Substructures

In the design of large structures it is usually advisable to divide the task into a few distinct
subtasks in order to maintain a good overview and control of the design. Most large
structures can be reduced to several levels of component structures for which the design
and analysis is relatively independent. Such a structure can best be modeled by subdividing
it into a hierarchy of parts, down to the module level, and then constructing each module
using a three-dimensional mesh of nodes and appropriate groupings of finite elements. As
shown below in Figure 1, the MAESTRO structural modeling is organized into four levels:
members (elements), strakes, modules, and substructures.
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Figure 1 Hierarchy of Structural Modeling

MAESTRO Elements

The basic unit of structural modeling is a principal member such as a transverse frame (red
beam), stiffened panel (dark blue), girder (yellow beam), rod (brown line), etc., as shown
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below in Figure 2. In order to have an efficient interaction between the finite element
analysis and the optimization, the finite elements in MAESTRO are in most cases the same
as the principal members. The elements are therefore relatively large; e.g. a complete panel
from one deck to another and from one frame to the next, or a corresponding segment of a
transverse frame or longitudinal girder. The finite element types most commonly used in
MAESTRO are described below.

Figure 2 MAESTRO Elements

CQuadR Stiffened Panel

This is the most general and hence most useful panel element in MAESTRO, and it is the
default element for all panels (strakes and quads). It is an orthotropic shell quadrilateral that
automatically includes the bending stiffness if the stiffeners in either the longitudinal or the
transverse direction. It is the same element as in the NASTRAN program, but in MAESTRO
the (quite large) task of calculating the orthotropic properties is automated.  The CQuadR
element is a 4 noded flat shell element with each node having 6 degrees of freedom.

Hybrid CBAR Beam Element
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This element has been developed for modeling of beams (frames, girders, additional beams)
attached to plating. The plating acts as one of the flanges of the beam, and MAESTRO
takes this into account in calculating the beam’s flexural properties, using a user-specified
effective breadth of this plate flange. In contrast, the axial stiffness is for the beam only
(which is why element is called "hybrid") because the in-plane stiffness of the plating is
accounted for by the panel element.  The neutral axis location and the moment of inertia of
each hybrid beam are automatically calculated and printed. In a finite element model, a
beam element is nothing more than a "line" element, joining two nodes and setting up a
relationship between their displacements and rotations. For this reason most finite element
programs display a beam element simply as a line. In that case they do not look like real
beams, and they can be difficult to see, especially in a large model. In order to make the
beam elements more visible and more realistic, MAESTRO displays them as "web panels";
that is it displays the web of the beam, but not the flange.

CTRIR Triangle Element

This is a flat, constant strain element that can be placed between any three nodes in a
module.

CRod

The rod element is a pin-jointed bar which can connect any two nodes in a module.  The rod
element can carry axial force and axial torsion only.

Compound

This consists of any user-defined assemblage of in-plane membrane elements (bar, beam,
triangle and quadrilateral elements) in any transverse section of any module.

CELAS2 Spring Element

The spring element is a linearly elastic spring which can connect any two nodes in a module.
These elements can carry either force or moment loads.  Forces in the spring element will
cause translational displacement and moments will cause rotational displacement.

Restraint Elements

MAESTRO has three types of restraint elements.  The RBE2 element is a rigid element,
while the RBE3 and RSPLINE element are interpolation elements.  RSpline elements can
act as a boundary element when conducting a fine mesh model.  The three restraint
elements offered by MAESTRO are described below:

RSpline: Transmits displacements to a group of nodes located between the two defined
reference nodes.  These translations are prescribed from the slope and displacement of
a flexible, tubular beam element connecting the two reference nodes.  This is the type
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of RSpline element used to transfer displacement from coarse mesh nodes to fine mesh
nodes.

RBE2: Used to create a rigid body connection between a group of dependent nodes
and one independent reference node.  An RBE2 element is usually used to model areas
that are very stiff compared to the adjacent structure.

RBE3: Used to transmit motion between a group of nodes and one reference node. 
The motion at the reference node is the least square weighted average of the motions
at the other nodes.  An RBE3 element is used to transfer forces and moments from the
reference node to several dependent nodes without adding stiffness to the structure.

Strakes and Modules

Figure 3 below, shows an example of a module, which is a portion of structure having the
following properties:

· It has one direction (regarded as its "lengthwise" direction) along which there are regularly
spaced transverse planes or sections, which constitute either the locations or the
boundaries of some or all of the individual structural members.

· Within each transverse section the layout of the members is similar, and in the lengthwise
direction the geometry of each section is either constant or linearly varying depending on
the endpoint definitions.

· Members that occur repeatedly tend to have the same local structural dimensions; that is,
plate thickness and flange and web widths and thicknesses. (These are sometimes
referred to as "scantlings"). 

Because of a module’s geometric regularity and uniformity of scantlings in the lengthwise
direction, it is convenient to regard a module as being made up of "strakes". As shown in
Figure 3, a strake is a lengthwise row of stiffened or un-stiffened panels, frame segments
and, optionally, a longitudinal girder along edge one of the strake. 

The location of beams and panels is not limited to strakes; they can also be inserted
individually at other locations and at various orientations. 
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Figure 3 MAESTRO Terminology

Each module has its own three-dimensional nodal mesh defined within the module’s
reference system. This mesh is generated by specifying the location of endpoints in a
transverse plane at both ends of the module. These end planes are called the reference
plane and the opposite plane. The program then creates a node at each user-defined
section location between the reference and opposite endpoint.

Once the nodal mesh has been defined, strakes are then created by specifying the pair of
endpoints that are in line with the sides of the strake. Strakes and sections are numbered
sequentially, as are the intervals between the sections. The program uses the terms
"strake", "endpoint", "section" and "module" to refer to locations within the structural model.
For example, the first panel in the keel strake is located at "strake 1, section interval 1".
Each strake extends for the full length of the module and has uniform scantlings. However,
shorter strakes and changes in scantlings can be obtained by assigning two (or more)
strakes to the same pair of endpoints and then selectively deleting portions of each.  Also,
various combinations of scantlings can be obtained by deleting the unwanted strake
elements and inserting "additional" elements in their place. MAESTRO provides an element
deletion feature that makes this relatively easy.

Frames need not occur at every section; they can occur at every other section, specific
sections only, or not at all. The total length between frames is referred to as a bay. This
means that each structural panel, which by definition extends from one frame to the next can
be comprised of two panel elements or three panel elements, or any number (n). The only
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limitation is that n must divide evenly into the highest section number in the module. Note
that section numbering begins with zero.

Any of the nodes lying in the two end planes of a module can be moved lengthwise, out of
their plane, by any (differing) amount, thus allowing the modeling of complex end shapes
and the joining of modules at arbitrary angles or orientations. Note that this does not move
the end sections or change the end values or section spacing.

Substructures

A substructure is a set of modules which are generally associated with each other, e.g. ,
bow, midbody, and stern. The substructures are merely a convenient means of grouping
modules together; there are no specific functions or operations associated with
substructures. A substructure’s origin is defined with respect to the global origin and may,
like modules, be oriented in any direction about the X, Y, and Z axes. Module origins and
axes are defined relative to their parent substructure’s origin and axes. For example, if the
midbody substructure origin is defined as being at X = 55m, Y = 0m and Z = 0m with respect
to the global origin, then a module within this substructure which starts 75m forward of the
global origin, or 20m forward of the substructure’s origin, would be defined with a module
origin of X=20m, Y=0m, and Z=0m.

5.2 Defining Job Information

Toolbar  

Menu  File > Job Information...

The MAESTRO Job Information dialog can be accessed from the File > Job Information...
menu, or from the toolbar.  This is where global settings and the job title can be defined.
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Title - provides the user with a location to associate a Job Title or description

Model Characteristics
The Cut Model option provides the ability to apply bending moments at bounding module
locations.  This is useful if it is the intent to not generate a complete model (only 0.4L
amidships for example) and apply bending moments at the ends.  

The transverse symmetry option notifies MAESTRO that it is the intent to construct a "half
model" and thus MAESTRO will automatically mirror the model (internally) about the
centerline for analysis.  This will also automatically restrain (internal to the calculation) the
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model on the centerline.

The Nodal Join Tolerance field sets the value, in the currently selected units, in which the
nodes will be automatically joined by the modeler and solver. Setting too small a value (less
than 5 mm or so) may cause some nodes to not join or free edges to be mistakenly
calculated. Conversely, setting the value too high may cause inadvertent nodal joining.
The seawater density and gravity values can be changed as desired.

Environment - here the user can define the model's environment.  For example, the user can
set the water density and gravitation acceleration in the unit system defined.  It is important
to understand that these parameters affect all aspects of the analysis so caution should be
taken if changing these values.

Hull Girder Stations - The Hull Girder Stations allows the user to change the default values
of the station spacing and 0 location for longitudinal and transverse hull plots.

The station spacing is defined for plotting the summed vertical loads (via the Hull menu).
The word DEFAULT sets the spacing equal to the section spacing of module 1, substructure
1. If another value is desired enter it here in the current length units. Station spacing is
merely a convenient interval along the length (or athwartship) of the structure at which the
program reports the total upward, downward and net vertical and horizontal loads that act on
the structure within each (structure X axis or Z axis) interval for each load case.

The stations defined in "Station Spacing" are spaced along the structure X  or Z axis, and
their numbering starts at zero and increases in the positive X direction (or Z direction in the
case of transverse). 

· Default. Station 0 is located at Xmin, the lowest (smallest positive or largest negative)
value of X (or Z) within the structure. 

· (User input value). Entering a value, in the current length units, specifying an overriding
value of X (or Z) for station 0. 

NOTE:  If the location of station 0 is such that it is within the structure, then all of the
loads that occur from Xmin to X0 will be allocated to station 0.

Safety Factors - Safety factors for panel, girder and frame elements can be set by clicking
on the associated button.

The Criteria drop-down has three options: Default, Explicit, and Forensic.

· Default selects that the two default values of safety factor - one for Collapse and one for
Serviceability that are selected are considered appropriate for all limit states of each type,
and there is no need for any explicit definitions of individual values. Therefore, for this
option, the individual panel, girder, and frame elements buttons are grayed-out and not
accessible.

· Explicit allows the user to specify an individual safety factor for each limit state. The
individual limit states are accessed via the Panel…, Girder…, and Frame… buttons which
are active for this criteria only. The user is cautioned to read Structural Evaluation and
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Partial Safety Factors prior to using the Explicit criteria.

· Forensic sets all of the safety factors to 1.0, i.e., the purpose of this job is to determine
whether any structural failures would actually occur for the loads that are specified in this
job.

The Comments tab allows the user to attach comments to the model.
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5.3 Defining Units

Toolbar  N/A

Menu  File > Units...

The Units dialog box can be accessed from the File > Units...  menu.

Individual parameters can be changed using the Label drop down boxes or a Standard Unit
System can be chosen from the drop down box.  The Set Parameter Data box must be
clicked for the units to change.

The seven Standard Unit Systems available are:

· SI (N, m) - Newtons and meters
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· SI (N, mm) - Newtons and millimeters

· SI (MN, m) - MegaNewtons and meters

· fps - Feet, pound-force and seconds

· mks - Meters, kilogram-force and seconds

· cks - Centimeters, kilogram-force and seconds

· ips - Inches, pound-force and seconds

THE USER CAN SWITCH BETWEEN UNITS AT ANY TIME. The model data is stored in SI
units (N,m) and is converted to the current selected units. Regardless of what units are
chosen, the underlying structural model does not physically change. All that changes is how
dimensional values are displayed to the user throughout the interface. For example, if a
structural model is 100 meters long and the user changes the length units to feet, the model
is still 100 meters long but it would be reported to the user as 328.08 feet long. This allows a
user to be switch to another system, say IPS units, enter data that is best address in the
temporary system, and then switch back to the analysis’s standard units. This is particularly
helpful when building a mixed system model.

5.4 Defining Materials & Properties

Quick Reference:

Defining Materials

Creating a Plate Property

Creating a Beam Property

Creating a Rod Property

Creating a Spring Property

Toolbar  

Menu  Model > Materials...

The materials defined in the dialog box are global and are used as reference for element
properties and therefore should be defined prior to creating an element property.

This tutorial shows the procedure for creating a new material.
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1.  Begin by opening the Materials dialog box from the Model  > Materials... menu, or from
the toolbar.

2.  Click the ID button to get the next unique ID for the new material.

3.  Type in a descriptive Name for the material and select the type: Isotropic, Orthotropic, or
Compound.

4.  Fill in the material parameter values in the units specified.

5.  Click the Create button.

This procedure can be repeated to create additional materials.  It can be helpful to create all
the anticipated materials prior to creating the model.

Toolbar  
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Menu  Model > Properties > 

Once a material(s) is defined, the Properties dialog box is used to create Plate, Beam, Rod,
and Spring element properties.

Begin by opening the Properties dialog box from the Model  > Properties> menu, or from
the toolbar.

This tutorial shows the procedure for creating a new plate element property.

1.  Click the Plate tab.

2.  Click the ID button to assign a unique ID to the plate element property.

3.  Give the plate element property a descriptive name.

4.  Right-click in the first large white space of the dialog and click Add.  This will add a layer
to the new property.
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5.  Select the material for the layer from the drop-down menu.  Define a thickness in the
units shown.

6.  Click Create.

Composite Structures

MAESTRO can create composite structures for strake, quad and tri shell elements.  In order
to create a composite structure, follow the steps for a plate property definition but now
additional layers can be added and fiber orientations set for each layer.  Input the
appropriate Laminate Failure Critera for the composite structure.  Stresses can be recovered
for each layer of a composite material.  See the Recovering Composite Layer Stresses
section for details.

This procedure can be repeated to create additional plate element properties. 

This tutorial shows the procedure for creating a new beam property.

1.  Click the Beam tab.



MAESTRO 11.0.0190

© 2014 Optimum Structural Design, Inc.

2.  Click the ID button to assign a unique ID to the beam element property.

3.  Give the beam element property a descriptive name.

4.  Select the beam type from the drop-down menu.

5.  Define the Web and Flange (if applicable) Height/Width/Inner Radius(for Tube Beams)
and thickness. The definitions for each type of beam's dimensions are shown below (Bf:
flange width, Tf: flange thickness, Hw: web height, Tw: web thickness):
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6.  Select the material.
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7.  Click Create.

Note, the beam properties list can become expansive and it may be helpful to sort the beam
properties in the dialog box and this order will be maintained when selecting a frame, girder
or beam property.

This tutorial shows the procedure for creating a new rod element property.

1.  Click the Rod tab.

2.  Click the ID button to assign a unique ID to the rod element property.

3.  Give the rod element property a descriptive name.

4.  Define the rod by its Principal Dimensions (Outside Diameter and Wall Thickness) or its
Integrated Characteristics (Section Area and Moment of Inertia).

5.  Select the material for the rod from the drop down menu.

6.  Click Create.

This tutorial shows the procedure for creating a new spring element property.
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1.  Click the Spring tab.

2.  Click the ID button to assign a unique ID to the spring element property.

3.  Give the spring element property a descriptive name.

4.  The spring properties are defined by the spring constant in the X,Y, and Z directions as
well as the permissible travel permitted in each direction.  

This travel distance is assumed to be the restriction in stretching and compressing the
spring.

5.  Click Create. 
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5.5 Defining Parts

Toolbar  

Menu  Model > Parts > Create/Modify

A MAESTRO model is made up of parts, or more specifically substructures and modules.  In
the model hierarchy, modules make up substructures, which make up the full model.  Before
you begin modeling, it is a good idea to first review your structural drawings and plan out
your Substructure and Module breakdown.

This dialog contains four tabs labeled General, Location, Sections, and Default Values. In
addition the window on the right side of the dialog displays the current parts tree structure.
The parts tree is interactive and allows the user, via right-button clicking, to set the current
part, the view part, and rename parts. The process of creating a new part involves entering
the required data in the fields of each tabbed page and clicking the Create button. Modifying
an existing part involves selecting the desired part from the Part Name drop-down list in the
General tab or from the parts tree at the right, changing the desired values and clicking the
Modify button. Note that whenever a part is modified from any of the Substructures and
Modules tabs that part becomes the Viewed Part. Each of the tabs in the Substructures and
Modules dialog are discussed more fully in the following sections.

This tutorial shows the procedure for creating a substructure and an accompanying module.

1.  Begin by opening the Substructures and Modules dialog box from the Model > Parts >
Create/Modify menu, or from the toolbar.

2.  Select top from the local parts tree; the radio button should be selected for Substructure
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under Part Type.

3.  In the Part Name box, type a forward slash after top and give a descriptive name for the
substructure; click Create.

Note: if you click the "+" next to top, the substructure just created will be shown along with
any other substructures created.

4.  In the Location tab, set the Origin Location and Rotation Angles for the substructure and
click Modify.

Note: the origin location of the substructures is relative to the top origin location, which by
default is (0,0,0).

5.  The Sections and Default Values tabs only apply to modules and thus are ignored for
substructures.

Additional substructures can be created in this same manner.  Now we are ready to create a
module within our newly created substructure.

6.  Click to the General tab and select the substructure from the local parts tree on the right.
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Note: the Part Name box now lists the substructure name after top.

7.  After the substructure name, type a forward slash and a descriptive name for the module.

8.  Click the radio button for Module and then click Create.

Note: clicking the "+" next to the substructure name will now display the modules that make
up that substructure.

9.  After making sure the new module is highlighted in the local parts tree and the name
shows up in the Part Name box, select the Location tab.  The Part Name box and Parts tree
specify which part is currently "active" and can be modified.

10.  Define the Origin Location and Rotation Angles for the module and click Modify.

Note: these values are applied within the current part's reference system.  For example if
your substructure X origin is set at 120 inches, then setting the X origin of the module to 0
inches is equivalent to 120 inches in the global reference system.

11.  Select the Sections tab.  The default sections is 10, with 1 unit spacing.
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12.  These sections can be re-spaced, or deleted and new sections can be created.  To do
this, highligh the sections and click Remove.

13.  Click Add... and define the number of sections and their spacing.  Multiple sections can
be added with different spacing.

14.  Click the Modify button.

12.  Select the Default Values tab.

13.  The Sections/Bay and Cylinder Length can be defined here.  The sections per bay
defines the number of strake sections per structural bay.  This allows for the transverse
frames to be placed every second section, or third section or any other regular spacing.  The
Cylinder Length parameter is for a specific application to cylindrical structures.  This
parameter defines the length between bulkheads (circular diaphragms) in the cylinder.  This
parameter is ONLY applicable to strakes of type "cylinder."

15. The Reference End and Opposite End Frame options defines whether a transverse
frame will be located at either end of the module's strakes.  This check box acts as a toggle,
turning Frames On/Off at the extreme ends of the modules.
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14.  Click Modify.

Additional modules can be created in the same manner for the current substructure or other
created substructures.

NOTE:

MAESTRO’s parts tree, by default, orders the substructures and their respective modules
alphabetically. Thus a model with a substructure called "hull" and modules called "bow",
"midships", and "aft" would be displayed as shown on the left. To maintain a specific order to
the substructures and/or modules it is recommended that the name include an abbreviated
numbering system (as shown below).

5.6 Parts Tree

The parts tree pane displays the hierarchy of substructures and modules in the model, in a
folder format directory.  The parts tree can be manipulated just as a directory tree can, but
the user must remember that modules must be contained in substructures.
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The tree can be shown or hidden using the parts tree icon .
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The number and organization of the parts may be adjusted either through the Parts
command on the main menu, or directly in the parts tree. Clicking the right mouse button
launches a popup menu offering the user several options.

Set Current Part

This will set the highlighted module or substructure as the current part.

Set View Part

This will set the highlighted module or substructure as the current view.  If a substructure is
selected, all the modules in that substructure will be visible.  To view the entire model,
highlight and right-click top and select Set View Part.

Set Current & View Part

This will set the highlighted module or substructure as the current part and the current view.
 

Rename

This will allow the highlighted module or substructure to be renamed within the parts tree.
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Copy

This will create a copy of the highlighted module or substructure.

Mirror

This will launch the mirror dialog and allow the user to Mirror or Add Mirror for the
highlighted part.

Delete

This will delete the highlighted module or substructure.  If a substructure is deleted, all of its
modules will be deleted as well.

Add Mirror

This will launch the mirror dialog and allow the user to Mirror or Add Mirror for the
highlighted part.

Set Visibility On

This will toggle the visibility of the highlighted part to On.  

Set Visibility Off

This will toggle the visibility of the highlighted part to Off.  If a substructure's visibility is set to
off, all of the modules within that substructure will have their  visibility set to off.

Visibility List

This will launch the Visibility List dialog which looks the same as the parts tree, but allows
the user to toggle the visibility on/off with one click for each module or substructure.

Set Transparency On

This will set the highlighted module or substructure as transparent.

Set Transparency Off

This will set the highlighted module or substructure as not transparent.

Show Weight

This will show a dialog providing the weight of the highlighted module of substructure.  If a
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substructure is selected, the weight will be for all of the modules within that substructure
combined.

5.7 Defining Stiffener Layouts

Toolbar        

Menu  Model > Stiffener Layout...

Stiffener layouts allow the user to define the number of stiffeners or breadth between
stiffeners for a panel element.  Stiffener properties are defined in the beam properties dialog
box.

Stiffeners are defined as beam elements, but they are not actual finite elements in a coarse
mesh model.  Instead, they are treated as additional stiffness in the defined direction for the
panel element they are defined on, thus converting the material to orthotropic.  In a coarse
mesh model, all stiffeners are treated as "internal" regardless of their defined location.  The
number of stiffeners, whether defined as internal or edge, is the key to how the mechanical
properties of the panel element are changed.  However, the location is relevant when
creating a fine mesh model from the coarse mesh model.  At this point, an actual beam
element will be created representing the properties of the stiffener at the defined location. 
As a result of MAESTRO's treatment of stiffeners, there are a couple caveats when defining
stiffened panels:

· An edge stiffener defined in a coarse mesh model on the centerline will not be flagged as
a centerline element.  Instead it will be treated as if there are two stiffeners with identical
properties, thus affecting the total stiffness, cross sectional area, etc.

· Similar to the point above, stiffeners may be modeled as "overlapped" and MAESTRO's
integrity check will not recognize this.  For example, two consecutive strakes may each
have a stiffener on their shared edge or a transverse stiffener layout with edge 1 and edge
2 stiffeners defined could be applied to a strake, thus creating overlapped stiffeners. 
Again this will be treated as if there are two stiffeners with identical properties, thus
affecting the total stiffness, cross sectional area, etc.

In the coarse mesh model, stiffeners are shown graphically with a red line representing their
location and orientation.  Stiffeners can be toggled on or off in the View Options dialog or

with the Stiffeners On/Off icon .

This tutorial shows the procedure for defining stiffener layouts that can be applied to a
strake panel or an additional quad element.
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1.  Begin by opening the Stiffener Layout dialog box from the Model > Stiffener Layout...
menu, or from the toolbar.  The dialog can also be accessed from within the Strakes dialog
box or the Fine Elements dialog on the Quad tab.

2.  Click ID to create a new layout.

3.  Give the layout a descriptive name.

4.  Select the property of the stiffener from the drop-down box.  If the property is not yet
defined, click the Property box and the Beam Property dialog will open.

5.  MAESTRO allows the user to define either the number of internal stiffeners or the
Breadth between stiffeners.  Select the radio button for the option you desire and fill in the
number of distance.

6.  MAESTRO also allows for an Edge 1 or Edge 2 stiffener.  The Edge 1 and 2 corresponds
to a longitudinal stiffener layout applied to a strake.  In this case, Edge 1 is the edge defined
by  EndPoint 1 and Edge 2 is defined by EndPoint 2.

7.  Click Create to save the stiffener layout.  This layout will now be listed in the drop-down
box in the Strakes and Quad dialog boxes.
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5.8 Importing Geometry

Toolbar  N/A

Menu  File > Import > 

Curves can be imported into MAESTRO to serve as construction geometry to assist in
model generation.  The idea is to import curves at strategic locations, such as the Reference
and Opposite ends of the Parts definition.  This will allow the user to "snap" to these
locations of interest using MAESTRO's construction geometry.  See the Construction
Geometry section for more information on MAESTRO's construction geometry.

Importing a . PLY File

Defining Surface Normal and Wettable Elements

This tutorial shows the procedure for importing geometry as an IDF, DXF, or GF format.

1.  Make sure that top is set to the current part.

2.  Select File > Import > from the menu.  Choose the file type for the input.

3.  Select your geometry file from it's saved location and click Open.

Note: MAESTRO reads in IDF format, but can also convert and read in DXF and GF files
using the File Translator dialog box.



Geometry/Finite Element Modeling 207

© 2014 Optimum Structural Design, Inc.

4.  Select the Translation Type and any unit or coordinate conversions.  MAESTRO can also
scale the model in any of the three Cartesian coordinate directions.

5.  Select the Read translated IDF file option if you would like MAESTRO to automatically
load the converted file.  Click OK.

6.  A prompt will open asking to insert marks?  Selecting yes will place a construction marker
at any curve end points or intersections.

Importing a .PLY File

This tutorial shows the procedure for importing geometry as a Polygon Mesh File Format (*.
ply).  The polygon mesh file supports individual quad and triangle elements as well as
endpoint and strake definitions.  Strakes will be given default properties but can be modified
individually or using groups.  A sample (PlyImport.txt) file can be found in the Models and
Samples > Import directory.

1.  Select File > Import > Ply-Polygon File Format (*.ply) from the menu.

2.  Select the geometry file from it's saved location and click Open.
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3.  Select the options from the dialog and click OK.  These options are similar to importing a
Nastran model. MAESTRO does not detect the previous coordinate orientation so we must
enter the correct rotations about the x, y, and z axes to transform the model from the Rhino
coordinate system to the MAESTRO coordinate system. The "Transform nodal coordinates"
option not only transforms the geometry but also the old coordinate system, so that it is
possible to work from MAESTRO coordinates. If this item is not checked and the user needs
to enter coordinates, they will need to be entered in the old coordinate system.
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The importing polygon mesh file will automatically create a new module of the mesh
elements.  All quad and triangle elements will be automatically assigned the same plate and
material property.  These can be changed individually or all at once by creating a group and
changing the group's property.

This sample model (S175.ply) can be found in the Models and Samples > Import directory.

For guidelines on creating a mesh in Rhino, see the following section.
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5.9 Creating Construction Geometry

Toolbar  N/A

Menu  Tools > Construction Geometry >

Mouse Hold Ctrl key & Right-Click

MAESTRO's construction geometry can be very helpful in defining EndPoints and additional
nodes.  

This tutorial shows the procedure for creating two construction lines and a construction
marker at their intersection.  A description of each type of construction geometry can be
found below.

1.  Open the construction geometry dialog box from the Tools > Construction Geometry >
menu or by holding the Ctrl key and right-clicking in the modeling space.

 

2.  Hold the mouse over CLine and the construction line options will fly out from the menu.

3.  Select one of the options to create a construction line.

4.  Follow the instructions in the command tab at the bottom of the screen to define the
construction line.

5.  Repeat this process to create an additional construction line that intersects the first one.

6.  Access the construction geometry menu and hold the mouse over CMarker and the
construction marker options will fly out from the menu.
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7.  Select the Cross option.

8.  Click on one of the construction lines near the intersection point.  Then click on the
second construction line.  

A construction marker will appear at the intersection.  This point can be used to "snap"
EndPoints or additional nodes to.

The Repeat command can be used to create multiple construction lines or markers by
selecting the construction geometry to create and then clicking on repeat in the menu.

Construction geometry can be deleted by holding the mouse over the Delete CGeom option
and the delete options will fly out from the menu.

Construction Markers

Point: This command allows the user to create a construction marker at a specified location
in space either interactively with the mouse or through the command line.

Bisect: This command allows the user to create a construction marker at a specified fraction
along a particular line segment.  To enter a specified fraction, delete the "{" in the command
line and type the fraction in decimal form (i.e. 0.25).

Project: This command allows the user to create a construction marker at the projection of a
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specified point on an indicated line

Cross: This command allows the user to create a construction marker at the crossing of two
indicated lines. If the two lines (or their extensions) do not physically intersect in space, the
marker is placed at the closest point on the primary line (the first line selected) to the
secondary line (the second line selected).  The two lines are selected using the mouse.

Mix: This command is similar to bisect, but instead the user selects two points of a line
segment.

Construction Lines

2 Points: This option will create a construction line in space between two selected points.

Parallel: This option will create a construction line in space passing through a specified point
and parallel to the specified direction vector. The direction vector is often specified by using
the mouse to select another line segment in the model parallel to the desired vector.

Longitudinal: This option allows the user to create a construction line in space through a
specified point in the longitudinal (i.e. module’s local X-dir) direction.

Transverse: This option allows the user to create a construction line in space through a
specified point in the transverse (i.e. module’s local Z-dir) direction.

Vertical: This option allows the user to create a construction line in space through a
specified point in the vertical (i.e. module’s local Y-dir) direction.

Delete Construction Geometry

All: This option will delete all existing construction geometry.

CMarkers: This option will delete all existing construction markers.

CLines: This option will delete all existing construction lines.
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Specify: This option allows the user to select which construction geometry to delete using
the mouse.

Query

Point: This option options a dialog allowing the user to click on nodes in the model and
report their XYZ coordinates.

Distance: This option opens a dialog allowing the user to click on nodes and recover their
distance from the global origin.

5.10 Creating EndPoints & Additonal Nodes

Quick Reference:

Creating EndPoints

Creating Additional Nodes

Toolbar  

Menu  Model > Nodes > Create/Modify > EndPoint

Keyboard  <Ctrl + n>

EndPoints are defined by a Reference and Opposite end of the current module.  A set of
nodes is created along the line between these two points at the module spacing defined in
the Parts dialog.

This tutorial shows the procedure for creating a set of EndPoints.

1.  Make sure the appropriate module is set as the current part and launch the EndPoints
dialog from the Model > Nodes > Create/Modify > EndPoint menu, or from the toolbar. 
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2.  Click the ID button to get the next unique ID for the new EndPoints.

The Reference and Opposite X values will be automatically filled according to the module
location and sections definition in the parts dialog.

3.  The Y and Z values can be typed in by the user, or "snapped" to a point in the model by
clicking in one of the coordinate value boxes and then clicking a point in the model. 

Values can be "snapped" to other EndPoints, Additional Nodes, or Construction Markers.

4.  Click the Create button.

This same procedure can be repeated for additional EndPoints.

Toolbar  

Menu  Model > Nodes > Create/Modify > Additional Node

Keyboard  <Ctrl + n>

Additional nodes allow the user to insert individual nodes into the model in addition to the
sets created with EndPoints.

This tutorial shows the procedure for creating Additional Nodes.

1.  Make sure the appropriate module is set as the current part and launch the Additional
Nodes dialog from the Model > Nodes > Create/Modify > Add'l Node menu, or from the
toolbar. 
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2.  Click the ID button to get the next unique ID for the new additional node.

3.  Type in the coordinate values or "snap" to a point in the model by clicking in one of the
coordinate boxes and the clicking the point in the model.

4.  Click the Create button.

This same procedure can be repeated for more additional nodes.

5.11 Creating Strakes

Toolbar  

Menu  Model > Elements > Create/Modify > Strake

Keyboard  <Ctrl + k>

Strakes are a convenient way of creating all of the structural elements between two sets of
end points.  The strake data is defined in the MAESTRO Strakes dialog box via the General,
Plating, Frames, Girders, Stiffeners, and Deletions tabs.

This tutorial shows the procedure for creating a strake between a set of defined end points.
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1.  Begin by opening the MAESTRO Strakes dialog box from the Model > Elements >
Create/Modify > Strake menu, or from the toolbar.

2.  Make sure the correct module is set to the current part and click the ID button to assign
the strake a unique ID.

Note: Frames can be defined as I-beams by selecting "Second Flange" as the strake type. 
This will use the selected T-beam property for the frame and automatically add a second
flange using the T-beam flange properties.  See the Second Flange verification section for
examples.

3.  Click in the EndPoint 1 box and then click the first end then the second end point defining
the strake.  The two boxes should automatically update with the end point numbers. 

Note: you may click anywhere along the line of nodes making up the end point.

4.  Select the location of the strake: Bottom, Side, Deck, or Other.  This is important for
MAESTRO to define the elements as wetted or not.  Bottom and Side will assign the shell
elements as "wetted".

5.  Click the Plating tab and select the plate property from the drop down menu.  A new
property can be created by clicking the Property box.

6.  Click the Frames tab and select the frame property and Frame Web Orientation.  If there
are no frames on this section, there should be a property with no frames defined.  A new
property can be created by clicking the Property box.

Frame Web Orientation

Frames in the transverse direction will be in-line with the YZ plane, whereas frames in
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the normal direction will be normal to the strake plating.

Sign Convention for Normal and Transverse Options

The Normal and Transverse options involve a Positive/Negative choice, and the positive
direction is defined by a right hand rule.  

To determine the positive direction, the index finger should point from Endpoint 1 to
Endpoint 2.  The middle finger should point in the +X direction and the thumb will then
be pointing in the positive direction.

7.  Click the Girders tab and if applicable, click the Enable Girder box and select the girder
property and Angle in degrees.  If there is no girder to be included in the current strake,
make sure the Enable Girder box is unchecked.

8.  Click the Stiffeners tab and if applicable choose the stiffener layout desired.  If no layouts

are defined or to create a new layout, click the Layout button or the Stiffener Layout icon 
from the toolbar.  See the Stiffener Layouts section for more information.

9.  Click the ID button to assign a unique ID and enter a descriptive name for the stiffener
layout.

Note: the first stiffener layout should be a null property.  This gives the option to define an
unstiffened strake or quad.

10.  Select the stiffener property from the drop down menu.  If the beam element property
desired is not already defined, a new one can be created by clicking the Property button.

11.  The stiffener layout can be defined by number of internal stiffeners or by defining the
breadth between stiffeners.

12.  The user can also define if there is an Edge 1 or Edge 2 stiffener.

13.  Click Create and then click Close to return to the MAESTRO Strakes dialog box.
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14.  Select the new Stiffener Layout from the drop down menu.

15.  Click the Deletions tab and check if any of the strake sections should have deleted
plate, frame or girder elements.

16.  Click Create.

5.12 Creating Additional Elements

Quick Reference:

Creating Quads

Creating Triangles

Creating Beams

Creating Rods

Creating Springs

Creating RSplines

Creating Brackets

In addition to strakes, MAESTRO has the ability to create individual panel elements as
triangles or quads (depending on the number of nodes used to define the element), beam
elements, and rod elements.

Toolbar  

Menu  Model > Elements > Create/Modify > Quad

Keyboard  <Ctrl + e>

This tutorial shows the procedure for creating an individual quad element.

1.  Begin by opening the Finite Element Quad dialog box using the Model > Elements >
Create/Modify > Quad menu, or from the toolbar.
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2.  Make sure the appropriate module is set as the current part and click the ID button to
assign a unique ID to the element.

3.  Click inside the Node 1 box and then click the four nodes that will define the quad
element in the model.

4.  Select the plate property from the Property drop down menu.  If the property is not
defined, click the Property button to define a new plate element property.

5.  Select the stiffener layout, if applicable.

6.  If a stiffener layout is chosen, chose the orientation of the stiffeners in the Direction drop
down menu.  The Side is defined as inside:opposite of the pressure side, outside:same as
the pressure side.

Note: Edge 1 is defined as the edge between nodes 1 and 2, Edge 2 between nodes 2 and
3, Edge 3 between nodes 3 and 4, and Edge 4 between nodes 4 and 1.

7.  Check the Wetted box if the element is part of the bottom or side shell.

8.  Click Create.

This procedure can be repeated to create additional quad elements.
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Toolbar  

Menu  Model > Elements > Create/Modify > Triangle

Keyboard  <Ctrl +e>

This tutorial shows the procedure for creating an individual triangle element.

1.  Begin by opening the Finite Element Triangle dialog box using the Model > Elements >
Create/Modify > Triangle menu, the toolbar, or clicking the Tri tab in the Finite Element
dialog box.

 

2.  Make sure the appropriate module is set as the current part and click the ID button to
assign a unique ID to the element.

3.  Click in the Node 1 box and click the three nodes that make up the triangle element in the
model.

4.  Select the plate property from the drop down menu.  If the property is not defined, click
the Property button to create a new plate element property.
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5.  Check the Wetted box if the element is part of the bottom or side shell.

6.  Click Create.

This procedure can be repeated to create additional triangle elements.

Toolbar  

Menu  Model > Elements > Create/Modify > Beam

Keyboard  <Ctrl +e>

This tutorial shows the procedure for creating an individual beam element.

1.  Begin by opening the Finite Element Beam dialog using the Model > Elements > Create/
Modify > Beam menu, the toolbar, or clicking the Beam tab in the Finite Elements dialog
box.
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2.  Make sure the appropriate module is set as the current part and click the ID button to
assign a unique ID to the element.

3.  Click in the Node 1 box and click the two nodes that make up the beam element in the
model.  Node 1 and Node 2 should now be populated with values representing the ID
(and Section number for Endpoints) of the Node and/or Endpoint.

4.  Select the beam property from the drop down menu.  If the property is not defined, click
the Property button to create a new beam element property.

5.  The next step is to define the Web Orientation of the beam element.  There are a total of
four ways to define the orientation of the beam element’s web; two methods use a
reference plane to define the web orientation while two methods define the web
orientation more directly.  For the reference plane method, the reference plane can be:
(1) the plane of an Associated 2D Element or (2) the plane formed by three nodes in
space.  Alternatively, the web orientation can be defined directly using: (1) the
Transverse (YZ) plane of the module or (2) defining a vector (e.g., {V1, V2, V3}).  

Reference Plane Methods

1. Associated Element – In this option the reference plane is the plane of a particular 2D
element (i.e., a strake panel, a triangle, or a quad element).  

(a) To use this option, first check the By Associated Element box in the Web Orientation
section of the Additional Element dialog.  If this option is selected, the Node 3 field
for the Third Node option is grayed out.  

(b) Next, the user can choose what type of element and what element ID should be used
as the reference plane.  For example, the user can choose Type Strake followed by
selecting (via the ID drop-down or graphically selecting with a mouse left-click) a
panel in the strake.

(c) Now that a reference plane has been defined, the user can define the web orientation
as being normal to that plane using the Normal (Positive/Negative) option or, for a
non-normal orientation, by specifying the angle (in degrees) away from the normal.
For example, specifying 30 would place the web at 30 degrees from the normal, or
60 degrees from the reference plane.

2. By Defining a Third Node - Alternatively, the reference plane is the plane passing
through three nodes: Node 1 and Node 2 at the ends of the beam, and a third node
(Node 3) chosen by the user.

(a) To use this option, first ensure that the By Associated Element check box IS NOT
checked.  When this check box IS NOT checked, the Node 3 field should be editable
(i.e., un-grayed and ready to receive user input).

(b) Populate the Node 3 field by left-clicking in the Node 3 field (to move the mouse
focus here) followed by clicking on any node that, together with Node 1 and Node 2,
forms the desired plane.  The value in this field represents the ID (and Section
number for Endpoints) of Node 3.

(c) Now that a reference plane has been defined, the user can define the web orientation
as being normal to that plane using the Normal (Positive/Negative) option or, for a
non-normal orientation, by specifying the angle (in degrees) away from the normal.
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For example, specifying 30 would place the web at 30 degrees from the normal, or
60 degrees from the reference plane.

Direct Methods

1. Using the Transverse (YZ) Plane of the Module – The first direct method places the
web directly in the transverse (YZ) plane of the module and points the web in a
positive or negative direction.  This is done by selecting Transverse
(Positive/Negative).  This option can only be used when the two nodes defining the
beam lie in the YZ plane of the module, which forms a beam vector.

2. Using a Vector to Directly Define Web Orientation – Finally, there is a second direct
method that defines the web direction in terms of a vector in the X, Y and Z
coordinates of the module.  The three components are placed inside curly braces
and separated by commas {VX, VY, VZ}.  The components can be any length; they do
not have to define a unit vector.

Sign Convention for Normal and Transverse Options

The Normal and Transverse options involve a Positive/Negative choice, and the positive
direction is defined by a right hand rule.  

In the Normal option the positive normal is determined by a right hand rule based on
three nodes: either the first three nodes of the Associated Element, or nodes 1 and 2 of
the beam and the specified Node 3.  The index finger points from node 1 to node 2.  The
middle finger points toward node 3 and both fingers are in the reference plane. Then the
thumb points in the positive direction.

In the Transverse option the index finger points from node 1 to node 2 of the beam
(defining the beam vector), and middle fingers points in the module’s positive X
direction.  The thumb now points in the module’s transverse (YZ) plane in the positive
direction.

6.  Enter values in the 2nd Flange Thickness and Width fields in order to simulate an I-beam
by way of using a T-beam property plus a second flange.  Please see the Second Flange
verification section for examples.

7.  Click Create.

This procedure can be repeated to create additional beam elements.

Toolbar  

Menu  Model > Elements > Create/Modify > Rod

Keyboard  <Ctrl +e>
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This tutorial shows the procedure for creating an individual beam element.

1.  Begin by opening the Finite Element Rod dialog using the Model > Elements > Create/
Modify > Rod menu,  the toolbar, or clicking the Rod tab in the Finite Elements dialog box.

2.  Make sure the appropriate module is set as the current part and click the ID button to
assign a unique ID to the element.

3.  Click in the Node 1 box and click the two nodes that make up the rod element in the
model.

4.  Select the rod property from the drop down menu.  If the property is not defined, click the
Property button to create a new rod element property.

5.  Click Create.

This procedure can be repeated to create additional rod elements.

Toolbar  

Menu  Model > Elements > Create/Modify > Spring
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Keyboard  <Ctrl +e>

This tutorial shows the procedure for creating a spring element.

1.  Begin by opening the Finite Element Spring dialog using the Model > Elements >
Create/Modify > Spring menu,  the toolbar, or clicking the Spring tab in the Finite Elements
dialog box.

2.  Make sure the appropriate module is set as the current part and click the ID button to
assign a unique ID to the element.

3.  Click in the Node 1 box and click the two nodes that make up the spring element in the
model.

4.  Choose the type of spring:

Regular:  The spring acts as a regular spring element in tension and compression.

Tension Only:  The spring only provides stiffness when it is in tension.

Compression Only:  The spring only provides stiffness when it is in compression.

Gap:  The spring only adds stiffness when the force on the spring nodes is enough to
displace the spring nodes more than the original distance between them.

** See the Verification section of the manual for sample models and comparison
results.
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5.  Select the spring property from the drop down menu.  If the property is not defined, click
the Property button to create a new spring element property.

6.  Click Create.

This procedure can be repeated to create additional spring elements.

Toolbar  

Menu  Model > Elements > Create/Modify > RSpline

Keyboard  <Ctrl + e>

This tutorial shows the procedure for creating an rigid spline element (RSpline).

1.  Begin by opening the Finite Element RSpline dialog using the Model > Elements >
Create/Modify > RSpline menu,  the toolbar, or clicking the RSpline tab in the Finite
Elements dialog box.

2.  Make sure the appropriate module is set as the current part and click the ID button to
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assign a unique ID to the element.

3.  Select the type of RSpline element.  For a description of the three types, please see the 
Model Organization section. 

4.  Click in the Node box and click the node that makes up the first part of the rigid spline
element in the model.  

5.  Checking Top-Down can be used to create a rigid link between a coarse mesh and fine
mesh model.  If Top-Down/Auto is selected, the slave nodes of the fine mesh model
between the two master nodes in the coarse mesh model will be automatically added.

6.  Click Create.

This procedure can be repeated to create additional rigid spline elements.

Toolbar  

Menu  Model > Elements > Create/Modify > Bracket

Keyboard  <Ctrl + e>

This tutorial shows the procedure for creating a bracket element.

1.  Begin by opening the Finite Element Bracket dialog using the Model > Elements >
Create/Modify > Bracket menu,  the toolbar, or clicking the Bracket tab in the Finite
Elements dialog box.
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2.  Make sure the appropriate module is set as the current part and click the ID button to
assign a unique ID to the element.

3.  Click in the Beam 1 box and click the two beams that will be connected by the bracket
element.

4.  Select a property from the drop-down box, or click Property to define a new one.

5.  Check the User Define box if you want to define the length of Leg 1 and Leg 2 of the
bracket.  Otherwise MAESTRO will automatically calculate these values.

6.  Click Create.

This procedure can be repeated to create additional bracket elements.  For more information
on brackets, see the Bracket Verification section.

5.13 Creating Compounds

Toolbar  
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Menu  Model > Elements > Create/Modify > Compound

Compound elements provide a convenient method for quickly creating repetitive transverse
structure.  Compounds are made up of spring, rod, beam, and plate elements.  A prototype
is created once and can be repeated along a module's longitudinal direction using the
replication rule.

This tutorial shows the procedure for creating a compound prototype and setting the
replication rule.

1.  Begin by opening the Compounds dialog box using the Model > Elements > Create/
Modify > Compound menu, or from the toolbar.

2.  Make sure the appropriate module is set as the current part and click the ID button at the
top of the dialog to assign a unique ID to the compound.

3.  Type in a descriptive name for the compound in the Name box and click Create Cmpd.

4.  Create Springs, Rods, Beams, Tris, and Quads that make up the compound in the same
procedure as creating an additional element, but instead of clicking Create, click Add in the
specific element tab.
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It is a good convention to define all elements on the reference end and set them for
additional sections using the Rule tab.

5.  Click the Rule tab.

The Rule tab allows the user to set at which sections within the module the compound will be
created.  The 0 represents the reference end and the last number represents the opposite
end.  Checking the box for each section will apply the defined compound at that section.

6.  Click the Set Rule button.

This procedure can be repeated to create additional compounds.

Compounds can have elements added or deleted at any time by adding or deleting elements
in their specific tabs.  The Modify Cmpd button is only used to modify the name of the
compound.  The entire compound can be deleted using the Delete Cmpd button.

5.14 Copying Elements

Similar to the module copy function, the element copy provides a method to quickly create
structure by leveraging existing elements.  As an example, we'll show how the tank structure
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below can be quickly expanded in the longitudinal direction.

The copy element command can be launched from the Model > Elements > Copy menu
option, or by dynamically querying an element and right-clicking and selecting copy.  This
command will open the Element Copy dialog:
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The right-hand side of the dialog will show a list of the elements to be copied.  To add more
elements, click once in the list white space and then click the elements in the model to copy.
 In the case of the example, we want to click all of the elements making up the tank.  Next
we want to set the number of copies to make.  In this example we just want to extend our
tank one endpoint spacing so we will leave this at 1.  The last information we need to specify
is the offset to copy the elements by.  This can be set by clicking on two nodes in the model
to automatically populate the Offsets input, or the user can manually enter these values.  In
this example, we can click on two nodes on the top of the tank in the direction we want to
offset the copied elements.  The Element Copy dialog should now look like this:
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Next, Click OK and the new copied elements (and necessary nodes) are automatically
created.

To complete the example, the old end shell elements (which are now internal to the tank)
can be deleted.
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5.15 Deleting Elements

Toolbar
 

Menu 

 Tools > Deletions > Select 

 Tools > Deletions > All Visible >

 Model > Elements > Delete >

Keyboard  <Ctrl + d>

In addition to deleting elements in the Strakes, Additional Elements, or Compounds dialog
boxes, the user can delete specific elements by selecting them with the mouse or by ID or
delete all of one element type at once.

This tutorial shows the different ways an element or elements can be deleted.

1.  An element can be deleted using the Model > Elements > Delete > menu, the Tools >
Deletions > Select, Tools > Deletions > All Visible > or from the toolbar.
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2.  The Model menu allows the user to select the type of element to be deleted.  A specific
element can be selected using the mouse or by the element ID.
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3.  The Deletion dialog box allows the user to select multiple elements to delete by clicking
on them with the mouse.  

The check boxes at the top of the screen serve as a filter for which types of elements may
be deleted.  Checking "Box" allows the user to click in the deletions dialog and then select
elements to delete by drawing a box around them.  Note: the element filters will not hold
when using the select by box option.

4.  The selected elements will appear in a list with their Module Name, Type and ID.  The
selected elements will also be removed in the model view.

To undelete an item, select it from the list and click the Recover Item button.

5.  Click Delete to permanently delete the selected elements.

6.  All visible elements can be deleted from the Tools > Deletions > All Visible > menu.
This allows the user to delete all visible elements of a specific type.

Once an element is added to the Deletion dialog, the user can right click on the element line
and a new menu will appear with additional deletions options.

These options will add the elements from the current view part that have the either the same
property, material, stiffener layout, or type as the currently selected element from the dialog
box.  Note: using the right-click menu does not take into account the selected element filters.



Geometry/Finite Element Modeling 237

© 2014 Optimum Structural Design, Inc.

The New Module button will create a new module consisting of the elements added to the
deletions dialog.

5.16 Mirroring a Model

There are two options when mirroring a part or the full model: Mirror and Add Mirror.  

The mirror dialog can be opened by right clicking on a part in the parts tree and selecting
Mirror or Add Mirror.  The dialog can also be launched from the Model > Mirror > Parts > or
Model > Mirror > Model menu.

Mirror

The mirror function will create a mirror of the selected part(s) with a new name defined by
the user.  The user also selects the new location, or Target of the mirrored part(s).

Add Mirror
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The add mirror function will create a mirror of the selected part(s), but includes the mirrored
parts in the original part(s).

The location of the new part(s) is such that the origin is at the same location as the original
part but all nodes and elements are reflected through the local  X-Y plane of the original
part.

Structure Options

Do not mirror centerline elements: By checking this box, MAESTRO will assume all
centerline elements were modeled with their full properties and thus not create a copy.

Flip Stiffener Side: By checking this box, MAESTRO will flip the stiffener side of the mirrored
elements such that the stiffener orientation matches with the original part(s).

Reverse Normal: By checking this box, MAESTRO will reverse the normal direction of the
mirrored elements such that the element normal side is preserved in the original part(s).

Groups & Restraints & Loads Options

Mirror Groups: By checking this box, any groups created in the original part(s) will be
mirrored in the new part(s).  Groups tagged as centerline groups will automatically combine
the two groups into a single group.

Mirror Restraints: By checking this box, any restraints not on the centerline will be mirrored
and applied to the new part(s).

Mirror Loads: By checking this box, any defined loads will be mirrored and applied to the
new part(s).

5.17 Quick Create

Toolbar
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Menu  N/A

The Quick Element Creation icon  is composed of a toggle button and a drop-down
button.

This capability is a powerful tool used during the modeling building phase in the FEA
process. Toggling this command On, the user can create endpoints, nodes, strakes, quads,
triangles, beams, rods, springs, and compounds without the use of dialog boxes. The use of
this functionality will be discussed below.

EndPoint

Additional Node

Strake

Quad

Triangle

Beam

Rod

Spring

Compound

EndPoint Creation



MAESTRO 11.0.0240

© 2014 Optimum Structural Design, Inc.

To create an Endpoint using the Quick Element Creation method, it is important to note that
the user must first define construction markers. Without construction markers, this
functionality will not work.

Select the Endpoint option from the drop-down menu. The user can now single click on the
first construction marker in the model that is to become the endpoint's reference end and
then double click on the construction marker that will become the endpoint's opposite end.
Repeat this process for as many endpoints as you wish.

After completing the Quick Creation sequence there are two important things to remember.
The first is to toggle off the quick creation icon and second, the Quick Creation process
does not update the ID numbers in the dialog box. Therefore if you are going to continue
using the dialog box you must close the Reference Points Dialog Box and the reopen it.

Additional Node Creation

To create an Additional Node using the Quick Element Creation method, it is important to
note that the user must first define construction markers. Without construction markers, this
functionality will not work.

Select the AddNode option from the drop-down menu. The user can now double click on the
construction marker in the model. Repeat this process for as many additional nodes as you
wish.

After completing the Quick Creation sequence there are two important things to remember.
The first is to toggle off the quick creation icon and second, the Quick Creation process
does not update the ID numbers in the dialog box. Therefore if you are going to continue
using the dialog box you must close the Reference Points Dialog Box and the reopen it.

Strake Creation

The user must first create a "prototype" strake, in the usual manner, for the other strakes.
This will serve to define all of the future strake properties except for their endpoint
connectivity. After creating this "prototype", select the Strake option from the drop-down
menu. The user can now single click on the first endpoint of the strake and then double-click
the second endpoint of the strake. Repeat this process for as many strakes as you wish, but
remember these new strakes are based on the properties of the "prototype" strake.

After completing the Quick Creation sequence there are two important things to remember.
The first is to toggle off the quick creation icon and second, the Quick Creation process
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does not update the ID numbers in the dialog box. Therefore if you are going to continue
using the dialog box you must close the Strake Dialog Box and the reopen it.

Quad Creation

The user must create a "prototype" quad, in the usual manner, for the other elements. This
will serve to define all of the properties except for their node locations. After creating this
"prototype", select the Quad option from the drop-down menu. The user can now single click
on the first three nodes in the model that are to become the element nodes 1, 2, and 3 in the
new quad, and then double click on the fourth node. Repeat this process for as many quad
elements as you wish, but remember these new quads are based on the properties of the
"prototype" quad.

After completing the Quick Creation sequence there are two important things to remember.
The first is to toggle off the quick creation icon and second, the Quick Creation process
does not update the ID numbers in the dialog box. Therefore if you are going to continue
using the dialog box you must close the Finite Element Dialog Box and the reopen it.

Triangle Creation

The user must create a "prototype" triangle element, in the usual manner, for the other
elements. This will serve to define all of the properties except for the node locations. After
creating this "prototype" triangle, select the Triangle option from the drop-down menu. The
user can now single click on the first two nodes in the model that are to become the element
nodes 1 and 2 in the new triangle, and then double click on the third node. Repeat this
process for as many triangle elements as you wish, but remember these new triangles are
based on the properties of the "prototype" triangle.

After completing the Quick Creation sequence there are two important things to remember.
The first is to toggle off the quick creation icon and second, the Quick Creation process
does not update the ID numbers in the dialog box. Therefore if you are going to continue
using the dialog box you must close the Finite Element Dialog Box and the reopen it.

Beam Creation

The user must create a "prototype" beam element, in the usual manner, for the other
elements. This will serve to define all of the properties except for the node locations. After
creating this "prototype" beam, select the Beam option from the drop-down menu. The user
can now single click on the first node in the model that is to become the element node 1 in
the new beam, and then double click on the second node. Repeat this process for as many
beam elements as you wish, but remember these new beams are based on the "prototype"
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beam.

After completing the Quick Creation sequence there are two important things to remember.
The first is to toggle off the quick creation icon and second, the Quick Creation process
does not update the ID numbers in the dialog box. Therefore if you are going to continue
using the dialog box you must close the Finite Element Dialog Box and the reopen it.

Rod Creation

The user must create a "prototype" rod element, in the usual manner, for the other
elements. This will serve to define all of the properties except for the node locations. After
creating this "prototype" rod, select the Rod option from the drop-down menu. The user can
now single click on the first node in the model that is to become the element node 1 in the
new rod, and then double click on the second node. Repeat this process for as many rod
elements as you wish, but remember these new rods are based on the properties of the
"prototype" rod.

After completing the Quick Creation sequence there are two important things to remember.
The first is to toggle off the quick creation icon and second, the Quick Creation process
does not update the ID numbers in the dialog box. Therefore if you are going to continue
using the dialog box you must close the Finite Element Dialog Box and the reopen it.

Spring Creation

The user must create a "prototype" spring element, in the usual manner, for the other
elements. This will serve to define all of the properties except for the node locations. After
creating this "prototype" spring, select the Spring option from the drop-down menu. The user
can now single click on the first node in the model that is to become the element node 1 in
the new spring, and then double click on the second node. Repeat this process for as many
spring elements as you wish, but remember these new springs are based on the properties
of the "prototype" spring.

After completing the Quick Creation sequence there are two important things to remember.
The first is to toggle off the quick creation icon and second, the Quick Creation process
does not update the ID numbers in the dialog box. Therefore if you are going to continue
using the dialog box you must close the Finite Element Dialog Box and the reopen it.

Compound

The compound quick create functionality works similar to the other quick create options. 
The Compounds menu option is a toggle on or off and will show a check mark when it is on.
To use the compound quick create, you must first create a compound.  Once the compound

is created, you can toggle on the compound quick create option from the  icon.  Next,
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create a "prototype" element in the compound, and then follow the procedure for creating
additional elements of that type after selecting the type from the quick create menu.

After completing the Quick Creation sequence there are two important things to remember.
The first is to toggle off the quick creation icon and compound option and second, the Quick
Creation process does not update the ID numbers in the dialog box. Therefore if you are
going to continue using the dialog box you must close the Compound Dialog Box and the
reopen it.

5.18 Defining Restraints

Toolbar  

Menu  Model > Define Restraints...

Keyboard  <Ctrl + r>

Restraints are used to restrict the model's movement in any of the 3 translational or 3
rotational degrees of freedom.

Objectives in Restraining a Model

Define Restraints Through the Model > Define Restraints Menu

Automatic Inertia Relief Restraints Method

Defining Module End Restraints (Create Boundary Modules Command)

The following tutorial shows how to define restraints for a model. In addition to the Model >

Define Restraints dropdown, which is addressed below, the dynamic query option 
may be used to query a node and edit the restraints. Right-click while dynamically querying
a node and select Restraints. This option will allow you to restrict the node in any
combination of the three rotations and translations.  The Fixed option will set all rotational
and translational restraints. The Pinned option will allow all rotations but no translations.
Springs can be set by choosing Spring and then one of six directions to place the second
node which is fixed. Refer to Spring Element Properties for more information on springs.
The Remove option will remove all constrains from a node, but will not remove springs.

Objectives in Restraining a Model

To solve the structures problem in FEA, adequate restraints must be modeled. The problem
may be singular or without a solution if proper restraints are not modeled. Alternatively, the
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deformation and stresses may be associated with a rigid body translation if proper restraints
are not modeled. To ensure none of the above occurs, all six degrees of freedom must be
constrained. There are several methods in place to accomplish this task. Constraining the
model twice transversely at different x values will prevent translation in the z-direction and
rotation about the y-axis. Constraining the model at each end section in the y-direction will
prevent y translation and rotation about the z-axis. Constraining the model twice in the
transverse direction at different y values will prevent rotation about the x-axis. Alternatively,
the user could constrain the model twice in the y-direction at two different transverse
locations. 

In addition to using user defined restraints, MAESTRO will constrain a model in the z-
direction and about the x- and y-axes if the model is marked as transverse symmetric.

Lastly, another way of constraining the model is by using spring elements. These tend be to
"softer" in that they allow motion at the structural nodes to which they are attached, but may
be used to reduced stresses and abnormal local deformations that usually occur at hard
restraints.

To read more about defining restraints continue to the below section "The Define Restraints
Menu." To look at several examples of constraining the FEA model and the viewing the
results see the below section "Defining Module End Restraints."

The Define Restraints Menu

1.  Begin by opening the restraints dialog by using the Model > Define Restraints... menu
option, or from the toolbar. 
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The first tab in the dialog gives a summary of the restraints.  The legend gives the graphical
representation when the view restraints option is selected.  This can be chosen from the 
View > Restraints menu option.  The magnitude of the restraint marker can be adjusted in
the View Options dialog.

If only a small portion of the ship has been modeled, the user can define boundary
conditions at the vessels “ends” by selecting the First Module and Second Module.  This is
useful for preliminary evaluation of the ship’s structure.

2.  Click the General tab.

3.  Click in the large white space and then select a node from the model to constrain.

4.  The module name and ID will automatically populate.

5.  The X, Y ,Z , Rx, Ry, and Rz boxes will be automatically filled with 0s meaning a free
condition.  Double click in the box to apply a fixed condition (1) or forced displacement (2)
per the Notation key.  The DX, DY, DZ, DRx, DRy, and DRz values specify the value of
forced displacement if any.

6.  Repeat steps 3-5 to add additional restraints.

7.  Select OK to save.

Automatic Inertia Relief Restraints Method

The idea of the inertia relief restraint methodology is to automatically place a single restraint
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point at the model CG and connect to surrounding structure using soft springs. If the model
is fully balanced, this single restraint is sufficient to prevent the model’s rigid body motion. In
order to fully balance a model in a quasi-static wave, the hydrostatic balance is first applied.
However, since the hydrostatic based equilibrium can only balance the force in heave, and
moments in roll  and pitch, additional adjustment is need for forces in surge and sway, and
moment  in  yaw.  This  adjustment  is  done  by  using  “inertia  relief”  (i.e.,  to  artificially  impose
very  small  accelerations  such  that  the  model  is  fully  balanced  in  all  6  directions).    This
methodology applies to static loading as well as for models with seakeeping loads applied.

The procedure for using this restraint approach is:
1. Create load cases in the model. Do not apply traditional restraints.
2. Run the hydrostatic balance for all load cases.
3. Run the inertia relief balance for all load cases.
4. Solve the model.

Defining Module End Restraints (Create Boundary Modules Command)

This feature enables the user to automatically constrain "end sections" within a cut model
such that the end sections remain plane during bending (i.e., rotating about the section's
neutral axis). The approach is well documented in class societies' literature (e.g., ABS, DNV,
and Lloyd's). Specifically, "Appendix B: Structural Strength Assessment" of the Common
Structural Rules for Double Hull Oil Tankers (IACS, July 2010) provides a detailed
description of class requirements and the use of this approach (see 2.5.4 and 2.6).

The Create Boundary Modules command can be found under the Model dropdown menu.
The feature is to be used only with cut models. The command joins a master node located
on the centerline at the height of the neutral axis to each slave node which is exposed at the
end cross section. A rigid link, RBE2 element, joins each slave node to the master at each
end of the cut model. The master node is located at an independent point where the vertical
neutral axis and the horizontal neutral axis intersect. The results look like the following:
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When applying restraints in this manner, RBE2 elements must be permitted to move at both
ends. This method of applying the moment about an independent point on the neutral axis is
effectively prescribing motion at all nodes on the end section (opposite end of the RBE2's
than the independent node). Thus, a spring element must be used instead of a rigid
restraint. These can easily be added by using the dynamic query for a node, right-click,
select Restraints, and then select Spring. The right-click during node query menu looks like
the following:

Section 2.6 of "Appendix B: Structural Strength Assessment" of the Common Structural
Rules for Double Hull Oil Tankers (IACS, July 2010) requires boundary restraints at the deck
with stiffness in the vertical direction and restraints at the bottom and inner bottom (stiffness
in only the global transverse direction). The "free" end of the spring should be constrained in
the 3 degrees of translation and the 3 degrees of rotation. The CSR required boundary
constrains are summarized in the following schematic.
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However, as will be shown below, an alternative constraining approach can yield very smiilar
results (e.g., nodal displacements and stresses). Below is a diagram of alternative boundary
restraints.

The next step is to load the model with an end moment and solve the finite element model
through Analysis/Evaluation.

Note: If boundary modules were explicitly defined in the model, any end moment applied to
the structure will be applied about the master node (independent point) of the boundary
module. To apply the moment in the traditional sense (distributed across all nodes of the
cross section), the boundary modules must be deleted.
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Two solved FEA models are shown below to demonstrate the similarity in mid-plane normal
stress in the x-direction between the two above restraint approaches. The solved model on
the right is the result of the CSR restraints mentioned above. The solved model on the left is
the result of the alternative restraint approach mentioned above.
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The mid-plane normal stress in the x-direction is virtually identical when comparing the
above two models. 

In addition to the restraint methods described above, examine what happens if an end
moment is applied in the traditional sense, meaning that it is not applied to the master node
(there isn't one) but is applied across all nodes on the end section. The solved FE models
below show the affect of excluding the boundary module from the FEA. The solved model on
the left is constrained with 4 springs at nodes near the horizontal neutral axis with stiffness
in X, Y, and Z directions. Use of springs makes the model prone to translate in space when
the nodal forces are distributed across the model. Noticeable out of plane deformations can
be observed near the deck but the longitudinal bulkhead along centerline is not affected as
much as in the below right hand model. 

The model on the right is constrained with three rigid restraints at the aft end, two Y-direction
translational restraints at nodes near the horizontal neutral axis and one Z-direction
translational restraint at a node on the double bottom on centerline. The fore end (which is
viewed below) of the cut model is fixed in translation in the X and Y directions at two nodes
near the neutral axis. A third restraint is placed at a node on the double bottom on
centerline; this node is fixed in Z translation. This method of restraint yields significant out of
plane bending both on deck and along the longitudinal bulkhead. Although the resultant
stresses are similar to the above analyses, this is not characteristic of the true state of
deformation of a full ship. These four scenarios serve as four examples of how the structural
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problem could be solved.
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6 Checking The Model

The topics in this section provide detailed information on the MAESTRO functionality used
during the model checks stage of an analysis.

6.1 Model Integrity Checks

Quick Reference:
Wetted Elements Check
Element Pressure Side Check
Aspect Ratio Check
Internal Angle Check
Warped Quad Check
Overlapped Elements Check
Free Edges Check
Element Connectivity Check

Routine model integrity checks are a simple and time saving process.  It can be beneficial to
conduct integrity checks after each module is completed, instead of trying to check the
entire model at once when it is completed.

The following tutorials show how to exercise several common model integrity checks.

Toolbar  N/A

Menu  View > Wetted Elements 

1.  This integrity check can be performed from the View > Wetted Elements menu option.

2.  All elements in the current view not defined as wetted, or strakes not defined as side or
bottom will disappear.

3.  Elements improperly defined can be changed from wetted to not wetted, or vice versa by

clicking the dynamic query icon, .

4.  Highlight the element to change and right-click with the mouse and check or uncheck 
Wet accordingly.

5.  Uncheck View > Wetted Elements from the menu to return to the element type view.
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Toolbar  N/A

Menu  View > Plate > Element Pressure Side

1.  This integrity check can be performed from the View > Plate > Element Pressure Side
menu option.

2.  All elements in the current view will be given a pink (pressure) side and gray
(non-pressure) side.

3.  This provides a quick graphical check on the hull pressure side as well as to verify a
common convention was used for defining interior structures.

4.  The dynamic query, , can be used to switch the pressure side of an element by
right-clicking and selecting Normal Reverse.

5.  Select View > Element Type from the menu to return to the element type view.

See Plate for additional details regarding Pressure Side conventions.

Toolbar  N/A

Menu  Tools > Integrity Check > Aspect Ratio

1.  This integrity check can be performed from the Tools > Integrity Check > Aspect Ratio
menu option.

2.  A dialog box opens allowing the user to set the maximum allowable aspect ratio; the
default value is 4.0.

3.  If there are no elements exceeding this aspect ratio a dialog box will notify the user of
this; otherwise the elements exceeding the aspect ratio will be identified with a color
corresponding to the aspect ratio as defined in the legend on the right of the screen. 
Elements that do not exceed the aspect ratio will be gray.

The Output tab at the bottom of the screen will also list the elements exceeding the aspect
ratio and their corresponding aspect ratio.

4.    Select View > Element Type from the menu to return to the element type view.

Toolbar  N/A
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Menu  Tools > Integrity Check > Internal Angle

1.  This integrity check can be performed from the Tools > Integrity Check > Internal
Angle menu option.

2.  A dialog box opens allowing the user to set the maximum allowable internal angle; the
default value is 150.0 degrees.

3.  If there are no elements exceeding this internal angle a dialog box will notify the user of
this; otherwise the elements exceeding the internal angle will be identified with a color
corresponding to the internal angle as defined in the legend on the right of the screen. 
Elements that do not exceed the internal angle will be gray.

The Output tab at the bottom of the screen will also list the elements exceeding the internal
angle and their corresponding internal angle.

4.  Select View > Element Type from the menu to return to the element type view.

Toolbar  N/A

Menu  Tools > Integrity Check > Warped Quad

1.  This integrity check can be performed from the Tools > Integrity Check > Warped
Quad menu option.

2.  A dialog box will open allowing the user to set the maximum allowable quad warping in
degrees; the default is 20.0.

3.  If there are no warped quads in the model, a dialog box will notify the user of this;
otherwise the quad exceeding the warped angle will be identified with a color corresponding
to the warped angle as defined in the legend on the right of the screen.  All other elements
will be gray.

4.  Select View > Element Type from the menu to return to the element type view.

Toolbar  N/A

Menu  Tools > Integrity Check > Overlapped Elements

1.  This integrity check can be performed from the Tools > Integrity Check > Overlapped
Elements menu option.
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2.  If there are no overlapped elements in the model, a dialog box will open notifying the user
of this; otherwise the overlapped elements will be grouped and shown on the screen.

3.  A dialog box will open asking if the user would like to use the deletion dialog box to delete
the overlapped elements.

It is recommended that the user investigate further to determine which is the true
"overlapped element" before deleting.

4.  Select View > Element Type from the menu to return to the element type view.

Toolbar  N/A

Menu View > Edges > Free Edges

1.  This integrity check can be performed from the View > Edges > Free Edges menu
option.
2.  A dialog box will open asking the user if they would like MAESTRO to create a group of
the elements with free edges and if MAESTRO should check for free edge errors.  If the
user answers Yes to the first question, a general group will be created and displayed with its
free edges in red on the screen.  If the user answers No, the entire model will be displayed
with its free edges in red.

It is easiest to see the free edges in wireframe mode , with stiffeners and end points
turned off.  
3.  Select View > Element Type from the menu to return to element type view.

Toolbar  N/A

Menu  Tools > Integrity Check > Element Connectivity

1.  This integrity check can be performed from the Tools > Integrity Check > Element
Connectivity menu option.
2.  A dialog box will open reporting the number of unconnected elements, if any.
3.  If there are any unconnected elements, they will be listed in the Output tab at the bottom
of the screen.
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7 Importing and Exporting

MAESTRO has the ability to import and export different data to support different aspects and
types of analysis related to the ship design process.

7.1 Importing Models and Data

MAESTRO has the ability to import different types of data files to support different aspects
of modeling and analysis as well as MAESTRO legacy data files.  The following describes
each of these types and provides the context in which a user would utilize them.

Geometry Import

MAESTRO (*.dat)

MAESTRO (*.mdl)

MAESTRO (*.mnf)

Nastran/FEMAP Neutral (.nas/.dat/.neu) 

Ply-Polygon (*.ply)

Ship Motion (*.smn)

Wave Scatter (*.sea)

Operating Profile (*.opf)

Tank Loader (*.txt)
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Geometry Import (DXF (R12)/GHS/IDF)

Curves can be imported into MAESTRO to serve as construction geometry to assist in
model generation.  The idea is to import curves at strategic locations, such as the Reference
and Opposite ends of the Parts definition.  This will allow the user to "snap" to these
locations of interest using MAESTRO's construction geometry.  See the Construction
Geometry section for more information on MAESTRO's construction geometry.  See
Importing Geometry for a details of the DXF, GHS, and IDF import options.

MAESTRO (*.dat)

The Import > MAESTRO (*.dat) allows user to import a legacy data input file and converts it
to an equivalent *.mdl file.  For a complete description of the *.dat file, see the Legacy Data
Preparation Manual.

MAESTRO (*.mdl)

Two existing MAESTRO models can be combined into one using the Import > MAESTRO
(*.mdl) menu option.  This functionality can be useful when two different users are creating
different parts of a model and want to combine them.  In order to combine the two files, open
one of the files and choose File > Import > MAESTRO (*.mdl) from the menu.
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Choose the MAESTRO file to be imported and click Open.

If there are duplicates between the two models, separate dialogs will open and give the
option to use existing properties and materials or create new ones.
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MAESTRO Neutral File (*.mnf)

The MAESTRO Neutral File is used when interfacing with NAPA data.  See the NAPA-
MAESTRO Interface section for more details.

Nastran

MAESTRO has the ability to import a Nastran analysis model or FEMAP neutral file from File
> Import > Nastran menu time.  FEMAP nuetral files allows users to import group definitions
from FEMAP into MAESTRO as general groups.  On import MAESTRO persists the Nastran
generated FE Tags and FEMAP generated property names..  

MAESTRO imports Nastran fixed format small field of: MAT1, MAT2, MAT8, PBAR, PBARL,
PBEAM, PCOMP, PSHELL, CTRIA3, CQUAD4, CBAR, CBEAM, CROD, CTRIAR and
CQUADR.

MAESTRO translates from Nastran as follows: 

Quad-->CQUADR 
Triangle and Compound Triangle ->CTRIR 
Frame, Girder and Additional Beam ->CBAR 
Rod->CROD 
Spring->CELAS2   
RSpline (2 node)->MPC 
RSpline (1 node)->RBE2 
Isotropic Material->MAT1 
Composite Material->MAT8 
Fixed Restraints and Enforced Displacement ->SPC, SPC1 

Concentrated Mass--> CONM2

Forces--> FORCE
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Coordinate Frames--> CORD2C, CORD2R, Cord2S, CORD1C, CORD1R, CORD1S

The user will be presented with the following dialog after selecting Nastran from the File >
Import menu.

Select the *.nas or *.dat file to import and click Open.  A Nastran Import dialog will open
allowing the user to set the module location and units.
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**When applying rotation to the imported model, the order the rotation is applied is roll (X-
axis), pitch (Z-axis), yaw (Y-axis).

This option will import the finite elements only, and not the loads.  The model can be
synchronized to the global model using RSpline elements by right-clicking on the new
module in the parts tree and selecting Synchronize.  This will automatically place RSplines
connecting the global model nodes with the imported Nastran model nodes.

Extract Module Command

To split the imported NASTRAN file into modules, use the Extract Module command under
Model > Extract Module. The extract module command allows the user to split the module by
defining upper and lower bounds for form a box that will be extracted. The extracted
contents are placed within a new module under the “top” folder called “extract#”.

Ply-Polygon (*.ply)

MAESTRO has the ability to import ply-polygon mesh geometry files (*.ply).  This feature will
create a new module of the quad and triangle elements in the mesh, all with the same plate
and material property.  See the Importing Geometry and Creating a Mesh In Rhino sections
for more detail.
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Ship Motion (*.smn)

See the Importing Hydrodynamic Loads section.

Wave Scatter (*.sea)

To support computations for the Extreme Load Analysis and Spectral Fatigue Analysis
process, a user can import a wave scatter diagram using this option.  A sample *.sea file can
be found in the Import Hydro Loads directory in the Models and Samples folder.

Operating Profile (*.opf)

To support computations for the Extreme Load Analysis and Spectral Fatigue Analysis
process, a user can import an operating profile using this option.  A sample *.opf file can be
found in the Import Hydro Loads directory in the Models and Samples folder.

Tank Loader (*.txt)

The tank loader allows a user to import a text file to automatically create one or more new
load cases in MAESTRO with the tank load definitions.
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The user can specify a base load case (e.g., lightship condition).  Note: the tank names in
the text file and MAESTRO must match.  Also, if multiple load cases are imported in a single
text file, the newly created MAESTRO load cases will all use the same base load case.  In
the case there are any slight differences in the tank geometry between the source file and
MAESTRO, the user can select to match percent filled, match mass, or let MAESTRO
automatically adjust the density to match the percent filled and mass.  This will attempt to
preserve the tank center of gravity assuming no major differences in tank geometry.

A sample of the text file input is below.  "loadcase" is a keyword used to separate the
different load cases in the file.

PART,  LOAD,  SPGR,  WEIGHT

LOADCASE "abc1"

1I.P,  0.000,  1.025,  0.000

1I.S,  0.000,  1.025,  0.000

LOADCASE "abc2"

1I.P,  0.000,  1.025,  0.000

1I.S,  0.000,  1.025,  0.000

7.2 Exporting Models and Data

MAESTRO has the ability to export different types of data files to support different aspects
of analysis processes.  The following describes each of these types and provides the context
in which a user would utilize them.

Ansys/Nastran

Wetted Cross Section

Wetted Surface

VERES
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PRECAL

To export a model, select File > Export from the main menu and then the type of file to
export.

Ansys/Nastran

This option will launch the Nastran/Ansys Export Options dialog.

To facilitate a way of effectively exporting the parts of the model of interest, please refer to
the Create Module (from general group) command in the Groups Tree section.

MAESTRO export to Nastran as follows: 

ELEMENTS & MATERIAL 
Quad-->CQUADR 
Triangle and Compound Triangle ->CTRIR 
Frame, Girder and Additional Beam ->CBAR 
Rod->CROD 
Spring->CELAS2   
RSpline (2 node)->MPC 
RSpline (1 node)->RBE2 
Isotropic Material->MAT1 
Composite Material->MAT8 
Fixed Restraints and Enforced Displacement ->SPC 

LOADS

Stiffness Matrix

MAESTRO can output the stiffness matrix in Nastran format by clicking the box next to this
option.  A Setting button will appear which can be clicked and a dialog will open to change
the material, pshell, and pbar properties.
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Mass Matrix

MAESTRO can output the mass matrix in Nastran format by clicking the box next to this
option.

Static Analysis
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The Parts List allows the user to select the part(s) or group(s) to export to the Nastran
export files.  To export the entire model, select "top".  Which parts or groups are to be
exported is shown under "Part Specification" on the right of the dialog box.  

FEMAP can be automatically launched once the file is created by clicking the radio button.

The Nastran export creates two files: a Nastran data deck file (*.nas), and a boundary only
data (i.e. enforced displacement) file (*.nas.spcd).  These files are automatically given the
same name as the *.mdl file and saved in the same location, but can be changed by clicking

the button.

Modal Analysis
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The procedure for this type of analysis is the same as for a static analysis, except there are
now more options available.

Structural Mass Matrix

There are two options for dealing with the structural mass matrix.  MAESTRO can either
export the densities and let Nastran calculate the mass, the Consistent option, or MAESTRO
can lump the mass at the nodes and export these values, the Lumped option.
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External Shell Added Mass

The two options for exporting the external shell added mass are to have MAESTRO write
the MFLUID card to be read in Nastran, or MAESTRO can use it's own functionality to
calculate the added mass and apply this mass to the nodes of the external shell elements. 
The Setting button is used to change the MFluid card settings; default values are used
otherwise.

Internal Tank Mass

The two options for exporting the internal tank mass is have MAESTRO write the MFLUID
card to be read in Nastran, or MAESTRO can lump the mass into the nodes defining the
tank skin elements so that the mass and center of gravity of the fluid is matched.

Wetted Cross Section

This option will launch the Export Wetted Cross Section dialog which allows the user to
select the location to save the *.wcs file.  The newly created file will contain the section
locations and wetted cross sectional areas as well as coordinates for the points defining the
cross section based on the defined wetted elements in the model.   

Wetted Surface

This option will launch the Export Wetted Surface dialog which allows the user to select the
location to save the *.wet file.  The newly created file will contain the node locations and
elements for the elements defined as wetted in the model.

VERES

This option will generate a VERES MGF, M3D, or M2D file.  The Start and End fields are the
X (longitudinal) locations of the hydrodynamic model sections and the Sections field is the
total number of sections wanted by the user.  This is the basis for the MGF file, which is the
VERES hydrodynamic sectional geometry.

The remaining options are are described below.
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.M3D

The *.M3D file exports the model’s nodal mass distribution.  This option is only valid for
models with less than 5,000 nodes.

.M2D

The *.M2D file exports the model’s sectional mass distribution.  This option is intended for
larger models with more than 5,000 nodes.

PRECAL

This option will generate a PRECAL HUL, HIN, CND, or INP file.  The following are brief
descriptions of the PRECAL file:

.HUL

The *.HUL file exports the model’s geometry.
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.HIN

The *.HIN file exports the mass properties of the model.

.CND

The *.CND file exports the conditions (i.e., speed and frequency) for the model.

.INP

The *.INP file exports the user specified options to calculate the vessel motions and wave
loads.
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8 NAPA-MAESTRO Interface

Table of Contents

Introduction

Why Create a NAPA/MAESTRO Interface

Level of Effort Comparison for Two Different Approaches

Using the NAPA/MAESTRO Interface for Structural Design

Interface Development Priorities

8.1 Introduction

The following documentation captures details of the NAPA/MAESTRO Interface (NMI) being
developed by Napa Ltd and DRS Defense Solutions, LLC, Advanced Marine Technology
Center (DRS).  This document includes a brief introduction to the NAPA product and the
MAESTRO product and how interfacing the two products can assist in making the structural
design process more efficient by leveraging a single 3D structural model.  This document
also provides a level of effort estimates for two analysis approaches: first, a MAESTRO-only
approach, where the model is built and analyzed in MAESTRO, and second, a combined
approach where the NAPA model is converted to a MAESTRO model, which is then
analyzed in MAESTRO.  Finally, a brief description of the current development pursuits and
priorities are provided.

8.2 Why Create a NAPA/MAESTRO Interface

NAPA Steel is a widely used ship structural design tool used during the early design stages. 
NAPA is used for various ship design purposes, such as calculation of weights, painting
areas, generating data for production planning and cost estimation, and creation of basic
drawings (e.g., drawings for Classification submittal and approval).  The NAPA model can
be converted into a Finite Element Model (FEM) and exported to various FEM systems (e.g.,
Nastran).  The NAPA model can also interface with detail design systems and classification
societies’ systems, which ensures integration during the whole ship design process.

Similar to NAPA, MAESTRO is used during early stage ship structural design.  MAESTRO is
a design, analysis, and evaluation tool specifically tailored for floating structures and has
been fielded as a commercial product for over 20 years and has a world-wide user base. 
MAESTRO’s history is rooted in rationally-based structural design, which is defined as a
design directly and entirely based on structural theory and computer-based methods of
structural analysis (e.g., finite element analysis).  MAESTRO core components are: rapid
coarse-mesh finite element modeling, ship-based loading, finite element analysis, limit state
buckling analysis (e.g., at the hull girder level, stiffened panel level, and local member level),
and design evaluation.

Interfacing these two products will bring more efficiency to the early stage ship structural
design, analysis, and evaluation process.  It will do so by allowing the designer to leverage
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one 3D model from start to finish within the scope of structural design and direct analysis
activities.  This will eliminate the very common practice of recreating 3D structural models to
serve different activities (e.g., one 3D model for Classification drawings and one 3D model
for structural analysis).  Further, by interfacing these two products, the designer does not
have to recreate key loading scenarios in different products.

8.3 Level of Effort Comparison for Two Different Approaches

The following section is organized as follows:

Sample Case Description

Comparison Details

Comparison Conclusions

Sample Case Description

A level of effort comparison was undertaken to quantify the potential efficiency of interfacing
NAPA data (i.e., the FEM data, loading data, etc.) with MAESTRO.  To perform this
comparison, a sample data set of a tanker cargo area, which is shown in below.  Additional
input was established to describe a normal scope of work (SOW) for this type of vessel and
analysis.  There were no specific Classification requirements established, although it was
assumed that reports would be generated for submittal to review authorities.  Further, there
was no specification for computing and imposing hydrodynamic loads or performing fatigue
analysis.  The table below provides the assumed SOW for this comparison.
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Comparison Details

Based on the assumed SOW, activities were developed and sequenced covering the Tasks
listed below.  Labor hour estimates where allocated to Junior, Senior, and Principal
personnel at a distribution of approximately 75%, 20%, and 5% respectively.   Although this
may be different from organization to organization, it provides insight to the potential
efficiencies of using the NAPA/MAESTRO Interface (NMI).  The percentages are provided
below and represent the savings for using the NMI during the course of the listed activity.
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Comparison Conclusions

As expected, there are particular activities that are not affected by the NMI; therefore, there
are no savings for these particular activities.  This comparison assumed three
analysis/design iterations for the cargo area, while assuming only one iteration for the full
ship analysis.  Based on these assumptions, it is estimated that a savings of approximately
45% can be realized using the NMI approach.  This comparison is based on only one data
set.  This type of comparison should be re-examined with multiple data sets and their
respective Classification rules.  Further, this comparison is based on the current state of the
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NMI development.

8.4 Using the NAPA/MAESTRO Interface for Structural Design

The following section is organized as follows:

The MAESTRO Neutral File

Finalizing the MAESTRO Finite Element Model

Conducting Structural Direct Analyses

Revising and Reassessing the Structural Design

Production Classification Drawings

The MAESTRO Neutral File

The figure below depicts the workflow for using the NAPA/MAESTRO Interface (NMI) in a
ship structural design process.  At the core of the interface is the MAESTRO Neutral File,
which contains the NAPA generated data that is pertinent for creating and analyzing the
MAESTRO finite element model.  Napa and DRS AMTC have successfully translated all of
the finite element mesh and scantling information (e.g., unit system, FE nodes, material
properties, and finite elements).  Napa and DRS AMTC have also implemented a translator
for pertinent loading information.  The loading data includes: longitudinal weight
distributions, longitudinal bending moment distributions, hull definition for hydrostatic loading
(i.e., the wetted elements in MAESTRO terminology), tank boundary definitions, tank content
and fill definitions, and hydrostatic equilibrium definition (i.e., trim and heel).  MAESTRO has
many different types of ship-based loading patterns, which include the ones listed above;
therefore, it is not difficult for MAESTRO to leverage this NAPA defined loading data.
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Finalizing the MAESTRO Finite Element Model

Once the user has imported the NAPA-generated MAESTRO neutral file, there are two
tasks to complete before analysis can be conducted.  The first task involves performing
integrity checks on the FEM to ensure it is a valid model and ready for analysis, which is
titled Finalize Finite Element Model in the figure above.  It should be noted that checking the
integrity of the FEM is necessary when performing finite element analyses, whether the
analyst is building the FEM from scratch or importing it from a 3rd-party system.  MAESTRO’
s integrity checks include: element connectivity, uniform element positive pressure sides,
proper wetted element definition, and proper tank definition.  The first figure below shows
the imported NAPA models.  The second figure below shows the hull wetted element
definition, which is important for MAESTRO’s ability to properly impose hydrostatic load.
MAESTRO has the ability to modify this definition, if necessary, to facilitate proper
hydrostatic loading, which is also shown.  Similar integrity checks can be run to verify that
tank boundaries and pressure normals are properly defined, which is shown in the third
figure below.
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Imported FEM from NAPA Steel to MAESTRO

MAESTRO "wetted" Elements for Hydrostatic Loading

Tank Boundary Definition and Creating Consistent Normal Definition
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Conducting Structural Direct Analyses

MAESTRO has the ability to perform comprehensive structural assessment for floating
structures.  This includes performing response analysis (i.e., deformation and stress
analysis) and limit state buckling analysis.  The limit state buckling analysis includes hull
girder collapse analysis, stiffened panel buckling analysis, and local member buckling
analysis.

Review the following sections for details of MAESTRO structural assessment capabilities:

Finite Element Analysis

Limit State Buckling Analysis

Fine Mesh Analysis

Free Vibration Analysis

Revising and Reassessing the Structural Design

After conducting the finite element analysis and post-processing the results, the designer
can revise the scantlings in NAPA and rerun the analysis.  Currently, this is a manual
process, but Napa and DRS are exploring ways to automate this feedback loop.

Production Classification Drawings

When the structural design is adequate and sufficiently optimized to meet the objectives of
the owner, the next step is to produce a complete set of structural drawings (i.e., the
scantling plans) suitable for submittal to a Classification authority.  At this juncture in the
design process, the updated NAPA model serves as the source for creating these 2D
drawings.  This utilization of the 3D model is currently being used among NAPA customers
in different levels.  This leads to a remarkable savings in developing class drawings.  With
the current version of NAPA, the fully automatic drawing creation needs development work
from the customer to complete company standard quality drawings.

8.5 Interface Development Priorities

The following sections describe the envisioned workflow and current capability of the
NAPA/MAESTRO Interface (NMI).  This development and progress has shown great
promise thus far.  The following items are being pursued and improved upon to increase the
robustness of the interface.

Finite Element Modeling

Napa and DRS are working to resolve a few issues related to generating the FEM mesh. 
The issues are related to the following: Warped Quads, Internal Quad Angles, Free Edges,
and Tank Boundary definition.
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Loading Conditions

Napa and DRS have identified the pertinent loading data to be transferred to MAESTRO. 
Formats for transferring this data have been agreed upon and testing of more loading
scenarios is necessary.

Analysis

All of the required analysis capability is available in MAESTRO.  As described in previous
sections, MAESTRO has an existing limit state analysis paradigm.  This paradigm includes
performing limit state analysis and collecting elements to represent the true stiffened panel. 
This paradigm is flexible in the sense that other criteria, such as those directed by
Classification societies, can be implemented if necessary.

Optimization/Feasibility

MAESTRO has the ability to perform optimization of structural scantlings using the Monte
Carlo method and the Simulated Annealing method.  This capability is in an Alpha stage of
development, but can potentially be leveraged to assist the designer in finding an optimized
design solution.  Napa and DRS are exploring ways to bring this technology to the design
process.
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9 Loading The Model

The topics in this section provide detailed information on the MAESTRO functionality used
while loading the model for an analysis.  It describes the different methods for loading the
model as well as options to graphically view the loads applied.

9.1 Groups Tree

The groups tree displays each group which has been created in the model, in a folder format
directory. Each group appears as its own directory, and cannot be a subdirectory of another
group.  However, individual groups within a folder may be organized into subfolders.The
following group types are all accessible from the Groups menu. The following groups each
have a tab in the groups dialogue as well.

 

General Groups

Volume Groups

Plate Groups

Nodal Groups, Module Groups, Section Groups, Bay Groups, and Corrosion Groups

To create a subfolder, select the appropriate group ID or Name, type in the subfolder name
before the group name followed by a forward slash, and click modify. Bring similar tanks into
the subfolder by dragging and dropping into the folder.
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Any group can be copied, deleted or renamed in the group window, using the popup menu
launched by right-clicking the mouse.

The General Groups right-click menu is:

Set View Part

This will set the highlighted group as the current view.

Set Visibility On
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This will toggle the visibility on for the highlighted group.

Set Visibility Off

This will toggle the visibility off for the highlighted group.

Context Default Color

This will display the highlighted group with the default MAESTRO element colors in the
context of the entire model; the un-highlighted groups will be represented in a wire-frame
view.

Context UserDef Color

This will display the highlighted group with the user-defined colors selected in the Groups
dialog. The highlighted group will be displayed in the context of the entire model, where the
un-highlighted groups will be represented in a wire-frame view.

Free Edges

This will check the highlighted group for free edges.

Rename

This will allow the group to be renamed within the groups tree.

Copy

This will create a copy of the highlighted group.

Delete

This will delete the highlighted group.

Normal

This will display the highlighted group with the normal side of elements colored.

Create Module

 Right-clicking general groups and selecting "Create Module" will split the module from
current module and place it within a new module under a folder named "general". "General"
will be located under the "top" directory and within it will be the group, with parts split into its
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own module titled "extract#".

Consistent Normal

Please see the Defining Consistent Normals section.

Wettable/Unwettable

This will toggle the plate elements of the highlighted general group as wet or unwet.

Flip Normal

This will flip the normal direction for the elements of the highlighted general group.

Eval/Un-Eval

This will flag the highlighted general group for allowing/ignoring it during limit state
evaluation.

Do/Undo Master

This will make the highlighted general group's elements master elements so they do not
show up when you display the coarse and fine mesh models at the same time.  When you
view all modules, the coarse elements used to create the fine mesh model will not be
displayed overlapping the new fine mesh elements.

Auto Create From Seeds

Please see the Creating Groups from Seed Elements section.

Peel Free Edge Elements

This functionality supports the creation of closed group (e.g., volume groups, plate groups,
etc.).  Once this function is executed on a particular general group, MAESTRO will search
the elements within this group and eliminate (or peel) elements that have a free edge.  The
user can use this function in combination with dragging and dropping the general group into
a plate group to eliminate unwanted beam elements.  Ultimately the user's goal is to be left
with a closed group without any free edges, which can then be converted to a volume group
for loading.

Create Patch

This will create an evaluation patch using the elements of the highlighted general group.
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Refine

This will launch the Refine dialog and allow the user to create a fine mesh model of the
elements in the highlighted general group.

Modify

This will launch the Modify Properties dialog which allows the user to modify the highlighted
general group's settings.  These settings will apply to all applicable elements of the general
group.  For instance changing the plate property will change all plate elements in the group
to the specified property.

The Volume Groups right-click menu is:
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** Please see the General Groups right-click menu definitions for menu options not listed
below.

Volume/Plate Pressure Side

This will display a graphical representation of which side of the plate elements the pressure
load is being applied to.

Volume Pressure

This will display a graphical representation of the volume pressure for the selected group if
defined in the currently selected load case.

Volume

This will report the volume of the group, if applicable.

Consistent Pressure Side

This will make all of the elements pressure side in the volume group uniform.

Flip Pressure Side
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This will flip the pressure side of all elements in the volume group.

Volume Table

This will produce a table of tank volumes and masses based on the currently selected load
case.  Note this option is only available when right-clicking on the "parent" volume group
item in the groups tree.

The Plate Groups right-click menu is:

** Please see the General Groups and Volume Groups right-click menu definitions for menu
options not listed below.

The Nodal Groups, Module Groups, Section Groups, Bay Groups, and Corrosion Groups
right-click menu is:
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** Please see the General Groups and Volume Groups right-click menu definitions for menu
options not listed below.

9.2 Creating Groups

Toolbar  

Menu  Groups >  

Keyboard  <Ctrl + g>

The groups dialog allows for the creation of 8 different types of groups.  New groups are
automatically added to the groups tree under its appropriate heading.  Groups are often
used to load the model as shown in the figure, as well as for post-processing.   For details
on using the group operations dialog, please see the Groups Menu section.

A more detailed description and steps to create each group are below:

General

Volume

Plate 

General/Volume/Plate Group Selection Options

Module

Section

Nodal

Bay

Corrosion

Wetted

Organizing Groups

Defining General Groups from an Elements List or Nodes List

Defining General Groups from Seed Elements

Defining Wetted Elements from General Groups

Defining Volume Groups from General Groups
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Defining Consistent Normals for Volume, Plate, and General Groups

General Group

The General groups dialog is a convenient way for the user to create a collection of
elements for viewing "areas of interest." The General groups is also used create a General
group which can then be refined for fine meshing or simply used for viewing this particular
"area of interest."  A general group can include any type of elements.

1.  Begin by opening the groups dialog box using the Groups > General... menu option, or
from the toolbar.

2.  Click the ID button to assign a unique ID to the general group.

3.  Type a descriptive name into the Name box and select Select under the Group Type.

4.  Check the Centerline Group if the general group spans the centerline of a half model.
This will automatically combine the mirrored group into one single group if the model is
mirrored.

5.  Checking the Full Strake/Full Compound box will include the entire strake or compound
as the part of the general group by clicking on any part of it.

6.  Checking the Whole Module box will include all elements of the module by clicking any
part of it.

7.  Click inside the main white part of the dialog box and then select the elements that make
up general group.  The Select By Box option can be checked to use a box window to add all
the elements within that select box.

Once an element is added to the group, right-clicking on the element will bring up a menu
allowing the user to flip normal side, or add all elements with the same property, material,
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stiffener layout, or type.  This will apply to all elements in the current view part.

8.  Select a color from the drop down menu to give the general group a unique color.

9.  Click the Create button.

The new general group will appear in the Groups Tree as one of the General groups, with
whatever name was given in the Groups dialog box.

Volume Group

Tanks can be easily created in MAESTRO by defining a volume group by clicking the
elements that make up the boundary faces of the tank.

This tutorial shows the procedure for creating a tank defined by a volume group.

1.  Begin by opening the groups dialog box using the Groups > Volume... menu option, or
from the toolbar.

2.  Click the ID button to assign a unique ID to the tank.

3.  Type a descriptive name into the Name box and select Volume under the Group Type.

4.  Check the Centerline Group if the tank spans the centerline of a half model.  This will
automatically combine the mirrored group into one single group if the model is mirrored.

5.  Checking the Full Strake/Full Compound box will include the entire strake or compound
as the tank boundary by clicking on any part.
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6.  Click inside the main white part of the dialog box and then select the elements that make
up the tank boundary faces.  The Select By Box option can be checked to use a box window
to add all the plate elements within that select box.

Once an element is added to the group, right-clicking on the element will bring up a menu
allowing the user to flip normal side, or add all elements with the same property, material,
stiffener layout, or type.  This will apply to all elements in the current view part.

7.  The Normal of the element can also be flipped by double clicking in the Flip Normal
column to change between Yes and No.

Once the Flip Normal is changed to Yes or No, it will remain the same as new elements are
added to the definition.

8.  Select a color from the drop down menu to give the tank a unique color. You can view the
tank in your user defined color by right-clicking the group in the groups tree and selecting 
Context UserDef Color

9.  Click the Create button.

The new tank will appear under the group tab of the parts tree under the Volume folder as
the name given in the Groups dialog box.

10.  Right-click the tank name and select Set View Part.

11.  Select View > Plate > Volume/Plate Pressure Side from the menu.

This will show the pressure side of the tank due to its volume contents.  In order for
MAESTRO to treat the tank load properly, the tank plate elements should all have their
volume pressure side on the inside of the tank.

12.  While still in the Volume/Plate Pressure Side view, the dynamic query can be used to
highlight an element and right-click and select Flip Pressure Side to change the pressure
side.  Similarly, the user can right-click on a volume group and select Consistent Pressure
Side.  This will automatically assign all of the inside or outside elements to the same
Volume/Plate Pressure side.  If the outside of the tank is the pressure side, the user can
right-click on the volume group and select Flip Pressure Side to automatically flip all the
pressure sides.

It is helpful to use the shrink elements view,   to verify the pink pressure side is on the
inside of the tank.

Plate Group

A plate group is a group of panel elements that can be used to apply a mass or pressure
load to.

1.  Begin by opening the groups dialog box using the Groups > Plate... menu option, or
from the toolbar.
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2.  Click the ID button to assign a unique ID to the plate group.

3.  Type a descriptive name into the Name box and select Plate under the Group Type.

4.  Check the Centerline Group if the plate group spans the centerline of a half model.  This
will automatically combine the mirrored group into one single group if the model is mirrored.

5.  Checking the Full Strake/Full Compound box will include the entire strake or compound
as the part of the plate group by clicking on any part of the strake or compound panels.

6.  Click inside the main white part of the dialog box and then select the elements that make
up the tank boundary faces.  The Select By Box option can be checked to use a box window
to add all the plate elements within that select box.

Once an element is added to the group, right-clicking on the element will bring up a menu
allowing the user to flip normal side, or add all elements with the same property, material,
stiffener layout, or type.  This will apply to all elements in the current view part.

7.  The Normal of the element can also be flipped by double clicking in the Flip Normal
column to change between Yes and No.

Once the Flip Normal is changed to Yes or No, it will remain the same as new elements are
added to the definition.

8.  The mass of the plate group can be defined here and will be used if the plate group is
added to a load case as a mass.

9.  Select a color from the drop down menu to give the plate group a unique color.

10.  Click the Create button.

The new plate group will appear under the group tab of the parts tree under the plate folder
as the name given in the Groups dialog box.
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General/Volume/Plate Selection Options

When adding elements to a general/volume/plate group, the element selection options are:

· Element: the user manually clicks each element to add to the group.

· Strake/Cmpd: the user clicks a single element of a strake or compound and that entire
strake or compound is added to the group.

· Whole Module: all of the selected module's elements are added to the group.

· Box: the user is able to create a box with the mouse and add all of the visible elements
within the box to the group.

· Patch: the user can add elements by selecting on evaluation patches.  This will add all of
the elements making up the patch.

In addition to these selection methods, there are several options available from the right-
click menu once an element is added to the group:

· Add By Prop:  This option will automatically add any other visible elements with the same
property (i.e., plate, beam, rod, spring property) as the element selected.

· Add By Mat:  This option will automatically add any other visible elements with the same
material property as the element selected.

· Add by Stif Layout: This option will automatically add any other panel elements with the
same stiffener layout as the element selected.

· Add By Type: This option will automatically add any other visible elements with the same
type (e.g., strake quad, strake beam, additional quad, etc.) as the element selected.
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· Add By Seed: This option will use the selected element, or elements, as seed elements in
order to search for other elements.  This option will open the Element Search Criteria
dialog and follows the same process as described here.

· Add By Attached Prop: This option will automatically add any attached elements that share
the same property as the selected element.

· Add By Attached Beams: This option will automatically add any visible beam elements
connected to the selected plate element.

Module Group

A module group is a group of module(s) used to scale the structural weight of a model.  This
group is used to define a non-structural mass whose spatial distribution closely
approximates the surrounding structure. The mass is distributed among the structural nodes
in the same proportion as the structural mass, and can represent items such as furniture,
paneling, auxiliary machinery, or any additional structural weight. This can also be used as a
tool to match a known weight distribution.

1.  Begin by opening the groups dialog box using the Groups > Module... menu option, or
from the toolbar.
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2.  Click the ID button to assign a unique ID to the module group.

3.  Type a descriptive name into the Name box.

4.  Click in the white space and then click on the module(s) to add to the group.

5.  Assign the modules a scaled mass/weight value.  This mass/weight is assumed to be
symmetric, and should be a half value for half-width models. Note the field is dependent on
the Units used; Mass (when working with SI Units) or Weight (when working with fps, mks,
cks, and ips Units).  

6.  The Add Whole Ship option can be clicked to add all modules.  In this case, the mass/
weight assigned to these modules is the full value, regardless of whether the modules are a
half-ship.

7.  Select a color from the drop down menu to give the module group a unique color.

8.  Click the Create button.

The new module group will appear under the group tab of the parts tree under the module
folder as the name given in the Groups dialog box.

Section Group

In the design of long structures such as ships, where overall bending is the dominant load
effect, the lengthwise distribution of mass must be accounted for early in the design, and
should be modeled as accurately as possible at all stages of the design. Ideally in a
three-dimensional model the masses should be placed at their actual locations, using
whichever of the methods presented here (volumes, bays, module, nodal, plate) is most
appropriate for each type of mass.

But at early stages of design some masses may be known (or estimated) only in the form of
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a one-dimensional distribution along the length of the structure, and the Section definition
option is intended for this (and only this, because it is very approximate). In the Section
option, the one-dimensional mass distribution is specified as a target value of mass per
length for each section interval of selected modules. For each section interval, the program
converts this target value of distributed mass into point masses at the endpoint-generated
nodes in each of the two sectional planes at the boundaries of that section interval. Hence
the selected modules must be orientated lengthwise in the structure. Transverse modules
(such as a transverse bulkhead) should not be included. With this option there is no flexibility
in choosing the nodes; within each section (YZ plane) the program uses all of the
endpoint-generated nodes, and it allocates the point masses in proportion to the structural
mass of the strake-based elements (panels, girder segments and frame segments) attached
to those nodes.

The target values of distributed mass are specified (and may differ) for each section interval.
The target values refer only to the modules for which they are defined. In the simplest case,
when each module constitutes a complete transverse section of the structure, the target
values correspond to the full cross section of the structure (or to a half section for a half
model). However, if some of the modules are in parallel (such as a hull module surmounted
by a superstructure module) then the target values of distributed mass must be divided and
apportioned among those modules. In a half model all specified values of mass should be
half values.

A sections group is used to define a non-structural mass which is distributed among the
sections of a module. The additional mass on the module can be either equal for all
sections, or different for each section. Within each section, each endpoint-generated node
carries the same mass.

1.  Begin by opening the groups dialog box using the Groups > Section... menu option, or
from the toolbar.



Loading The Model 303

© 2014 Optimum Structural Design, Inc.

2.  Click the ID button to assign a unique ID to the section group.

3.  Type a descriptive name into the Name box.

4.  Click in the white space and then click on the module(s) to add to the group.  Clicking any
element of a module will add the entire module to the group.

If the Module all sections box is checked, when a module is added, it's mass/weight per
length will apply to all sections of that module.

5.  Define the mass/weight per length for each section or entire module.

The mass will automatically update based on the length of the section.

6.  Select a color from the drop down menu to give the section group a unique color.

7.  Click the Create button.

The new section group will appear under the group tab of the parts tree under the section
folder as the name given in the Groups dialog box.

Node Group

A node group is used to define an additional mass which is equally divided among a
collection of nodes. The nodes may be of any type (endpoint-generated or additional), and
can be located anywhere in the model.

1.  Begin by opening the groups dialog box using the Groups > Node... menu option, or
from the toolbar.
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2.  Click the ID button to assign a unique ID to the node group.

3.  Type a descriptive name into the Name box.

4.  Click in the white space and then click the nodes to be added to the group.  Checking
the All visible nodes in the section will add all the nodes in the section of the next clicked
endpoint node.  Note: this must be unchecked to add an additional node to the group.

5.  Check the Centerline Group if the node group spans the centerline of a half model.  This
will automatically combine the mirrored group into one single group if the model is mirrored.

6.  Define the mass/weight of the node group.  Each node will receive an equal portion of the
total mass/weight.  Note: if the nodal group is made up of only centerline nodes, the mass/
weight should be assigned the full value regardless of whether is is a half model.

7.  Select a color from the drop down menu to give the section group a unique color.

8.  Click the Create button.

The new node group will appear under the group tab of the parts tree under the Node folder
as the name given in the Groups dialog box.

Bay Group

This group option is intended for large solid masses that are supported at several nodes and
whose center of mass is at an appreciable distance from these nodes. Common examples
are bays of containers, main engines, and un-modeled portions of structure such as masts. 
Bays, and the sets of masses within them, are selected individually by using the groups
dialog. In addition, the way a support node handles mass may change between load cases.
This simulates the case of containers, particularly, which are constrained by cell guides and
one-way attachment devices. 
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NOTE: The defined centroid and gyradii are not carried over in a Natural Frequency
Analysis.

1.  Begin by opening the groups dialog box using the Groups > Bay... menu option, or from
the toolbar.

2.  Click the ID button to assign a unique ID to the bay group.

3.  Type a descriptive name into the Name box.

4.  Click Create.

5.  Click Add Set.  You can then give the set a name, mass, centers of gravity and radii of
gyration.

6.  Click in the lower window, and then select nodes from the model to add to the set.

7.  The columns for X+, X-, Y+, Y-, Z+, and Z- are used to define whether the corresponding
node can receive force in that direction due to an additional acceleration, designated either
with a "Y" for yes or "N" for no.

8.  Click Modify to save the changes.

Sample bay set input data can be found in the Models and Samples MAESTRO installation
directory as BayAcceleration.mdl and BayBalance.mld.

Corrosion Group

This group option allows the user to define a group that will consider corrosion effects. The
user can define which side (stiffener, plate, or both) the corrosion effects occur. Further, the
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user can choose to apply corrosion by a percentage or as a net. The user can apply
corrosion to the plate, web, or flange associated with the corrosion group.

1.  Begin by opening the groups dialog box using the Groups > Corrosion... menu option,
or from the toolbar.

2.  Click the ID button to assign a unique ID to the corrosion group.

3.  Type a descriptive name into the Name box.

4.  Check the Centerline Group if the general group spans the centerline of a half model.
This will automatically combine the mirrored group into one single group if the model is
mirrored.

5.  Checking the Full Strake/Full Compound box will include the entire strake or compound
as the part of the general group by clicking on any part of it.

6.  Checking the Whole Module box will include all elements of the module by clicking any
part of it.

7.  Click inside the main white part of the dialog box and then select the elements that make
up the tank boundary faces.  The Select By Box option can be checked to use a box window
to add all the plate elements within that select box.

Once an element is added to the group, right-clicking on the element will bring up a menu
allowing the user to flip normal side, or add all elements with the same property, material,
stiffener layout, or type.  This will apply to all elements in the current view part.

If the Whole Module box is checked when selecting elements, an additional dialog box will
open.
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This allows the user to define the corrosion side and method for defining the corrosion.  This
will be applied to all elements in the selected module.

8.  Select a color from the drop down menu to give the corrosion group a unique color.

9.  Click the Create button.

The new corrosion group will appear under the group tab of the parts tree under the
Corrosion folder as the name given in the Groups dialog box.

Group Wetted Elements

A general group of all defined "wetted" plate elements can be created using the Groups >
Wetted Elements menu.  This will automatically create the general group "wet" and does
not involve using the Groups dialog.  Elements are defined as "wetted" by checking the box
for quads and triangles or by selecting "side" or "bottom" as the location in the strakes
dialog.

Expanded Group Organization Feature

Subfolders can be created under any group types. The subfolder’s icon will be a folder, while
the group itself will have an icon matching that of a part.  To create a subfolder and group
within this subfolder, the user must use the "/" (forward slash) character when naming the
group.  

For example, to create a subfolder and group called "postprocessing" and "forward"
respectively, the user would enter the following in the name field: "postprocessing/forward". 
The resulting group in the Group Tree would look like the following:
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Once multi-level groups are created, the user can simply drag and drop the group tree
objects into any folder.

Defining General Groups from an Elements List or Nodes List

A list of elements or nodes can be output to the grid tab at the bottom of the MAESTRO
interface by selecting the group or module in which you are interested and clicking Results
> List > Elements or Results > List > Nodes. The individual elements or nodes can be
made into a general group by right-clicking and selecting Create General Group. Multiple
elements or nodes can be selected as well and made into a general group. To refresh the
list and view only elements or nodes that are visible, right-click and select Show Current
View.

General Groups from Seed Elements

There are many cases where the user would like to generate large general groups.  These
general groups are used for post-processing, conversion to other group types, etc.  The
following example demonstrates how creating general groups from seed elements can make
this process much quicker than other MAESTRO group creation methods.  This method is
especially useful when importing Nastran (or other 3rd-party finite element models) models
that need the hull wetted elements generated for proper hydrostatic/hydrodynamic loading.

The following example creates a general group of the hull envelope using seed elements
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1.  Begin by opening the groups dialog box using the Groups > General... menu option, or
from the toolbar.

2.  Click the ID button to assign a unique ID to the general group.

3.  Type a descriptive name into the Name box.

4.  Click inside the main white part of the dialog box and then select one or more seed
elements that make up the hull boundary.

5.  Click Create.  A general group, consisting of the identified seed elements has now been
created and can be viewed in the Groups tree.
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6.  From the group tree, select previously defined seed group, right mouse click to select
“Auto Create from Seeds” menu item
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7.  The Element Search Criteria dialog box now appears.  Define the criteria and click OK.
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NOTE:

Here the user has the ability to define the searching criteria by specifying a bounding box
range (e.g., Min. X, Max X, Min. Y, etc).  The searching criteria is further refined by
specifying the threshold angle of neighboring elements.  For example, if the user defines
160 degrees, any element whose edge face normal is connected to the seed element having
an element normal angle greater than 160 degrees relative to the seed element edge face
normal will be added to the group.  This new element, just added to the group will then
perform the same criteria check, thus adding the element if it is within the threshold angle
and within the bounded box.  This process continues until all elements, within the specified
criteria are added to the group.

8.  The new General Group has been added to the groups tree.  View the new group to
confirm the definition.  In this example, we've created the elements associated with the hull
envelope.  Now, it is the task to make these elements wetteable in order for MAESTRO to
apply hydrostatic loading.  See the next section for details on how to accomplish this.

Defining Wettable Elements from General Groups

The following tutorial provides details regarding the definition of wettable elements from a
general group; therefore, it is assumed you have successfully created a general group.

1.  From the groups tree, right-click on the general group of interest and select the
"Wettable/UnWettable" menu item.
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2.  Next, you are asked whether you want to make all elements wettable or unwettable.  Yes
= make all elements in group wettable elements / No = unwettable elements 

3.  Using the Parts tree, view the entire model and then choose View > Wettable Elements
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to confirm the elements have been defined correctly.

Defining Volume Groups from General Groups

Volume groups can be created from existing general groups using the group operations
dialog.  This will convert all of the shell elements from the general group into a new volume
group. In addition to this method, a general group can be right-clicked to reveal the Peel
Free Edge Elements command. Wetted elements can be subtracted from general group as
explained in the group operations dialog. Furthermore, free edges can be peeled to reveal a
tank within the module. Free edge elements that have been peeled from the general group
are preserved as a new general group. They can be dragged and dropped back into the
main general group or discarded. When the volume group is all that remains, it can be
dragged and dropped under the volume group folder.

Defining Consistent Normals for Volume, Plate, and General Groups

The following procedure will facilitate defining consistent normals for volume and plate
groups.  This is especially helpful when importing finite element models from 3rd-party tools,
where a consistent normal definition is not present (such as the image below)

1.  Begin by right-clicking on the volume (and/or plate and/or general) group of interest and
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select the "Consistent Normal" menu item.

2.  At this point, although the normals are consistent, they still may need to be flipped, which
can be done either by dynamically querying individual elements or flipping the normal for the
entire group.  Click "Flip Pressure Side" to flip the normal for the entire group.

9.3 Defining Loads

Toolbar  

Menu  Loads > Create/Modify...

Keyboard  <Ctrl + l>

A load case consists of all of the loads which act on the structure at the same time. Loads
which do not act simultaneously should be placed in separate load cases (unless their
interaction is negligible). Each load case produces a separate solution for the nodal
displacements, and hence load effects, in the structure. In the evaluation portion of
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MAESTRO, for each possible limit state, the solutions for all load cases are examined to find
the worst case (lowest adequacy parameter) for that limit state. A dynamic load case
requires masses and accelerations. The mass data is obtained by selecting any combination
of masses and by adding properties that are specific to the intended load case. 

The following figure presents the overview of MAESTRO's loading capabilities.

The following subsections give more details regarding the Loads dialog:

Creating A Load Case

General Tab

End Moments Tab

Acceleration Tab

Mass Tab

Point Force Tab

Pressure Tab

Balance Tab

Restraint Tab

Corrosion Tab
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9.3.1 Creating A Load Case

The following tutorial shows the procedure for defining a load case.

1.  Begin by opening the loads dialog from the Loads > Create/Modify... menu option, or
from the toolbar.

2.  Click the LoadCase button to create a new load case.

3.  Give the load case a descriptive title.

4.  Check the desired options for the load case on the general tab and click Create.

5.  Click on each of the relevant tabs to define each aspect of the load case.

Note: Fore more information on each tab option, see the specific tab topics of this section.

6.  Repeat steps 2-5 to create additional load cases.
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9.3.2 General Tab

The general tab allows the user to select the particular load options as well as view the
status/summary of the currently selected load case.

Depending on which options are checked, the load tabs will activate/de-activate accordingly.

9.3.3 Mass Tab

The Mass tab allows the user to add previously defined groups to the load case definition as
well as redefine the values of these groups. Properties of masses can be added using six
options: as volumes, as scaled-up structural mass, as sections, as various groups of point
masses, and as large solid masses whose centroid is at an appreciable distance from the
supporting nodes, such as main engines and bays of containers. For each load case, any
combination of the previously defined groups (Volume, Module, Section, Node, and Bay) can
be chosen, and specific properties can be assigned if they differ from the default value.
MAESTRO will use these values to calculate all of the inertia forces in all members
throughout the structure, and apply these as loads.

NOTE:

In non-SI unit systems that specify densities in force units, the masses should be defined in
terms of weight; for example, the fps or ips unit systems use pounds as a weight where
mass is specified.  Therefore, when using a unit systems that specifies density in terms of
force (this can be found in the Units dialog), mass should be interpreted as weight. 
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MAESTRO will automatically convert these weights to mass internally by dividing by gravity.

NOTE:

In a half model all specified values of mass should be half values.  For a half model, all
masses (except for Bay Set) are assumed to be symmetric and there is no need to define
the corresponding mass in the un-modeled half.   For example, a plate group defined in the
modeled side will be assumed to be included in the un-modeled side as the same
mass/weight.

Each method for defining a mass is described in more detail below:

Volume

Module

Section

Node

Plate

Bay

Distribution

Volume Mass

The Volume mass tab is for the user to add "tanks" or volume groups to the current load
case definition. These previously defined volume groups are made available to the user via
the drop-down menu. After a volume group is added the user can specify the parameters of
the volume contents.
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Once a group is selected from the drop-down menu, click Add to add the tank group to the
dialog.  

Volume Status
The volume status can be set to either Intact or Flooded.  The Flooded status will assume
the free surface of the fluid in the tank is at the equilibrium waterplane.  If the flooded tank is
fully submerged, the tank is fully filled.   The fluid is assumed to have the same properties as
the environment defined in the Job Information dialog if the original content's density is less
than the environment density, otherwise the original content's density is used.  When
performing the hydrostatic balance of the model, MAESTRO will use  the "added mass"
method to calculate the model's new equilibrium.

Volume Type
The tank load "Type" can be defined three ways: mass, fraction of the volume filled, or the
pressure "head" measured parallel to the total acceleration vector, from the point of lowest
pressure to the point of highest pressure.  The fraction and head option will automatically
calculate the mass/weight of the tank using the given density. The volume can also be
loaded with "dry::mass" as the type. This option distributes the pressure as does liquid
mass, but the "free surface" remains fixed despite any trim or heel of the ship.

Volume Value
The value of the mass, fraction, or head is entered into the Value column. 

Volume Density
Enter the density of the volume content in the units specified.

Volume Pipe Head
An optional value of the additional "head", measured as the height of fluid in a pipe for this
volume, can be added by entering a value into the Pipe Head column. Using the fluid density
of this volume, MAESTRO will calculate and add a constant pressure throughout the
volume. The height is constant and assumed as defined. The additional "Pipe Head" option
is to be used when the tank volume is filled to the tank top and a pressure head of a certain
height is known to be applied above the tank top. 
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Volume DeBallast
Alternatively, if the pressure head is unknown, "DeBallast Pressure" can be applied to
simulate deballasting a tank or to "press up" a tank. This pressure will be applied as a
constant over all boundaries of the tank.

Volume Permeability
A permeability can be added by entering the decimal percent of space that can be occupied
in the "Permeability" column. The permeability will multiply the density to adjust in the space
occupied by the fluid volume.

The Total Mass button will report the total mass of the defined volume groups based on their
loading.  

The CK OverFill will check that no tanks are overfilled based on the density and loading
parameter.

Module Mass

Mass that is not of the load-carrying structure but whose spatial distribution approximates
that of the structure is usually represented as a scaled version of the structural mass. This
offers the user a method to generate a specified amount of additional (non structural) mass
and allocate it to a group of specific modules in proportion to their structural mass. Here the
user can add Scaled Mass groups, that were previously created using the Groups dialog, to
the current load case definition. These previously defined scaled mass groups are made
available to the user via the drop-down menu. In each load case a new value can be
specified for the amount of mass to be added, and this overrides the value given in the
scaled mass group dialog.



MAESTRO 11.0.0322

© 2014 Optimum Structural Design, Inc.

Once a module group is selected from the drop-down menu, click Add.  The Mass column
displays the previously defined Mass and can be overridden here, if desired.  

The Total Mass button will report the the total mass of all the module groups in the current
load case.

Section Mass

In the design of long structures such as ships, where overall bending is the dominant load
effect, the lengthwise distribution of mass must be accounted for early in the design, and
should be modeled as accurately as possible at all stages of the design. Ideally, in a
three-dimensional model, the masses should be placed at their actual locations, using
whichever of the methods presented here (volumes, bays/sets, scaled, nodal, plate) is most
appropriate for each type of mass.

But at early stages of design some masses may be known (or estimated) only in the form of
a one-dimensional distribution along the length of the structure, and the Section mass option
is intended for this (and only this, because it is very approximate). 

Here the user can add Section Interval groups that were previously created using the
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Groups dialog to the current load case definition. These previously defined section groups
are made available to the user via the drop-down menu. 

Note:  The values of the section groups can only be changed via the groups dialog.

Once a section group is selected from the drop-down menu, click Add.  The section interval,
length, mass/length and mass values are updated from the section definition, but these
values can only be changed using the groups dialog.

Node Mass

The Node mass option offers the user a method to generate a specified amount of additional
(non structural) mass and allocate it equally among the nodes defined in the nodal group.
The user can add Nodal groups, that were previously created using the Groups dialog, to
the current load case definition. These previously defined nodal groups are made available
to the user via the drop-down menu. The default value of total mass to be added can be
overridden in this dialog.
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Once a node group is selected from the drop-down menu, click Add.  The Mass column
displays the previously defined mass and can be overridden here, if desired.  

The Total Mass button will report the the total mass of all the node groups in the current load
case.

Plate Mass

The Plate mass option offers the user a method to generate a specified amount of additional
(non structural) mass and allocate it equally among each plate element that defines the plate
group. Here the user can add Plate groups, that were previously created using the Groups
dialog, to the current load case definition. These previously defined plate groups are made
available to the user via the drop-down menu. The default value of total mass to be added
can be overridden by another value.
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Once a plate group is selected from the drop-down menu, click Add.  The Mass column
displays the previously defined mass and can be overridden here, if desired.  

The Total Mass button will report the the total mass of all the plate groups in the current load
case.

Bay Mass

The bay mass option is intended for large solid masses that are supported at several nodes
and whose center of mass is an appreciable distance from these nodes.   Here the user can
add Bay groups, that were previously created using the Groups dialog, to the current load
case definition. These previously defined bay groups are made available to the user via the
drop-down menu. The default value of mass to be added can be overridden by another
value, if desired.

See the ...\MAESTRO\Models and Samples\Loads\Bayset directory for sample model data.



MAESTRO 11.0.0326

© 2014 Optimum Structural Design, Inc.

Once a bay group is selected from the drop-down menu, click Add.  The Mass column
displays the previously defined mass and can be overridden here, if desired.  

The Total Weight button will report the the total weight of all the bay sets in the current load
case.

The CK Tip Over button will check to see if any of the bay sets are tipped over.

Mass Distribution

The mass distribution option is intended to allow the user to input a mass value or weight
density at defined longitudinal coordinates.  Users can choose to use linear interpolation or a
step function for defined weight densities.  It also allows the user to define the transverse
and vertical center of gravity and inertias for the total mass distribution weight (the specified
center of gravity and inertia is only for the weight represented by the distribution).

First, the user can toggle between the modes of Lump,  Density (Linear), or  Density (Step),
by left-clicking on the Weight check box.  Second, the user can toggle between Specifying
CG, Specifying CG and Inertias, and No Specification of CG.  Finally, the user can select
particular nodal groups (via a drop-down) to Exclude from the mass distribution load.
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Click Add Row to add a new row of mass or mass density input.  Enter the x-location of the
mass in the "X(units)" column.  Clicking the button next to "CG" or "CG & Inertia" will allow
the user to enter the transverse and vertical CG or CG  and Inertias for the total mass
distribution weight.  Note: if additional loads are imposed on the model, the total model CG
will be different from the mass distribution CG.

The CG Utility allows the user to have MAESTRO automatically calculate the user-defined
VCG and TCG for the weight distribution in order to reach a target VCG and TCG for the
entire model.  The user specifies the Target VCG and TCG, the weight and CG of any other
loads in the load case, the weight distribution's weight, and clicks "Compute" to determine
the user-defined VCG and TCG for the weight distribution.
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Mass distribution data can be copy and pasted from another program, such as Microsoft
Excel.  Before pasting the data, there needs to be enough blank rows to accommodate the
data in the input window.

The Total Weight button will report the the total weight of all the mass distribution rows
entered in the current load case.
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9.3.4 Acceleration Tab

The Acceleration tab can be used to apply an additional acceleration to the model.  The
acceleration can be applied at the center of flotation, center of gravity, or at a user defined
location (The center of flotation and center of gravity values are automatically calculated). 
The acceleration can be applied to all 6 degrees of freedom in the ship or world coordinate
system.

The acceleration units and reference point length units are regarded as those defined in the
Units dialog.
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9.3.5 End Moments Tab

The End Moments tab can be used to apply a prescribed bending moment, shear force, or
torsional moment to a "cut model" only.  The "cut model" option can be selected in the Job
Information dialog.  The model boundaries are defined by the Start and End Modules in the
Restraints dialog.

The force and length units are regarded as those defined in the Units dialog.

Even if only half of the model is defined, the values for the full cross section should be
applied. If a bending moment is applied to the model, the MAESTRO balance command can
be used to calculate the shear force.  Please see the End Moments section of the Balancing
the Model documentation.

A "sagging" bending moment is positive and a "hogging" bending moment is negative. 
Shear force is positive upwards at the reference and opposite end.

A horizontal bending moment is positive if the resulting curvature in the model's XZ plane
has its concave side in the +Z direction.
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The sign of the torsional moment applied to the reference and opposite end is governed by
the right-hand rule about the model's X axis.

9.3.6 Point Force Tab

The Point Force tab allows previously defined groups, or a user selected node to have a
force, moment, or combination of forces and moments applied to it.  If a group is given a
point force or moment, the force or moment is evenly distributed to the nodes in the group.

If there is symmetry of structure (a half model) and if the current load set is also symmetric,
then any point loads that lie in the center-plane of the structure should be full values. 

The inertia components are defined for the group and are used for dynamic analyses.

9.3.7 Pressure Tab

This tab provides five methods of defining the location and magnitude of pressure loads
which are to be applied to the panels (quadrilaterals and triangles) of this model in the
current load case. Within each panel all pressure loads are cumulative. Thus if two pressure
loads of opposite sign are specified for the same panel, the final total load is the net value of
the two. For a panel in a strake, pressure is positive when it acts on the side of the plating
opposite from the transverse frames. If it is desired that the pressure acts on the same side
as the frames, then the pressure should be made negative. If a panel element has been
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deleted by the Strake dialog deletion tab, Geometry and Load (rather than the Geometry
Only) option, then the pressure load is not applied to that panel, even though it may lie within
the range of sections specified in the Plate group.

Each method for applying a pressure load is described in more detail below.

Plate(LinPress)

Plate(Surface Head)

Plate(Surface Zero)

Additional Beam

Edge

Plate(LinPress)

The Plate(LinPress) pressure loading option is that of an "actual" pressure. This pressure
can be added to a predefined plate group (this will result in only being able to define a
constant pressure) via the drop-down arrow just to the left of the Add Plate Group button or
alternatively, can be added to a strake. If a pressure load is to be applied to panels of the
strake, the user can define the pressure along the strake edge 1 and strake edge 2. Using
this option, the pressure can vary linearly across the strake width. 
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Plate(Surface Head)

The Surface Head option is intended for hydrostatic pressure, for which the value is
proportional to the depth below the free surface of a fluid (or other zero pressure plane). In
the Surface Head option the pressure is always an actual pressure.  For strake panels, the
pressure varies linearly across the strake width, in proportion to the local depth below the
zero pressure surface, and in the lengthwise direction it is constant over each panel and is
calculated separately for each panel, based on the depth of that panel below the zero
pressure surface. For additional (non-strake) panels and triangles, the pressure is calculated
at each corner of the element and then multiplied by either one fourth or one third of the
element area.

NOTE:
The words depth, height, and head always mean normal to the zero pressure surface, which
is also the direction of the total acceleration. If the current load case includes any heel or
trim or other rotation of the structure, then the direction of the total acceleration is no longer
parallel to the structure Y axis. If the current load case includes any dynamic accelerations
(i.e. distinct from gravity) then the zero pressure surface will rotate so as to remain normal to
the total acceleration vector, and the direction of the total acceleration will not be parallel to
either the Yref axis or the structure Y axis.
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Plate(Surface Zero)

The Surface Zero option is intended for hydrostatic pressure, for which the value is
proportional to the depth below the free surface of a fluid (or other zero pressure plane). In
the Surface Zero option the pressure is always an actual pressure, not a design pressure.
For strake panels, the pressure varies linearly across the strake width, in proportion to the
local depth below the zero pressure surface, and in the lengthwise direction it is constant
over each panel and is calculated separately for each panel, based on the depth of that
panel below the zero pressure surface. For additional (non-strake) panels and triangles, the
pressure is calculated at each corner of the element and then multiplied by either one fourth
or one third of the element area. Using the Surface Zero option, the user will be expected to
define the zero pressure surface by specifying a point, in structure coordinates, through
which the surface passes. 

The Zero X, Zero Y, and Zero Z are the X, Y, and Z values, in structure coordinates, of a
point through which the zero pressure surface passes. The surface will automatically be
normal to the total acceleration vector.

NOTE:
The words depth, height, and head always mean normal to the zero pressure surface, which
is also the direction of the total acceleration. If the current load case includes any heel or
trim or other rotation of the structure, then the direction of the total acceleration is no longer
parallel to the structure Y axis. If the current load case includes any dynamic accelerations
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(i.e. distinct from gravity) then the zero pressure surface will rotate so as to remain normal to
the total acceleration vector, and the direction of the total acceleration will not be parallel to
either the Yref axis or the structure Y axis.

Additional Beam

The Additional Beam option allows the user to impose a pressure load to an additional
beam. Positive pressure acts in the direction of the beam's Y axis, which is determined by
the web orientation. This convention means that when the beam is attached to plating, as in
a strake or on a compound, the pressure is positive when it acts on the "smooth" side of the
plating; i.e. the side opposite the additional beam. For example, on a transverse bulkhead, if
the additional beam faces forward, then a positive pressure would be applied to the aft side
of the bulkhead, causing a forward force.

If an additional beam is a substitute for a strake based transverse frame element then it will
automatically receive the strake related loads. If this is not desired then the frame element
should be deleted (Delete Geom & Load) explicitly using the Deletion tab found in the Strake
dialog. An additional beam will always receive whatever loads are defined for it here, in this
data group.

The Pressure on Node 1 and Pressure on Node 2 columns define the pressure load value at
the corresponding nodes.
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The Width column defines the width of the pressure load.  For vertical beams on the
centerline of the overall structure, a half width should be used.

Edge

This pressure load option serves to impose a uniform in-plate stress at the lower or upper
end of a strake panel, in the lengthwise direction; i.e. parallel to the X axis of the panel (or
the mean plane panel if the strake is warped and/or skewed). At each end, the stress
applied there is positive if it acts in the positive X direction, and negative if it acts in the
negative X direction. Thus to impose a lengthwise compression on the panels of a strake,
the stress applied at the lower end (smaller section number) would be positive, and the
stress applied at the upper end would be negative. The intention is that the panel end
coincides with a "cut" cross section of the model, and the stress comes from an adjacent
portion of structure that is not being modeled. For greater flexibility in modeling, the stresses
can be applied at any section along the strake; they are not limited to the reference and
opposite ends of the strake. The program automatically converts the stress into equivalent
nodal forces in the panel X direction and equivalent nodal moments about axis parallel to the
panel Z axis. If the strake is warped and/or skewed, the axes are those of the mean plane
panel. These forces and moments are then transformed to structure coordinates and applied
to the model.

The Edge Side column defines the end (lengthwise) of the strake that will receive the
specified stress. Lower represents the edge that corresponds to the smaller section number.
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9.3.8 Balance Tab

The balance tab of the Loads dialog is used to define a stillwater immersion condition or
wave condition if the load is defined as a floating structure.  The first check box can be
clicked to cycle through No Wave, Sinusoidal or Trochoidal.  MAESTRO will automatically
calculate and apply the Froude-Krylov forces, if desired, by clicking the check box F-K
Effect.  The Froude-Krylov effect is the fact that under a wave, due to the rotation of the
water particles, the vertical pressure distribution is not linear – it approaches the hydrostatic
pressure exponentially as you go deeper.

The trochoidal wave profile is calculated from the following equations.
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The first line of inputs defines the models emergence, heel angle and pitch angle.  The
second line of inputs defines the wave length, amplitude, phase angle and heading.  Note:
all angles are defined in degrees.

The phase angle is MAESTRO is defined as follows:

Assume the ship is stationary. For a positive phase angle shift, the wave moves
forward compared to the original position.

The Center of Flotation will be automatically calculated by selecting Default, or it can be
specified by the user.  This functionality can be useful if the model will not balance and user
wants to specify a center of flotation close to the expected in order to get the balance to
solve.

The Emergence (i.e., negative of immersion), Heel Angle, and Pitch Angle will automatically
update if the MAESTRO balance function is used to place the model in an equilibrium
position.

9.3.9 Restraint Tab
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The Restraint tab is activated by selecting the Re-define Restraints box found under the
General tab of the Loads dialog box. This allows the user to override restraints initially
defined, if any, and have restraints specific to each load case.

9.3.10 Corrosion Tab

The Corrosion tab is activated by selecting the Corrosion box found under the General tab of
the Loads dialog box. This allows the user incorporate the pre-defined corrosion groups into
a particular load case.  The "Percentage of remaining thickness" column allows the user to
add or subtract thickness to the previously defined corrosion groups by multiplying the
corrosion group's net thickness by a percentage.  A percentage greater than 100% will
increase the thickness of the elements in the corrosion group, whereas a percentage less
than 100% will reduce the thickness.   A percentage of 100% will keep the thickness as
defined in the corrosion group.

9.3.11 Hull Girder Load Target

The hull girder load target can be used to ensure that either a minimum longitudinal or
transverse loading envelope is met. The hull girder load target is used to supplement an
existing load case.  For example, if the intent is to impose an "Additional" bending moment in
the form of a envelope, it is suggest the "base" loading condition (e.g., Full Load or Ballast
Load) is established and balanced as a first step.  The second step would then be to define
the particular hull girder target "envelope."  This second step would NOT be re-balanced as
the intent is to provide "Additional" bending moment to the already existing (and balanced)
load case.  The hull girder load target dialog can also be used to add additional forces and
moments on top of all other structural and hydro loads. The hull girder load target pattern



MAESTRO 11.0.0340

© 2014 Optimum Structural Design, Inc.

can be applied by clicking the checkbox for "Hull girder load target" in the loads dialog:

This will enabled a new tab "Hull Girder Load Target".
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The target load is to represent either an additional longitudinal or transverse loading
envelope, but not both. Longitudinal or transverse coordinates may be assigned the target
loads.  The final or additional bending moment or shear force must be distributed to a
general group of the user's choice.  (See the Groups Menu section for details on creating
Vertical Element Groups)  Selecting "Final" will scale up all of the existing load patterns so
that the total loading meets that defined in the Hull Girder Target Load.  Selecting
"Additional" will apply the specified loads on top of the existing loads from other load patters
in the load case.

The available loads are:

VBM: Vertical Bending Moment

VSF: Vertical Shear Force

LTM: Longitudinal Torsional Moment

HBM: Horizontal Bending Moment

HSF: Horizontal Shear Force

Surge: Surge Force

9.4 Importing Hydrodynamic Loads

The following section is organized as follows:

Ship Motion File Definition

Importing the Ship Motion File

Reviewing the Ship Motion File

Ship Motion File Definition

Ultimately, the mapped pressures must be captured in MAESTRO’s Ship Motion file (*.smn),
which serves as the mechanism for incorporating the hydrodynamic loading component into
the direct structural analysis.  The Ship Motion file  (*.smn) is a text file that can be
generated by the analyst and must have the following items:

· Units [Keyword units with second-token key word /n-m/ips/fps/nmm/in lb/ft lb]: See Line 2
in the figure below.
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· Loadcase Name

o [Keyword dynamicbaseload: The value represents the MAESTRO Base Load Case ID
associated with the Hydrodynamic Analysis Output] See Line 3 in the figure below.

o [Keyword loadcase: The value represents the Seakeeping Analysis Load Case run]  See
Line 4 in the figure below.

· Keyword speed/heading/frequency: The value represents the speed, heading, and
frequency for the particular loadcase.

· Displacement [Keyword displacement and displacementimag: Not currently required for
response analysis] See Lines 9 & 10 in the figure below.

· Acceleration [Keyword acceleration and accelerationimag: Seakeeping Resulting Real and
Imaginary Accelerations, respectively, at MAESTRO Loading Condition Center of Gravity.
See Lines 12 & 13 in the figure below.

· Element Pressures (Keyword elmpressure):  Element FETag (see Wetted Elements), and
Pressures (Real and Imaginary).  See figure below.

Importing the Ship Motion File

Before the Ship Motion file can be imported, the user must ensure the appropriate
MAESTRO model (i.e., *.mdl file) is open.  Note there is an example MAESTRO model
located in the Models and Samples/Extreme Load Analysis directory.  The file is named
S175-ITTC-2010-nd-mass-933.mdl.

To import the Ship Motion file, click File > Import > Ship Motion (*.smn).  Choose the file
of interest and click OK.  Note there is an example MAESTRO Ship Motion file
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corresponding to the S175-ITTC-2010-nd-mass-933.mdl file and is located in the Models
and Samples/Extreme Load Analysis directory.

Reviewing the Ship Motion File

Once the Ship Motion file has been imported successfully, it is desirable to visually inspect
the imported hydrodynamic loads to verify what ship motion data was imported.  This can be
done for each Base Load, Speed, Heading, and Wave Periods defined in the imported Ship
Motion file.

To visually inspect the imported Ship Motion file, click ELA/SFA > Frequency Load
Database, which launches the dialog box shown below.

Base Load, Speed, Heading, and Wave Period cases can be chosen via their respective
drop-downs.  Once a particular case is chosen, the user can access the Pressure,
Acceleration, or Displacement tabs to review the imported data.

Further, when reviewing the data presented in the Pressure tab, the user can right-click and
chose to visually inspect the Phase 0, Phase 90, or a specific Phase angle complex
pressures.  This is shown in the figure below.  Note that these pressures can be dynamically

queried on the model by accessing the dynamic query icon, .
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9.5 Balancing the Model

Toolbar  

Menu  Model > Balance...

How to Use the Balance Functionality

End Moments and/or Shear Force Balancing

Load Balancing Verification Samples

Balancing the model
MAESTRO provides two types of static equilibrium balance: hydrostatic balance and inertia relief
balance. Hydrostatic balance occurs when the center of gravity and the center of buoyancy of a
floating structure align vertically in earth coordinate system. As a result of hydrostatic balance, the
floating structure has equilibriums in heave, pitch and roll, i.e.
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To get equilibrium in surge, sway and yaw, inertia relief balance has to be used. Inertia relief balance
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All reported resulting values (see image below) are for the full ship if the model is defined as having
Transverse Symmetry (via the Job Information dialog).

How to use the balance tool?

1. Open the Hydrostatic Balance dialog from the Model > Balance... menu option, or the toolbar.
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2. Run hydrostatic balance

a. Select the balance type as “Hydrostatics”. This type is the default selection. For a floating
structure model, user should always run hydrostatic balance first. In many cases, you
only need to run hydrostatic balance. For a non-floating structure model, where a wave
profile is not defined, this selection automatically switches to “Inertia relief”.

b. Check All Load Cases if you would like to balance all load cases, otherwise only the
currently selected load case will be balanced.

c. Select Auto balance or User Control to define the model center of floatation or heel and
trim angles.

d. Click OK to balance the model.

e. Review the output tab to make sure the hydrostatic balance is successful.

3. Check bending moment and shear force distribution.

4. If either the bending moment or the shear force distribution has no closure, run inertia relief
balance (Optional). Repeat step 2 with the balance type selection as “Inertia relief”. 

To correctly use the combination of hydrostatic balance and inertia relief balance, especially for  the
case of re-balancing the model, two common scenarios are given below,

Scenario #1:  A floating structure without pre-defined (initial) additional accelerations
Step 1: Run hydrostatic balance for a selected load case.
Step 2: Run inertia relief balance. Additional accelerations are automatically defined for the selected
load case.
Step 3: Check bending moment and shear force distribution to validate the equilibrium.
Step 4: If for any reason the load case is changed, the model has to be re-balanced. Again, we need to
run hydrostatic balance first. Since additional accelerations are found in the load case, a message box
is prompted 
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In this scenario, there are no initial additional accelerations, so we’ll select “Yes” to initialize the
additional accelerations due to previous inertia relief balance run.
Step 5: Repeat step 1~3.

Scenario #2:  A floating structure with pre-defined (initial) additional accelerations. The initial
accelerations may come from a third-party hydrodynamic analysis.  
Step 1: Run hydrostatic balance for a selected load case. Since additional accelerations are found in
the load case, a message box is prompted 

In this scenario, the initial additional accelerations are defined by the user, so we’ll select “No” to keep
the additional accelerations.
Step 2: Run inertia relief balance.
Step 3: Check bending moment and shear force distribution to validate the equilibrium.
Step 4: If for any reason the load case is changed, the model has to be re-balanced. Again, we need to
run hydrostatic balance first. Since additional accelerations are found in the load case, a message box
is prompted 

Because the additional accelerations have been modified by previous inertia relief balance, we’ll select
“Cancel” to stop the balance.
Step 5: Go to load dialog’s additional acceleration page, and re-enter the user defined original
accelerations.
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Step 6: Repeat Step 1~3 to re-balance the model.

Balancing a Model in a Wave
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L   = Ship length.

l    = Wave length.  In the figure, l = L

a   = Wave amplitude.

x   = Wave axis, always measured from the Reference Origin

xc = Location of a wave crest.  In the figure xc = l/2

j   = Phase angle.  Moves a wave crest along the x axis away from the origin.

    = (xc / l) ´ 360°.  In the figure j = 180°, which places a trough at the origin.

q  = The angle between structural coordinate and wave coordinate using the right hand rule.

To calculate the wave height in a ship structural location (x, z), the structural coordinates
should be transformed to the wave coordinates. (Rotation about y axis)
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x =  x*cos(q)-z*sin(q)

h = x*sin(q)+z*cos(q)

 

Figure 1, Balanced model, Heading=0

Figure 2, Un-balanced Model Heading = -60
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Figure 3, Balanced Model Heading = -60

Figure 4, Balanced Model, Rotate Module -60 degrees, Heading = 60, Equivalent to Figure 1
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Figure 5, Un-Balanced Model, Rotate Module -60 degrees, Heading = 0, Equivalent to Figure 2

Figure 6, Balanced Model, Rotate Module -60 degrees, Heading = 0, Equivalent to Figure 3

These models (balance_wave_60.mdl and balance_wave_rotate_60.mdl) can be found in
the Models and Samples/Loads/Balance directory of the MAESTRO installation directory.

End Moments and/or Shear Force Balancing

When you apply an End Moment to a cut model, you specify this moment by giving it a
vertical bending moment at the reference and opposite end.  When you balance the model,
the inputs for the two moments are kept constant and the vertical shear force at each end is
calculated so that there is a force and moment balance.  The opposite end shear force in the
loads dialog is calculated to be equal, but opposite to that of the actual shear force at that
end, in order to balance the loads.  The reference end shear force in the graphical
representation is actually representing the shear force at a small distance in from the actual
end.  As a result, this shear force value also includes the distributed load from the end to
that point, which is why the loads dialog and graphical representation do not match.
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A sample model (endshear.mdl) can be found in the Models and Samples/Loads/Balance
directory of the MAESTRO installation directory.
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10 Analyzing and Post-Processing

The topics in this section provide detailed information on the MAESTRO functionality used
for analyzing and post processing a model.

10.1 Solver Types

MAESTRO offers three solver methods for coarse mesh model analyses: Sparse, Iterative,
and Skyline.  Fine mesh model analyses use the Sparse solver method. The different
solvers can be accessed from the Preferences dialog.

Sparse Solver

MAESTRO's Sparse solver method uses the Intel Pardiso sparse solver and is the default
and most commonly used solver within MAESTRO. The package PARDISO is a
high-performance, robust, memory efficient and easy to use software for solving large
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sparse symmetric and non-symmetric linear systems of equations on shared memory
multiprocessors. The solver uses a combination of left- and right-looking Level-3 BLAS
supernode techniques [11]. In order to improve sequential and parallel sparse numerical
factorization performance, the algorithms are based on a Level-3 BLAS update and
pipelining parallelism is exploited with a combination of left- and right-looking supernode
techniques [6, 7, 8, 10]. The parallel pivoting methods allow complete supernode pivoting in
order to compromise numerical stability and scalability during the factorization process. [13]

Iterative Solver

MAESTRO's iterative solver method uses Intel's iterative sparse solver which is based on a
reverse communication interface.  This scheme gives the solver great flexibility, as it is
independent of the specific implementation of operations such as matrix-vector
multiplication. [14]  When this solver is selected, the user can choose a maximum number of
iterations to perform and a tolerance.  The analysis will complete whenever the number of
iterations or tolerance is met.  The iterative solver is mostly used for large models that are
unable to be solved using the sparse solver. 

Skyline Solver

MAESTRO's Skyline solver is an in-house sparse solver with the matrix stored using the
skyline storage scheme.  This solver is an alternative, or backup to MAESTRO's Sparse
solver, and is less efficient.  The benefit of the Skyline solver is that since it was developed
in-house, it can be used to troubleshoot an error if the Sparse solver is not able to solve. 
Whereas an error from the Sparse solver is indescript,  the Skyline solver will return an error
message directing to a specific error in the matrix and an FE tag.

Beams Attached to Plating

Eccentric Beam Element
This element consists of only the beam itself.  That is, both the area A (and the

parameter a  = AE/L) and the moment of intertia I (and the parameter b  = EI/L3)
refer to the beam alone, and I is calculated about the beam's own centroid, the
centroidal axes being denoted as x,y.  However, the element nodes are located not
along the beam's centroidal axes, but rather at the toe of the web as shown in Fig.
8.16.  That is, the origin of the element axes (x,y) is located at a distance g below the
origin of the centroid axes, such that y = y + g.  Therefore in this type of modeling the
plate elements are located at their true position, in the plane of the plating. 
However, the axial force in the beam continues to be proportional to the change in
length of the neutral axis, and this is displaced from the element x-axis. [1]
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Hybrid Beam Element

The element is termed "hybrid" because the axial stiffness and the bending stiffness
are based on different cross sections.  The axial stiffness parameter is a  = AE/L in
which the area A is the area of only the beam itself (flange and web).  The bending

stiffness parameter is b e = EIe/L3 in which the neutral axis position and the moment

of inertia Ie are calculated for the combined section formed by the beam plus a plate

flange of effective breadth be.  The element nodes are located at the neutral axis of

the combined section, as shown in figure 8.14.  Thus, in the hybrid element the
plate's contribution to the beam bending stiffness is accounted for in the calculation
of Ie, and the expression for the beam stiffness matrix remains unchanged. [1]
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Failure Mode Evaluation

For detailed information on the two types of failure mode evaluations available, see the 
Failure Mode Evaluation section.

10.2 Analyzing the Model

Toolbar  

Menu  File > Analysis/Evaluation > Global FEA

The following tutorial shows the steps to analyze a coarse mesh model.  A model can be
analyzed with or without balancing the model first.

1.  Open the Analyze dialog from the File > Analysis/Evaluation > Global FEA menu
option, or from the toolbar.
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2.  Select the the beam elements should be treated, either as Eccentric Beams or Hybrid
Beams.

3.  Check whether to calculate stresses and reaction forces.

4.  Click the radio button for the type of Failure Mode Evaluation to perform, if applicable.  If
evaluation patches have not been created, MAESTRO will automatically create the patches
during the analysis process.

5.  MAESTRO can also save the fine mesh models, if applicable, automatically after solving
the global model by checking the box.

Any errors or issues with each load case will be shown in the output tab, otherwise a dialog
box will appear stating the analysis is complete.
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10.3 Natural Frequency Analysis

A natural frequency analysis can be performed by MAESTRO by checking the option in the
Loads dialog.  A separate load case should be created for the natural frequency analysis.

In the Current Status from Other Menus window on the General tab gives a summary of the
natural frequency analysis criteria.  To change the criteria, click the Criteria button next to
the Natural freq. analysis line.  Clicking this button will launch the Natural Frequency
Analysis Setup dialog.
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Under the Job Type section, MAESTRO can perform an analysis for the structure vibrating
in vacuo or in fluid.  When Wet Mode is selected, the added mass of the seawater is
automatically applied to the "wetted" elements if an immersion condition is defined.

MAESTRO offers three iterative solver methods: Subspace, Inverse Power, and Lanczos.

The Lanczos and Subspace Iteration Methods are both computationally efficient with the
Lanczos Method performing exceptionally well with medium to large size models. A Sturm
Check may be used if the Skyline solver is the solver of choice. Of the two, the Subspace
Method is the preferred algorithm in MAESTRO and is the most robust. However, the
Lanczos Method is somewhat computationally quicker. 

The Inverse Power algorithm (also known as simply Inverse Iteration or Inverse Iteration with
Sweeping) is used to calculate the eigenvector for the lowest eigenvalue. At the end of each
iteration, the new "guessed" eigenvalue is provided by the Rayleigh quotient, further
improving upon the initial eigenvector. This method is computationally dense when retrieving
many modes and has potential to miss modes of vibration. It is sufficient for finding the
prominent global modes of vibration. A Sturm Check to prevent missing modes may be
elected if the Skyline solver is the solver of choice. 
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The user can input the number of natural frequencies to compute, the eigenvalue tolerance
for the iteration solver and the shift in hertz for free-free or partially restrained systems.  The
maximum number of iterations may need to be increased if the convergence is slow; the
default value is 999.

The natural frequency analysis load case will be solved during the coarse mesh analysis. 
The Output tab will display a summary of the natural frequencies calculated during the
analysis:

"ACU-%" is the accumulated modal participation factor.  Modal effective mass and
participation factor are relative measurement to the total vibration.  For example, if the
"ACU-%" is 99% in the first five modes, it implies the first five modes are dominant modes,
and the rest of the modes can often be ignored.  Modal effective mass and participation
factors are often used in constrained vibration such as Dynamic Design Analysis Method
(DDAM).

To view the different mode shapes, select the natural frequency analysis load case from the
load case drop-down and set the model to deformed view from Results > Deformed Model.
 The different mode shapes can be selected by right-clicking in the model space and
selecting the frequency from the menu.
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10.4 Stress Results

The following sections provide a description of MAESTRO’s available elements and their
associated stresses.  MAESTRO uses an FEA standard method, called the Gauss
Quadrature method, for element numerical integration for element stress computation.  This
method operates by evaluating (or sampling) elements at multiple points (Gauss points)
within a given element.  The stress values calculated at these Gauss points are
subsequently extrapolated to other locations in the elements.  These other locations (e.g.,
stresses at nodes, element centroids, element top surface, element mid-plane, etc.) are the
more commonly exposed stresses for use by the engineering analyst.  MAESTRO takes this
industry standard approach.

MAESTRO's contour plot is either a nodal contour by checking the Corner Stress option in
the View Options dialog, which averages all values at the nodes or an average elemental
centroidal stress.
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10.4.1 CROD (Rod)

The axial stress of rod elements will be displayed when Mid Normal X and Mid Von Mises
are selected from the Results menu.

The dynamic query icon  can be used to highlight a rod element and recover the axial
stress.  Double-clicking the element will echo the results to the Output tab.

Rod elements will be grayed out when stress options other than the two listed above are
chosen.  However, the axial stress can still be recovered from a rod element using the
dynamic query function.

10.4.2 CBAR (Beam)

The CBAR element is a uniaxial element with tension, compression, and bending
capabilities.  The CBAR element is used for modeling MAESTRO frames, girders, and
additional beams.  The CBAR element recovers the mid-plane axial stress (SigX), the axial
stress at the beam flange and plate connection, as well as the beam stress.  As shown
below, these stresses are recovered at the start, mid-span, and end of the CBAR definition.
The CBAR element also reports Moments and Shear Force at the start and end of the
element.
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In addition to the specific beam stress options, the Mid X Normal and Mid Von Mises are the
only stress options that will graphically display the beam element's axial stress.

Hybrid Beam versus Eccentric Beam Method

The following discusses how MAESTRO models beams attached to plates.  The engineering
analyst can choose which method to use for a given analysis but should be aware of the
impact on CBAR stress results.  This option is set at the time of the analysis via the Analysis
dialog.

Hybrid Beam Method

First, the Hybrid Beam method.  MAESTRO has the ability to use the so-called Hybrid Beam
element for the modeling of beams (frames, girders, and additional beams) attached to
plating.  The element is termed "hybrid" because the axial stiffness and the bending stiffness

are based on different cross sections.  The axial stiffness parameter is , in which
the area A, is the area of only the beam itself (flange and web).  The bending stiffness

parameter is , in which the neutral axis position and the moment of inertia ( )
are calculated for the combined section formed by the beam plus a plate flange of effective

breadth .  The element nodes are located at the neutral axis of the combined section, as
shown in the figure below.  Thus, in the hybrid element the plate's contribution to the beam

bending stiffness is accounted for in the calculation of and the expression for the beam
stiffness matrix remains unchanged.  This method requires the specification of the effective
breadth of plating to be considered as part of the bending stiffness, which can be
problematic for automatic data generation.
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Eccentric Beam Method

An alternative approach is the Eccentric method, or Offset Beam method, which consists of

only the beam itself.  That is, both the area A (and the axial stiffness parameter )

and the moment of inertia I (and the stiffness parameter ) refer to the beam
alone, and I is calculated about the beam's own centroid.  However, the element nodes are
located not along the beam's centroidal axes, but rather at the toe of the web as shown in
the figure below.  That is, the origin of the element axes (x,y) is located at a distance g

below the origin of the centroid axes, such that .  Therefore in this type of
modeling the plate elements are located at their true position, in the plane of the plating. 
Further, the locations between the node and the beam’s neutral axis (i.e., g) can be
regarded as joined by rigid link.  Although this method is well suited for automatic data
generation, issues arise with how this method handles particular loading scenarios where
shear forces are more dominant because stiffener and plate are not jointly carrying the
loads.  However, this error decreases with increasing refinement of the FEM mesh.
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Beam Element Stress Recovery Locations

The beam stress menu from Results > Stress > Beam > allows the user to select the
location of the recovered stress to plot graphically.  The Flange Max Tension and Flange
Max Compression options will plot the higher of the compressive or tensile stresses at the
beam flange from either the start or end location.  The beam stress results menu is only
used to select which stress value to plot for each beam element.

The dynamic query icon  can be used to highlight a beam element and recover the
stresses.  Double-clicking the element will echo the results to the Output tab.
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When querying a beam element, all stresses, including local axial stress and shear stress
will be recovered as well as the bending moments and shear force at each end of the beam.
The stresses at the mid location of the plate connection and flange are calculated by linearly
interpolating the appropriate stresses at the start and end locations of the beam.  

10.4.3 CQUAD4R

The CQUAD4R is the most commonly used element in MAESTRO.  The CQUAD4R element
is a 4 noded flat shell element with each node having 6 degrees of freedom (DoF) and has
an additional drilling DoF, which is a rotational DoF whose vector is normal to the element’s
analysis plane.  MAESTRO’s CQUAD4R element has the ability to automatically include the
appropriate bending stiffness if a stiffener layout definition is present.  This is true in either
the longitudinal direction or the transverse direction.  This element is the same element used
in NASTRAN, but in MAESTRO, the (quite large) task of calculating the orthotropic
properties is automated.

The CQUAD4R element recovers bare pate and stiffened plate element stress at the top,
middle and bottom of the element’s centroid and corners.  The different stresses at each
location of the element can be plotted by selecting the option from the Results menu.  The
element X, Y, shear and Von Mises stresses can be plotted and recovered for each of the
three locations on the plate element.  When using the Results menu, the reported Top, Mid,
and Bottom stresses are those found at the element centroid.
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The figure below presents these three locations for a bare plate element (Figure a) and a
stiffened plate (Figure b).  Von Mises stresses are also reported at the Top, Mid, and
Corners.  The Von Mises corner stresses represent effective stress at the corners and is

computed as  .  The Von Mises corner stresses are
exposed to the user by dynamically querying individual elements.  The Von Mises corner
stress represent the stress at the mid-plane.

        

(a) Bare Plate (b) Stiffened Plate

Additionally, MAESTRO exposes the CQUAD4R X, Y, and shear mid-plane stress at the
element corners using the List or MS Excel export option.  Internally, MAESTRO is also
computing additional stresses, such as: corner stresses at the Top and Bottom of the
element plate field, but currently does not expose them to the user.  Future development will
expose these particular stresses.

10.4.3.1 CQUAD4R (Bare)

MAESTRO will recover stress on a bare plate element at the top, middle and bottom of the
element.  The different stresses at each location of the element can be plotted by selecting
the option from the Results menu.  The element local X, local Y, shear and Von Mises
stresses can be plotted and recovered for each of the three locations on the plate element. 
The figure below presents these three locations for a bare plate element.

Bare Plate Stress Recovery Locations

The dynamic query icon  can be used to highlight a bare plate element and recover
the stresses.  The drop-down arrow next to the dynamic query icon can be used to select
which stresses to display when highlighting an element.
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10.4.3.2 CQUAD4R (Stiffened)

MAESTRO can recover stresses for a stiffened panel at the mid-plane of the plate (Top), the
neutral axis of the plate and stiffener combination (Mid) and the axial stress at the mid-plane
of the stiffener flange (Bottom/Stiffener Flange).  The figure below presents these three
locations.
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Stiffened Panel Stress Recovery Locations

Top

The Plate X Normal, Plate Y Normal, Plate XY Shear, and Plate Von Mises stresses can be
recovered at the mid-plane of the plate for a stiffened panel from the Results > Stress >
Top > menu.

The dynamic query icon  can be used to highlight a stiffened panel and recover the
stresses in the plate.  Double-clicking the element will echo the results to the Output tab.  

Mid

The X Normal, Y Normal, and Von Mises stresses are recovered at the neutral axis of the
stiffener and plate structure.  The shear stress reported for Mid is the Plate Shear stress
from the mid-plane of the plate.

The dynamic query icon  can be used to highlight a stiffened panel and recover the
stresses in the plate.  Double-clicking the element will echo the results to the Output tab.  

Bottom/Stiffener Flange

The only stress recovered for a stiffened panel at the bottom location is the axial stress at
the mid-plane of the stiffener flange.  This can be graphically displayed by selecting either 
Results > Stress > Bottom > Stiffener Axial Flange or selecting the appropriate stress
direction (Normal X or Normal Y) corresponding to the orientation of the stiffener.  If bottom
Normal Y stress is chosen from the Results menu, any stiffened panels with longitudinal
stiffeners will be grayed out because the axial stress of the stiffeners is orientated in the X
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direction.

The dynamic query icon  can be used to highlight a stiffened panel and recover the
stresses in the plate.  Double-clicking the element will echo the results to the Output tab. 
The Stiffener Flange Axial stress will always be displayed as SigX, regardless of the stiffener
orientation because it is reporting the stiffener local X, or axial, stress.

As with the bare plate elements, the dynamic query drop-down can be used to filter which
location stresses should be displayed.  Note there is no "bottom" stresses reported for a
stiffened panel, only the Stiffener Flange Axial stress.
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10.4.4 Directional Stress

Toolba
r

 N/A

Menu 
 Results > Stress >
Directional

 Results > Stress > Define
Direction...

 Results > Stress > Show
Direction

Introduction

Method for Determining In-plane Stress Vector

Global X

Global Y

Global Z

User-defined Cutting Plane

Introduction

When constructing a finite element model, it is ideal to generate elements such that their
respective local X and Y axes are all aligned in a uniform direction, i.e. aligned to a global
axis.  The reason for this, is so the analyst can be assured the direction of the stress vectors
are uniform when recovering stress in a given axis (e.g. post-processing Mid X Normal
stress).  The presentation of stress in a uniform manner such as this allows the analyst to
better assess the stress path in a given direction.  Because it is impossible to construct a
complete full ship model in this manner, MAESTRO provides the option to display all panel
elements' stress in a given global direction, regardless of the elements local orientation. 
When this option is checked on, all panel elements' in-plane stress vector will be aligned to
the global X, global Y, global Z or a user-specified direction.

The dialog for defining directional stress is shown below.  Before describing the options
available for defining directional stress it is useful for the analyst to understand the internal
logic used by MAESTRO to determine the re-aligned in-plane stress vector.  The following
example shows how in-plane stress vectors are determined and aligned to the Global X axis.
 The user has the ability to also align the in-plane stress vectors to the Global Y and Global
Z axes in a similar manner.
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Method for Determining In-plane Stress Vector

For panel elements, neither of whose local x and y axes are in the Global direction selected,
the in-plane stress vector will be automatically determined by MAESTRO.  To illustrate
MAESTRO's logic for determining the in-plane stress vector let's take the following example
of a given element in 3D space (Figure 1 below).  MAESTRO creates two global cutting
planes that intersect the centroid of the element.  The example below illustrates the
alignment of the in-plane stress vector with the Global X axis; therefore, the two cutting
planes created are in the XY and XZ cutting planes.  The XY and XZ cutting planes are
shown below in Cyan and Green respectively (Figure 2 below).



Analyzing and Post-Processing 375

© 2014 Optimum Structural Design, Inc.

Figure 1. Element in 3D Space
Figure 2. Global Cutting Planes: XY (Cyan) & XZ (Green)

Using the intersection of the element and the global cutting plane, an in-plane stress vector
is created as shown for the global XY cutting plane in Figure 3 and Figure 4.
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Figure 3. Element & XY Cutting Plane Intersection Figure 4. In-plane Stress Vector

A similar process for the global XZ cutting plane results in another in-plane stress vector as
shown in Figure 5 and Figure 6.
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Figure 5. Element & XZ Cutting Plane Intersection Figure 6. In-plane Stress Vector

As described above, MAESTRO has located two in-plane stress vectors.  The user now has
the ability to use the in-plane stress vector generated from the XY or YZ cutting planes or
alternatively, the user can ask MAESTRO to automatically choose between the two vectors
based on the maximum projected area of the element onto the XY or YZ cutting plane.  This
projection of area is illustrated in Figure 7 and Figure 8 for the XY global cutting plane and
Figure 9 and Figure 10 for the global XZ cutting plane.
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Figure 7. Element Projected Area on XY Cutting Plane
Figure 8. Projected Area on XY Cutting Plane
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Figure 9. Element Projected Area on XZ Cutting Plane Figure 10. Projected Area on XZ Cutting Plane

Since in this example the projected area in the XZ cutting plane is the larger of the two, the
chosen stress vector would lie in the XZ cutting plane as shown in Figure 10.

As noted in the beginning, the example described above shows how in-plane stress vectors
are determined and aligned to the Global X axis.  The user has the ability to also align the
in-plane stress vectors to the Global Y and Global Z axes in a similar manner.

The sections below describe the options available for directional stress.

Global X

Global X via XZ/XY Cutting Plane

This will align the elements' in-plane stress vector to the global X direction based on largest
projected area on the XZ or XY plane as described above.

Global X via XZ Cutting Plane
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This will align the elements' in-plane stress vector to the global X direction based on the
intersection of the XZ cutting plane and the element as described above.

Global X via XY Cutting Plane

This will align the elements in-plane stress vector to the global X direction based on the
intersection of the YZ cutting plane and the element as described above.

Global Y

Global Y via XY/YZ Cutting Plane

This will align the elements' in-plane stress vector to the global Y direction based on largest
projected area on the XY or YZ plane, in a similar manner to the above example, which was
for the Global X direction.

Global Y via XY Cutting Plane

This will align the elements' in-plane stress vector to the global Y direction based on the
intersection of the XY cutting plane, in a similar manner to the above example, which was for
the Global X direction.

Global Y via YZ Cutting Plane

This will align the elements' in-plane stress vector to the global Y direction based on the
intersection of the XZ cutting plane and the element, in a similar manner to the above
example, which was for the Global X direction.

Global Z

Global Z via XZ/YZ Cutting Plane

This will align the elements' in-plane stress vector to the global Z direction based on largest
projected area on the XZ or YZ plane, in a similar manner to the above example, which was
for the Global X direction.

Global Z via XZ Cutting Plane

This will align the elements' in-plane stress vector to the global Z direction based on the
intersection of the XZ cutting plane and the element, in a similar manner to the above
example, which was for the Global X direction.

Global Z via YZ Cutting Plane

This will align the elements' in-plane stress vector to the global Z direction based on the
intersection of the YZ cutting plane and the element, in a similar manner to the above
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example, which was for the Global X direction.

User Defined Cutting Plane

This will allow the user to define the direction of two arbitrary vectors (Vector 1 and Vector
2), which determine a special cutting plane, to which the in-plane stress vector will be
aligned.

The options for setting the stress vector are shown in the Define Stress Direction dialog,
which can be opened from Results > Stress > Define Direction...

The stress direction can be either applied to the Full Model or the Current View Part by
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clicking the appropriate radio button in the Define Stress Direction dialog.  Stress direction
settings can be set for multiple view parts and will be applied when viewing the entire model
or multiple view parts. 

As an example, the next two figures show a module with the elements stress vector first
aligned in the global X direction (Figure 11) and the second aligned in the Global Z direction
(Figure 12).  Figure 11 shows the panel element's all have their local x axis orientated in the
Global X direction, whereas Figure 12 shows the panel element's all have their local x axis
orientated in the Global Z direction.  In this example we would expect the sigma x stress of
Figure 11 to be equal to sigma y (which is now in the direction of the Global X axis) of Figure
12 to be equal, and vice versa.

Figure 11: Align Stress to Global X, SigX = 9.2E02, SigY = 6.66, Tau = 613.96
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Figure 12: Align Stress to Global Z, SigX = 6.66, SigY = 9.2E02, Tau = -613.96

The directional stress option can be toggled on by selecting Results > Stress > Directional
from the menu.  A check mark will appear next to this option when it is turned on.

The direction for each element can be displayed with a quill by selecting Results > Stress >
Show Direction from the menu.  A check mark will appear next to this option when it is
turned on.  The length of the quill can be adjusted in the View Options dialog.

Figure 13 demonstrates the 6 user-defined stress directions on the directional stress.mdl
model.  The blue quills represent the new element local-x direction after the adjusted
alignment.  This model can be found in the MAESTRO installation directory under the 
Models and Samples folder.
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Figure 13: Demonstration of the 6 User-Defined In-Plane Stress Vector Orientations

10.4.5 Contour Plot

Toolbar
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Menu  Results >  Contour

MAESTRO has the functionality to produce a contoured deformation or stress plot by
toggling on the icon or selecting Results > Contour from the menu.  A check mark will
appear in the menu next to this option when contour view is toggled on.

Deformation Contour Plot

MAESTRO's contour plot is either a nodal contour, which averages all values at the nodes or
an average elemental centroidal stress depending on whether the Corner Stress option is
checked in the View Options dialog.  Nodal contouring produces a smooth contour plot.

10.5 Analysis Results

Toolbar  N/A
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Menu  Results > 

The following tutorials shows the basic functionality for viewing the stress and deformation
results.

1.  Click on the Result menu to open the drop down menu.

2.  Click on Deform to show the model in a deformed or undeformed state.

3.  Click on Stress and select which stress to display.

A detailed description of each type of stress that can be recovered can be found in the 
Stress Results sections.

4.  A contoured stress plot can be shown by clicking the Contour Plot icon  or selecting
Results > Contour from the menu.

Individual element deformations and stresses and nodal deformations and forces can be
identified using the dynamic query function of MAESTRO.  
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5.  Click the dynamic query icon .

6.  Select Node to query nodes, otherwise select the results you would like to query from the
element.  A check mark will appear next to the selected option.

7.  You may now highlight an element or node to view the results.

Double-clicking on a node or element will output the results to the output window at the
bottom of the screen.

8.  All element stress results, nodal forces, reaction forces, or negative adequacy parameter
report can be output to the grid or output tab by selecting from the Results > List > menu.
This spreadsheet can be easily copy and pasted into another program if desired.  

In order to output nodal forces, the option Total Point Force must be checked under the
Loads menu before listing nodes.

The negative adequacy option will list the number of elements with a negative adequacy
parameter and those elements percentage of the total structural weight for the selected load
case.

If a Failure Mode Evaluation method was selected for the analysis, the results can be
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graphically displayed from the Results > Adequacy menu.  The adequacy parameters
menu will be different depending on whether MAESTRO or ULSAP evaluation is chosen.

MAESTRO                                                                                                        ULSAP
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Selecting one of the parameters will display the patches colored by their adequacy
parameter value.  MAESTRO can automatically display each elements smallest adequacy
parameter by selecting Minimum Value (Plate), Minimum Value (Beam), or Minimum Value
(All).  You can also choose to display only the Positive or only the negative adequacy
parameter results.  

The dynamic query icon  (with Adequacy checked from the drop-down) can be used
to highlight an element and recover the adequacy parameters.  Double-clicking the element
will echo the results to the Output tab.

10.6 Viewing Stress Ranges

Toolbar
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Menu  View > Options

The following tutorials shows the basic functionality for viewing stress ranges for a given
load case.  The user will first define and apply a range and then optionally hide any elements
outside of this defined range.

1.  After the results have been loaded, click on the Result menu to open the drop down
menu.

2. Click on Stress and select which stress to display.

A detailed description of each type of stress that can be recovered can be found in the 
Stress Results sections.

3.  Click on the View Options icon  or select View > Options... from the menu.

4.  From the View Options dialog (see below), click the Apply Defined Range checkbox.
This will enable the Min and Max Range fields for the user to define the stress range of
interest.
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5.  Click OK when finished.

Individual element stresses for the defined range are now presented.  Elements that are
outside of the user-defined range are colored either blue (below range) or red (above
range).

6.  To hide the elements outside of the user-defined stress range, click the  icon.

10.7 Viewing Stress in a Given Direction

The following tutorials shows the process of viewing element stresses in a given direction
once the model is solved and the results are loaded.



MAESTRO 11.0.0392

© 2014 Optimum Structural Design, Inc.

1.  Create a general group for the plate elements of interest.

2.  Define the top layer fiber orientation.

a.  Right-click on the group name in the group tab of the parts tree and select
"Modify".

b.  Check the "Orientation" checkbox.

c.  Define a desired global orientation for the group.

d.  Click OK.

3.  Launch the View Options dialog .

4.  Click the Direction checkbox once.  "Off" will change to "Fiber" next to the checkbox.  (A
small tick should be shown at each element centroid.  You can scale the tick by increasing/
decreasing the point load scale on the right side of the View Options dialog box.)

5.  Once the orientation is verified, click the Direction checkbox once more to change it from
"Fiber" to "Stress".
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6.  Click OK.

7.  The displayed Stress X is now in the given direction.

10.8 Viewing Areas of Interest

Toolbar  

Menu  View > Options

The following tutorials shows how a user can post-process a given area of interest.  This is
useful when the analyst would like to isolate a particular area to view deformation or stress. 

1.  After the results have been loaded, click on the Result menu to open the drop down
menu.

2. Click on Stress and select which stress to display.
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A detailed description of each type of stress that can be recovered can be found in the 
Stress Results sections.

3.  Click on the View Options icon  or select View > Options... from the menu.

4.  From the View Options dialog (see below), click the Apply Defined Range checkbox.
This will enable the Min and Max Range fields for the user to define the stress range of
interest.
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5.  Click OK when finished.

Individual element stresses for the defined range are now presented.  Elements that are
outside of the user-defined range are colored grey.

6.  To hide the elements outside of the user-defined stress range, click the  icon.

10.9 Recovering Composite Layer Stresses

Stresses can be recovered in each layer of a composite shell element.  The following steps
will detail the procedure to recover stresses from each of the layers.

1.  Solve the model.

2.  Select one of the stress options from the Results > Stress menu.
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3.  Click the Layers icon  to turn on layers.

4.  Click the dynamic query icon .

5.  Highlight an element and right-click to bring up the menu to choose which stress direction
to display as well as to choose the composite layer at the bottom of the menu.

6.  Once a stress option is chosen from the dynamic query fly-out menu, highlighting an
element will now report the chosen layer stress.
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The model used in this sample (Composite_4Layer.mdl) can be found in the Models and
Samples MAESTRO installation folder for reference.

10.10 Evaluation Patch (E-patch)

Central to the structural assessment paradigm in MAESTRO, is the concept of the
Evaluation Patch (E-patch).  The E-patch is a strength assessment entity that serves to
represent the true stiffened panel, panel between stiffeners, stanchion span and/or beam
column span that are located throughout a global the FEM.  These Epatches are created by
automatically searching the entire FEM and collecting (if necessary) the multiple finite
elements (plates or beams) to represent the true panel geometric parameters.  Thus, the
true boundary conditions and true structural spans are calculated, stored, and subsequently
used to calculate the limiting structural failure modes throughout the FEM.

10.10.1 Defining Evaluation Patches

When running an analysis with one of the failure mode options selected, MAESTRO will
automatically check if evaluation patches are defined.  If no evaluation patches are defined
in the model, MAESTRO will automatically search and create patches using the Level 0
option.  If patches were previously defined, the following will prompt the user:
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Note: If "Yes" is clicked, all previous evaluation patch information will be erased and the
Level 0 patches will automatically be found and created and the analysis will run.  

All evaluation patches in a model can also be deleted by selecting Model > Evaluation Patch
> Delete All.

There are four ways to create evaluation patches in MAESTRO, which are described in
more detail below:

Level 0 Patch Automatic Search

The level 0 patch automatic search option can be accessed from the prompt when running
an analysis with a failure mode evaluation option selected or from the Model > Evaluation
Patch > Auto-Generate menu option.  The menu option method will launch the Patch Search
Criteria dialog:
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The level 0 search can be performed on the full coarse mesh model, or the current View
Part only.  This method will search the model and define evaluation patches based on the
boundaries created by beam elements and changes in plate support direction (e.g., the
intersection of the side shell and the main deck will be treated as a boundary).  The
threshold for the definition of a plate support boundary can be set by the user.  This value is
defined as any plate supports with a change in direction greater than the threshold value will
be considered a boundary.  An example of a level 0 patch search is shown below:
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Level 1 Patch Automatic Search

When a model is more refined and stiffeners are now defined as beam elements, like the
example module above, the level 1 patch search allows the user to quickly define patches
representing the true span of a stiffened panel.  Using the Patch Search Criteria Dialog, the
radio button next to Level 1 will change the dialog when it is selected.
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Now instead of using all beam elements as boundaries, the level 1 option allows the user to
select the beam properties to be used in the search.  Using the sample module again, the
frame and girder beam properties can be selected and added to the "Boundary Support
Beams" list by clicking on the item (multiple beam properties can be selected and moved at
once) in the "Beam Property Library" list and clicking the ">>" button.
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Beam properties can be removed from this list by using the "<<" button.  Click OK to perform
the search.  The image below shows the evaluation patches created using the level 1 search
option:



Analyzing and Post-Processing 403

© 2014 Optimum Structural Design, Inc.

The evaluation patches now represent the  true stiffened panel (including the beam
elements representing stiffeners).

Manual Patch Creation

The manual patch creation method can be used in conjunction with the level 0 and level 1
automatic search algorithms.  This operation will overwrite the applicable existing patches
used to create the manual one.

A manual patch can be created by following these steps:

1. Create a general group of the elements making up the patch.

2. Expand the group tree and select the created group.
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3. Right-click and select "Create Patch” from the menu.

4. This will open the Evaluation Patch dialog showing the new patch parameters.

Evaluation Patch without Geometry

The following steps walk through the process of creating an evaluation patch interactively
through the Evaluation Patch Dialog:

1. Open the “Limit State Creation/Evaluation” dialog box.

2. Click the ID button.

3. Change the radio button from “Auto” to “User defined”.

4. Enter the desired data.

5. Click Create.

10.10.2 Element Query & Collection

Fundamentally, the E-patch is a collection of elements with its boundary supported by
bulkheads or beams.  It should be noted that an E-patch can also be a single element if that
element meets the boundary support criteria.  In traditional MAESTRO, an E-patch was a
lengthwise strake panel or a few strake panels, if the section per bay was defined as greater
than one (this will make sense to the seasoned MAESTRO user).  The E-patch searching
algorithm queries each element within the FEM to:

· Identify possible element free edge(s),
· Identify element supports (e.g., is the element edge bound by beam elements, is

the element edge bound by a BHD, etc.),
· Identify element material, scantlings, 
· Identify stiffener definition (e.g., stiffener layout),
· Identify element length/width,
· Check element collection flatness,
· Identify if an element is evaluable,
· Determine beam-column effective width,
· Determine the directional stress and average panel pressure.

Based on the query findings, the E-patch is created and parameters stored.  It should be
noted that the E-patch generation process can be used with imported NASTRAN FEMs. 
Because most NASTRAN explicitly model beams to represent secondary members, the
E-patch algorithm will only collect elements between stiffeners (i.e., local plate between
stiffeners).

Effective Plating
The collection of beam elements into E-patches has one additional component that
addresses the need to calculate effective plating attached to a beam (i.e., plate-stiffener
column).  This provides a thorough method to compute the effectiveness of plating that acts
in conjunction with a stiffening member.  To do this, the E-patch searching algorithm finds
each beam and the associated plate elements.  The associated plate elements are the
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collection of plate elements (i.e. panel E-patch) on either side of the beam element.  This
information (i.e., breadth between stiffener), in addition to other recovered parameters (e.g.,

beam span (L),  (modulus of elasticity), and  (material yield)) are used to find the lesser
value of the following:

· Post-buckling, 

· Average breadth between neighboring spacing, 

· 1/3 of beam span, 

As stated previously, E-patches are defined automatically and can graphically be presented
by a quilt of colors (see the figure below).  This figure demonstrates, there can be hundreds,
if not thousands, of generated E-patches throughout the FEM.  The E-patch has been
exercises with FEM that had over 1 million elements.

Finally, regarding Element Collection for E-patches, it should be noted that the user has the
ability to overwrite the E-patch definition if so desired.  The steps to perform manual E-patch
creation are documented in the following sections of the Help manual.

10.10.3 Element Scantlings & Stress Recovery

After elements are queried and collected, it is the job of the E-patch algorithm to determine
the representative scantlings and stresses amongst the E-patch.  The sections below
discuss the various scenarios an FEM may present in this regard and is important for the
analyst to understand.  

Scantling Determination

If scantlings of individual elements within an E-patch definition are different, MAESTRO
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must determine what scantlings to use for the strength assessment of the E-patch.  For
MAESTRO’s native strength assessment limit states as well as the ALPS/ULSAP method of
failure mode evaluation implemented in MAESTRO, the approach used for determining the
E-patch scantling  (i.e., in this scenario) is a weighted average (e.g., 

).

Stresses of individual elements within an E-patch definition are also likely to be different;
therefore, MAESTRO must determine what stresses to use for performing the strength
assessment within the Epatch.  

MAESTRO Native Limit State Evaluation

For MAESTRO’s native strength assessment limit states (see image below), the approach
used for determining the E-patch stress is a weighted average of the directional stress (i.e.,
stress vectors aligned with E-patch orientation).  The approach for the ALPS/ULSAP method
is slightly different.   For this strength assessment method, the E-patch stress collection
finds the nodal stress along the E-patch edge.  The edge nodal stresses are then averaged
and the SigX Upper, SigX Lower, SigY Upper, and SigY Lower are thus defined (see the
figures below).
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MAESTRO E-patch Stress

ALPS/ULSAP Limit State Evaluation

For the ALPS/ULSAP strength assessment, the figure below shows an E-patch that has four
CQUAD4R (Quad) elements.  Two of these elements were defined via a Strake and two
were defined via an Additional Quad.  Each of these elements has their own stresses (e.g.,
SigX, SigY, SigXY) and each node (or corner) that defines the element also has stress
values.  Further, for an individual Quad element there are four nodes representing the
corners (C1, C2, C3, and C4).  These corners are shown in the figure below.
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ALPS/ULSAP E-Patch Stress

The E-patches can be further post-processed by accessing the individual E-patch definition,
which is exposed in MAESTRO’s Limit State Creation/Evaluation dialog (see figure below).
Here the user can review the E-patch definition parameters such as Length, Width, and
Stresses.  The design pressure input value is only used in the calculation of the panel
adequacy parameters and does not affect the general finite element analysis.  The user has
the ability to redefine manually the E-patch parameters by using the User Defined button
and directly inputting the appropriate values.  Once these values are defined, the user can
click the Compute button, which accesses a summary of the strength assessment
computations.  Note that these values can be presented, via the Compute button, when the
Auto button is selected in the Limit State Creation/ Evaluation dialog as well.
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10.10.4 Working with Evaluation Patches

Toolbar  

Menu  Model > Evaluation Patch > Create/Evaluate 
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The following tutorial describes what an evaluation patch is and how it is used in MAESTRO.

How do you automatically define patches?

From the main menu, select Model>Evaluation Patch>Auto-Generate. Patches can also be
automatically generated when evaluation is selected in an analysis.

How do you delete all patches?

From the main menu, select Model>Evaluation Patch>Delete All.

How do you manually create a patch?

1. Create a general group. It is suggested the group to be named as “Eval/abcdefg1”.

2. Expand the group tree and select the created group.

3. Right-click the mouse and select "Create Patch” from the menu.

How do you query a patch?

1. From the Dynamic Query icon ( ), select patch.

2. Use the mouse to highlight the desired structure.

How do you evaluate a patch interactively?

1. From the main menu, Select Model>Evaluation Patch>Create/Evaluate, or click the patch

icon  to open the “Limit State Creation/Evaluation” dialog box. 

2. Select a patch from the ID drop down box and click compute.
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How do you view the properties of a patch?

1. Open the "Limit State Creation/Evaluation” dialog box.

2. Expand the column until the name of the plate property is seen.

3. Move the cursor to the plate property, and right-click it.
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How do you modify the scantlings and stress parameters of a patch?

1. Open the “Limit State Creation/Evaluation” dialog box.

2. Change the radio button from “Auto” to “User defined”.

3. Enter the desired data

4. Click Modify.

How do you change an evaluation method?
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1. Open the “Limit State Creation/Evaluation” dialog box.

2. Change the radio button in the method frame to the desired evaluation method.

How do you evaluate an individual element?

1. Open the “Limit State Creation/Evaluation” dialog box.

2. Place the cursor in the patch ID drop down box.

3. Use the mouse to select an element.

4. Modify the geometry and load parameters if necessary.

5. Click Compute button.

How do you define a patch without building a model?

1. Open the “Limit State Creation/Evaluation” dialog box.

2. Click the ID button.

3. Change the radio button from “Auto” to “User defined”.

4. Enter the desired data.

5. Click Create.

How do you view the element evaluation flag?

From the main menu, click View>Patches>Element Evaluation.

How do you turn an element evaluation flag on or off?

1. Query a Patch

2. Right-click and select "Evaluation Off”.

How do you remove a patch?

1. Query a patch.

2. Right-click and select "Remove”.

How do you define the Ultimate Strength Parameters? (Applies to ULSAP evaluation
method)

1. From the main menu, select Model>ULSAP Parameters.

2. Click the ID button. Enter proper values for the ULSAP ultimate limit state parameters and
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click “Create”.

Note, the default ultimate limit state parameters will be automatically applied to any patch
which is not specifically associated to a set of ultimate limit state parameter.

If a patch is in a perfect initial condition, the user has to define a set of ultimate limit state
parameters with zero imperfection. If all patches are in a perfect condition, then the user
does not define any set of ultimate limit state parameters.

How do you get the ULSAP text output file for an individual patch?

1. Open the “Limit State Creation/Evaluation” dialog box.

2. Select the radio button “ULSAP”.

3. Click the ULSAP text output checkbox.

4. Click Compute and then follow the result processing instructions.

How do you get the ULSAP text output results for all panels?

1. Open the "Limit State Creation/Evaluation" dialog box.

2. Select the radio button "ULSAP".

3. Double-click the ULSAP text output checkbox.

4. Click Compute and then open the Output tab to review the results.

See ALPS/ULSAP  for more details.

How do you associate a set of ultimate limit state parameters to a patch?

1. Define a set of ultimate limit state parameters.

2. Open the “Limit State Creation/Evaluation” dialog box.

3. Select the radio button “ULSAP”.

4. Select the parameter set.

5. Click Modify.

How do you create a MAESTRO Scalable Solver Limit State Data?

1. Manually define a patch from a general group.

2. Associate the patch to a set of limit state parameters.

3. Click Modify.
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4. Export the MAESTRO Data

10.11 Failure Mode Evaluation

Introduction

A large and complex thin-wall structure can fail in many different ways, which are called the
failure modes.  The various factors that determine the failure modes include the geometry of
the structure, the boundary conditions, and the loading on the structure.

MAESTRO provides two different types of failure mode evaluations for stiffened panels and
their components: MAESTRO and ALPS/ULSAP.  MAESTRO also provides ALPS/HULL,
which addresses progressive collapse of the hull girder.  Click on the link for either method
for more detailed information on how to perform and interpret each type of evaluation.  The
evaluation includes yielding and buckling failure modes.  For a given ship structural system
and pertinent loading conditions, the calculated stresses must not be greater than the limits
prescribed and/or computed for these failure modes.

Adequacy Parameters as a Measure of Safety

For a structure to be safe under a given load condition, the load effect Q must remain below
the limit value QL by a certain factor, called the safety factor, g.

Expressed mathematically, the safety requirement is,   

LQQ £g

If we define a “strength ratio”

LQ

Q
R

g
=

then the safety requirement becomes

1£R

Each of these requirements constitutes a constraint on the design.  In MAESTRO each
constraint is expressed in the form
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g(R) >  0

Safety against structural failure is measured by a parameter called the Adequacy parameter,
denoted by g(R), which is defined as 

g(R) =  
1 -  R

1 +  R

g

g

 

 

The advantage of using an adequacy parameter of the strength ratio is that g always lies
within the normalized limits of -1 and +1, whereas R ranges from 0 to infinity. Specifically,
g(R) ® 1 as R ® 0 either as a result of very small load or very large limit value and at other
extreme, g(R) ® -1 as R ® ¥, either as a result of very large load or very small limit value.
Since all of the constraints in MAESTRO are of the above form, it is sufficient, in explaining
each of the failure types to simply explain what is Q and QL for that failure type.

For convenience of reference in post-processing, each of the adequacy parameters (for
both MAESTRO and ALPS/ULSAP) is identified by an acronym, usually consisting of four
letters.  First, it should be states that there are two broad categories of limit states, i.e.
adequacy parameters, the ultimate or collapse limit states, in which the structure or member
has failed in its primary, load-carrying role; and the serviceability limit states, which involve
the deterioration or loss of other, less vital functions.  Typically the first letter is P, G, F or  B
referring to panel, girder, frame, or beam.  The second letter indicates the type of failure;  it
may be either C (collapse) or S (serviceability) or it may indicate a particular type of
unserviceability:  Y (yield) or B (buckling).
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MAESTRO Adequacy Parameters ALPS/ULSAP Adequacy Parameters

10.11.1 Panel Collapse and Serviceability

The following sections discuss the available panel collapse and serviceability analysis
methods implemented in MAESTRO.

10.11.1.1 MAESTRO

MAESTRO's limit states cover failure modes associated with Panels and Beams
(Girders/Frames).  The table below provides a summary of the 14 failure modes
automatically evaluated using the MAESTRO native criteria.
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Panel Failure
Modes

PCSF Panel Collapse, Stiffener Flexure

PCCB Panel Collapse, Combined Buckling

PCMY Panel Collapse, Membrane Yield

PCSB Panel Collapse, Stiffener Buckling

PYF Panel Yield, Flange

PYP Panel Yield, Plate

PSPB Panel Serviceability, Plate Bending

PFLB Panel Failure, Local Buckling

Beam Failure
Modes

BCT Beam Collapse, Tripping

BCCF Beam Collapse, Compression in Flange

BCCP Beam Collapse, Compression in Plate

BYF Beam Yield, Flange

BYP Beam Yield, Plate

BCPH Beam Collapse, Plastic Hinge

10.11.1.1.1  Panel Failure Modes

MAESTRO's limit states for panels cover 8 different modes of failure.  The table below
provides a summary of these failure modes.
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Panel Failure
Modes

PCSF Panel Collapse, Stiffener Flexure

PCCB Panel Collapse, Combined Buckling

PCMY Panel Collapse, Membrane Yield

PCSB Panel Collapse, Stiffener Buckling

PYF Panel Yield, Flange

PYP Panel Yield, Plate

PSPB Panel Serviceability, Plate Bending

PFLB Panel Failure, Local Buckling

Panel Failure Modes:  Collapse

Collapse limit states are defined when the structure or member has failed in its primary,
load-carrying role.

Panel Collapse, Stiffener Flexure (PCSF)

The PCSF failure mode examines either the (a) Ultimate Strength of Plates, Chapter 12.6 of
Reference [1], or (b) Ultimate Strength of Stiffened Panels, Chapter 14 of Reference [1].
The Ultimate Strength of Plates is examined when an element is a bare plate (i.e.,
unstiffened), while the Ultimate Strength of the Stiffened Panels is examined when the
element has stiffeners associated with it (i.e., a stiffener layout is defined).

For stiffened plates, this collapse occurs due to the axial compression and flexure of the
plate-stiffener combination or by the axial compression .  Each stiffener is regarded as an
isolated beam column, with the plating acting as one of the two flanges.  For this scenario,
there are three different types of failure modes depending on the sign of the bending
moment, and the deflection of the plating/flange: Mode I, Mode II and Mode III.  The
underlying theory for this failure mode is given in Chapter 14 of Reference [1].

The following sign convention (for theoretical computation) is used:

· Stress : Positive if compressive.

· Bending moment : Positive when the plating is in compression

· Lateral Deflection :  Positive towards the stiffeners.

· Eccentricity : Positive towards the stiffeners.
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The three modes of failure are :

 Mode I  : “Stiffener-induced” collapse due to compression failure of the stiffener.

Collapse occurs due to compression failure of the stiffener flange.  The combination of
in-plane compression and negative bending is illustrated in the figure below.  

s s
s d

f a

f a fM y

I

A y

I
= + +

+0 0( )D
F

Collapse occurs when the stress in the mid-thickness of the flange, sf  equals the failure

value, which is the minimum of yield stress sYs or the elastic tripping stress sa,T.  

The terms in the above equation are:

A and I : Cross sectional area and moment of inertia of the beam column.

M0 and d0 : Bending moment and deflection due to lateral load (“dead load”).

D : Eccentricity 

yf : distance from the centroidal axis of the c.s. to the mid-thickness of the stiffener flange.

Mode II : “Plate induced” collapse due to compression failure of the plating.

This failure mode occurs due to a combination of in-plane compression and a positive
bending moment as shown in the figure below.  The total stress acting through the plating as
obtained from the beam-column formula would be 
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where sF is the failure stress and the subscript ‘tr’ stands for the property of the transformed

section. Collapse occurs when sf equals the failure value, which is the minimum of yield

stress sYs or the elastic tripping stress sa,tr

Mode III : Combined failure of stiffener and plating. 

This failure occurs due to a large positive bending moment M0, which would cause a large

tensile stress in the stiffener.  The failure is due to a simultaneous stiffener tensile yielding
and compressive yielding of the plate.  It can be shown from the interaction curve of Figure
14.2 of [1] that the load combination required for mode III failure is given by the expression  
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While evaluating PCSF, the effects of transverse compression and in plane shear are also
taken into account.  The respective reduction factors ray and rt are given by

ray

ay

ay u

= -1
s

s ,
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Panel Collapse, Combined Buckling (PCCB)

In general, a stiffened panel is subjected to longitudinal, transverse, and shear loads, and
the different buckling modes corresponding to these loads will interact to a considerable
degree.  This failure algorithm examines the interaction between these loads and the elastic
overall panel buckling due to any combination of longitudinal stress sx, transverse stress sy

and shear stress t.  The strength ratio, RPCCB, for this combined buckling mode is calculated

by using an interaction formula to combine the strength ratios for longitudinal buckling,
transverse buckling and shear buckling for the panel.  

The algorithm first calculates the uniaxial elastic critical stresses sx,cr, sy,cr and tcr, based on

the theory in Chap 13 of [1].  It then formulates the uniaxial strength ratios Rx = sx/sx,cr, 

Ry = sy/sy,cr and Rs = ty/tcr and inserts these into the following formula for the total

(interactive) strength ratio:
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The elastic buckling modes for a stiffened panel are presented in chapter 13 of Ref. [1].

Panel Collapse, Membrane Yield (PCMY)

This failure mode checks for any yielding that occurs through the thickness of the plating
(membrane yield).  When yielding occurs, it can easily extend into a significant portion of the
structure and could lead to overall collapse.  MAESTRO evaluates PCMY using the Von
Mises equivalent stress, which is obtained by using the mid-plane mean longitudinal stress
acting on the panel, the mean transverse stress and the shear stress, as 

s s s s s tvm x y x y xy= + - +2 2 23
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PCMY
c vm

Y

R  =  
g s

s

where

vm  =  Von Mises stresss

c  =  combined safety factor for collapseg

Panel Collapse, Stiffener Buckling (PCSB)

This failure mode checks the flexural-torsional and lateral-torsional buckling ("tripping")
behavior of flanged stiffener subjected to axial compression, end moment, lateral pressure
and any combination of these.  The effects of cross-sectional distortion, postbuckling
behavior of the plate (incorporated by considering the plate effective width) and plasticity are
included.  A detailed description of this mode of failure can be found in Reference [17] and [
18].

For the evaluation of PCSB (Panel Collapse Stiffener Buckling), the overall evaluation patch
parameters of length, width, etc., are used.  However, the stress and pressure loads used
for the evaluation are evaluated at each individual element.

For transversely stiffened panels, the stiffeners are at right angles to the principal
compressive stress and so they can do little to prevent or delay plate buckling.  However, if
they buckle before the plating then overall panel buckling follows immediately.  This is a very
undesirable mode of collapse since it occurs rapidly and without warning.  Therefore the
PCSB limit state becomes the requirement that stiffener buckling must not precede plate
buckling.

Panel Failure Modes:  Unservicability

Serviceability limit states are defined when the deterioration or loss of other, less vital
functions have occurred.

Panel Yield Flange (PYF)

For plates that have stiffeners defined, this limit state examines the combined axial stress
and stiffener bending stress in the stiffener flange.  The bending stress in the stiffener flange
is simply the (M*y)/I and is unidirectional.

For unstiffened plates, the flange is taken as the bottom fiber (i.e., extreme fiber) of the plate
(see Bare plate).
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Panel Yield Plate (PYP)

For plates that have stiffeners defined, this limit state examines the von Mises stress due to
the combination of axial stress, shear stress, and bending stress calculated at the root of the
stiffener flange and compared tot he stiffener yield stress.

For unstiffened plates, the plate is taken as the top fiber (i.e., extreme fiber) of the plate
(see Bare plate).

Panel Serviceability, Plate Bending (PSPB)

The limit state PSPB (Panel Serviceability, Plate Bending) deal with plate bending due to
pressure and do not consider or allow for any permanent set; they require that the total
stress at the plate surface (membrane stress + bending stress) remains below yield.  Since
pressure can vary within an evaluation patch these limit states are evaluated for every
element within the evaluation patch.  The bending stress due to lateral pressure is given by
the expression

s b kp
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where k is a constant that depends on the boundary conditions and the aspect ratio of the
plate.  Values of k are given in Figure 9.6 of Ref. [1].  This bending stress is automatically
calculated by MAESTRO based on the evaluation patch parameters and incorporated into
the Von Mises stress, which is then compared to yield.

Panel Failure, Local Buckling (PFLB)

PFLB refers to the failure related to the buckling, elastic or inelastic, of plating between
stiffeners.  Buckling may be caused by sx, sy, or t, or by various combinations of these. 

“Local” buckling implies buckling of plating between stiffeners.  When failure occurs due to
buckling of plating crosswise to the stiffeners (e.g. buckling due to lengthwise compression
in a transversely stiffened panel) then such buckling is collapse of the panel rather than
unserviceability.  Therefore this limit state uses the word “failure”, represented by the letter F
in the acronym PFLB, rather than the letter C (for collapse) or S (for serviceability).  

sL denotes a stress that acts lengthwise (parallel to the stiffeners) and sT will denote a stress

that acts transversely (across the stiffeners).  The corresponding failure stresses (elastic or
inelastic buckling stress or, for thick plating, yield stress) when the applied stresses act in
isolation are denoted sL,F and sT,F.  Similarly the value of shear stress that would cause
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failure (again elastic or inelastic buckling, or yield) when it alone acts on the plating is
denoted tF.  The values of sL,F, sT,F and tF are calculated from the equations of chapter 12 of

[1].  The corresponding strength ratios are RL = sL/sL,F , RT = sT/sT,F , and RS = t/tF.  These

“act alone” strength ratios are then converted to interactive values RL,F and RT,F by an

extension of the procedure given on page 435 of Reference [1].  To give a brief picture of
this, for a slender plate, the shape of the curve is almost linear, whereas for a thick plate it
approaches the Von Mises ellipsoid. 

The partial safety factor varies between gS and gC, depending on the stiffening and on the

relative values of RL,F and RT,F.  For unstiffened panels gc is used.  For a stiffened panel: if

the transverse stress is zero or tensile use gs; otherwise use a value between gs and gc
according to the value of RT,F relative to RL,F

10.11.1.1.2  Beam Failure Modes

MAESTRO's limit states for girders cover 6 different modes of failure.  The table below
provides a summary of these failure modes.

Girder Failure
Modes

BCT Beam Collapse, Tripping

BCCF Beam Collapse, Compression in Flange

BCCP Beam Collapse, Compression in Plate

BYF Beam Yield, Flange

BYP Beam Yield, Plate

BCPH Beam Collapse, Plastic Hinge

Beam Failure Modes : Collapse

Collapse limit states are defined when the structure or member has failed in its primary,
load-carrying role.

Beam Collapse, Tripping (BCT)

This failure mode checks the flexural-torsional and lateral-torsional buckling ("tripping")
behavior of flanged stiffener subjected to axial compression, end moment, lateral pressure
and any combination of these.  The effects of cross-sectional distortion, postbuckling
behavior of the plate (incorporated by considering the plate effective width) and plasticity are
included.  A detailed description of this mode of failure can be found in Reference [17] and [
18].  In particular, Reference [17] deals with girders.
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Beam Collapse, Compression, Flange/Plate (BCCF, BCCP)

Beams are loaded as a “beam column” and collapse may occur due to combined bending
and buckling.  Collapse is assumed to occur when there is compressive yielding in either the
beam flange or plate flange, as there is very little reserve strength beyond this point for
beam columns.  The stresses in the beam flange is the beam axial stress plus the bending
stress at the flange (M*y)/I.  Detailed theory can be obtained from section 11.3 of Ref. [1].

Beam Failure Modes : Serviceability

Serviceability limit states are defined when the deterioration or loss of other, less vital
functions have occurred.

Beam Yield, Flange/Plate (BYF, BYP)

Compressive failure of a beam is, in general, a complex buckling phenomenon, and to serve
as an approximate preliminary check for failure, the Von Mises stress at the beam flange
and the plate flange are calculated and are checked against the yield stress.  This occurs for
both tension and compression stress.

Beam Failure Modes : Collapse

Collapse limit states are defined when the structure or member has failed in its primary,
load-carrying role.

Beam Collapse, Plastic Hinge (BCPH)

Collapse of a beam will occur if sufficient plastic hinges are formed to allow it to undergo
large deformations as a mechanism.  If the bending moment at one of the two ends in the
beam segment exceeds the plastic moment for that beam's cross section, collapse is
assumed to have occurred for that beam.  Chapter 16 of Reference [1] provides detailed
theory of plastic hinge.

10.11.1.2 ALPS/ULSAP

The following capability is an optional MAESTRO module.  Run Fast Lock if you are not
certain have purchased this optional module.

A complete description of the theoretical basis for the ALPS/ULSAP module can be found in:

1. MARSTRUCT 2011 Paper (ULSAP)

2. Benchmark Study (ULSAP)
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Supporting verification tables presented in the above documents can be found in the 
...\MAESTRO\Models and Samples\Verification Models\ULSAP directory.

For a ALPS/ULSAP tutorial, go here: ALPS/ULSAP 

ALPS/ULSAP's limit states cover failure modes associated with Panels, Girders and Frames.
The table below provides a summary of the 13 failure modes automatically evaluated using
the ALPS/ULSAP criteria.

Panel Failure
Modes

PCCB Panel Collapse, Overall Grillage Collapse - Mode I

PCPE Panel Collapse, Plate Induced Failure, Yield at Panel Edges - Mode II

PCPM Panel Collapse, Stiffener Induced Failure, Yield at Midspan - Mode III

PCWB Panel Collapse, Stiffener Induced Failure, Web Buckling - Mode IV

PCSB Panel Collapse, Stiffener Induced Failure, Tripping - Mode V

PYM Panel Yield, Mid-plane

PYF Panel Yield, Stiffener Flange

PYP Panel Yield, Plate

Beam Failure
Modes

BCT Beam Collapse, Tripping

BYC Beam Gross Yielding

BCWB Beam Collapse, Web Buckling

BCC Beam Collapse, Beam-column

FCPH Frame Collapse, Plastic Hinge

10.11.1.3 ABS HSNC

The ABS High Speed Naval Craft rules have been implemented into MAESTRO's limit state
framework.  When exercising these limit states, level 0 evaluation patches should be used
and the HSNC Allowable Stress value in the material properties should be entered according
to the rules.  For more details on the different limit states and equations, please reference
the following ABS Guides:
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ABS Rules for Building High Speed Naval Craft

ABS Guide for Buckling and Ultimate Strength For Offshore Structures

10.11.1.4 Running Standalone Evaluation

Standalone evaluation can be run be accessing the Limit State Creation/Evaluation dialog
and following the procedure outlined in Using Evaluation Patches.

10.11.1.5 Post-processing Failure Modes

Toolbar  N/A

Menu  Results > 

Post-processing of the various failure modes can be accomplished by accessing the 
Results > Adequacy menu.  The adequacy parameters menu will be different depending on
whether MAESTRO or ULSAP evaluation is chosen.

MAESTRO ULSAP
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Selecting one of the parameters will display the patches colored by their adequacy
parameter value.  MAESTRO can automatically display each elements smallest adequacy
parameter by selecting Minimum Value (Plate), Minimum Value (Beam), or Minimum Value
(All).  You can also choose to display only the Positive or only the negative adequacy
parameter results.

Similar to Viewing Stress Ranges, Adequacy values can be defined by the user and viewed,
e.g., to determine all negative adequacy values.
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The dynamic query icon  (with Adequacy checked from the drop-down) can be used
to highlight an element and recover the adequacy parameters.  Double-clicking the element
will echo the results to the Output tab.

10.11.2 Hull Girder Progressive Collapse

The following sections discuss the available hull girder progressive collapse methods
implemented in MAESTRO.

10.11.2.1 ALPS/HULL

The following capability is an optional MAESTRO module.  Run Fast Lock if you are not
certain have purchased this optional module.

A complete description of the theoretical basis for the ALPS/HULL module can be found in:

1.  MARSTRUCT 2011 Paper (HULL)

2.  Benchmark Study (HULL)

For a ALPS/Hull tutorial, please go here: ALPS/HULL

Ship hulls are subjected to a variety of hull girder or local load components. Of these,
vertical bending is a primary hull girder load component. It is known that the horizontal
bending may sometimes be large in the magnitude, approaching the magnitude of vertical
bending moment when the ship runs at an oblique heading in waves. Also, in some vessels
such as bulk carriers carrying dense cargo such as iron ore, an uneven alternate hold
loading condition is normally applied, and, as a result, large shearing forces will be imposed.
Moreover, torsion is normally considered to be important for vessels with low torsional
rigidity due to large deck opening such as for instance in container vessels and some large
bulk carriers. 
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Figure 1 Hull girder sectional load components

Local plate elements of ship structures are subjected to lateral pressure loads due to cargo
or water. To view a complete picture of hull girder ultimate strength behavior, therefore, all
hull girder sectional load components mentioned above, i.e., vertical bending, horizontal
bending, vertical sectional shear, horizontal sectional shear and torsion in addition to local
lateral pressure loads, see Fig.1, should be considered simultaneously in a consistent
procedure for hull girder ultimate strength analysis. 

By application of the finite element method, quite accurate ultimate strength solutions have
been obtained in several specific cases by a number of investigators. However, a weak
feature of the conventional finite element method is that it requires enormous modeling effort
and computing time for large sized structures. Therefore, most efforts in the development of
new calculation methods have focused on reducing modeling and computing times.

The obvious way to reduce modeling effort and computing time is to reduce the number of
degrees of freedom. Modeling the object structure with very large sized structural units is
perhaps the best way to do that. Properly formulated structural units in such an approach
can then be used to efficiently model the actual nonlinear behavior of large structural units.
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Ueda and Rashed (1974, 1984), who suggested this idea, called it the idealized structural
unit method (ISUM).

For applying ISUM, various structural units making up the object structure should be
developed in advance.  Until now, several ISUM units have been developed, and based on
these units a family of the computer program ALPS has been written by Paik (1995b). ALPS
is an acronym for the nonlinear Analysis of Large Plated Structures.

The ALPS/HULL module calculates efficiently the progressive collapse behavior of ship
hulls. The benefit of the ALPS/HULL module is that it can accommodate the effects of all
possible hull girder sectional load components, i.e., vertical bending, horizontal bending,
vertical shearing force, horizontal shearing force and torsion in addition to local pressure
loads, in the ultimate strength calculations.

The ALPS/Hull failure modes are summarized in the table below:

Failure Mode Acronym Failure Mode Description

OC Overall Collapse

PB Collapse of plating between support members
(stiffeners)

BCC Beam-column Type Collapse

SWB Local Buckling of Stiffener Web

TR Flexural-torsional Buckling of Stiffener

GY Gross Yielding

RT Rupture due to Tension

CC Crushing due to Compression

·      
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10.11.2.2 ProColl

Enter topic text here.

10.12 Creating and Analyzing a Fine Mesh Model

The following tutorial shows the process for creating and analyzing a fine mesh model.

There are four different types of fine mesh analysis models that can be automatically
created in MAESTRO: a top down model, an embedded model, a ALPS/HULL model, and a
Nastran Map model.  

When automatically creating a top down or embedded fine mesh model within MAESTRO,
the following loads are automatically prescribed to the fine mesh model from the coarse
mesh model:

· Immersion

· LinPress

· Surface Head

· Surface Zero

· Point load

· Convert mass nodal group into point mass

· Convert mass bay group into point mass

· Convert mass plate group into point mass

Top Down Analysis

The top-down analysis is a two steps analysis. The coarse mesh model has to be solved
first.  The boundary displacements of the fine mesh model are calculated using coarse mesh
results via linear interpolation.  The displacements of the coarse mesh nodes are then
applied to the fine mesh nodes through RSpline elements.  The fine mesh model is a
different finite element model with imposed displacement boundary conditions. This method
uses the same logic as MG/DSA.

Groups can be created within the fine mesh model and loaded in the load case dialog as
with the coarse mesh model.  MAESTRO will automatically flag these groups as fine mesh
and ignore them while solving the coarse mesh model.

The following example will walk through creating a simple top down fine mesh model:
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1.  Begin by opening FineMeshStep0.mdl from the Models and Samples MAESTRO
Installation directory.

2.  Create a general group of the middle 4 strake panels, including the strake frames.

3.  Right-click on the group in the parts tree and select Refine.
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4.  Use the default settings and click OK.

You should now be to the same point as FineMeshStep2.mdl.

In a top down analysis, the original coarse mesh elements are not deleted from the model. 
To view the coarse and fine mesh elements together, select View > All Modules from the
menu. 
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In order to solve the fine mesh model, you must first solve the coarse mesh model and then
solve the fine mesh model separately.  This can be done by solving the coarse mesh model
as usual and then right-clicking on the fine mesh model in the parts tree and selecting solve.
 A box can also be checked to "Solve All Fine Mesh Models" in the Analysis/Evaluation
dialog box.  This option will first solve the coarse mesh model and then the fine mesh model
with one command.   RSplines are used to transmit the displacements of the coarse mesh
nodes to the fine mesh nodes along the RSpline element.

Embedded Analysis

The embedded fine mesh analysis is a one step analysis. The coarse mesh model and the
fine mesh model are tightly connected by the Rspline elements.  When the embedded model
is created by the refine method, the "Master element"  has to be deleted.  Otherwise the
structure is over stiffened by the fine mesh model. An embedded fine mesh model has no
"Master element". The RSpline element provides a "restraint" stiffness matrix, and the
stiffness matrix is added into the global stiffness matrix, so the coarse mesh model and the
fine mesh model can be solved together at the cost of larger band width and much more
computer time. For "top-down" analysis, the global result never changes no matter how the
fine mesh model is modified; but for "Embedded" fine mesh analysis, the global results are
dependent on the fine mesh model and they are closely coupled.

The following example will walk through creating a simple embedded fine mesh model:
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1.  Begin by opening FineMeshStep0.mdl from the Models and Samples MAESTRO
Installation directory.

2.  Create a general group of the middle 4 strake panels, including the strake frames.

3.  Right-click on the group in the parts tree and select Refine.
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4.  Select Embedded for Analysis Type and use the default values for the rest of the input
and click OK.

You should now be to the same point as FineMeshStep2Embed.mdl.

In an embedded analysis, the coarse mesh elements from the general group are now
replaced by the fine mesh elements.
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The fine mesh and coarse mesh models will now solve simultaneously in an embedded
analysis.  Again, RSplines are used to transmit the displacements of the coarse mesh nodes
to the fine mesh nodes along the RSpline element.

ALPS/HULL Analysis

Due to the complexity of this subject, please see the ALPS/HULL section.

Nastran Map Analysis

The Nastran Map option will create a separate fine mesh analysis model of the general
group with a 1 to 1 ratio.  All strake panels, frames and girders will be converted to quad and
beam elements.  This model can then be exported to Nastran to analyze with the global
response imposed through the use of RSpline elements.  Internal stiffener layout properties,
if existing, are automatically lumped to the edges of their associated element.
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Either method follows the same general procedure.

1.  Create a general group of the elements that will be refined into the fine mesh model.

2.  Right-click on the group name in the parts tree and select refine.  This will open the
Refine dialog box.

The fine mesh model will be created as a module with the given name either under top if you
are using the embedded method or separately for the top down method.  The join tolerance
and user defined module origin can be overwritten if desired.

3.  Select the Analysis Type.

4.  Select whether the element loads from the coarse mesh model should be mapped onto
the fine mesh model.  This would include tank, pressure, mass, etc. loads.

5.  The minimum length along non-stiffened edge can be set to control the mesh size.  
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6.  Select how the model's web and flange elements should be treated.

7.  Click OK.

10.13 Transparency View

Toolbar         

Menu  View > Set Visibility > Visibility On  View > Set Visibility > Visibility Off

Parts Tree  Right-click > Set Transparency On  Right-click > Set Transparency Off

MAESTRO has the ability to toggle a part in a regular or transparent view.  This view can be
applied at the module level, or the full model.  The transparent view will allow all internal
structure and external structure to be seen at once.

The transparency view can be set using the toolbar, by clicking either the Set Part

Transparent icon  or the Unset Part Transparent icon  and then  clicking the part
desired, using the main menu, or by right-clicking on a part within the Parts Tree and
selecting Set Transparency On or Off.
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11 ULS-Based Optimization

MAESTRO allows a user to optimize a given structure ranging from a single module to a full-ship
model.  The optimization uses the MAESTRO loading patterns and failure mode evaluations (and
safety factors) to minimize the structural weight and cost, while maximizing safety, given a set of
user-defined constraints.  At each scantling iteration, a new finite element analysis is run and
adequacy parameters are evaluated for all patches in the model.  The worst case evaluation patch
for each design cluster (a group of evaluation patches with the same scantling properties) is then
optimized and the FE analysis is re-run in an iterative manner. The work-flow for performing a
structural optimization is presented below.  Each of these steps is discussed in more detail in the
Optimization sub-sections.

Optimization examples can be found in the MAESTRO Models & Samples directory.

Optimization Work-Flow

The workflow and subsections assume that the finite element model has been created and the
appropriate load cases to use in the optimization process have been defined.

1.  Create evaluation patches representing the true stiffened panels of the structure to be optimized.
Information on the different methods for creating evaluation patches can be found here.

2.  Define general groups of the structure to be optimized which represent areas of common plate
and beam properties.  For example, the user may desire one or more strakes (or other area) to all
have the same plate thickness, frames, and girders for manufacturing purposes.

3.  Launch the Optimization dialog from the Model > Optimization... menu option and select the
general settings for the design, including the search method.
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The design space can be defined by either scantling constraints or by limiting properties to those
available in the MAESTRO property library.

4.  Set the default minimum and maximum constraint values for plates and beams.
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5.  Define any custom plate, stiffener, or frame constraints to apply to specific design clusters.
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6.  Add the design clusters to be optimized and assign the constraints to each group.
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7.  Click Run to start the Optimization process.  The results will be displayed in the Grid tab of the
Output window.

11.1 Setting up the Optimization Model

Setting up the Model

During the optimization process, MAESTRO will calculate the adequacy parameters for each
evaluation patch in the model, but then use the worst case patch from each design cluster to
optimize the structure.  The design cluster is intended to represent the typical structural layout of a
ship where there are areas of common plating, frames, and stiffeners larger than just a single
stiffened panel.  The image below shows a midship section with the evaluation patches defined on
the left and the design clusters defined on the right.
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     Evaluation Patches Design Clusters

The design clusters are created as general groups and can be selected using the evaluation patch
selection method from the groups dialog.  A design cluster must be created for each piece of
structure to be included in the optimization.  For example, a single module of a ship can be
optimized using the full ship FEA results by only creating and adding design clusters for that
particular structure representing the module.

Once the design clusters have been defined, the optimization settings can be defined by clicking on
the Model > Optimization menu item.

The first tab allows the user to define the general settings for the optimization:
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The Design Space can be defined by plate, stiffener, and frame properties or by selecting available
properties from the existing ones in the MAESTRO properties library.  The next section will discuss
the implications of these two choices.

The failure mode evaluation defines which failure mode calculations to use during the optimization. 
Currently, ALPS/ULSAP is the only supported method; however additional criteria will be added in
the future.

The Num. Design Cycles field allows the user to specify the number of iterations to perform without
finding a more optimal solution before ending the optimization.  The Num. of Solutions field allows
the user to specify the number of solutions to find before ending the analysis.

The search method field allows the user to select between a variety of search methods including
Simulated Annealing, Genetic Algorithms, Monte Carlo, and exhaustive.  It is not recommended to
use the exhaustive search option with the scantling Design Space option unless the model is very
small or the constraints are very strict (i.e., small design space) as the computation time can be very
long.
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11.2 Optimization Parameters

The next three tabs of the Optimization dialog allow the user to specify the constraints for the
overall design as well as specific constraints for each design cluster depending on how the Design
Space is defined.

Scantling Constraints

If the Scantling Design Space option is selected, Overall and “local” constraints can be defined.  On
the Overall Defaults tab, the plating and beam properties for the overall design can be set.

The plate and beam constraints can be set as dynamic which vary by a percent increase and
decrease or a minimum and maximum value for each parameter.  Leaving a static constraint
parameter blank will create a constraint in which that parameter remains fixed, unless overridden by
a local constraint.  For example, to only allow only the plating thickness to change, the following
settings could be used:
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Note: Any static constraints defined will override dynamic constraints for the same parameter.

The constraints tab allows the user to specify local constraints that can be applied to one or more
design clusters.  To create a new constraint, click the ID, type a name for the constraint (this will be
used to identify the constraint when applying to manufacturing groups), enter the plate constraint
parameters and click create.  Click modify after making changes to the constraint.  
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The plate property constraints can be defined in multiple ways by specifying operators and values
for one or more inputs.  Double-clicking in the operator field changes the way the constraint variable
is defined.  In addition to specifying possible plate thickness, the differences in plate thickness and
stiffener web and frame web can be specified.
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The stiffener constraints can be defined by the limits of the explicit stiffener properties as well as the
following ratios:

HSW/TSW: Height of stiffener web to thickness of stiffener web.
BSF/TSF: Breadth of stiffener flange to thickness of stiffener flange.
BSF/HSW: Breadth of stiffener flange to height of stiffener web.
TSW/TPL: Thickness of stiffener web to thickness of plate.
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The frame constraints tab is similar to the stiffener tab, but it also allows the user to specify a
stiffener cutout parameter where V1 is the margin and V2 is the ratio of frame height to cutout
height.

Property Library Constraints

If the Property Library design space definition option is selected, only a single constraints tab is
shown in the Optimization dialog.  
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The tabs ending in “Lib.” List the available plate, frame, girder, stiffener, and stiffener layouts based
on what is defined in the model.  In these tabs, constraints are now defined by selecting available
properties from the left-hand side of the dialog and moving them to the right-hand side.  This
constraint will then limit the optimization to only using these selected properties in the constraint
definition when applied to a design cluster.

More general, local constraints can also be set and used as they were in the Scantling design space
definition.

Applying Constraints

Once the constraints are defined for either method of defining the Design Space, the individual
design clusters constraints can be set on the Structure Tab.
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The left hand side of the dialog shows the list of available general groups (design clusters) defined
for the model.  To add a constraint to a design cluster, click the check box next to one or more of the
groups in the tree, select the constraint from the drop-down menu, and click Add.  Constraints can
be removed by selecting the group from the list on the right and clicking Remove.

The MinMax constraint is the overall constraints defined on the Overall Defaults tab.  Any
manufacturing group can have multiple constraints applied to the group.  In this case, the plate,
frame, or stiffener constraints would override the overall default constraints.  For example, a design
cluster may have the overall defaults (MinMax) constraint applied and a frame constraint applied.  In
this case, the plating and stiffener constraints from the MinMax set would remain and the frame
constraint would now use the parameters set in the local constraint set.

A control group defines active evaluation patches. A manufacture group usually has many evaluation

patches. However, if one of the patches in the design cluster is defined in the control group,

MAESTRO will optimize this patch instead of optimizing the worst patch in a manufacture strake. 

11.3 Optimization Results

To run the optimization after the settings are defined, click Run at the bottom of the Optimization
dialog.  The progress of the optimization can be followed in the Output tab at the bottom of the
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screen.

Once an optimization run is complete, the user will be prompted with a message asking whether to
display the results.  The results of the optimization will be shown in the grid tab at the bottom of the
window.

The output displays the results for the X number of designs requested from the general tab of the
Optimization dialog.  For each design found, the minimum adequacy parameter, new structural
weight, ratio of the new structural weight to the original structural weight, ratio of the weight of the
structural members with negative adequacy parameters to the original structural weight, ratio of
the weight of the structural members with negative adequacy parameters multiplied by the
structures adequacy parameter to the original structural weight, and the number of cycles ran
before finding the design will be shown.  Right-clicking on one of the designs brings up a menu
allowing the user to select this design and update the structure.  After a new design is selected, a
finite element analysis run is required to see stress, displacement, and adequacy parameter results.
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12 MAESTRO-Wave (Hydrodynamic Loads)

The MAESTRO-Wave module provides the ship designer with an integrated
frequency-domain and time-domain computational tool to predict the motions and wave
loads of any vessel.  To compute these hydrodynamic motions and loads, MAESTRO-Wave
first calculates the velocity potentials, source strengths, and flow velocities at the centroids
of the hydrodynamic panels for each speed, heading, and frequency requested, and then
maps the source strength to the structural panels. The equations of motion are formulated
using the structural mesh rather than the hydrodynamic mesh. This approach results in a
perfect equilibrium for the structural model. Bending moments, shear forces and torsional
moments are automatically in closure. No inertia relief and artificial loads are needed to
balance the model. The computation of these hydrodynamic forces is based on a
user-selected wet panel discretization method: 

· 3D potential theory using the zero speed Green function with a speed correction
parameter. 

· 2D Strip Theory using either the Free Surface Green Function or the Rankine Source
Method

· 2.5D High Speed Strip Theory using the Rankine Source Method

· Universal RAO

A variety of visualizations and output data are available for purposes of post-processing.

A typical workflow for using the frequency-domain and time-domain MAESTRO-Wave

capabilities is:

1.  Run the frequency-domain MAESTRO-Wave for a full spectrum of ship speeds, headings,

and waves.

2.  Using the frequency-domain results, identify the parameters (i.e., speed, heading, wave

frequency, and wave amplitude) of the extreme load cases.

3.  Run the time-domain MAESTRO-Wave with the specified speed, heading, wave

frequency, and wave amplitude combination.

4.  Use the time-domain results to determine the worst-case wave phase.

5.  Create a design-wave at this worst-case phase, which includes the non-linear
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Froude-Krylov affects.

The sections below describe the details of the MAESTRO-Wave computation technology
being developed by Dr. Chengbi Zhao (South China University of Technology) and DRS Training
& Control Systems, LLC, Advanced Marine Technology Center (DRS AMTC).  These sections
include theoretical background to MAESTRO-Wave, as well as its application and use within
the MAESTRO system.  The last section provides validation material, which compares with
results from industry recognized numerical tools and experimental results.

Table of Contents

Theory Manual

User Manual

Validation

12.1 Theory Manual

MAESTRO-Wave Theoretical Background

Introduction

Linear Boundary Value Problem

Double Body Potential

Unsteady Potential

Unsteady Pressure, Force, and Moment

Unsteady Pressure

Added Mass and Damping Coefficients

Restoring Force and Moment Coefficient

Exciting Force and Moment

Motion in Regular Waves

Wave Induced Shear Force and Bending Moment

Roll Damping
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Introduction

This section describes the theoretical background of the computer program

MAESTRO-WAVE.  It provides an overview of the theories and the computational

methodologies in a concise manner.  The use of MAESTRO-Wave and its capabilities are

described in the MAESTRO-Wave User Manual section.

MAESTRO-Wave is a panel program designed to solve the boundary-value problem for the

interaction of water-waves with bodies in finite- and infinite-water depth. Viscous effects of

the fluid are ignored and thus the flow field is potential without circulation. A perturbation

series solution of the nonlinear boundary value problem is postulated with the assumption

that the wave amplitude is small compared to the wave length. It is also assumed that the

body stays at its mean position and any oscillatory amplitude of the body motion is of the

same order as the wave amplitude. The time harmonic solutions corresponding to the

first-terms of the series expansion are solved for a given steady-state incident wave field.

The incident wave field is assumed to be represented by a superposition of the fundamental

first-order solutions of particular frequency components in the absence of the body. The

boundary value problem is recast into integral equations using the wave source potential as

a Green function. The integral equation is then solved by a panel method for the unknown

velocity potential and/or the source strength on the body surface. Using the latter, the fluid

velocity on the body surface is evaluated.

For incident waves of specific frequencies and wave headings, the linear problem is solved

first. The following sections describe the problem setup and the procedure for finding a

solution, followed by a discussion on the rigid body motions.  The expressions for

hydrodynamic forces are also derived, including hydrodynamic coefficient definitions.

Since the focus is primarily on hydrodynamic interactions, it is appropriate to mention any

restrictions on or assumptions about the bodies which may be analyzed using

MAESTRO-Wave. The bodies are assumed to be neutrally buoyant, and they may be

submerged or surface piercing. An extremely thin submerged body may be difficult to

analyze when the thickness between the two facing surfaces is small compared to the other

dimensions of the body may render the integral equation ill-conditioned. However, a thin

body floating on the free surface (in other words the draft is very small) is not included in

this category, since only one side of the body would be adjacent to the fluid domain.  Other

than these panel considerations, the standard constraints for potential flow theory apply.
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Linear Boundary Value Problem

A ship with forward speed U in deep water is considered. The right-handed Cartesian
coordinate system O-xyz is adopted. The origin of the system is located at the intersection
of the center-plane and the mid-ship section of the undisturbed free surface, with x-axis
pointing forward, z-axis vertically upward and y-axis to port side, see Figure 1.  This is a
ship-fixed system and the ship is free to sink and trim.

Figure 1. MAESTRO Wave Coordinate System

The unsteady six degree-of-freedom ship motions are described using the standard

seakeeping notation, including three translations (surge, sway, and heave) and three

rotations (roll, pitch, and yaw) about the x-, y-, and z-axes, respectively.  The rotations are

given by Euler angles.  The incoming wave system is defined later.

The total velocity potential in the fluid domain can be expressed as

fy +F=                          (3.1)

where y is the total potential, F   is the double body potential with advanced speed U , and

f  is the unsteady potential.

Double Body Potential

The double body potential F can be expressed as

                            j+-=F Ux                        (3.2)

where the advance speed U introduces a steady basis flow, and j  is the disturbance

potential due to body in the steady flow.  The double body potential is subject to the

following:

0][ 2 =FÑL (3.3)
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denotes the unit normal vector of body surface, pointing into the

body.

The expressions above can be rewritten in terms of the disturbance potential j , which is

represented as the potential of a source density distribution over the body surface S . The

potential at a point ),,( zyxp  in space due to a unit point source located at a point

),,( dhxq  on the body surface is ),(/1 qpr ,where ),( qpr  is the distance between points

p  and q . The point ),,(1 dhx -q  is the symmetry point of point q  for waterplane, and

),( 11 qpr  is the distance between points p  and 1q . Accordingly, the potential at p  due to

a source density distribution )(qs  on the body surface is
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),( qpG is the double body Green function
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According to the boundary of body surface, the integral equation for source density s  can

be obtained by
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Once this equation is solved for s , the potential at any point can be obtained by equation

(3.4). The velocity components at any point of the flow are obtained by equation (3.9).
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Unsteady Potential

According to linear potential theory, and using the classical convention of notation, the

unsteady potential f of a floating body is a superposition of the potentials due to the

undisturbed incoming wave f0, the potential due to the diffraction of the undisturbed

incoming wave on the fixed body f7 and the radiation potentials due to the six body

motions 
6,5,4,3,2,1, =iif

 (or surge, sway, heave, roll, pitch, yaw),

å
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In regular waves a linear potential f , which is a function of the earth-fixed coordinates and

of time t, can be written as a product of a space-dependent term and a harmonic

time-dependent terms, as follows:
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Where 0j
 is the unit incident wave potential, 7j

 is the unit diffraction potential,

6,5,4,3,2,1, =iij
 are the unit radiation potentials, and A is the amplitude of the incident

wave. The incident wave frequency is given by 0w
, and w  is the frequency of encounter,

which are related by the ship’s speed and relative heading to the incident wave direction b ,

and wave number k , defined as follows
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The wave direction angle b  is 180=b  for head seas, 135=b  for bow quartering seas,

90=b  for beam seas, 45=b  for stern quartering seas, and 0=b  for the following seas.
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Incident Wave Potential

The incident wave, known a priori, is defined using the expression for infinite deep water
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The velocity of the incident wave at any point is
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Radiation Potential

Each radiation component 
)6,5,4,3,2,1(, =iij

 is subject to the following boundary

conditions
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The source density on body surface for radiation potential can be obtained by
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The Green function is
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And 0J
 is the Bessel function of the first kind, 0Y

 is the Bessel function of the second kind, 0H
 is

the Struve function.  The integral term in (3.29) can be calculated by a self-adaptive

trapezoidal integral. 

Once equation (3.27) is solved for
6,5,4,3,2,1=iis

, the radiation potential and velocity

components at any point are obtained by
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Diffraction Potential

The diffraction potential 7j
  is subject to the boundary conditions

0][ 7
2 =Ñ jL               (3.32)

0
)(

][ 07 =
¶

+¶

n
B

jj

          (3.33)

0][ 7 =
¶

¶

n
Bot

j

              (3.34)

And the source density on body surface for diffraction potential can be obtained by
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The Green function of (3.28) is adopted in here to solve the boundary value problem. 

Similarly as was done for radiation, once equation (3.35) is solved for 7s
, the diffraction

potential and velocity components at any point are obtained by
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Unsteady Pressure, Force, and Moment

Unsteady Pressure

The pressure of body surface on wave can be calculated by Bernoulli’s equation.
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The steady part of the pressure field can be extracted from above formula.
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The unsteady part is
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and 
},,{ 321 xxxx =

r

 is the response amplitude operator (RAO) of the surge, sway

and heave.

},,{ 654 xxx=W
v

 is the response amplitude operator (RAO) of the roll, pitch and
yaw.

Added Mass and Damping Coefficients

The added mass and damping coefficient are associated with the first term in the right hand

side of (4.4) and depend on both the forward speed and the frequency of oscillation.

The add mass coefficient is
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The damping coefficient is
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Restoring Force and Moment Coefficient

The restoring coefficient is associated with the second term in the right hand side of (4.4) and

depends on both the forward speed and they are associated with gradient of the

hydrostatic pressure and of the steady dynamic pressure field.  The restoring coefficient is
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Exciting Force and Moment

The Exciting force is due to the incident and diffracted wave potential. In view of the

first term in the right hand side of (4.4), the exciting force can be expressed as follows
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Motion in Regular Waves
The unsteady component of the pressure is examined under the assumptions of small

monochromatic motions at a single frequency. The unsteady force and moment on the body due to

the oscillatory motion are expressed as follows
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And the components of unsteady force is 
),,( 321 FFFF =

 while the components of unsteady

moment is 
),,( 654 FFFM =

.

The equations of motion that govern the steady-state time-harmonic response of the body follow

from the application of Newton’s second law. Using the definitions (5.1) of the resultant force, the

response amplitude operator RAO can be determined by the linear equation system.
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Where jx
 is RAO,
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 is the mass matrix.  Newman (1977) gives a general

expression for the mass matrix, as follows
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 can be obtained by solved the complex coefficient linear

equation group (5.2).

Wave Induced Shear Force and Bending Moment

The wave induced shear force and bending moment are defined as Figure 2:

Figure 2. Definition of Shear Force and Bending Moment

The Wave Induced SF and BM Shear Force in Wave is:
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MAESTRO-Wave can account for the effects of viscous roll damping in addition to the

potential flow damping during the analysis.  The damping is defined as:

B44(w) + B44,v (6.1)

where B44,v is the viscous damping calculated using the user-defined critical damping ratio,

k:

k=(B44(wn)+B44,v)/(B44,critical) (6.2)

 The critical damping is defined as:

B44,critical = 2.0*sqrt(C44*(A44(wn)+I44)) (6.3)

Assuming that B44(wn) is small compared to B44,v the resulting damping force can be found

by:

B44(w) + k*B44,critical(w) (6.4)

12.2 User Manual

This section is intended to provide a general introduction and how-to guide for the MAESTRO-Wave interface.  This tool is completely integrated into MAESTRO and will use the existing structural mesh for the seakeeping calculations.

Model Requirements

General Tab
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Frequency-Domain Input

Time-Domain Input

Mesh Tab

Roll Damping Tab

Results

Model Requirements

The model requirements in order to run the MAESTRO-Wave analysis are:

- The full model must be modeled (half models must be mirrored)

- The loading condition (i.e., mass distribution) must be defined in a MAESTRO load case

- The forward direction must be in the +X direction for non-zero speed runs

- "Wettable" elements must be defined in the model and an immersion definition must exist
in the MAESTRO load case

MAESTRO-Wave can be launched from the Wave menu.

The MAESTRO-Wave dialog is split into 4 tabs, each of which will be discussed below.  The
first step is to create a new "Sea Load".  The "Sea Load" is a unique load case used by
MAESTRO-Wave, which is derived from a "Base Load" (i.e. MAESTRO load case).  Similar to
the loads dialog, the "Sea Load" can be created or modified using the "Create/Modify"
button or deleted using the "Delete" button.  Once the "Sea Load" case(s) is created, the
"Compute" button will run the MAESTRO-Wave calculations.  It is recommended to click the
"Create/Modify" button after making changes on each tab to ensure the chosen options are
saved.  Once a "Sea Load" is created, it is saved with the model, similar to a MAESTRO load
case.

General Tab
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The "Analysis Setup" section allows the user to select whether to run the analysis as a frequency
domain or time domain analysis.

The "Job Type" section provides the user with three options of what output to produce:

Motion & FEA Panel Pressures: Computes the motion and loads RAOs while saving FEA panel
pressure data with minor point force corrections (e.g., for later use in buckling checks)

Motion & FEA Nodal Forces: Generates the motion and loads RAOs while saving FEA nodal force
data (e.g., for later use in fatigue analysis)

Motion only: Not yet implemented.

The "Results File" section allows the user to save the MAESTRO-Wave data in either binary or
ASCII format.  The binary format results in a smaller, faster loading file that is accessed as needed
when post-processing MAESTRO-Wave data.  The ASCII format results will be entirely loaded into
memory when imported, but the *.smn files can be edited by the user.  It is recommended to use
the binary format unless there is a specific need to access the ASCII version of the results.

The "Liquid Tanks" section provides the user with three options of how to handle the liquid
tank loads in the model:

Smear tank mass to tank skins: This option will calculate the mass of the tanks for the base
loading condition and smear it to the tank boundary shell elements.
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Frozen: This option will use the same method as the Sloshing option but assume that the
tanks are full so no free surface effects are included.

Sloshing: This option will solve the tank boundary value problem separately and add the
loads to the equation of motion.

The "Summary" section lists the current settings from all tabs for the current Sea Load.

Frequency-Domain Input

The frequency domain input tab defines the conditions to be run during the analysis for the
specific "Sea Load" case.  The values for speed, heading and wave period can be entered as
a comma separated list or an an ellipse.  For example, "0,5,...,25" in the speed entry would
be interpreted as 0, 5, 10, 15, 20, 25.  The units for speed and heading are in knots and
degrees, respectively and the wave period can be entered in one of three ways: wave
period in seconds, wave frequency in radians per second or the ratio of wave length over
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length overall of the vessel.  Clicking the radio button next to the input option desired will
allow the input to be changed.  A summary of the conditions for the selected "Sea Load"
case are displayed at the bottom of the page.  The total number of conditions that will be
run is equal to:

# conditions = # speeds x # headings x # wave periods

Time-Domain Input

Linear: The velocity potential and Froude-Krylov forces are evaluated on the hull mean
wetted surface.

F-K nonlinear: The velocity potential is evaluated on the hull mean wetted surface and the
Froude-Krylov forces are evaluated on the instantaneous hull wetted surface up to the
incident wave.

Body nonlinear: The velocity potential and the Froude-Krylov forces are evaluated on the
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instantaneous hull wetted surface up to the incident wave.

F-K nonlinear (with Hydrostatics): The velocity potential is evaluated on the hull mean
wetted surface and the Froude-Krylov forces are evaluated on the instantaneous hull
wetted surface up to the incident wave and combined with linear hydrostatic forces.

The time domain input tab allows the user to specify one condition to run.

The user specifies the speed, heading, and sea condition for the run.  The sea condition is
defined by a regular wave with a wave height and wave period, or by a wave spectrum
defined by a significant wave height and peak period.

The output section allows the user to specify the length, time step, and output interval for
the simulation run as well as whether to calculate the motion only or the motion and the
loads.

Mesh Tab
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The Mesh tab allows the user to select how the wetted surface is discretized for the
analysis.

Original Element:  This option will use the MAESTRO element mesh in the analysis.  This is a
higher fidelity analysis, but can be slow.  It is recommended to use this option when the
number of wetted panels is less than 3,000.

Patch Element:  This option will use the MAESTRO evaluation patch elements in the analysis
and will be faster than the "Original Element" option.  Source strengths will be computed
based on the evaluation patches and mapped to the FEA elements.  An additional input
section will appear where the user can select how the velocity potentials (and associated
pressures due to radiation and diffraction) will be evaluated:

Fine Mesh: Each FEA element will have its own velocity potential computed.

Coarse Mesh: All FEA elements within the patch will use the same value for velocity
potential.
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Regardless of which Potential Evaluation method is chosen, the hydrostatic and
Froude-Krylov pressures will be computed for each FEA element individually.

Sectional Element:  This option will open additional input sections in the dialog allowing the
user to select how the velocity potentials will be evaluated and to specify the section
locations to be used in the calculation.  The velocity potential evaluation options are the
same as described in the Patch Element section above, but in this case, the MAESTRO
evaluation patch elements are replaced by internally created patches that span between
each defined section.  The width of the patches is dependant on the number of points used
internally to define each section.  The section locations are defined by the user input Start
and End locations and the number of sections to be cut in between them.
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The Start and End locations should be located so as to cut sections so that the 2D section
cut is a single curve (e.g., do not make a section cut in a bulbous bow where there would be
two curves defining the section).  The example below shows where to cut the bow of the
model (red line) and where not to cut the model (blue line).  For the stern cut, this example
shows a recommended location to start the sections because if the spacing is wide, the
interpolation of the section area between cuts could result in unwanted area.  The start
location should be at the aft end of the ship.



MAESTRO-Wave (Hydrodynamic Loads) 483

© 2014 Optimum Structural Design, Inc.

The four strip theory methods also require the same section input described above and also
allow the user to specify whether the vessel is a monohull or catamaran.

Strip Theory (2D Pressure):  This option uses a zero-speed Green's Function strip theory
approach and will compute the resulting pressures on the elements for use in
post-processing evaluations.

Strip Theory (2.5D, high speed, Pressure):  This option uses a Rankine Source method with
a forward speed correction term in the free surface computation.  This method is
recommended when running cases with a Froude number greater than 0.4.  This option
includes the panel pressure calculations.

Strip Theory (2D Section):  This option uses a  zero-speed Green's Function strip theory
approach, but does not compute the element pressure information.  It is faster than the 2D
Pressure method, but only the hull girder and motion RAOs will be available for review and
post-processing.  (i.e., the user can post process the hull girder RAOs to select a design
waves, but would not be able to create the resulting load cases without the pressure
information.)

Strip Theory (2.5D, high speed, Section): This option uses a Rankine Source method with a
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forward speed correction term in the free surface computation.  This method is
recommended when running cases with a Froude number greater than 0.4.  It is faster than
the 2.5D Pressure method, but only the hull girder and motion RAOs will be available for
review and post-processing.  (i.e., the user can post process the hull girder RAOs to select a
design waves, but would not be able to create the resulting load cases without the pressure
information.)

Universal RAO: This method uses algorithms to generate RAOs for various vessel types
based on the length, beam and draft entered by the user.

Roll Damping Tab
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The Roll Damping tab allows for roll damping effects to be accounted for in the analysis. 
Depending on the method that is chosen, additional inputs are required to define the
method.

B44(w) + k*B44,critical(w): This method accounts for the potential flow and viscous damping

effects.  The critical roll damping ratio, k, is the ratio of the actual (potential plus viscous)
damping to the critical damping and the critical damping is defined as:

B44,critical= 2.0*sqrt(C44*(A44(wn)+I44))

(k1+k2*Ang+k3*Ang)*(B44,critical(w)): This method allows the user to specify constants k1, k2,

and k3 to apply a second order, roll amplitude dependent scale factor on the critical
damping term.

Barr Method: This method calculates the roll damping based on the bilge keel definition,
ship characteristics, and forward speed:

4 44 44 4 )(2 CmMBCR +=
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Results

Once the MAESTRO-Wave analysis has been run, a dialog will open asking to import the
results.  Click "Yes" to have the Frequency Load Database automatically populated with the
results.
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Once the results are imported, the hydrodynamic pressures can be viewed graphically by
opening the Frequency Load Database dialog from the Wave > Regular Wave Database
menu option.

This dialog allows you to select the base load that was run and the speed, heading and wave
period condition of interest.  The first tab provides the list of elements and their calculated
pressures.  Right-clicking in this dialog allows the calculated pressures or stresses to be
plotted on the model elements.  

The Point Force tab provides the resultant nodal forces at each of the FE nodes in the
model.  The Acceleration and Displacement tabs provide the displacement and acceleration
RAOs for the selected load case and condition.  Right clicking in the dialog will output the
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accelerations, velocities, or displacements for all frequencies run at the selected speed and
heading to the Output tab.  These results can be viewed in MAESTRO (Viewing RAOs and
Statistics) or easily exported to a spreadsheet tool such as Microsoft Excel to plot the RAOs. 

12.3 Validation

The  S-175  container  ship  is  well  known  because  it  was  used  by  the  ITTC  (2010)  to  carry  out  a

comparative  numerical  study  of  linear  wave-induced  motions  and  structural  loads.  The  database

that  resulted  from  that  study  includes  numerical  results  from  many  institutions,  and  also  some

experimental data. Table 1 lists the main particulars of this ship.

Length between perpendiculars 175 m

Breadth 25.4 m

Depth 15.4 m

Draught 9.5 m

Displacement 24742 ton

LCG aft of midship 2.5 m

Block coefficient 0.572

Midship section coefficient 0.98

Total mass 23972251 kg
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XG(from AP) 84.97 m

YG(from centerline) 0 m

Rxx 9.652

Ryy 42.07

Rzz 43.17

Table 1: Main particulars of the S175 container ship

Three  hydrodynamic  analyses  were  conducted  for  this  comparison.  For  the  first  analysis,  which  is

labeled as “MAESTRO-Wave” in the results figures, the hydrodynamic mesh is the same as the finite

element mesh, as shown in Figure 1(a). For the second analysis, labeled as “MAESTRO-Wave (Coarse

Mesh),” the hydrodynamic mesh is  coarser than the finite element mesh,  as  shown in Figure  1(b).

The first two models were analyzed using MAESTRO-Wave. The third model, as shown in Figure 1(c),

was analyzed using PRECAL6.6 (2010). 

Fig. 1(a) MAESTRO-Wave Seakeeping model

Fig. 1(b) MAESTRO-Wave (Coarse Mesh) Seakeeping model 



MAESTRO 11.0.0490

© 2014 Optimum Structural Design, Inc.

Fig. 1(c) PRECAL Seakeeping model 

The ship is advancing with constant speed v=22.145 knots with 4 different headings, b=0°, b=90°, b

=120°  and  b=180°.  All  results  are  presented  in  a  non-dimensional  way  using  wave  amplitude  (A),

wave  number  (k),  encounter  frequency  (w),  water  density  (r),  gravitational  acceleration  (g),  ship

beam(B) and ship length between perpendiculars (Lpp) as given in Table 2:

Translational motions (heave, sway and surge)

Rotational motions (roll, pitch and yaw)

Bending moments

Shear forces

Table 2: Non-dimensional parameter definition

The motion and load RAO results, along with the available experimental data from ITTC, are shown
below in Figures 2 to 6.
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Fig. 2 Motion RAO (b=120° , Fr=0.275)
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Fig.3 Motion RAO (b=180° , Fr=0.275)
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Fig. 4 Motion RAO (b=0° , Fr=0.275)
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Fig. 5 Motion RAO (b=90° , Fr=0.275)
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b=180° b=0°

Fig. 6 Vertical bending moment RAO (Fr=0.275)
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13 Extreme Load Analysis

The Extreme Load Analysis (ELA) module imports unit wave load data from a hydrodynamic
analysis (MAESTRO-Wave or other) via *.smn file format. It then allows the user to calculate
hull girder load response RAOs, and provides the necessary short-term and long-term
statistical computations to predict extreme values of the maximum loads for a given vessel. 
This includes the ability to define or import wave scatter diagrams, operational profiles, and
wave spectra as well as compute hull girder RAOs for user-defined dominant load
parameters (e.g., vertical bending moment).  Finally, extreme equivalent regular waves
(equivalent design waves) are internally computed and selected for assessment of extreme
global loads.  The user has a variety of options to add still water loads to the wave-induced
wave loads and re-balance these components.

Table of Contents

Introduction

Procedure Using MAESTRO

Structural Model and Loads

Export Mass Distribution and Wetted Elements

3rd Party Hydrodynamic Analysis

Compute RAOs in MAESTRO

Viewing RAOs and Statistics

Calculate Design Wave

Structural Response Analysis and Assessment

Validation

13.1 Introduction

The structural design portion of many classification society’s guides and rules are intended
to provide the basis for a preliminary step-by-step design of a hull structure.  Often however,
due to the novel nature of a design or additional class notation requirements set by the
owner, it is the task of the designer to conduct a direct structural analysis.  Central to this
direct analysis, is the use of a computational tool based on linear seakeeping theory for
calculating the load and motion parameters that best characterize the extreme ship
response behavior for critical loading conditions (e.g., Full Load).  Once these extreme ship
responses are identified, the structural integrity (i.e., global and local structure) of the vessel
can be assessed. 
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13.2 Procedure Using MAESTRO

As shown in the figure below, MAESTRO can be leveraged to execute a direct analysis
process where both the global and local design is assessed for structural adequacy.  The
following steps outline the primary steps in the process:

1. Generate MAESTRO Global Model (Structure and Base Loading Conditions)

Option 1:

2. Run MAESTRO-Wave

Option 2:

2a. Export MAESTRO Mass Distribution and Wetted Elements Data (See the Exporting
Models and Data section)

2b. Generate Hydrodynamic Model and Perform Hydrodynamic Analysis in 3rd party tool

2c. Apply Hydrodynamic Loads to MAESTRO Model (Ship Motions File *.smn)

2d. Compute RAOs in MAESTRO (inertia relief)

3. View RAOs 

4. Calculate Equivalent Extreme Design Wave (Wave Spectra, Wave Scatter Diagram,
Operating Profiles)

5. Combine Hydrostatic and Hydrodynamic Loads into New Load Cases

6. Perform Structural Response Analysis (Global and Local)

7. Assess Structural Adequacy (Global and Local)
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13.3 Structural Model and Loads

To meet the analysis needs and avoid inaccuracies and uncertainties, it is important that the
MAESTRO model is sufficiently comprehensive.  This means that the overall model should
encompass all hull structure and ideally superstructure (i.e. when the superstructure
participates in the global response).  Further, there must be sufficient compatibility (e.g.
mesh size, mass distribution, CGs, etc.) between the hydrodynamic and structural model so
that the mapping of computed hydrodynamic pressures onto the MAESTRO model can be
done appropriately.

The results of the Global Design Analysis are to be used to identify hot spots so that Local
Design Analysis (i.e. mesh refinement) can be undertaken.

All of the static loading components necessary to accurately develop vessel loading
conditions (i.e. Base Loading Conditions) can be created using MAESTRO.  These loading
components include, but are not limited to: lightship distribution (Scaled Modules,
Self-Weight, Mass Distribution), tank loads, hydrostatic loads, and concentrated mass.  See
Loading the Model for complete details.  These load components are typically combined in a
MAESTRO load case and represent a base load case (e.g. Full Load, Minimum Operations,
and Arrival).  The figure below shows an example of MAESTRO’s tank and hydrostatic
loading.
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13.4 Export Mass Distribution and Wetted Elements

The next major step in this type of direct analysis is to conduct a seakeeping analysis to
determine the motions and loads resulting from operations of the vessel.  

If using MAESTRO-Wave to perform the seakeeping analysis, go here first and then jump to
the Viewing RAOs section, otherwise follow the steps below:

After computing the motions and loads, it will be the task of the analyst to appropriately map
these loads to the MAESTRO model.  To facilitate both of these steps, MAESTRO provides
the ability to export key data: overall mass distribution and Wetted Element definition or hull
geometry.

The following section is organized as follows:

Export MAESTRO Mass Distribution for VERES or PRECAL

Export MAESTRO Wetted Elements and Mass Distribution

[****]

Export MAESTRO Mass Distribution and Geometry for VERES and PRECAL

For a particular base load case, MAESTRO provides the ability to export geometry and
mass distribution files specifically intended to be consumed by the seakeeping analysis tool 
VERES (VEssel RESponse program), which is developed by MARINTEK, and the 3D
Hydrodynamic PREssure CALculation Program PRECAL, which is developed by MARIN.

In addition to the mass distribution and geometry, MAESTRO also has the ability to compute
the radii of gyration about a location, which can be used as additional input and/or
comparison to the seakeeping tool of choice.

Export MAESTRO Wetted Elements and Mass Distribution

MAESTRO offers the ability to export particular information of all wetted elements, tank
elements, and nodal mass in the FE model.  This is accomplished by exporting a Wetted
Surface file (*.wet).

To export the Wetted Surface file, click File > Export > Wetted Surface, which will allow the
user to name and specify the location of the file.  A sample Wetted Surface file is located in
the Models and Samples/Extreme Load Analysis directory and is called 
S175-ITTC-2010-nd-mass-933.wet.

http://www.sintef.no/Home/MARINTEK/Software-developed-at-MARINTEK/VERES/
http://www.marin.nl/web/Facilities-Tools/Software/Manoeuvring-Seakeeping-and-Nautical-Software.htm
http://www.marin.nl/web/Facilities-Tools/Software/Manoeuvring-Seakeeping-and-Nautical-Software.htm
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The exported file includes the following information associated with the model and elements:

· Model units (See Line 2 in the figure below)

· Nodes of Wetted Elements: Number of Nodes, FeTag, Node XYZ location, Location of
Part in MAESTRO model (See Lines 1-10 in the figure below)

· Wetted Elements: Number of Elements, FeTag (“-“ sign indicates pressure side opposite
of normal), Element Node IDs, Center of Gravity Location, Normal Vector (normalized),
Location of Part in MAESTRO model (See Lines 682-687 in the figure below)

· Tank Elements: 

o Tank (Volume Group) ID and Name (See Line 1330 in the figure below)

o Element FeTag, Element Node IDs, Center of Gravity Location, Normal Vector
(normalized), Location of Part in MAESTRO model (See Lines 1331-1333 in the figure
below)

· All Nodes: Number of Nodes, FeTag Node XYZ location, Location of Part in MAESTRO
model (See Lines 2137-2142 in the figure below)
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· Equivalent Nodal Mass (each load case): Load Case ID and Name, FeTag, Mass Value
(See Lines 14786-14793 in the figure below)

13.5 3rd Party Hydrodynamic Analysis

At this point in the direct analysis process, seakeeping analysis tools can be utilized to
predict ship motions and wave induced loads. 

This analysis will incorporate the vessels: Base Loading Conditions, Operational Profile,
Environmental Conditions, and Hull Geometry (including appendages), some of which can
be extracted from the MAESTRO Global model, as described in previous sections.  

Typically this computation is executed using a spectral-based approach and relies on
Response Amplitude Operators (RAOs).  RAOs are calculated for regular waves of unit
amplitude for a range of wave frequencies and wave headings, typically set forth by Class
guidance.  
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The seakeeping analysis tool can also be used to identify Most Probable Extreme Values
(MPEVs) for global load parameters of interest (i.e. Vertical Bending Moment, Shear Force,
etc) as well an equivalent design wave (EDW).  The EDW is a sinusoidal wave characterized
by its: amplitude, length (or frequency), heading, and phase angle.  This EDW simulates the
magnitude and location of the extreme value of the global load parameter of interest. 
Ultimately, the external hydrodynamic pressures, computed by the seakeeping analysis tool,
should be extracted.

13.6 Compute RAOs in MAESTRO

Once a Ship Motions File (*.smn or *.bmn) is loaded into MAESTRO, the hull girder load and
stress/displacement RAOs can be calculated and the model can be rebalanced, if desired. 
From the Wave menu, select the "Compute RAOs" option:

If MAESTRO-Wave was used to create the Ship Motions File (*.smn or *.bmn), the RAOs
have already been calculated, with the exception of the Stress RAOs.  It is recommended
that the model be re-balanced using the "Sectional Loads" option when importing loads from
a 3rd party hydrodynamics code.  The stress RAO is only needed for the Spectral Fatigue
Analysis.  Click OK to run the RAO calculation.  A dialog will display when the calculations
are complete.

13.7 Viewing RAOs and Statistics

Once a Ship Motions File is imported from a 3rd party analysis or from MAESTRO-Wave and RAOs
have been calculated, they can be viewed graphically in the MAESTRO GUI.  Select Wave > View

RAOs/Statistics/Time series from the menu:
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Listed on the left-hand side of the dialog, are the speeds and headings available for display.
One speed and one heading should be selected at a time.  The options along the top allow
the selection of the type of study, response, RAO type, and which section or sections to plot.
 The available Study types are: Hull Girder Load, Motion, Stress, Deflection, Stress
Spectrum and MSI.  The default Section is "ALL" which will plot all sections, or a specific
section can be selected from the drop-down.  Choosing a specific section allows the user to
export the RAO from that specific section versus the maximum value.  The check boxes for
"Computed" and "Imported" allow the user to plot either the computed (i.e. Wave > Compute
RAOs) RAO or the imported (MAESTRO-Wave or 3rd party results) RAO, or both.

Clicking "Plot/Clear" will plot the RAO next to the MAESTRO model, populate the Output
window with a list of computed values or some combination of both depending on what is
being queried.
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Using the dynamic query, you can select the node at the maximum value and recover the
location, condition and maximum value.

Right-clicking the queried node allows the associated RAO curve or all the RAOs currently
displayed at the selected section to be output and plotted in Microsoft Excel.
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To recover the RAO at a specific section, use the section drop-down in the RAO dialog to
select the desired location.

The Short Term Statistics tab allows the user to compute the extreme values using short
term statistics and display the results in the Output tab.  The short term statistics
calculations default to a 3 hour exposure.
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The statistical values that can be presented are: Significant Values, Standard Deviation
(RMS), Expected Maximum, or Average 1/n'th Largest Value (most of which can be set to
display single or double amplitude).  Where applicable, additional inputs will be displayed (i.
e., exposure duration for Expected Maximum and 'n' for the 1/n'th Largest).  The Wave
Spectrum can be selected as Bretschneider, JONSWAP, NorthAtlantic2, OCHI,
PiersonMoskowitz or any other spectrum that has been added by the user through the Wave
Spectrum dialog.  The Wave Spreading is currently limited to Long-crested seas.  If using an
analytical spectrum, the spectrum parameters are user-defined by a significant wave height
(s) and period range (defined in seconds).  Selecting the "Combination of Hs and Tz" allows
for multiple combinations of significant wave heights and periods.  A summary of the current
height/period pairs is shown in the table in the lower right.  Pairs can also be added by right-
clicking and selecting "Add" from within the table.  If a user defined spectrum is chosen,
spectrum parameters do not apply and are hidden.

The Long Term Statistics tab allows the user to compute the extreme values using long term
statistics.

The Wave Scatter Diagram and Operating Profile will be discussed in the next section.
Similar to the short term statistics output, the long term hull girder responses are listed in the
Output tab.

13.8 Calculate Design Wave

It should be noted that the imported hydrodynamic loads are unit wave generated
responses, therefore, an equivalent design wave must be defined to simulate the magnitude
and location of the extreme loading condition.  In MAESTRO, the equivalent design waves
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are automatically calculated for the long and short term analysis.  

Before we can calculate the design waves using long term statistics, we first need to define
a wave scatter diagram and operating profile.  MAESTRO is able to import Wave Scatter (*.
sea) and Operating Profile (*.opf) files.  User-defined Wave Scatter diagrams can be
imported from the File menu.  To view an imported Wave Scatter diagram, select Wave >
Wave Scatter Diagrams from the menu.  There is also a Library button that allows the user
to select one of four pre-defined wave probabilities.  The Library wave probabilities only
expose the wave height probability to the user; associated wave period probabilities and/or
spectral shapes are derived from the wave height and are computed internally in a similar
fashion to how they are implemented in the Navy's SPECTRA program.

A list of the available wave scatter diagrams are shown in the drop-down at the top of the
dialog.  The values within the diagram can be edited as well as how the wave period is
defined.  If changes are made, the user must click "Modify" to save the changes.

The Operating Profile can be imported from the File menu, or created by the user.  To
create or view an existing profile, select Wave > Base Operational Profiles from the menu.
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To create a new profile, click the "New" button to open the Create Operating Profile dialog. 
Here, the user can enter a name for the profile at the top of the form.  The significant wave
height probabilities are defined by the selected wave scatter diagram.  The probabilities of
each speed/wave or heading/wave cells can be input by the user.  The sum of the speed/
wave and heading/wave probabilities must each equal 1.0.  To save the operating profile,
the user must click the "Create" button to update the values, save the profile and close the
dialog.
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Once back in the Base Operating Profile dialog, the profile probabilities can be modified by
making changes in the table and clicking the "Modify" button.  Unneeded profiles can be
deleted using the "Delete" button and the user can click the "Preview" button to view the joint
probabilities defined for the operating profile.  The Operating Profile Preview dialog allows
the user to select any available Operating Profile, Wave Scatter Diagram and Sea Load. 
The joint probabilities can be displayed with or without the probabilities of the seaway
included so the user can evaluate how the operational profile is combined with the speeds
and headings used to define the Sea Load.
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To calculate the design waves, select Wave >  Compute Design Wave from the menu.
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Similar to the View RAO dialog, the available speeds and headings from the database are
shown on the left which can be used to control which speeds and headings are included in
the evaluation.  Unlike the View RAO dialog, however, this tree also includes a list of wave
periods below the headings which can be used to control which wave periods are allowed to
be used when creating the equivalent design wave.  The base MAESTRO load case can be
selected from the load case drop-down.  The design load parameter (DLP) can be selected
from the drop-down list and includes:

This DLP value can be computed using the imported hull girder loads from the *.smn file or
the ones computed within MAESTRO and can be computed for all stations, or a user-
specified one.  The user specifies how many of the largest design waves to compute for the
selected DLP and whether or not to include hydrostatics, either from still water or a sine
wave.  The risk factor is is effectively a scaling factor for the selected exposure time
(Exposure time / Risk Factor = extreme value exposure time).  The Risk Factor is
implemented as described by OCHI's book, Ocean Waves, and can be left at 1 for normal
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use.

The wave scatter diagram, operating profile and wave spectrum can be selected from those
available in the drop-down lists.  The extreme value(s), using long term statistics can be
calculated either by finding a value with a given probability of exceedance or defining the
return period (in years), which finds the most probable extreme value expected to occur in
the given time period.

The short term statistics design waves are calculated in a similar fashion to the long term,
but using a user-defined exposure time and significant wave height/wave period pairs
describing the short term design sea state(s).  (If a user defined spectrum is chosen,
spectrum parameters do not apply and are hidden.)  The full exposure time for each defined
seaway is given to each combination from the selected speeds and headings.

To calculate a design wave or waves, click "Add". 

Once calculated, the design waves table at the bottom of the dialog will display the list of
design waves created.  
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These can be added as new MAESTRO load cases by clicking the "OK" button.  When
applicable, a dialog will display allowing the user to create a second load case for each DLP
with a 180 degree phase shift for the wave.  For example, the vertical bending moment DLP
would include a hogging and sagging case.

In the end, MAESTRO has added the loading components from the Base Load Case
together with the hydrodynamic loading components defined in the Extreme Load dialog. 
These new load cases can be seen in the MAESTRO load case dialog.
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In addition to having MAESTRO automatically find the largest design waves for each DLP,
the user can specify their own design wave condition by selecting Wave > Define Design
Wave from the menu.
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This dialog allows the user to select the specific case (base load, speed, heading and wave
period) and recover the design wave.  The user can also specify a wave phase angle, wave
scale factor and whether to include hydrostatics.  Clicking "Add" will create this new design
wave and clicking "OK" will create a new MAESTRO load case.
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13.9 Structural Response Analysis and Assessment

After equilibrium has been achieved, the analyst can perform structural response analysis
and assessment.

MAESTRO has the ability to perform comprehensive structural assessment for floating
structures.  This includes performing response analysis (i.e., deformation and stress
analysis) and limit state buckling analysis.  The limit state buckling analysis includes hull
girder collapse analysis, stiffened panel buckling analysis, and local member buckling
analysis.

Review the following sections for details of MAESTRO structural assessment capabilities:

Finite Element Analysis

Limit State Buckling Analysis

Fine Mesh Analysis

13.10 Validation

Short Term Statistics Validation

To  validate  the  implementation  of  MAESTRO’s  short  term  statistics,  the   S175  model  from  the

MAESTRO-Wave  validation  was  used.  The  hull  girder  load  RAOs  computed  by  VERES  were  first

imported into MAESTRO, and then the short  term statistics of vertical  bending moment and shear

force at x=-0.831m were calculated using MAESTRO. The comparison between MAESTRO and VERES

are shown in the figures below. The procedure for obtaining the result and the raw data is provided

in this section below.
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Figure 1. RMS comparison (VBM and VSF)
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Figure 2. Expected maximum value (3 hours exposure)

Figure 3. 1/100th largest value

Long Term Statistics and Design Wave Validation

S175 Example

MAESTRO’s long term statistics and design wave calculations follow the guideline given by ABS’s

“Guide for ‘SafeHull-Dynamic Loading Approach’ for Vessels”, where the long term probability of the

response is expressed as a summation of joint probability over the short-term sea states. This

approach is a little different from the Weibull fit approach adopted by VERES.  A quantitative
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comparison of long term statistics and design waves is given in this section. Supporting data and

procedure are provided in this section below.

Figure 4. Comparison of Probability of Exceedance
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Figure 5. VERES Design wave 
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Figure 6. MAESTRO Design Wave

VERES MAESTRO

Wave period 11.5 s 11.5 s

Heading Head sea Head sea

Wave amplitude 7.43 m 5.93 m

Figure 7. Design Wave Comparison

44,000 Ton Tanker Example

The second example of the design wave calculations  uses  a  44,000 ton tanker.  Table  1 below lists

the main particulars. 

Length between perpendiculars 180 m

Breadth 32.2 m

Draft 12.1 m

Displacement 44000 ton

Block coefficient 0.8

Table 1. Main particulars of the 44,000 ton tanker

Wave induced extreme vertical bending moment can be obtained using CSR’s empirical formula:
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For 150<L<300,

So:

Mwv,hog=1.496263E6 kNm

Mwv,sag=1.624232E6 kNm

For the direct calculation, the ship is assumed to travel at a speed of 15 knots. MAESTRO-Wave was

used to generate a unit wave hull  girder load database. The design wave for  the extreme bending

moment  with  the  probability  of  exceedance  of  10E-8  was  obtained  using  the  MAESTRO-ELA

procedure. The wave scatter diagram used in these calculations is provided here. 
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Hogging Sagging

Extreme Vertical BM CSR (kN*m) MAESTRO-Wave-ELA(kN*m)

Hogging 1.496263E6 1.5127E6

Sagging 1.624232E6 1.5127E6

Table 2. Design wave comparison between CSR and MAESTRO-Wave-ELA

Comparison Procedures of Short Term Statistics and Data

To validate the implementation of the short term statistics, the following procedure was used to

compare the numerical calculations between MAESTRO and VERES:

1. From the MAESTRO model, export input data (*.mgf and *.m3d) to VERES

2. Use VERES to calculate the hull girder load RAOs and short term statistics, then import the

hull girder load RAOs (*.re3) obtained from VERES into MAESTRO

3. Evaluate the short term statics using MAESTRO

4. Compare the short term statistics between MAESTRO and VERES

Step 1: From a MAESTRO model (S175), export *.mgf and *m3d
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MAESTRO

VERES

Step 2: Run VERES, then import VERES’s hull girder load RAOs (*.re3) into MAESTRO
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Because of the different definition of the standard coordinate system and forward speed, we need
to first validate the hull girder load transformation:

VERES’s result: Speed= 22.15 knots; Heading=180.00 Degrees, Wave-Period=10.000(s)

Speed= 22.15 knots; Heading=180.00 Degrees,
Wave-Length=156(m),Wave-Period=10.000(s)

VERES(*.mpl)

          
X(m)            FX(N)           VSF(N)           HSF(N)

         
TM(Nm)          HBM(Nm)          VBM(Nm)

GLOBAL WAVE INDUCED LOADS 
Longitudinal distribution of Vertical bending

moment\nat wave period T = 10.00 sec 
Project: Strip 

LONGITUDINAL POSITION FROM AP [m] 
Vertical bending moment RAO  [MNm/m] 

Strip          ; 22.15kn   0.0° 
21 
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Validation of hull girder load transformation

VERES hull girder load output (*.re3)
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Loading condition description: Design waterline                                 
                                                                                 

 ShipX exported data                                                             
  0.10250000E+04  0.98100004E+01

  0.17500000E+03  0.25400000E+02  0.95000000E+01
  0.25521638E+01  0.95000114E+01

  0.24589460E+08     10.7471     36.0770     37.7174      1.5489
     1     2     2

    21     0
     0     1     1     1     1     1

      0.0000      0.0000
    -89.1630
    -80.3290
    -71.4960
    -62.6630
    -53.8300
    -44.9970
    -36.1640
    -27.3310
    -18.4970
     -9.6640
     -0.8310
      8.0020
     16.8350
     25.6680
     34.5010
     43.3340
     52.1670
     61.0010
     69.8340
     78.6670
     87.5000
     1     1     1

   6.173333      0.0000000E+00  0.0000000E+00   2.552164       9.500000    
       0.00

  0.5235988    
 (0.0000000E+00,0.0000000E+00) (0.0000000E+00,0.0000000E+00)

 (0.0000000E+00,0.0000000E+00)
 (2.9278616E-04,-1.0993685E-04) (-1.8454379E-09,-5.2993437E-10)

 (6.6216243E-04,3.6967665E-04)
 (5.1601825E-04,-2.9952833E-04) (-6.6783681E-09,1.6185717E-09)

 (2.6169475E-03,1.3457955E-03)
 (5.4996356E-04,-4.8918091E-04) (2.0920536E-09,-3.7759862E-09)

 (4.8721568E-03,2.2767528E-03)
 (2.7487063E-04,-6.9205387E-04) (4.4208548E-09,-2.5479796E-09)

 (6.9558271E-03,3.0020671E-03)
 (-3.1623701E-04,-8.5914182E-04) (2.9644256E-09,1.0749742E-08)

 (8.3225975E-03,3.2373371E-03)
 (-1.1267348E-03,-8.9411967E-04) (-2.1466644E-09,9.3044701E-09)

 (8.6264079E-03,2.7909027E-03)
 (-2.0068453E-03,-7.0888991E-04) (-5.6307727E-09,9.3655839E-10)

 (7.7891247E-03,1.6865621E-03)
 (-2.8119758E-03,-2.5684034E-04) (7.6665729E-10,-1.1113070E-09)

 (5.9814430E-03,1.6664337E-04)
 (-3.3574887E-03,4.6942133E-04) (2.0180618E-10,-3.1927692E-09)

 (3.5340027E-03,-1.4063178E-03)
 (-3.6380005E-03,1.3604547E-03) (6.2689764E-09,-1.1599233E-09)

 (7.9582509E-04,-2.6489859E-03)
 (-3.7343407E-03,2.2991067E-03) (2.2751414E-09,1.1482131E-09)

 (-1.9480305E-03,-3.2877352E-03)
 (-3.6831100E-03,3.1887067E-03) (-1.4027158E-09,-1.0879617E-09)

 (-4.4871401E-03,-3.2296702E-03)
 (-3.4928671E-03,3.9092861E-03) (1.3068827E-09,-3.2540275E-09)

 (-6.5681450E-03,-2.5775346E-03)
 (-3.2476222E-03,4.3408046E-03) (2.8426259E-09,-1.6119713E-09)

 (-7.8658685E-03,-1.5777572E-03)
 (-3.0614564E-03,4.3869969E-03) (-3.4056080E-09,-1.7949733E-09)

 (-8.1349127E-03,-5.1186705E-04)
 (-3.0641919E-03,4.0294547E-03) (8.1236601E-10,-6.4131922E-09)

 (-7.3043732E-03,3.1714491E-04)
 (-3.3327376E-03,3.3218495E-03) (5.3662772E-09,7.5477519E-10)

 (-5.5535613E-03,6.6439860E-04)
 (-3.8599116E-03,2.3976176E-03) (1.1874810E-09,-9.4807184E-10)

 (-3.3636054E-03,4.3253604E-04)
 (-4.6241558E-03,1.2959157E-03) (-9.2287333E-10,-5.8274041E-10)

 (-1.3772559E-03,-1.2683733E-04)
 (-5.4090121E-03,3.6898727E-04) (8.1908363E-10,5.8054200E-10)

 (-7.4647163E-05,-2.7826574E-04)
 (0.0000000E+00,0.0000000E+00) (0.0000000E+00,0.0000000E+00)

 (0.0000000E+00,0.0000000E+00)
 (6.2992965E-11,1.7610052E-11) (1.7806091E-05,1.6310177E-06)

 (2.1644369E-11,5.9500710E-11)
 (2.3037278E-10,-3.9732627E-11) (9.2772163E-05,3.0600451E-05)

 (2.0652112E-10,1.7508304E-11)
 (-8.2977222E-11,1.3332574E-10) (2.6316993E-04,1.0279805E-04)

 (4.7777038E-10,2.4102845E-11)
 (-1.6335887E-10,3.8373058E-11) (5.3349003E-04,2.1750382E-04)

 (3.0113223E-10,1.6646673E-10)
 (-5.9925079E-11,-6.0073463E-10) (8.8210101E-04,3.5988213E-04)

 (7.9465393E-11,1.8254745E-10)
 (1.4964649E-10,-5.1905896E-10) (1.2682551E-03,5.0479476E-04)

 (-5.7614604E-11,-4.3306056E-10)
 (4.6976317E-10,3.6861528E-11) (1.6401167E-03,6.1986136E-04)

 (2.1607859E-10,-9.6233022E-10)
 (2.0286178E-10,1.0826677E-10) (1.9472582E-03,6.7767146E-04)

 (5.6839455E-10,-1.0647837E-09)
 (1.5578895E-10,1.9402488E-10) (2.1540695E-03,6.6565670E-04)

 (4.2505155E-10,-1.0241965E-09)
 (-1.2237827E-10,1.5072735E-10) (2.2345160E-03,5.8578642E-04)

 (2.2995841E-10,-7.0552197E-10)
 (4.1389381E-10,9.0844825E-11) (2.1775670E-03,4.5998581E-04)

 (-1.2013686E-10,-1.6427805E-10)
 (5.0035415E-10,2.0549513E-10) (1.9899667E-03,3.2324585E-04)

 (1.7343868E-10,-4.6304652E-10)
 (2.7724012E-10,3.4686157E-10) (1.6908133E-03,2.0724317E-04)

 (-3.7066645E-11,-6.3402861E-10)
 (4.2254111E-10,2.6887062E-10) (1.3119353E-03,1.3137849E-04)

 (-1.6497992E-10,-2.9183075E-10)
 (7.3351175E-10,3.4029501E-10) (8.9800468E-04,9.9714794E-05)

 (-7.2582551E-10,5.3920307E-10)
 (5.1715476E-10,6.7324846E-10) (4.9847155E-04,1.0336906E-04)

 (-4.1373710E-10,-9.4275601E-11)
 (1.8662509E-10,1.5780262E-10) (1.6085076E-04,1.1941216E-04)

 (-3.1080233E-10,1.9318354E-11)
 (5.3746513E-10,3.4687739E-10) (-8.2979925E-05,1.1937772E-04)

 (1.0199264E-10,-2.3368124E-10)
 (6.5686595E-10,3.1911024E-10) (-2.3013340E-04,7.6380093E-05)

 (-1.3865855E-09,-8.2125423E-10)
 (4.3959067E-10,2.2740043E-10) (-2.9067765E-04,2.8780481E-05)

 (4.1126794E-10,-8.8589586E-10)
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VERES’s short term statistics output

1 
SHORT TERM STATISTICS 
Vertical bending moment at Transverse cut X =  88.33 m\nHs =  1.00 m 
Project: Strip\nWave spectrum Pierson-Moskowitz  \nLong-crested seas 
MEAN ZERO-CROSSING PERIOD, Tz [sec] 
Expected max (single ampl.) in 3.0h [MNm] 
3 
Strip          ; 22.15kn   0.0° 
Strip          ; 22.15kn  30.0° 
Strip          ; 22.15kn  60.0° 
11 
5.000000 4.628933e+001 
6.000000 7.873611e+001 
7.000000 1.032626e+002 
8.000000 1.142099e+002 
9.000000 1.143639e+002 
10.000000 1.082660e+002 
11.000000 9.944653e+001 
12.000000 8.995063e+001 
13.000000 8.078248e+001 
14.000000 7.238907e+001 
15.000000 6.488220e+001 
11 
5.000000 5.180000e+001 
6.000000 8.098574e+001 
7.000000 9.982944e+001 
8.000000 1.057945e+002 
9.000000 1.028170e+002 
10.000000 9.537379e+001 
11.000000 8.634589e+001 
12.000000 7.727655e+001 
13.000000 6.886210e+001 
14.000000 6.133758e+001 
15.000000 5.472401e+001 
11 
5.000000 5.110350e+001 
6.000000 6.292495e+001 
7.000000 6.598369e+001 
8.000000 6.257636e+001 
9.000000 5.637862e+001 
10.000000 4.961499e+001 
11.000000 4.329860e+001 
12.000000 3.775369e+001 
13.000000 3.301147e+001 
14.000000 2.899287e+001 
15.000000 2.560390e+001

1 
SHORT TERM STATISTICS 
Vertical shear force at Transverse cut X =  88.33 m\nHs =  1.00 m 
Project: Strip\nWave spectrum Pierson-Moskowitz  \nLong-crested seas 
MEAN ZERO-CROSSING PERIOD, Tz [sec] 
Expected max (single ampl.) in 3.0h [MN] 
3 
Strip          ; 22.15kn   0.0° 
Strip          ; 22.15kn  30.0° 
Strip          ; 22.15kn  60.0° 
11 
5.000000 8.960674e-001 
6.000000 1.287121e+000 
7.000000 1.548043e+000 
8.000000 1.623498e+000 
9.000000 1.564158e+000 
10.000000 1.440573e+000 
11.000000 1.296750e+000 
12.000000 1.156063e+000 
13.000000 1.027967e+000 
14.000000 9.147770e-001 
15.000000 8.161898e-001 
11 
5.000000 8.918413e-001 
6.000000 1.229682e+000 
7.000000 1.455018e+000 
8.000000 1.503943e+000 
9.000000 1.432619e+000 
10.000000 1.309156e+000 
11.000000 1.173150e+000 
12.000000 1.042496e+000 
13.000000 9.251044e-001 
14.000000 8.220065e-001 
15.000000 7.325537e-001 
11 
5.000000 7.975678e-001 
6.000000 1.103233e+000 
7.000000 1.234206e+000 
8.000000 1.205639e+000 
9.000000 1.104630e+000 
10.000000 9.836690e-001 
11.000000 8.664744e-001 
12.000000 7.616724e-001 
13.000000 6.706778e-001 
14.000000 5.924718e-001 
15.000000 5.252566e-001

Step 3: Evaluate the short term statics using MAESTRO
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Station at -0.831 (m)
  Tp(s)   Tz(s)   Tm(s)   Vert. BM(MN.m)(Expected Maximum

Value,3 hours exposure,Single Amplitude)
==>[Speed=11.3949(m/s),Heading=120.00]

  7.035   5.000   5.430            51.6663
  8.442   6.000   6.516             63.418
  9.849   7.000   7.602            66.4764
 11.256   8.000   8.688            63.0189
 12.663   9.000   9.774            56.7502
 14.070  10.000  10.860            49.9362
 15.477  11.000  11.946            43.5731
 16.884  12.000  13.032            37.9874
 18.291  13.000  14.118            33.2133
 19.698  14.000  15.204            29.1767
 21.105  15.000  16.290            25.7743

Station at -0.831 (m)
  Tp(s)   Tz(s)   Tm(s)   Vert. BM(MN.m)(Expected Maximum

Value,3 hours exposure,Single Amplitude)
==>[Speed=11.3949(m/s),Heading=150.00]

  7.035   5.000   5.430            52.8213
  8.442   6.000   6.516            81.7938
  9.849   7.000   7.602            100.567
 11.256   8.000   8.688            106.487
 12.663   9.000   9.774            103.434
 14.070  10.000  10.860            95.8955
 15.477  11.000  11.946            86.8029
 16.884  12.000  13.032            77.6837
 18.291  13.000  14.118            69.2166
 19.698  14.000  15.204            61.6419
 21.105  15.000  16.290            54.9907

Station at -0.831 (m)
  Tp(s)   Tz(s)   Tm(s)   Vert. BM(MN.m)(Expected Maximum

Value,3 hours exposure,Single Amplitude)
==>[Speed=11.3949(m/s),Heading=180.00]

  7.035   5.000   5.430            47.0364
  8.442   6.000   6.516            79.4232
  9.849   7.000   7.602             103.92
 11.256   8.000   8.688            114.886
 12.663   9.000   9.774            114.954
 14.070  10.000  10.860            108.799
 15.477  11.000  11.946            99.9402
 16.884  12.000  13.032            90.4011
 18.291  13.000  14.118            81.1864
 19.698  14.000  15.204            72.7309
 21.105  15.000  16.290            65.1753

Station at -0.831 (m)
  Tp(s)   Tz(s)   Tm(s)   Vert. SF(MN)(Expected Maximum

Value,3 hours exposure,Single Amplitude)
==>[Speed=11.3949(m/s),Heading=120.00]

  7.035   5.000   5.430           0.809491
  8.442   6.000   6.516            1.11451
  9.849   7.000   7.602            1.24572
 11.256   8.000   8.688             1.2163
 12.663   9.000   9.774            1.11368
 14.070  10.000  10.860           0.991438
 15.477  11.000  11.946           0.873247
 16.884  12.000  13.032           0.767418
 18.291  13.000  14.118           0.675627
 19.698  14.000  15.204           0.597073
 21.105  15.000  16.290           0.530185

Station at -0.831 (m)
  Tp(s)   Tz(s)   Tm(s)   Vert. SF(MN)(Expected Maximum

Value,3 hours exposure,Single Amplitude)
==>[Speed=11.3949(m/s),Heading=150.00]

  7.035   5.000   5.430           0.911049
  8.442   6.000   6.516            1.24261
  9.849   7.000   7.602            1.46794
 11.256   8.000   8.688            1.51567
 12.663   9.000   9.774            1.44321
 14.070  10.000  10.860            1.31818
 15.477  11.000  11.946            1.18071
 16.884  12.000  13.032             1.0493
 18.291  13.000  14.118           0.930848
 19.698  14.000  15.204           0.826972
 21.105  15.000  16.290           0.737064

Station at -0.831 (m)
  Tp(s)   Tz(s)   Tm(s)   Vert. SF(MN)(Expected Maximum

Value,3 hours exposure,Single Amplitude)
==>[Speed=11.3949(m/s),Heading=180.00]

  7.035   5.000   5.430           0.906277
  8.442   6.000   6.516            1.29622
  9.849   7.000   7.602             1.5582
 11.256   8.000   8.688            1.63398
 12.663   9.000   9.774            1.57389
 14.070  10.000  10.860            1.44866
 15.477  11.000  11.946             1.3041
 16.884  12.000  13.032            1.16275
 18.291  13.000  14.118            1.03371
 19.698  14.000  15.204            0.91967
 21.105  15.000  16.290           0.820471

MAESTRO output: Expected maximum value (3 hrs)
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Comparison Procedures of Long Term Statistics and Design Waves

Scatter Diagram
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VERES MAESTRO

LONG TERM STATISTICS 

Vertical bending moment at Transverse cut X =  88.33 m 

Project: Strip\nCombined N. Pacific Region, Annual (added 0.75% at 0.01m

to total 100%)\nWave spectrum Pierson-Moskowitz  \nLong-crested

seas\nIndependent headings. 

Single amplitudes   [MNm] 

PROBABILITY OF EXCEEDANCE 

1 

Strip          ; 22.15kn 180.0°; T_R =  36.13 [s], Weibull slope, h = 1.2842 [-] 

8 

309.759369 1.000000e-002 

445.872803 1.000000e-003 

564.172180 1.000000e-004 

669.540161 1.000000e-005 

765.747314 1.000000e-006 

939.869995 1.000000e-008 

1020.297852 1.000000e-009 

1097.056519 1.000000e-010

Station=-0.831 (m), Speed=22.15 (Knots),Heading=  180.00 DEG
      Exceedence    Extreme-Value

            0.01     4.77771e+008
           0.001     5.92224e+008
          0.0001     7.15364e+008
          1e-005       8.293e+008
          1e-006     9.29434e+008
          1e-007     1.01981e+009
          1e-008     1.10282e+009
          1e-009     1.18001e+009
          1e-010     1.25246e+009

Long term design wave validation
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S175: Dynamic Only

Sagging Hogging
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Load Case =6, "Extreme6"
Station        X(m)         Bending Moment(N*m)
  0            -87.5           205159
  1           -83.25           327658

  2              -79     2.53624e+006
  3           -74.75     8.24339e+006
  4            -70.5     2.21185e+007
  5           -66.25     4.45718e+007

  6              -62     7.77594e+007
  7           -57.75     1.18727e+008
  8            -53.5     1.74835e+008
  9           -49.25     2.39426e+008

 10              -45     3.13038e+008
 11           -40.75     3.91612e+008
 12            -36.5     4.73895e+008
 13           -32.25     5.55303e+008

 14              -28     6.34343e+008
 15           -23.75     7.04733e+008
 16            -19.5     7.64713e+008
 17           -15.25     8.10706e+008

 18              -11     8.41269e+008
 19            -6.75     8.54534e+008

 20             -2.5     8.48414e+008
 21             1.75     8.22708e+008

 22                6     7.79692e+008
 23            10.25     7.23153e+008
 24             14.5     6.53821e+008
 25            18.75     5.76905e+008

 26               23     4.93515e+008
 27            27.25     4.11058e+008
 28             31.5     3.30191e+008
 29            35.75     2.55918e+008

 30               40      1.8852e+008
 31            44.25     1.31872e+008
 32             48.5     8.46629e+007
 33            52.75     5.27907e+007

 34               57     2.69063e+007
 35            61.25     1.08585e+007
 36             65.5           219655

 37            69.75    -4.15442e+006
 38               74    -5.15871e+006

 39            78.25    -4.36895e+006
 40             82.5    -3.48765e+006
 41            86.75    -2.21861e+006

 42               91    -1.75749e+006
 43           94.423     -1.8179e+006

Maximum Bending Moment(Full Ship) in Structural Coordinates:
M=8.54534e+008(Nm)

Load Case =7, "Extreme6+180"
Station        X(m)         Bending Moment(N*m)
  0            -87.5          -205159
  1           -83.25          -327659

  2              -79    -2.53624e+006
  3           -74.75    -8.24339e+006
  4            -70.5    -2.21185e+007
  5           -66.25    -4.45718e+007

  6              -62    -7.77594e+007
  7           -57.75    -1.18727e+008
  8            -53.5    -1.74835e+008
  9           -49.25    -2.39426e+008

 10              -45    -3.13038e+008
 11           -40.75    -3.91612e+008
 12            -36.5    -4.73895e+008
 13           -32.25    -5.55303e+008

 14              -28    -6.34343e+008
 15           -23.75    -7.04733e+008
 16            -19.5    -7.64713e+008
 17           -15.25    -8.10706e+008

 18              -11    -8.41269e+008
 19            -6.75    -8.54534e+008

 20             -2.5    -8.48414e+008
 21             1.75    -8.22708e+008

 22                6    -7.79692e+008
 23            10.25    -7.23153e+008
 24             14.5    -6.53821e+008
 25            18.75    -5.76905e+008

 26               23    -4.93515e+008
 27            27.25    -4.11058e+008
 28             31.5    -3.30191e+008
 29            35.75    -2.55918e+008

 30               40     -1.8852e+008
 31            44.25    -1.31872e+008
 32             48.5    -8.46629e+007
 33            52.75    -5.27907e+007

 34               57    -2.69063e+007
 35            61.25    -1.08585e+007
 36             65.5          -219662

 37            69.75     4.15441e+006
 38               74      5.1587e+006

 39            78.25     4.36894e+006
 40             82.5     3.48764e+006
 41            86.75      2.2186e+006

 42               91     1.75748e+006
 43           94.423     1.81789e+006

Maximum Bending Moment(Full Ship) in Structural Coordinates:
M=-8.54534e+008(Nm)

S175: Dynamic + Stillwater

Sagging Hogging
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Load Case =2, "Extreme2"
Station        X(m)         Bending Moment(N*m)
  0            -87.5           228765

  1           -83.25    -1.74478e+007
  2              -79    -3.45041e+007

  3           -74.75     -6.7919e+007
  4            -70.5    -8.81071e+007
  5           -66.25    -1.19532e+008

  6              -62    -1.32021e+008
  7           -57.75    -1.58248e+008
  8            -53.5    -1.51691e+008
  9           -49.25    -1.50235e+008

 10              -45    -1.25755e+008
 11           -40.75    -1.04325e+008
 12            -36.5    -6.54408e+007
 13           -32.25    -3.07289e+007

 14              -28     1.58479e+007
 15           -23.75     5.69865e+007
 16            -19.5     1.00997e+008
 17           -15.25     1.34296e+008

 18              -11     1.58932e+008
 19            -6.75     1.75542e+008

 20             -2.5      1.8102e+008
 21             1.75     1.59776e+008

 22                6     1.22504e+008
 23            10.25     8.80165e+007
 24             14.5     3.64368e+007
 25            18.75    -4.13126e+006

 26               23     -5.7696e+007
 27            27.25    -8.95541e+007
 28             31.5    -1.34053e+008
 29            35.75    -1.52314e+008

 30               40    -1.80504e+008
 31            44.25    -1.78415e+008
 32             48.5     -1.8701e+008
 33            52.75    -1.57909e+008

 34               57    -1.49241e+008
 35            61.25    -1.16222e+008
 36             65.5    -1.01747e+008
 37            69.75    -7.09816e+007

 38               74    -5.45563e+007
 39            78.25    -3.21274e+007
 40             82.5    -2.11692e+007
 41            86.75    -7.04854e+006

 42               91           635005
 43           94.423           574342

Maximum Bending Moment(Full Ship) in Structural Coordinates:
M=-1.8701e+008(Nm)

Load Case =3, "Extreme2+180"
Station        X(m)         Bending Moment(N*m)
  0            -87.5          -181553

  1           -83.25    -1.81032e+007
  2              -79    -3.95766e+007

  3           -74.75    -8.44058e+007
  4            -70.5    -1.32344e+008
  5           -66.25    -2.08676e+008

  6              -62     -2.8754e+008
  7           -57.75    -3.95702e+008
  8            -53.5    -5.01362e+008
  9           -49.25    -6.29086e+008

 10              -45    -7.51831e+008
 11           -40.75    -8.87549e+008
 12            -36.5    -1.01323e+009
 13           -32.25    -1.14134e+009

 14              -28    -1.25284e+009
 15           -23.75    -1.35248e+009
 16            -19.5    -1.42843e+009
 17           -15.25    -1.48712e+009

 18              -11    -1.52361e+009
 19            -6.75    -1.53353e+009

 20             -2.5    -1.51581e+009
 21             1.75    -1.48564e+009

 22                6    -1.43688e+009
 23            10.25    -1.35829e+009
 24             14.5    -1.27121e+009
 25            18.75    -1.15794e+009

 26               23    -1.04473e+009
 27            27.25     -9.1167e+008
 28             31.5    -7.94435e+008
 29            35.75     -6.6415e+008

 30               40    -5.57545e+008
 31            44.25    -4.42159e+008
 32             48.5    -3.56335e+008
 33            52.75    -2.63491e+008

 34               57    -2.03053e+008
 35            61.25    -1.37939e+008
 36             65.5    -1.02187e+008
 37            69.75    -6.26728e+007

 38               74    -4.42389e+007
 39            78.25    -2.33895e+007
 40             82.5     -1.4194e+007
 41            86.75    -2.61133e+006

 42               91     4.14998e+006
 43           94.423     4.21013e+006

Maximum Bending Moment(Full Ship) in Structural Coordinates:
M=-1.53353e+009(Nm)

S175: Dynamic + Sine Wave

Sagging Hogging
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Load Case =4, "Extreme4"
Station        X(m)         Bending Moment(N*m)
  0            -87.5           694928

  1           -83.25    -1.71342e+007
  2              -79    -3.04362e+007

  3           -74.75    -5.53546e+007
  4            -70.5    -5.56614e+007
  5           -66.25    -5.55367e+007

  6              -62     -2.1123e+007
  7           -57.75     1.05062e+007
  8            -53.5     9.60105e+007
  9           -49.25     1.88418e+008

 10              -45     3.16424e+008
 11           -40.75     4.48834e+008
 12            -36.5     6.04086e+008
 13           -32.25     7.55034e+008

 14              -28     9.14736e+008
 15           -23.75     1.05942e+009
 16            -19.5     1.19409e+009
 17           -15.25     1.30106e+009

 18              -11     1.38013e+009
 19            -6.75     1.42907e+009

 20             -2.5     1.44134e+009
 21             1.75     1.40173e+009

 22                6     1.32238e+009
 23            10.25      1.2253e+009
 24             14.5     1.09212e+009
 25            18.75     9.55468e+008

 26               23     7.93496e+008
 27            27.25     6.48087e+008
 28             31.5     4.88972e+008
 29            35.75     3.58906e+008

 30               40     2.26178e+008
 31            44.25     1.33013e+008
 32             48.5     4.20755e+007
 33            52.75      4.8907e+006

 34               57    -4.02928e+007
 35            61.25    -4.87815e+007
 36             65.5     -6.3334e+007
 37            69.75    -5.23521e+007

 38               74    -4.62831e+007
 39            78.25     -2.9959e+007
 40             82.5     -2.1455e+007
 41            86.75    -8.33652e+006

 42               91    -6.93597e-006
 43           94.423    -2.15402e-005

Maximum Bending Moment(Full Ship) in Structural Coordinates:
M=1.44134e+009(Nm)

Load Case =5, "Extreme4+180"
Station        X(m)         Bending Moment(N*m)
  0            -87.5         -46752.8

  1           -83.25    -1.90289e+007
  2              -79    -3.82319e+007

  3           -74.75    -8.21733e+007
  4            -70.5    -1.28525e+008
  5           -66.25    -2.09795e+008

  6              -62    -2.97187e+008
  7           -57.75    -4.21871e+008
  8            -53.5    -5.55379e+008
  9           -49.25    -7.24841e+008

 10              -45     -9.0073e+008
 11           -40.75     -1.1037e+009
 12            -36.5    -1.30505e+009
 13           -32.25    -1.51654e+009

 14              -28    -1.71258e+009
 15           -23.75    -1.89429e+009
 16            -19.5     -2.0442e+009
 17           -15.25    -2.16604e+009

 18              -11    -2.25197e+009
 19            -6.75    -2.29431e+009

 20             -2.5     -2.2893e+009
 21             1.75    -2.25384e+009

 22                6    -2.18181e+009
 23            10.25    -2.06234e+009
 24             14.5    -1.92074e+009
 25            18.75    -1.74044e+009

 26               23    -1.55295e+009
 27            27.25    -1.34177e+009
 28             31.5    -1.14967e+009
 29            35.75    -9.47717e+008

 30               40    -7.78877e+008
 31            44.25    -6.08481e+008
 32             48.5    -4.78778e+008
 33            52.75    -3.51234e+008

 34               57    -2.64024e+008
 35            61.25    -1.77506e+008
 36             65.5    -1.27443e+008
 37            69.75    -7.72739e+007

 38               74    -5.34294e+007
 39            78.25    -2.88872e+007
 40             82.5    -1.81938e+007
 41            86.75    -6.04138e+006

 42               91    -1.45747e-005
 43           94.423     7.65373e-006

Maximum Bending Moment(Full Ship) in Structural Coordinates:
M=-2.29431e+009(Nm)
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14 Spectral Fatigue Analysis

The Spectral Fatigue Analysis (SFA) module provides the ability to perform global fatigue
screening of the vessel.  The SFA module introduces additional functionality to the ELA
module to compute Stress RAOs, displacement RAOs, define and associate structural
groups to SN curves and Stress Concentration Factors (SCFs), and compute fatigue
damage based on the Miner cumulative damage principle.

Table of Contents

Defining a Spectral Fatigue Analysis Load Case

Fatigue Screening

Validation

14.1 Defining a SFA Load Case

Before creating a fatigue load case, the hydrodynamic loads need to be imported either
from MAESTRO-Wave or a 3rd party seakeeping tool.  For more information, see the
importing *.smn file section.  Once the loads are imported, the Stress/Displacement RAOs
need to be calculated.  Select ELA/SFA > Compute RAOs from the menu.

If the loads are imported from a 3rd party tool, it is recommended that the model be re-
balanced using the "Sectional Loads" option.  Ensure the "Stress/Displacement" box is
checked and click "OK".  This will open the Analysis/Evaluation dialog.
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Click "OK" to calculate the RAOs.

Once the RAOs are calculated, the spectral fatigue analysis load case can be created using
the standard MAESTRO load case dialog.
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First create a new "Fatigue" load case, check only the "Fatigue" option, and click Create. 
(The actual loading is defined in the "base" load cases.)  This will expose the "Define" button
allowing the user to specify the fatigue load case parameters.  Clicking "Define" will open the
Spectral Fatigue Analysis dialog:

The Spectral Fatigue Analysis dialog is split into two tabs.  The "Description" tab allows the
user to specify the operation and wave environment.  The base load case will be
automatically populated with existing MAESTRO load cases. Multiple "base" load cases can
be added to the "Fatigue" load case to describe the operations of a ship over its lifetime. 
For example, the ship's lifetime could be 30 years defined by the following conditions:

Load Case Exposure Time

Full Load Departure 10 years

Full Load Arrival   4 years

Min Op Departure 12 years

Min Op Arrival   4 years

The same base load cases could also be combined with different wave environments.  Once
the Operation and Environment parameters are selected, click the "Add" button to add to the
list of operating descriptions.  The operating profile and wave environments can be created
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or imported.  Please see this section for more details on these options.

 

The "Structure" tab allows the user to associate structural groups (i.e. MAESTRO groups)
and associate S-N curves and stress concentration factors (SCF).  
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The groups drop-down will automatically be populated with the available Plate, Volume,
General, Section, and Module groups defined in the model.  Additional groups can be
created after the initial definition of the load case and added at a later time.  The S-N curve
drop-down is populated with the available S-N curves from the classification societies:
American Bureau of Shipping (ABS) and Det Norske Veritas (DNV):

ABS_B

ABS_C

ABS_D

ABS_E

ABS_F

ABS_F2

ABS_G

ABS_W

DNV_I

DNV_II

DNV_II

DNV_IV

DNV_Ib

DNV_IIIb

The SCF is the ratio of the "hot spot" stress to the nominal stress computed for that location
where the "hot spot" stress is defined as the surface value of the structural stress at a given
"hot spot" and the nominal stress is the stress at a cross section of the structural detail,
away from the "hot spot".

When a group is added, the S-N curve and SCF is applied to all the elements included in the
group.  Similar to the "Description" tab, multiple groups with different S-N and SCFs can be
added and a summary will be displayed in the table.

Once the "Description" and "Structure" tab are completed, click "OK" to save the load case
parameters.  You can return to this dialog at any time to make changes to the load case.
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14.2 Fatigue Screening

The Fatigue load case is run and analyzed in the same process as a standard MAESTRO
load case.  Using the Analysis/Evaluation dialog, the user can run the analysis once their
load case is defined.  If you plan to run the fatigue screening on a top-down fine mesh
model, make sure to select the "Solve All Fine Mesh Models" option in the dialog below.

Using the calculated stress RAOs, the fatigue damage is calculated using Miner's Rule and
stored as the fatigue damage ratio in the standard MAESTRO results file (*.rlt).  If the
fatigue damage, D, is greater than 1.0, then the structure has a fatigue problem.  The
fatigue life, FL, is then calculated using the fatigue damage value as:

FL = service life/D

This means any structure with a damage ratio greater than 1.0 will have a fatigue life shorter
than the service life.

Once the analysis is complete, the damage ratio is plotted for each element.
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Using the dynamic query, the damage ratio for each element can be individually queried.
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14.3 Validation

The 44,000 ton tanker model from the ELA validation is also used for the spectral fatigue validation.
The quad element “/top/s2 midbody hull/m4 tank4 strake 12 section 7” is selected for a hand
calculation, and is then compared to the calculation using the MAESTRO SFA module.
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Figure 1. Quad element “/top/s2 midbody hull/m4 tank4 strake 12 section 7”

To perform a spectral fatigue analysis, the stress RAO database (*.sfa) has to first be generated.

Once the database is created, the “real” and “imaginary” stress and deflection of a selected speed,
heading  and  wave  frequency  can  be  obtained  from  the  “Frequency  Load  Database”  dialog  for  a
sanity check. When the result of a frequency load case is selected, all regular post process functions,
such as query, stress, deflection and the result lists are available to the user.



MAESTRO 11.0.0550

© 2014 Optimum Structural Design, Inc.

Figure 2. Selection of the full model stress and deflection

Heading=180, Wave Period=11sec, Real Heading=180, Wave Period=11sec, Imaginary
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Figure 3. Full model of Stress and deflection

To verify the stress RAO calculation of a specific case, the “Define ELA Loads” command was used to
create  regular  MAESTRO  load  cases.  Note  that,  in  order  to  match  the  automatic  stress  RAO
calculation,  the  hydrostatics  should  not  be  included  when  generating  an  ELA  load  case,  as  shown
below.

Once  a  regular  MAESTRO  load  case  is  created,  the  loads  (either  individual  elemental  loads  or  hull
girder loads) can be reviewed and examined. The corresponding finite element analysis results can
then be compared to the automatic stress RAO results.
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Element stress RAOs can be obtained from the MAESTRO “Response Amplitude Operator” dialog, as
shown in Figure 4.

Figure 4. Retrieve selected element stress RAO

Table 1 lists the principal stress RAO of quad element 4922, computed by MAESTRO.  Table 2 gives
the hand calculations of the principal stress for a wave period at 11 seconds. Figure 5 shows the
principal stress RAO of quad element 4922.

T(sec) Omega (rad/s)
RAO:Stress(N/mm^2)

FeTag=4922,S=15.00(Knot):H=  180DEG
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30.000 0.209 0.479

29.000 0.217 0.420

28.000 0.224 0.351

27.000 0.233 0.270

26.000 0.242 0.176

25.000 0.251 0.071

24.000 0.262 0.099

23.000 0.273 0.232

22.000 0.286 0.414

21.000 0.299 0.638

20.000 0.314 0.909

19.000 0.331 1.249

18.000 0.349 1.693

17.000 0.370 2.316

16.000 0.393 3.235

15.000 0.419 4.607

14.000 0.449 6.600

13.000 0.483 8.530

12.000 0.524 7.429

11.000 0.571 5.636

10.000 0.628 7.876

9.000 0.698 6.094

8.000 0.785 1.150

7.000 0.898 2.610

6.000 1.047 1.314

5.000 1.257 0.726

4.000 1.571 0.834

3.000 2.094 2.630

Table 1. Stress RAO of quad element 4922
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Stress (MPa) Real (Phase angle=0) Imaginary(Phase

angle=90)

Modulus

sx 5.3442 1.7884 5.6355

sy 0.70454 -2.3635 2.46627

txy -2.10E-02 -6.54E-03 0.02201

s1 5.344295 1.78841 5.6356

s2 0.704445 -2.36351 2.46626

Table 2. Hand calculation of the principal stress of quad element 4922 for wave period at 11
seconds

Figure 5. Quad element 4922 stress RAO

The transformation to the principal directions can be illustrated as: 
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Two sea states, shown below, are selected for the stress spectrum calculation. The stress spectra of

the two sea states are given in Table 3 and 4. 

Zero-crossing frequency=0.150166 Hz
Sea State: Hs=1200.000(mm) Tp=8.000s Probability=0.40000

Wave-Freq-e(Omega) Wave-Period-e(s) Wave-Length-e(mm) Response(N/mm^2)^2

0.243957 25.7553 1035.32 3.96E-27

0.2536 24.776 958.08 5.60E-24

0.264022 23.7979 883.933 2.51E-21

0.275324 22.8211 812.853 6.00E-19

0.287615 21.8458 744.865 2.85E-16
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0.301031 20.8723 679.954 1.40E-13

0.315731 19.9004 618.111 2.92E-11

0.331906 18.9306 559.334 2.88E-09

0.349782 17.9631 503.622 1.51E-07

0.369641 16.9981 450.963 4.63E-06

0.391821 16.0359 401.352 8.84E-05

0.416746 15.0768 354.779 0.001114

0.444945 14.1213 311.234 0.009806

0.47709 13.1698 270.708 0.063876

0.514046 12.223 233.183 0.324081

0.556945 11.2815 198.644 1.32606

0.607293 10.3462 167.072 4.46027

0.667138 9.41813 138.443 10.4081

0.739327 8.49852 112.727 8.8981

0.827933 7.589 89.8897 3.02143

0.938968 6.69159 69.8875 9.8995

1.08165 5.8089 52.6657 5.62666

1.27079 4.94433 38.1554 0.24561

1.53157 4.10244 26.2679 0.279134

1.91011 3.28944 16.8882 0.041644

2.49923 2.51405 9.8648 0.001522

3.51235 1.78889 4.99466 0.002185

5.54604 1.13291 2.00325 0.004808

Table 3. Stress RMS=2.09537(N/mm^2)

Zero-crossing frequency=0.167133 Hz
Sea State: Hs=1500.000(mm) Tp=7.000s Probability= 0.60000

Wave-Freq-e(Omega) Wave-Period-e(s) Wave-Length-e(mm) Response(N/mm^2)^2

0.243957 25.7553 1035.32 5.31E-46



Spectral Fatigue Analysis 557

© 2014 Optimum Structural Design, Inc.

0.2536 24.776 958.08 2.10E-40

0.264022 23.7979 883.933 1.51E-35

0.275324 22.8211 812.853 3.48E-31

0.287615 21.8458 744.865 9.83E-27

0.301031 20.8723 679.954 1.84E-22

0.315731 19.9004 618.111 9.70E-19

0.331906 18.9306 559.334 1.65E-15

0.349782 17.9631 503.622 1.06E-12

0.369641 16.9981 450.963 2.87E-10

0.391821 16.0359 401.352 3.63E-08

0.416746 15.0768 354.779 2.33E-06

0.444945 14.1213 311.234 8.24E-05

0.47709 13.1698 270.708 0.001742

0.514046 12.223 233.183 0.023712

0.556945 11.2815 198.644 0.219866

0.607293 10.3462 167.072 1.44493

0.667138 9.41813 138.443 5.78983

0.739327 8.49852 112.727 7.60377

0.827933 7.589 89.8897 3.60714

0.938968 6.69159 69.8875 15.2455

1.08165 5.8089 52.6657 10.4644

1.27079 4.94433 38.1554 0.522929

1.53157 4.10244 26.2679 0.65222

1.91011 3.28944 16.8882 0.103386

2.49923 2.51405 9.8648 0.003919

3.51235 1.78889 4.99466 0.005742

5.54604 1.13291 2.00325 0.012759

Table 4. Stress RMS=2.34854(N/mm^2)
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Figure 6. Stress spectra of Quad element 4922

S-N Curve Material a Log a m

Ib Welded joint 5.75E12 12.76 3.0

IIIb Base material 1.0E13 13.00 3.0

Table 5. DNV One Slope S-N Curve

The damage ratio of quad element 4922 over a design life of 5 years is calculated according to the

equation below:

One slope S-N curve, DNV-Ib, is used. The probability of sea state 1 is 0.4, and the probability of sea

state 2 is 0.6.
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To  calculate  fatigue  damage  using  MAESTRO,  first  define  a  spectral  fatigue  load  case,  as

shown  below,  and  then  run  a  MAESTRO  analysis.  Note  that  for  the  spectral  fatigue  load

case,  the  solution  dialog  is  just  a  place  holder.  The  options  for  stress  and  adequacy

calculation do not apply.
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To view the element fatigue damage, select ELA/SFA > View damage Ratio, as shown below:
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Figure 7. Quad 4922 Fatigue Damage Ratio

The fatigue damage ratio calculated by MAESTRO matches the hand-calculated value.
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14.4 Extreme Stress Analysis

In  addition  to  calculating  stress  RAOs  for  each  element  in  the  model,  MAESTRO  is  also  able  to
compute mean stress and extreme stress values.   The mean stress is  a  statistical  measure of  each
element’s stress RAO and is defined as:
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where

mm

The  extreme  stress  is  a  measure  of  each  element’s  extreme  stress  value  given  a  probability  of
exceedence or exposure time.  Using short term statistics, the extreme stress is defined as:

Where

Using long term statistics, the extreme value is calculated using a probability of exceedence equal to

 in which N is the number of wave load peaks determined from a scatter diagram and operating
profile. 

Similar to the design wave calculations in which the unit wave load RAOs are used to determine the
design wave corresponding to the maximum hull girder loads, the extreme stress value is calculated
using the element stress RAOs.  The benefit of the extreme stress calculation is that it  enables the
user to screen the maximum expected stress for each element given a short term exposure or long
term design life.  

The extreme stress analysis setup can be accessed from Wave > Extreme Stress Analysis:
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Similar  to  the  design  wave  computation,  the  extreme  stress  analysis  will  create  a  new  static  load
case based on the dialog settings.  For using either short or long term statistics, the base load case
and regular wave runs must be selected for the analysis in addition to an operating profile and wave
spectrum.   The  default  operating  profile  assumes  equal  probability  of  all  speeds  and  headings
selected.   For  long  term statistics,  a  wave  scatter  diagram  and  either  a  probability  level  or  return
period must be selected.   For the short  term statistics,  an exposure time and spectrum definition
must be provided.  

To create the extreme stress analysis  load case, click "Add".   The calculation can be performed on
the  entire  ship  or  on  a  selected  group  or  groups  only.   Once  the  load  case  is  created,  it  can  be
analyzed like any other static load case.  Since the stresses are computed using statistics, the results
of the extreme stress analysis does not include deflections or loads.  These stresses can also be used
as input into MAESTRO’s limit state evaluation framework.
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15 Advanced Processing and Programming

The following topics discuss advance capabilities offered with MAESTRO.  These include
batch processing, accessing results via a COM interface and importing 3rd party
hydrodynamic loads.

15.1 Batch Processing

Introduction

MAESTRO has the ability to perform batch processing.  This is useful, for example, when
the user would like to sequentially solve multiple models with many load cases without
having to manually launch the process.  Further, several post-processing keywords are
available for users to compare a result to a known value.

The batch file will consist of at least three tokens separated by a space: first to launch
(behind the scene) MAESTRO, second to identify the model, and third to define a keyword.
Note, the second and third tokens may need to be bracketed by quotation marks if there are
multiple sub-keywords present.  The presence of a third token will allow MAESTRO to start
the batch process.  If a third token is not present, MAESTRO will simply launch the GUI with
the selected model open.  An example batch file (maestro.bat) is found in the Models and
Samples/Advanced/Batch Processing directory of the MAESTRO installation directory.

An example would be:

first_token second_token third_token

cd ..\..\system modeler92.exe "ex1_ulsap.mdl" run

Keywords

The following keywords are available to support batch processing and accessing results for
a given fetag.  The keywords have been categorized into Processing and Post-processing.

Processing

The batch processing is initiated by the presence of a third token as described above.  The
example above uses run as the third token, which would initiate the batch process with the
default Analysis and Evaluation setup parameters.  If the model consists of fine-mesh
analysis models, the Sparse solver will be used as the solver method.

The default Analysis and Evaluation setup parameters and behaviors are:

· Equation Solver Method = Sparse

· Beams Attached to Plating = Eccentric Beam
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· Stresses & Reaction Forces = Calculate Stress & Calculate Reaction Forces

· Failure Mode Evaluation = None

· A log file containing all of the results will be generated

Keyword: hybrid

Used to change the method of Beams Attached to Plating from the default, Eccentric Beam,
to Hybrid Beam

Example: cd ..\..\system modeler92.exe "ex1.mdl" hybrid

Keyword: iterative

Used to launch the Iterative solver.  Note the user is to define the number of iterations and
tolerance.  If an iteration number and tolerance are omitted, the number of iterations and
tolerance default to 20,000 and 1.0E-5 respectively.

Example: cd ..\..\system modeler92.exe "ex1_iter.mdl" "iterative 2000 2.0E-6"

Keyword: maestro

Used to perform limit state analysis using MAESTRO.

Example: cd ..\..\system modeler92.exe "ex1_maestro.mdl" maestro

Keyword: nostress

Used to turn off stress calculations during batch processing.

Example: cd ..\..\system modeler92.exe "ex1.mdl" nostress

Keyword: noreaction

Used to turn off reaction force calculations during batch processing.

Example: cd ..\..\system modeler92.exe "ex1.mdl" noreaction

Keyword: nolog

Used to turn off the functionality that generates a log file containing the results.

Example: cd ..\..\system modeler92.exe "ex1.mdl" nolog

Keyword: ulsap

Used to perform limit state analysis using ALPS/ULSAP.
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Example: cd ..\..\system modeler92.exe "ex1_ulsap.mdl" ulsap

Post-processing

The following keywords are used to access results for a given model, load case, and fetag
so the user can compare the values to a known quantity.  If the solution quantities do not
match the prescribed quantities, MAESTRO will produce an  error message such as the on
below.  This is useful from a quality checking perspective.

Keyword: adq

Used to access a variety of adequacy parameters associated with structural evaluation using
the MAESTRO and ALPS/ULSAP limit states.  Note the adequacy comparisons have a built
in tolerance of 0.001.  Sub-keywords associated ONLY with ALPS/ULSAP are noted below. 
Examples is provided below.

Sub-keywords to adq for MAESTRO and ALPS/ULSAP

· Load Case Specification: LC=

· FeTag Specification: FETAG=

· Panel Limit States: pcsf | pccb | pcmy | pcsb | pytf | pytp | pycp | pspbl | pspbt | pflb

· Beam Limit States: bct | byc | bcwb | bcc | bccf | bccp | bycf | bycp | bytf | bytp | bcph

· Rod Limit State: euler

Example: cd ..\..\system modeler92.exe "ex1_maestro.mdl" maestro "adq LC=1
FETAG=6 pccb=0.535"

Sub-keywords to adq for ALPS/ULSAP only

· Panel Limit States: pcpm | pcpe 

Example: cd ..\..\system modeler92.exe "ex1_maestro.mdl" ulsap "adq LC=1 FETAG=6
pcpe=0.502"

Keyword: disp

Used to access the displacement results of a given load case and fetag.  Note the user is to
define (via sub-keywords) the load case, fetag, type of displacement, and tolerance.  An
example is provided below.

Sub-keywords to disp:
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· Load Case Specification: LC=

· FeTag Specification: FETAG=

· Displacement Type: dx | dy | dz | rx | ry | rz | dt (total translation)

· Comparison Tolerance: tol=

Example: cd ..\..\system modeler92.exe "ex1_maestro.mdl" maestro "disp LC=1
FETAG=37 dt=0.001 tol=1.0E-6"

Keyword: stress

Used to access the mid-plane stress results of a given load case and fetag.  Note the user is
to define (via sub-keywords) the load case, fetag, type of mid-plane stress, and tolerance. 
An example is provided below.

Sub-keywords to stress:

· Load Case Specification: LC=

· FeTag Specification: FETAG=

· Mid-plane Stress Type: sxx | syy | syx | svm

· Comparison Tolerance: tol=

Example: cd ..\..\system modeler92.exe "ex1_maestro.mdl" maestro "stress LC=1
FETAG=51 sxx=3518734.5 tol=0.01"

Keyword: freq

Used to perform a natural frequency analysis.

Sub-keywords to freq:

· Load Case Specification: LC=

· FeTag Specification: FETAG=

· Frequency Mode Selection: iMode=

· Frequency: freq=

· Comparison Tolerance: tol=

      Example: cd ..\..\system modeler92.exe "Natural Frequency\w4_13_girder_free.mdl" run
"freq LC=1 iMode=7 freq=73.2816 tol=1.0E-4"

Keyword: alpshull
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Used to access the results of an ALPS/HULL analysis.  Note: all values entered should be in
SI (N, m) units.

Sub-keywords to alpshull:

· Maximum Bending Moment: maxbm=

· Comparison Tolerance: tol=

· Incremental Loading Steps: steps=

· Bending Moment Curvature: curve={vertical rotation increment, horizontal rotation
increment}

· Shear Force & Torsional Moment: shear={vertical shear force, horizontal shear force,
torsional moment}

· Plate Initial Condition: plateinit={Max deflection/thickness, residual stress/yield stress}

· Stiffener Initial Condition: stiffinit={Max deflection/length, residual stress/yield stress}

· Aluminum Heat Affected Zone: haz={breadth, yield stress ratio}

      Example: cd ..\..\system modeler92.exe "Dow.mdl" alpshull maxbm=-1.00007E10
tol=1.0E20 steps=200 curv={0.00001,0} shear={0,0,0} plateinit={0.001,0.01}
stiffinit={0.01,0.2} haz={0.5,0.3}"

15.2 Programming

MAESTRO exposes the results file (*.rlt) through COM interfaces.  Two samples, on written
in C# and one written in VC++6 are provided in the Models and Samples/Advanced/
Programming directory.

MAESTRO also provides an example program in C# that shows users how to compare 

15.2.1 Read Results

MAESTRO offers extensive post-processing functionality.  However, there are specific
needs a user may have that is not included in the product.  To assist the user in extracting
results, MAESTRO exposes the results (*.rlt file) through a COM interface.

To use the MAESTRO COM interface successfully you need to understand:

· C++/C# Programming

· How to access the particular data.
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Two sample programs are provided in the Models and Samples/Advanced/Programming/
Read Results directory.

15.2.2 Run MAESTRO Solver

MAESTRO offers batch processing functionality as described in the Batch Processing
section.  The batch processing described in this particular section describes how a user can
access multiple results for custom processing.  To assist the user processing multiple
entities and load case, a sample program has been provided.

A sample program, written in C# is provided in the Models and Samples/Advanced/
Programming/Run MAESTRO Solver directory.
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16 Tutorials

Much of the help file is mini-tutorial or how-to based.  The following full tutorials present a
broader range of MAESTRO features.

16.1 Creating a Mesh in Rhino

Generating a Mesh using Rhino

Preface to Creating Meshes in Rhino to be Used in MAESTRO
It  should  be  noted  that  aspect  ratio  affects  MAESTRO's  Finite  Element  Analysis  results.
Therefore, the auto-meshing procedures used in this walk-through should only be used with
MAESTRO's hydrostatics solver and MAESTRO Wave.  

The recommended procedure using Rhino is listed below: 
1. Set the model placement/orientation and units
2. Join surfaces together
3. Create mesh from surfaces
4. Join meshes (if needed)
5. Check for naked edges
6. Fix naked edges where gaps/overlaps in the geometry exist

a. “Match Mesh Edge” command
b. Manually adjust mesh vertices
c. Manually Delete/Add faces to fix mesh

7. Mirror meshes about centerline (if needed)
8. Check for naked edges on centerline; fix if necessary
9. Cull Degenerate Mesh Faces
10. Unify Mesh Normals
11. Check normal direction
12. Save mesh

Step 1. Set the Model Placement/Orientation and Units
Placement/orientation:  The  hull  should  be  oriented  with  the  X-direction  as  the  longitudinal
axis. MAESTRO interprets +Y as the up direction, so it is beneficial to also rotate the model
-90 degrees from the typical orientation of +Z as the up direction. The coordinate rotations
can also be executed in MAESTRO, however this will only rotate the model geometry; it will
not  rotate  the  module's  local  coordinate  system.  Hence,  all  coordinates  entered  into
MAESTRO will be subsequently transformed into the new orientation. 

Units: The .ply import setting in MAESTRO allows permits a change to the incoming units in
the same dialogue as the orientation. For information on available unit systems see the Help
File under Geometry/Finite Element Modeling > Defining Units. 

Step 2. Join Surfaces Together
All surfaces that are to be meshed should be joined together if possible.  This will force the
meshing algorithm to use the same points on the common edge(s) between joined surfaces
and  prevent  gaps/naked  edges  from  appearing  in  the  mesh.   Any  naked  edges  resulting
from surfaces that cannot be joined will be fixed later.  Select all surfaces to be joined and
execute the Join command or select Edit > Join from the menu.
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Step 3. Create Mesh from Surfaces
Select all surfaces to be meshed and execute the Mesh command or select Mesh > From
NURBS Object  from the menu.   A  dialog  with  the meshing parameters  will  appear  where
the user can make adjustments and preview the generated mesh.  An image of the dialog
with suggested settings for a ship (with units set to meters) is shown below in Figure 3.1:

Figure 1.3a: Suggested Meshing Parameters

In addition to this dialogue, clicking simple controls will give an option to use a slider bar and
make the process easier. Again, you may preview the meshing precision level before
creating the mesh. The listed values were found to generate a reasonable balance between
mesh density and accurate representation of the hull shape.  Additional information on
selecting parameter values can be found in the section Picking a Mesh Density, found later
in this Appendix.  Additional information on the individual meshing parameters can be found
in the Rhino Help.

Step 4. Join Meshes (if needed)
Unless all of the ships surfaces were able to be joined prior to creating the mesh, there will
be multiple meshes.  Select all meshes to be joined and execute the Join command or
select Edit > Join from the menu.  

Step 5. Check for Naked Edges
Select the mesh and execute the ShowEdges command or select Analyze > Edge Tools >
Show Edges from the menu.  The number of naked edges found in the mesh will be shown
in  the  command  window.   The  radio  button  in  the  dialog  should  be  set  to  Naked  Edges
which will be shown in the selected highlight color (usually magenta).

Step 6. Fix Naked Edges Where Gaps/Overlaps in the Geometry Exist
If naked edges are present in the mesh, there are several methods to repair them.  Three of
the methods are described below and can be used exclusively or in combination.
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a. “Match Mesh Edge” command
This is the most automated of the three methods described, but it may require some
trial-and-error  in  setting  the  DistanceToAdjust  parameter.   An  appropriate
DistanceToAdjust will depend on the mesh panel size with the value being only large
enough to achieve the desired result (e.g. try 50%-75% of an average panel edge). 
Additional  details  about  this  command  can  be  found  in  the  Rhino  help.   To  repair
specific  edges,  do  not  pre-select  the  entire  mesh.   Execute  the  MatchMeshEdge
command or select Mesh > Mesh Repair Tools > Match Mesh Edge from the menu
and  left-click  on  PickEdges  in  the  command  window  or  type  “p”  and  press  Enter.
Select the naked edge(s) to be repaired.  Below in Figures 1.6a and 1.6b are before
and after images of using the Match Mesh Edge command.

Figure 1.6a: Bulb with Mesh Discontinuity Figure  1.6b:  Bulb
after Match Mesh Edge Command

b. Manually Adjust Mesh Vertices
The user can manually adjust the locations of the mesh vertices along the naked
edge to create a point-to-point connection between the two mesh edges.  To turn on



Tutorials 575

© 2014 Optimum Structural Design, Inc.

the mesh vertices, select the mesh and use either the PointsOn command, select 
Edit > Control Points > Control Points On from the menu or simply press F10.
The mesh vertices along the naked edge can now be dragged and dropped onto
other existing vertices.  (Make sure that Object Snap for points is enabled.) Below in
Figures 1.6c and 1.6d are images of the naked edge before and after manually
relocating the vertices.

Figure 1.6c: Bulb with Mesh Discontinuity    Figure 1.6d:
Bulb after Manually Adjusting Mesh Vertices

c. Manually Delete/Add faces to Fix Mesh
The user can manually delete a row of faces along the naked edge and recreate
them either manually with the Patch Single Face command or automatically by using
the Fill Hole command.  It is easiest to select faces for deletion if viewing the shaded
model.  Meshes can be deleted by using the DeleteMeshFaces command or by
selecting Mesh > Mesh Edit Tools > Delete Mesh Faces from the menu.  Below in
Figure1.6e is an image of a naked edge where a row of faces has been deleted.
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Figure 1.6e: Naked Edge with 1 Row of Mesh Faces above Edge Deleted

For  areas  where  the  user  may  want  direct  control,  mesh  faces  can  be  created
manually using the PatchSingleFace command or by selecting Mesh > Mesh Repair
Tools > Patch Single Face  from the menu.  When prompted, the user selects two
existing mesh face edges to define a new mesh face.  If the edges share a vertex, a
triangle will be created, otherwise a quad will appear.  (Only one face is created each
time the command is run, but right-clicking in a viewport will repeat the last command
to speed up the process.)   Below in Figures 1.6f  and 1.6g are images of the mesh
being patched manually.
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Figure 1.6f: Manually Patching Figure  1.6g:
Manually Patching All the Way to the Perimeter

We  may  continue  to  mesh  all  of  the  way  to  perimeter  by  creating  individual  mesh
faces or now we may use an alternate method. We choose to take advantage of the
FillMeshHole by calling it from the command line or selecting Mesh > Mesh Repair
Tools  >  Fill  Holefrom  the  menu.  When  prompted,  select  an  edge  along  the
boundary of the hole in the mesh.  Below in Figures 1.6h and 1.6i are images of the
manually  added  face  to  enclose  the  hole  and  of  the  result  from  the
FillMeshHolecommand
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 Figure 1.6h: Closing Perimeter with 1 Mesh Face Figure 1.6i:
Mesh after Fill Mesh Hole 

Note: If a mesh edges appears to be joined and have point-to-point connectivity, but
still  reports  a  naked  edge,  this  can  normally  be  fixed  with  the  AlignMeshVertices
command (Mesh > Mesh Repair Tools > Align Mesh Vertices in the menu).  See
the  Rhino  help  for  details  on  this  command.   Just  execute  the  command,  click  on
SelectNakedEdges and then select the edge to repair.

Step 7. Mirror Meshes about Centerline and Join (if needed)
If  only  half  of  the  ship  was  modeled,  the  user  will  have  to  mirror  the  mesh  about  the
centerplane  to  create  a  closed  volume  representing  the  full  ship.   This  can  be  done  by
selecting  the  newly  generated  mesh(es)  and  typing  Mirror  at  the  command  prompt  or
selecting Transform > Mirror from the menu.

Step 8. Check for naked edges on centerline; fix if necessary
If the hull was mirrored and joined in Step 7, check again for naked edges. If the centerline
mesh edges appear to be joined and to have point-to-point connectivity, but still reports a
naked edge, this can be fixed with the AlignMeshVertices command (Mesh > Mesh Repair
Tools > Align Mesh Vertices in the menu).  See the Rhino help for details on this
command.  Just execute the command, click on SelectNakedEdges and then select the
edge to repair.

Step 9. Cull Degenerate Mesh Faces
Once all naked edges have been eliminated and the mesh forms a closed volume, select the
mesh and execute the CullDegenerateMeshFaces command or select Mesh > Mesh Edit
Tools > Cull Degenerate Mesh Faces from the menu.  This will remove mesh faces with
zero area and edges with zero length.  While the geometry will not change, there will be a
message in the command window indicating if any mesh faces were modified or removed.

Step 10. Unify Mesh Normals
Unlike joining surfaces in Rhino, joining meshes does not reset the normal direction of each
component  mesh  to  a  consistent  direction.   To  ensure  the  mesh  normals  are  consistent,
select  the  mesh  and  execute  the  UnifyMeshNormals  command  or  select  Mesh  >  Mesh
Repair  Tools > Unify  Normals  from the menu.   A  message in  the command window will
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indicate  how  many  mesh  faces  were  updated.   It  is  best  to  rerun  this  command  until  the
message  indicates:  “All  face  normals  are  already  oriented  in  the  same  direction.”   (Mesh
normals toggling back and forth  may indicate  the presence of  a  degenerate  mesh  face or
edge.)

Step 11. Check normal direction
Mesh  normals  can  be  checked  by  selecting  the  mesh  and  executing  the  Dir  command or
selecting  Analyze  >  Direction  from  the  menu.   Vectors  representing  the  mesh  normal
direction will  appear intermittently  on the mesh.   Mesh normals  should  be pointing inward,
towards hull, because MAESTRO automatically flips surface normal from Rhino. If they are
not, left-clicking on the mesh or typing “f”  on the command line with Enter  will  reverse the
normal  direction of  the mesh.   Right-clicking or  pressing Enter  at  an empty  command line
will complete the command. 

Since each individual mesh face can have its own normal direction, it is safest to check the
normal direction using shading.  To turn on shading, enter the perspective view and execute
the Shade command or select View > Shaded from the menu.  To change the color of the
backfaces, execute the Options command or select Tools > Options… from the menu.  In
the tree, navigate to Rhino Options > Appearance > Advanced Settings > Shaded.
Change the Backface settings to use “Single Color for all backfaces” and set the color to
something conspicuous like Magenta as shown below in Figure 1.11a.
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Figure 1.11a: Backface Color Settings

Again,  as  MAESTRO  auto  flips  surface  normal,  the  backface  should  be  facing  outward
(towards the water) and the entire hull should be shaded magenta. It is worthwhile to rotate
the hull and verify that all panels are magenta.
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Figure 1.11b: Backface Oriented Outwards Showing Inward Normal

Step 12. Save mesh
If  the mesh is  the only item in the model  (including hidden items or  layers that  are  turned
off),  it  can  be  saved  using  the  SaveAs  command  or  File  >  Save  As…  from  the  menu.  
Otherwise, select the mesh and execute the Export command or File > Export Selected…
from the menu.   The file  type should  be set  to “PLY –  Polygon File  Format  (*.ply)”.   After
clicking the Save button, an Export PLY dialog will appear.  In this final dialog, ASCII should
be the selected format with no additional options checked as shown below in Figure 1.12a.

Figure 1.12a: .PLY Export Settings

16.2 Midship Design Tutorial

Click here to launch the Midship Design Tutorial document.

This tutorial will walk through the complete process of creating and analyzing a midship
section in MAESTRO given a basic set of design parameters and hull geometry.  To use this
tutorial, you are expected to have a general knowledge of the MAESTRO graphic user
interface (GUI) and MAESTRO elements (i.e., substructures, modules, strakes, etc.).  If you
are not comfortable with these areas, please first review the General section of the
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MAESTRO help file.

16.3 Basic Features

This Tutorial is intended to do two things simultaneously:
· to demonstrate and explain some of the basic features and options of the Modeler, and

· to go through the steps of actually building a small model, starting with  ¼ of the engine
room of a small naval vessel.

16.4 ALPS/ULSAP

The following tutorials will walk through using and modifying an existing ULSAP model
provided in the MAESTRO distribution directory and creating an ULSAP model from scratch.
 For more information, see the ALPS/ULSAP section above.

Modifying and Using an Existing ULSAP Model

Creating a new ULSAP Model

Text Out (All Panels) Option

Modifying and Using an existing ULSAP Model

1.  Open the model UlsapSample.mdl from ...\MAESTRO\Models and Samples\ALPS
\ULSAP directory.

Note: the Modeler window appears to be empty since the model is not associated with any
visible geometry.

2.  Launch the ULSAP Evaluation Dialog from Model > Evaluation Patch > Create/Evaluate.
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3.  Select a panel from the drop-down box next to ID.

4.  Click the "Compute" button.  The following results dialog for that patch will open.



MAESTRO 11.0.0584

© 2014 Optimum Structural Design, Inc.

Creating a New ULSAP Model

1.  Open a new file from File > New.

2.  Open the Units dialog from File > Units...
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3.  From the drop-down box under Standard Unit Systems, select "SI (N,mm)" and click
Apply to Parameter Data.  This will set the units to SI using Newtowns and meters.

4.  Open the Material dialog from Model > Materials... or clicking the material icon .
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5.  Click the ID button to create a new material.

6.  Enter the following data and then click Create:

Name: ULSAP Material

Type: Isotropic

Young's Modulus: 2.04e+011

Poisson Ration: 0.3

Density(kg/m^3): 7850

Yield Stress(N/m^2): 2.35e+008

Ultimate Tensile Strength(N/m^2): 4e+008

Reduced Yield Stress at AL Heat Affected Zone(N/m^2): 2.35e+008, Right-clicking in
the value box will pop up a dialog with typical values:

7.  Open the Properties dialog from Model > Properties > Beam or clicking the Properties

icon .
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8.  Click ID to create a new beam property.  Click No when prompted whether you would like
to copy an existing property.

9.  Enter the following data and click Create:

Name: 360x12-100x15-T(mm)

Type: select "Tee"

Web Height: 0.360

Web Thickness: 0.012

Flange Width: 0.10

Flange Thickness: 0.015

Material: Select "ULSAP Material"

10.  The ULSAP Parameters can be changed by selecting Model > ULSAP Parameters.
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We will use the default values for this tutorial, so click Close.

11.  Launch the ULSAP dialog from Model > Evaluation Patch > Create/Evaluate.
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12.  Click the ID button to create a new panel.

13.  Select "User Define" under Input Data.

14.  Select "None" under Parameter Set.  If ULSAP parameters were previously defined in
step 10, you could select those here.

15.  Select the Text Output checkbox to get a complete text result. (Double-click this
checkbox for the "Text Out (All Panels)" option) 

16.  Enter the following data and click Create:

Plate

Length: 2.64

Width: 3.6
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Thickness: 0.021

Material: ULSAP Material

Initial Shape: buckling

Init. Maximum Deflection: 0.0045

Compressive Residual Stress:

Stiffener

Name: Select 360x12-100x15-T(mm)

Number: 3

Init. Maximum Deflection: 0.00264

Compressive Residual Stress:

Breadth Heat Affected Zone for Aluminum:

Load (A figure of these stress definitions can be found below)

Stress Lower: -1e+07

Stress Upper: -1e+07

Stress Shear:

Pressure:

The material and stiffener properties can be queried within the dialog by right-clicking inside
the appropriate cell.

17.  Click the Compute button to obtain the results.
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The output tab will provide a full text output of the input data and the results.

Stress Definition:
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Text Out (All Panels) Options

The Text Out (All Panels) option all generates a list of all the panels results into the Output
tab.  The results are generated when the user clicks the Compute button.  The results of the
evaluation patch are presented first and followed by the beam evaluations.

16.5 ALPS/HULL

NOTE:

The sample ALPS/HULL analysis models used in this tutorial are DryDock_1.mdl and
DryDock_2.mdl, can be found in the Models and Sample directory.  For more information,
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see the ALPS/Hull section above.

Analysis Setup

Additional Pressure Loading

Post-Processing

Creating an ALPS/HULL Model

The progressive hull girder collapse model is a hull girder cross sectional module with one
frame length.  This "one bay" module should only consist of quad and bar elements, such as
the one shown below.  The plates and webs of the longitudinal girders should be modeled as
non-stiffened quads (bare plate) while stiffeners and girder flanges can be modeled as bar
elements.  The hull girder collapse model can be generated manually or automatically from
the global model by using MAESTRO's refinement functionality.

1.  Open the sample DryDock_1.mdl, which is located in the ...\MAESTRO\Models and
Samples/ALPS/Hull directory.  You will notice that this model is a half-model, which is a
common starting point for users.  The steps below will demonstrate how to arrive to a
full-model, which is required for the progressive hull girder collapse analysis.
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2.  Create a general group of the section (i.e., one frame spacing) of interest from the global
model as shown below.  Be sure to check the "Centerline Group" box before creating the
group.  Click here to learn about creating general groups.

3.  View the newly created general group by right-clicking on the group in the Groups Tree
and click on "Set View Part."  If necessary, modify the general group to capture all the
elements participating in the progressive hull girder collapse analysis.

4.  Right-click on the general group again and choose Refine from the menu, as shown
below.  This will bring up the Model Refinement dialog box, shown in the second figure
below.
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5.  Choose the ALPS/HULL analysis type and click OK.  This will automatically convert the
existing strakes and stiffener layouts to the appropriate elements as described above and
will generate the ALPS/HULL analysis model and place it under the finemesh object in the
Parts Tree.
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6.  In the Parts Tree expand the finemesh object and right-click on the ALPS/HULL analysis
model that was generated in the previous step.  Choose Add Mirror from the menu, which
will access the Mirror dialog.
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Be sure the correct boxes are checked, as shown above.  Finally, click OK.

7.  To view the full width model, expand the finemesh folder and right-click on the fine mesh
model and "Set View Part".

Analysis Setup

Now that the full-model is successfully generated, the user can now proceed with the
ALPS/Hull analysis.  Note that the user can also add additional localized pressures.  This is
described the next section.

1.  Expand the finemesh object again if necessary and right-click on the analysis model.
Choose ALPS/HULL from the menu, which will launch the Analysis Setup dialog.
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2.  The Hull Girder Progressive Collapse Analysis Setup dialog provides several user input
fields.  For this dry-dock structure, select Sagging, enter 250 for the Number of Incremental
Loading Steps, and enter -0.0001 for the Vertical Rotational Increment.

A description of all the Hull Girder Progressive Collapse Analysis input parameters are
provided below.

Load Setup

Select either a Hogging or Sagging scenario to be analyzed as well as define the number of
incremental loading steps for the analysis.  The user can increase the number of
incremental steps if complete hull girder collapse was not obtained.  

Bending

The Vertical and Horizontal Rotation Increment represents the value at which each load step
will be executed, either in the Vertical Rotation or Horizontal Rotation plane.

Shear Force & Torsional Moment

The user can impose an initial Vertical Shear Force on the hull girder collapse analysis
model.

Plate Initial Condition
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The user can impose known initial out-of-plane deformations or residual stress.

Stiffener Initial Condition

The user can impose known initial out-of-plane deformations or residual stress.

Aluminum Heat Affected Zone

The user can define the heat affected zone for aluminum structures.

3.  When all the parameters have been defined, click OK.  When the analysis is complete,
i.e. all Incremental Loading Steps are done, the user can begin to post-process the results
(as described in Post-Processing).  At this point the user can proceed to Post-processing the
current results or can go through the steps of the next section, which address Additional
Pressure Loading.
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Additional Pressure Loading

In addition to defining global ALP/HULL analysis parameters (see above), the user has the
ability to impose local pressure loading.  If the user elects to impose local pressure loads on
the hull girder collapse model, these loads will be combined with the global analysis
parameters.  See Defining Pressure for complete details on creating and imposing pressure
loads.

The following steps demonstrate how the user can add additional internal pressure and
hydrostatic pressure to the ALPS/HULL model.  To impose this additional pressure, the user
will leverage the Surface Head method and the automatic Immersion pressure.  The user
also has the ability to leverage other local pressure loading methods such as Surface Zero
or LinPress.

If you wish to do this part of the tutorial, when you perform Step 1, you will be asked wether
you want to save the current model.  Since this is a tutorial, you should click on NO.

1. Open the sample DryDock_2.mdl, which is located in the ...\MAESTRO\Models and
Samples/ALPS/Hull directory.

2. The existing model has a total of six load cases, but the user only has the ability to
perform ALPS/HULL calculations on a single load case; therefore, the user must create a
new load case.  See Creating A Load Case for a complete description of creating and/or
modifying load cases.  Create a new load case and title it ALPS_HULL Additional Pressure.
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3. The next step will be to impose the hydrostatic pressure on the wetted elements
associated with the ALPS/HULL analysis model.  We do this by selecting the Floating
Structure load option followed by clicking Modify.  Upon clicking Modify, the loads dialog
should expose the Balance tab.  The Balance tab should have no wave (i.e. a stillwater
condition); this is shown below.  To view the hydrostatic pressure caused by the immersion,
go to the main menu and click on Load/View Pressure/Immersion (shown in the next two
figures).  The second of these figures was obtained by viewing the Wettable Elements with
the hydrostatic pressure.  To view the Wettable Elements, go to the main menu and click 
View/Wettable Elements.
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4.  Now that the hydrostatic pressure is imposed, we focus on imposing the internal
pressure.  To do this we must first create a Plate group in the area of interest.  For this
tutorial it is assumed that this is a dry-dock and it is filled to a height of 350 inches. 
Therefore the plate group will consist of all the plate elements in the inner sides and the
inner bottom of the dry-dock.  For this tutorial, name the plate group alps_hull internal
pressure.  The next figure shows the process of creating the plate group with one side and
half of the inner-bottom having been selected.  The next figure shows the complete plate
group.
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5.  After creating the internal plate group, the user can include it in the current load case
(i.e. ALPS_HULL Additional Pressure).  See Creating A Load Case for a complete
description of how to modify existing load cases.  The intent is to add the additional internal
pressure by using the  Plate(Surface Head)loading pattern.  Within the Loads dialog, open
the Plate(Surface Head) tab under the Pressure tab.

6.  Add the alps_hull internal pressure plate group and input 350 for the Head value (see
below).  Make certain to click Modify after inputting the Head value.  We are now finished
adding additional pressure.

7.  The next step is to verify the application of the Surface Head, which is done by selecting
the Loads/View Pressure/Surface Head menu item.  The model should look like the image
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below.

8.  The combined pressure load can be viewed by selecting the Loads/View
Pressure/Combined Pressure on Plate menu item.  The model should look like the image
below.  Dynamically spin the model around to view the pressure on the bottom shell.
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9.  The model is now ready to be solved and includes additional pressure.  To solve the
ALP/HULL model, go to the Parts tree, expand the finemesh object, right-click on the
general group 001 part, and then select ALPS/HULL from the menu.  Now, using the steps
described in Analysis Setup, the user can solve the ALPS/HULL model.

Post-processing

The user can review the following results from the progressive collapse analysis at a given 
Step:

· SigXX Stress to Yield Stress Ratio

· VonMises Stress to Yield Stress Ratio

· The particular Failure Mode, which are summarized in the table below:

Failure Mode Acronym Failure Mode Description

OC Overall Collapse

PB Collapse of plating between support members
(stiffeners)
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BCC Beam-column Type Collapse

SWB Local Buckling of Stiffener Web

TR Flexural-torsional Buckling of Stiffener

GY Gross Yielding

RT Rupture due to Tension

CC Crushing due to Compression

· SigXX, SigYY, SigXY, SigVM

The user can graphically plot these various values by right-clicking in the modeling window,
which will launch the menu shown below.  Once the menu appears the user first chooses the
result parameter of interest followed by the Step of interest.  The contour plot will reflect the
current selection.

The Define Range From... provides a mechanism to choose what Step first appears in the
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menu post-processing menu.  The user can also echo the complete Curvature versus
Moment results to the Output tab, which can then be plotted using 3rd party applications.

Finally, the user can animate the progressive collapse analysis, i.e. step through each

increment, by clicking the  icon.

The ALPS/HULL results can be turned on and off by checking or unchecking the
"ALPS/HULL" box in the View Options dialog.

ALPS/HULL Report

The results of an ALPS/HULL analysis can also be viewed in report form by right-clicking
during the ALPS/HULL results view and selecting Create Report...

This will launch a new window with a report of the results:
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This report can be exported to PDF, Microsoft Excel, or Microsoft Word.
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16.6 Optimization

The following tutorial will walk through an example process of optimizing a box girder
structure.

16.6.1 Defining the Model

DEFINITION OF MODEL, BOUNDARY CONDITIONS AND LOADS 

1.1 Making a Backup Copy of the Modeler File

This document shows how to prepare the input data and interpret the output for optimization
jobs.   This  document  assumes  that  you  have  already  gone  through  the  Tutorial  that  is
available through the Help button.  In effect it is a second tutorial and you are invited to open
the relevant Modeler file – ex2.mdl – and actually fill in the Dialog Boxes as shown herein. 
To do this will require deleting the existing entries in the Dialog Boxes and then re-entering
the  data.   To  safeguard  the  original  file  you  should  first  make  a  backup  copy,  say
ex2backup.mdl.  Later in the tutorial you will also want to display the output file – ex2.out –
and that is achieved from within the Modeler by going to the Main Menu and clicking File >
Analysis / Evaluation > Legacy Version of MAESTRO > View Output File.  If you do not
have this file or if it becomes corrupted you can generate a new copy by running the ex2 job,
simply by clicking on the execute button at the right end of the upper toolbar.

1.2 Description Of The Structural Model

This example demonstrates optimization of a simple but realistic  module- a rectangular box
girder with vertical and transverse symmetry, both of structure and of loading.  The structure
might,  for  example,  be  a  segment  of  a  pontoon  in  a  semi-submersible.   The  one-module
model of the structure is shown in the following figure.  If you open the Modeler file ex2.mdl
you will have a color picture of the structure.  You may wish to shrink and move the Modeler
display so that you can see it side by side with this document.  As in the earlier tutorial, you
can gain more display space by closing the Parts Tree window and hiding the Refine toolbar
(under Tools > Toolbars in the Main Menu).
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The model consists of four strakes.  To simplify the example, the maximum design value of
transverse  pressure  is  the  same  for  all  strakes.   This  means  that  the  module  has  vertical
symmetry  (about  the  half  height)  of  loading  as  well  as  of  geometry.   Because  of  this,  the
results for strake 3 should be the same as for strake 2, and the results for strake 4 should be
the same as for strake 1.

In  this  module,  there  is  a  transverse  bulkhead  at  each  end,  modeled  with  two  “additional”
panels and stiffened by two "additional" beams (as always, the word "additional" means "not
strake-related").

1.3 Boundary Conditions For Modules

In this example, the boundary forces are the bending moment and shear force that act  at  the
end of the module.  In ships and in box girder bridges this information can be obtained from a
prior and relatively simple analysis of the overall structure, because it is essentially a beam. 
This  is  not  possible  with  a  semi-submersible  because  of  the  interconnection  between
pontoons,  columns  and  deck  structure.   For  such  a  structure  the  MAESTRO  model  would,
initially at least, include however much of the structure is necessary in order to have known
boundary conditions.  This would be either the entire structure or, depending on the degree of
symmetry, one half or one quarter of it. 

In  most  applications  of  MAESTRO  this  overall  model  is  the  only  model  that  is  required.  
Since  all  of  the  modules  are  in  the  model  they  interact  fully,  just  as  in  the  real  structure.  
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Hence each module always has the correct boundary conditions. 

1.4 Boundary Forces For This Example 

The  above  explanation  is  given  because  in  this  example,  for  the  sake  of  simplicity,  the
boundary conditions for the relevant portion of the structure are assumed to be already known,
which is not the usual situation.  Normally the analysis portion of the design process would
deal with all of the modules simultaneously, such that in the analysis, and in the subsequent
module-by-module evaluation and optimization, all of the modules have the correct boundary
conditions,  automatically  and  at  all  times.   But  for  this  simple  introductory  example  we
restrict ourselves to just one module. 

The boundary loads and external pressures are: 
(1) a lateral pressure on each strake of 12 psi; 
(2) an alternating (hog, sag) vertical bending moment, for which the characteristic value

(expected  maximum  lifetime  value,  with  an  acceptably  small  probability  of
exceedance) is 1.95x108 lb-in. 

To be consistent with these loads, and to preserve their symmetry, the shear force at the ends
is taken as zero.  The program's echo print of the loads is given on pages 8-13 of the output,
which you obtain by going to  the Main Menu and clicking File  >  Analysis  /  Evaluation  >
Legacy Version of MAESTRO > View Output File.

1.5 Partial Safety Factors

The partial safety factors for this example are obtained from the American Petroleum Institute
Bulletin  2V,  "Design  of  Plane  Structures".   The  loads  described  above  correspond  to  the
"extreme service condition", for which the factors are 1.25 for serviceability limit states and
1.50 for ultimate (or collapse) limit states.  These values are specified in the criteria (page 2 of
the output).

16.6.2 Optimization Data

OPTIMIZATION DATA

This chapter shows how to use the Groups Dialog Box and the Optimization Dialog Box to
define the data needed for optimization.  

2.1 Optimization Initial Settings – Job Information Dialog Box

Before beginning any optimization task, you should always perform a MAESTRO structural
analysis on the entire model and be sure to correct all errors and serious inadequacies.  After
an analysis job in which there are no serious inadequacies, you should open the Job
Information Dialog Box from File > Analysis / Evaluation > Legacy Version of
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MAESTRO > Job Information.

The General Page in the Job Info Dialog Box is the only page that needs to be altered to
initiate the optimizer.  The Optimization radio button in the Job Type section must be
selected, which unlocks options in the lower half of the Dialog Box.  

The above figure shows that the user has told MAESTRO go through 3 design cycles.  The
checked “Final Evaluation” box tells it to perform an analysis of the final design cycle
scantlings and to put the results into the ex2.OUT file.  The checked “Save Scantlings” box
instructs MAESTRO to create a “restart” file that records the scantling values at each design
cycle for each module that is being optimized.  Restart files are explained in a later section.

2.2 Optimization Dialog Box  -  Page 1, Optimization Data And Overall Defaults

In MAESTRO the optimization is performed separately for each module.  The optimization
data is specified in two Groups: 
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1. one Standard Group  -  a module-independent group of Min/Max constraints and
other Constraint Sets which serve as default Constraint Sets for all modules,

2. any number of module-specific General Groups, containing Constraint Sets which
can selectively override the default Constraint Sets, and which can also include other
types of Constraint Sets that are not in the Standard Group.

These  two  Groups  and  their  component  Constraint  Sets  are  defined  in  the  Optimization
Dialog Box pictured below.  There is no toolbar icon for this Dialog; you obtain it  from the
Main Menu by clicking on File > Analysis / Evaluation > Legacy Version of MAESTRO >
Optimization Settings.

This  picture  shows  the  Overall  Defaults  page,  which  defines  the  overall  information  and
Constraint Set 1, which specifies the default Min/Max constraints.

2.2.1 Type of Optimization
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The  Standard  Default  button  on  the  Overall  Defaults  page  of  the  Optimization  Dialog  Box
brings up the Group Opt. Settings dialog box shown to the left.  This dialog allows the user to
define  different  Optimization  Types  for  each  of  the  module-specific  General  Groups.  
MAESTRO  can  optimize  based  on  Weight  only,  Cost  only  or  Multi-objective:  a
non-dimensional  weighted  sum  of  weight  and  cost.   The  latter  is  nearly  always  the  true
objective in structural design.  Least weight by itself (i.e. at any cost) is appropriate only for
aircraft  and aerospace  vehicles.   With  the  multi-objective  approach  the  cost  implications  of
weight  can  be  explicitly  included;  for  example,  a  weight  reduction  may  mean  more  cargo
capacity and hence more revenue.

The non-dimensional weighted sum is defined as
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where C0 and W0 are "reference" values.  These are simply typical values for the structure.  In
this example they are C0 = 131.7 K-DOLLARS  and W0 = 15.02 long tons, which are nothing
more than the starting values of cost and weight, obtained by making an Analysis run before
starting the optimization.  The units were specified in the Units page of the Job Information
Dialog Box.

The resulting non-dimensional values are combined by means of weighting parameters, P1 and
P2, which are simply fractions that add to 1.0.  In this example, for simplicity, the values are
0.5  and  0.5;   i.e.  cost  reduction  and  weight  reduction  are  given  equal  importance.   In  the
Dialog Box they are specified as percentages.

2.2.2 Discretization

MAESTRO  provides  a  feature  whereby  the  designer  can  specify  a  list  of  standard  (or
available) thicknesses, the criteria as to how round off is to be done for the various member
types,  and the desired (or  permissible)  increments  in  web depths  and flange  breadths  of  the
various member types.

During  the  optimization  process  the  design  variables  are  treated  as  continuous  variables,  in
order  to  avoid the high  computational  cost  of  discrete  variable  optimization.   But  when  the
design  is  seen  to  be  converging  the  designer  can  specify  that  the  next  run  should  include
discretization of the design variables.  In that run, the discretization will  be done during the
last of the design cycles requested for that run.  The discretization is not simply a rounding up
all of the design variables to the next standard size.  

2.2.3 Cost Function

For  structural  optimization  the  only  costs  that  are  relevant  are  those  that  are  influenced  by
scantlings.   The two types of cost that  are most  directly related to  scantlings are  the cost  of
materials  and  the  cost  of  fabrication,  and  for  these  MAESTRO  provides  the  following
"general purpose" cost function

 
NS

)C + C + C ( = Cost fgspå

where NS = number of strakes, and all of the four cost terms are on a per-strake basis.
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Stiffened Panel Cost
Csp  = cost of the stiffened panel for each strake.  In the general-purpose cost function this is

defined as

sp 1 p sw sw sf sf 2C  =   [ ABt  +  
A

d
ls ( h t  +  b  t ) +   

A

d
 lsr r

in which 

s is the number of stiffeners:

 s =  
B

b
 -  1

tp, hsw, tsw, bsf and tsf are the panel scantlings

A is the length of the module

d is the section spacing

B is the width of the strake (mean value if tapered)

l is the stiffener length in each panel (l = B if transversely stiffened)

ρ1 is the volumetric cost coefficient (cost per unit volume) for a stiffened panel

ρ2 is the lineal cost coefficient (cost per unit length of stiffener) for a stiffened panel

Girder Cost

Cg = cost of girder for each strake, given by

g g 3 gw gw gf gf 4C  =  dN  [ (h t  +  b  t ) +  ]r r

where

ρ3 is the volumetric cost coefficient for fabricated beams

ρ4 is the lineal cost coefficient for fabricated beams

gN  =  
A

d
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Ng  is the number of girder segments (elements) in the current strake;  if  no elements are
deleted this is

Frame Cost
Cf = cost of the frames for each strake, given by

f f 3 fw fw ff ff 4C  =  N  B [  ( h t  +  b  t ) +  ]r r

where Nf is the number of frames per strake.

2.2.4 Cost Coefficients

The  above  function  contains  four  coefficients,  ρ1,  ρ2,  ρ3  and  ρ4.   Their  default  values  are
defined in the Module Opt.  Settings Dialog Box, and alternative values can be specified for
individual  strakes.  The lineal (cost per unit length) coefficients would reflect such items as
welding costs and would influence the optimum number of stiffeners in each strake of plating.
  These  coefficients  might  vary  according  to  which  shipyard  is  building  the  ship.   For
example, one shipyard might have more automatic welding machines so that its cost per unit
length of stiffener weld might be cheaper than at another shipyard.  In this case, the optimum
design would probably have more stiffeners and less steel than at another shipyard with higher
welding costs.

Note that for optimization there is no need for absolute values for the coefficients;  they need
only have the correct relative magnitudes.

In this  example the cost  unit  is  K-DOLLARS ($1000)  but  this  is  arbitrary.   The volumetric
cost  coefficient  will  therefore  be  in  units  of  K-DOLLARS per  in3.   Let  us  say  that  a  rough
"order of magnitude" figure for steel cost (including handling and other costs that are related
to the amount of steel) is $1.75 per pound.  Translating to the example units gives $0.50 per
in3  or  0.0005 K-DOLLARS per  in3.   Similarly  let  us  say  that  a  rough  "order  of  magnitude"
figure  for  welding  costs  is  $6.00  per  inch  of  weld,  which is  0.006  K-DOLLARS per  inch.  
These values are inserted as the volumetric and lineal cost coefficients in the first page of the
Dialog Box.  The cost function allows for different values to be used for rolled "panel line"
members  (plating  and  stiffeners)  and  fabricated  members  (frames  and  girders)  but  for
simplicity we here use the same values for both.

2.3 Constraints Imposed Directly On Design Variables

In  addition  to  the  inbuilt  constraints  relating  to  structural  failure  and  other  limit  states,
MAESTRO  allows  the  designer  to  specify  any  number  of  other  constraints  directly  on  the
design  variables.   These  constraints  arise  from  many  factors  such  as  avoidance  of  local
failures, production and fabrication considerations, and operational requirements.

There are three types of such constraints:
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A.  those  involving  only  one  design  variable  and  which  specify  a  minimum,  and/or  a
maximum value for it, or a fixed value for it;

B. those involving a pair of design variables and which impose a linear relationship (equality
or inequality) between them.

C. those which "freeze" any number of design variables to the values that have already been
assigned to them in the finite element data.

NOTE: It is mandatory that all design variables either be assigned a fixed value,
be "frozen", or have minimum and maximum values specified for them.

The  default  minimum/maximum  constraints  are  always  specified  in  the  first  page  (Overall
Defaults) of the Dialog Box and they constitute Constraint Set 1 of the optimization data.  The
proportionality constraints are defined in the second page of the Dialog Box. In this example
they are all defined in Constraint Set 2.

The  “acronym”  button  at  the  lower  right  of  the  Dialog  Box  provides  a  pop-up  list  that
explains the various acronyms.  
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In this example the minimum values of flange width (8 inches for the frames and 9 inches for
the girders) are chosen not because of fabrication but rather to prevent flexural-torsional (or
lateral-torsional) buckling for these members.  This is more than just  a local type of failure,
and  in  the  future  it  will  be  added  to  those  limit  states  which  are  examined  explicitly  by
MAESTRO.  The stipulation of a minimum value (which might depend on the member length
and  other  factors)  is  more  typical  of  code  based  design,  and  this  example  shows  that,  if
desired, the requirements of such codes can be incorporated into the constraint set. 
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2.4 Optimization Dialog Box – Page 2, Other Constraint Sets

The  first  page  –  Overall  Defaults  –  defines  only  the  default  min/max  constraints  and  these
always constitute Constraint Set 1.  The rest of the constraints are defined in the second page,
labeled  Constraints.   The  following  figure  shows  the  second  page,  with  Constraint  Set  2
selected  (in  the  ID  box)  and  after  clicking  on  the  Girder  tab.   Each  new  Constraint  Set  is
created by clicking the ID button and then clicking on Create.  Then you go to the subpages
(Plate, Girder, Frame, Other)  and define the constraints that make up  that Constraint Set.  As
you  define  them  you  should  click  on  Modify.   As  a  minimum  you  must  click  on  Modify
before leaving a subpage or your definitions will be lost. 
 

The  constraints  of  Constraint  Set  2  all  impose  limits  on  the  proportions  of  individual
members  and  on  the  relative  sizes  and  thicknesses  between  members,  in  order  to  ensure  a
balanced and buildable structure.  Most of the constraints are direct proportions, with the left
hand  side  being  a  simple  ratio  and  the  right  hand  side  being  the  limit  value  (V1).  
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Double-click  in  the  Operator  cell  to  toggle  between  min/max,  >,  =  and  <.   Some  sample
constraints  are  given  in  the  Girder  subpage  shown above.   The  first  constraint  prevents  the
height  of  the  girder  web  from being  more  than  50  times  the  web  thickness,  to  prevent  web
buckling.   The  second  constraint  requires  that  the  girder  web  height  must  be  at  least  10%
larger than the frame web height, in order that the flanges do not intersect, thereby avoiding a
complicated  welded  joint.   The third,  fourth,  fifth  and  last  constraints  involve  both  a  lower
and an upper limit on a ratio (V1 and V2).  The second to last constraint prevents the stiffener
web  thickness  from  being  more  than  twice  the  thickness  of  the  plating,  because  a  large
difference in thickness causes an unbalanced heat input during welding. 

If a fixed value is to be imposed this may done by means of an equals sign.  For example,  if it
was desired to fix the girder web thickness at 0.25 inches,  this  could be done by adding the
following line

TGW = 0.25

An alternative is to “freeze” any design variable to its current value.  For constraints in which
the left hand side is a design variable, “freeze” is an additional operator, as shown in the first
line of the above figure.

The  Frame  and  Stiffener  subpages  are  similar  to  the  Girder  subpage,  whereas  the  Other
subpage  allows  the  definition  of  more  complicated  constraints  on  the  design  variables,  and
some special constraints relating to the entire module.  Examples are given in the following
figure.

The first constraint illustrates the more general form that is available.  This constraint requires
that  the  total  height  of  the  cutout  in  the  frame  web  for  the  stiffener  penetration  must  not
exceed 70% of the frame web height.  The height of the cutout is taken as the stiffener web
height plus a semicircle 1 inch in radius.  The constraint is then

hsw + 1.0 < 0.7 hfw

In the data input the two design variables must be on the left hand side and the constant term
on the right hand side.  Hence the MAESTRO form of the constraint is

0.7 HFW - 1.0 HSW > 1.0
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The  above  figure  shows  the  Other  subpage  after  the  frame  web  cutout  constraint  has  been
generated by the following 9 steps.  If you actually perform these steps you will be generating
a new fourth line of data, and the 10th step will Remove it.

1. Click on Add.  A new blank line appears in the List Box.
2. Click in the Coef. #1 cell and type in 0.7
3. Double  click  in  the  first  Variable  cell  to  get  a  drop-down  list  of  variables.   Scroll

down and select HFW.
4. Define  the  first  operator.   You  can  toggle  through  the  three  operators  by  double

clicking. Double click on the + symbol to change it to -.
5. Double click in the second Variable cell to get a drop-down list of variables.  Scroll

down and select HSW.
6. Click in the Coef. #2 cell and type in 1.
7. Go to the second operator cell, toggle (double click) until you get the > symbol.
8. Click in the RHS cell and type in 1.
9. Click on Modify.
10. Since we don’t want this line, click on Remove.

2.5 Data Concerning Module-Related Load Effects

2.5.1 Module Level Design Limits (Constraints)

As shown in the next figure,  this  example contains two constraints that  pertain to the entire
module rather than to an individual strake.

(1)  Minimum required value of moment of inertia of the module (MIN.IMOD)
Here the limit or constraint is some maximum permissible value of module deflection due to
vertical bending.  Such a limit is unlikely to be relevant for a pontoon, but naval vessels can
have such limits arising from radardirected guns, and in aircraft structures such limits are
universal and are dominant in the design.  Therefore, in order to demonstrate how MAESTRO
can accommodate such a limit, the pontoon will be required to have a moment of inertia of at
least 3.0x105 in4.  This is specified in the "MIN.IMOD" line of the Other subpage. 

(2)  Minimum required value of section modulus of the module (MIN.ZMOD)
This  constraint  limits  the  maximum  stress  due  to  vertical  bending  of  the  module.   For
example,  a ship's  hull  is  subjected to long term cyclic  bending due to  waves,  and it  may be
desired to limit the cyclic stress to avoid fatigue.   In this  example the module is  required to
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have a minimum section modulus of 15000 in3.  This value is specified in the "MIN.ZMOD"
line of the Other subpage.

The  above  figure  shows  the  Other  subpage  after  the  MIN.IMOD  and  the  MIN.ZMOD
constraints have been defined.  The first  of these was generated by the following six steps.  
Again, if you perform these steps you will be generating a new line, and the 7th step will delete
it.

1. Click on Add.  A new blank line appears in the List Box.
2. Click on Coef. #1 and type in 1
3. Double  click  in  the  first  Variable  cell  to  get  a  drop-down  list.   Scroll  down  and

select MIN.IMOD.
4. Double click on the > symbol to change it to =.
5. Click in the RHS cell and type in 300000.
6. Click on Modify.
7. Since we don’t want this line, click on Remove.

2.5.2 Dual Level Optimization

Some  loads  and  load  effects  involve  the  entire  structure  -   for  example,  the  hull  girder
bending, shear and torsion of a ship hull.  These load effects cannot be controlled adequately
by a local resizing of a few structural members, but rather by the coordinated resizing of all of
the  members  that  make  up  the  cross  section  of  the  ship.   In  MAESTRO  terminology,  it
requires  a  coordinated  resizing  of  all  of  the  strakes  that  make  up  the  cross  section  of  the
module.  Likewise, many of the more serious types of structural failure are caused principally
by these overall load effects.  For example, one of MAESTRO’s failure modes for a stiffened
panel is Panel Collapse, Membrane Yield (PCMY).  Of course in its scope this failure mode
relates  to  (occurs  in)  individual  panels,  and  for  this  reason  it  is  checked  as  part  of  the
strake-by-strake analysis and adequacy evaluation.  But if a panel was found to be inadequate,
it  would  be  inefficient  to  cure  the  problem  only  by  a  local  strengthening  of  that  panel.   In
order to achieve an optimum solution all such panels must be redesigned simultaneously, and
the  optimization  must  account  for  the  influence  that  the  redesign  has  on  the  overall  load
effect.  In other words, the requirement (constraint) that such failure must be cured is part of
the module level optimization problem, in which the variables are the strake sectional areas. 
At this second level of optimization MAESTRO determines the precise distribution of strake
areas  that  best  (optimally)  satisfies  the  PCMY  constraint  and  all  other  module  level
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constraints.  Consequently, for any structure in which the module level load effects, combined
with other load effects,  might be sufficient  to cause membrane yield of plating,  "dual level"
optimization should be used.  This is  done by inserting the keyword "DUAL" as part of the
"Further  Constraints"  data.   Alternatively  if  the  input  data  includes  either  of  the  other  two
"module  level"  limit  states  (MIN.IMOD  and  MIN.ZMOD)  then  MAESTRO  automatically
uses  dual  level  optimization.   (To  give  the  designer  maximum  flexibility,  the  PCMY
constraint does not automatically invoke dual level optimization.)

2.5.3 Nullifying a Structural Limit State

The Limit States subpage allows the designer to “nullify” a structural failure mode, which
means that MAESTRO will ignore any inadequacy that might occur due to that failure mode,
and that Limit State will not influence the optimization.  Obviously, this should only be done
when the designer is certain that the inadequacy will be dealt with by some other means,
outside of the optimization process.  In the Limit States subpage, double clicking to the right
of a limit state acronym will generate a “nullify” tag.

2.6 Defining Constraint Sets That Are Strake-Specific

Thus far the Constraint  Sets  that  have been defined are  intended to  be used for  all  strakes.  
Therefore,  when  we  come  to  the  third  page  of  the  Dialog  Box,  they  will  be  placed  in  the
Standard Group.  But it often happens that there are some strakes for which we want to define
some  special  (different)  data,  such  as  a  special  constraint.  To  do  this  we  create  a  new
Constraint Set in which we define that new data.  Then, when we come to the third page of
the Dialog Box, we will  place that Constraint  Set  in a “General  Group” which is  associated
with those strakes.
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For  example,  the  above  figure  shows  a  new  Constraint  Set  (number  3)  in  which  there  is  a
constraint  that  the  stiffener  spacing must  not  be  less  than  12  inches,  as  might  be  needed  to
accommodate  automatic  welding  machines.   The  Breadth  Between  Stiffeners,  BBS,  is  an
alternative design variable to the number of  stiffeners,  STF.   The following four  steps  were
used to create this Constraint Set.  If you want to create it yourself then you must first delete it
by  using  the  down-arrow  to  select  Constraint  Set  3  and  clicking  on  Delete.   Then  do  the
following:

1. Click on the ID button to generate a new Constraint  Set,  having the next available
ID number.

2. Go to the line labeled Breadth Between Stif. and toggle (double click) the Operator
until the > symbol appears.

3. Click in the cell under V1 and type in 12.

4. Click on Create.  If  you make any subsequent changes,  be sure to click on Modify
before leaving the page.

Later (in the third page of the Dialog Box) when we assign the Constraint Sets to Groups, we
will include Constraint Set 3 in a Group that refers to the strakes for which this constraint is to
be imposed.  These will be strakes 2 and 3, which are the side strakes in the structure.

2.7 Using General Groups to Identify Modules and Strakes

The Standard Group of constraint sets is a module-independent group which serves as a
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default group for all modules.  We also need a way of identifying individual modules, and
strakes within those modules, for which we want to associate some module-specific (or
strake-specific) constraint sets.  In this example we want to associate constraint set 3 – the set
containing the BBS > 12 constraint that we just defined – with strakes 2 and 3 of module 1.
We identify these modules by means of the Group Dialog Box, and the button for that is near

the bottom of the Pre-Processing Toolbar, with a picture of thre stacked blocks.   Click on
this to open the Dialog Box and you will see that one of the types of groups is the
General group.  Click the General tab and then click the down-arrow in the ID box and
select group 1.  This will fill the List Box with the two strakes of module 1 that constitute
General Group 1, as shown in the following figure.

 
 To see how this group was defined let’s make a second group, using the following steps:

(1) Click the ID button to get the next ID number (002)
(2) Click the Full Strake/Full Compound check box, since we want to specify all of

strakes 2 and 3
(3) Click anywhere in the List Box and then move your cursor to the model and click on

the two side strakes of the structure (strakes 2 and 3).  They will disappear to
confirm that they have been selected.

(4) Normally at this point you would click on Create and then on Close, and you would
have created a second General Group consisting of strakes 2 and 3 of module 1.  But
since we already have General Group 1 we don’t want this second group, so click
only on Close.

(5) Re-open the Optimization Dialog Box.

2.8 Optimization Dialog Box  -  Page 3, Creating Groups Of Constraint Sets

As noted earlier, optimization is performed separately for each module.  The optimization
data is specified in two Groups: 
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1. one Standard Group  -  a module-independent group of Min/Max constraints and
other Constraint Sets which serve as default Constraint Sets for all modules,

2. any number of module-specific General Groups, containing Constraint Sets which
can selectively override the default Constraint Sets, and which can also include other
types of Constraint Sets that are not in the Standard Group.

The association of Groups and Constraint Sets is done in the third page of the Optimization
Dialog Box, with “Structure” as its tab.  In the first box you select which type of group
(Standard or General) and in the second box you select, one by one, which  Constraint Sets
are to be in that group.  The next figure shows the completed Dialog Box.  

If you want to create this data yourself you should clear the six lines by highlighting them and
clicking on Remove.  Then recreate them as follows: 

1. In the first box select Standard
2. In the second box select Min/Max
3. Click on Add, which generates the first line in the List Box, saying that Min/Max is

the first Constraint Set in the Standard Group.
4. In the second box select Constraint Set 2
5. Click on Add, which generates the second line in the List Box, saying that

Constraint Set 2 is the second Constraint Set in the Standard Group.  This completes
the Standard Group.

6. In the first box select General Group 1.  This is the group that was defined using the
Groups Dialog Box, and it consists of strakes 2 and 3 of module 1.

7. In the second box select Min/Max
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8. Click on Add, which generates the third line in the List Box, saying that Min/Max is
the first Constraint Set in General Group 1.

9. In the second box select Constraint Set 2
10. Click on Add, which generates the fourth line in the List Box, saying that Constraint

Set 2 is the second Constraint Set in General Group 1
11. In the second box select Constraint Set 3 (recall that this was BBS > 12)
12. Click on Add, which generates the fifth line in the List Box, saying that Constraint

Set 3 is the third Constraint Set in General Group 1
13. In the second box select LOCAL
14. Click on Add, which generates the sixth line in the List Box, saying that the LOCAL

option is the fourth Constraint Set in General Group 1.  This means that the strakes
defined in General Group 1 (the side panels, strakes 2 and 3) will have only Local
optimization (not Dual Level optimization).

15. Click on Apply, to preserve this definition of these two groups.  This is like the
Modify button in other Dialog Boxes.

2.9 Choice of Initial Values of the Design Variables 

With MAESTRO the initial scantlings are arbitrary.  They do not need to satisfy all 
or  indeed any  of  the  constraints.   But  it  is  preferable  to  select  values  that  at  least
appear  to  be  reasonable,  because  to  do  otherwise  increases  the  number  of  design
cycles  required for  convergence.   If  anything  it  is  best  to  be  conservative,  because
convergence  is  slightly  faster  from  the  feasible  side.   A  good  approach  is  to  use
whatever  values  may  be  available  from  existing  similar  structures,  and  to  make  a
"best  estimate"  for  the  other  values.   In  fact,  the  latter  provides  an  interesting  and
challenging opportunity to try out one's "design eye", and to then gauge its accuracy
from the extent of MAESTRO's changes  either an improvement in the measure of
merit  due  to  the  optimization,  or  the  identification  and  correction  of  any
inadequacies in the starting design, or both.

Oftentimes, from experience with a given type of  structure  it  is  known beforehand
that  a  particular  limit  state  is  likely  to  be  one  of  the  governing  constraints  in  the
design.  For example,  some ship structural  design rules require  a  certain minimum
value  of  section  modulus,  and  for  some  ship  types  this  requirement  is  one  of  the
governing constraints.  In such cases a common technique in rulebased design is to
first  obtain  member  sizes  that  satisfy  the  local  strength  rules  (which  are  relatively
straightforward)  and  then  to  "scale  up"  the  design  until  it  just  satisfies  the  overall
strength rules, such as minimum section modulus of the structure.  This is about the
best that rulebased design can do;  to do more would require the calculation of the
load effects (stresses, etc.) and of all of the limit values of the load effects, and both
of these tasks require a computer. 

One  of  the  aims  of  this  example  is  to  illustrate,  qualitatively,  the  savings  that
rationally  based  design  can  achieve  compared to  rule  based  design.   Therefore  the
starting design will be a typical "good" rulebased design  one which just fulfills any
governing  overall  (i.e.  module  level)  constraints.   The  relevant  constraint  is  the
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minimum  section  modulus  requirement,  the  second  of  the  two  module  level
constraints discussed earlier.

2.10 Running the Job and Viewing the Output File

We are now ready to run the job.  The progress of the job, and later the job output
file,  will  be  displayed  in  the  Output  pane  of  the  Modeler  display,  which  can  be
viewed by clicking on the Output tab at the bottom left corner of the display.  Then
make  the  Output  pane  larger  by  placing  the  cursor  on  the  border  between  the
Viewport  and  the  Output  pane  until  you  get  a  double-headed  arrow and  move  the
border up so that the Output pane nearly fills the entire display.

Now go to the execution toolbar (at the far right of all the toolbars along the top) and

click on the Run Coarse Mesh button    (the MAESTRO logo).

You  will  be  asked  if  you  want  to  overwrite  the  input  file  EX2.DAT.   The  usual
response is Yes, in order that the file will reflect any and all changes you have made
in  the  model  by  means  of  the  Modeler.   However,  sometimes  there  are  reasons  to
make a change to the DAT file by editing it directly, instead of using the Modeler. 
In that case you would answer No.  Click on Yes.

In the Output pane MAESTRO will display its progress as it runs through the three
optimization cycles and the final evaluation cycle that we requested (in the Job Info
Dialog  Box  –  see  Section  2.1).   When finished  it  will  ask  if  you  want  to  load  the
result.  Click on Yes.  If it asks about overwriting the ex2.rlt file, say Yes (always).  

This  loads  the  results  into  the  Modeler  so  that  the  Modeler  can  display  them
graphically.  However, most of the results of an Optimization Job are text and tables
rather than graphics, and so we first want to look at the output file, ex2.out

In the Main Menu click on Edit and then on Maestro Out.

The  output  file  consists  of  “pages”  (although  they  are  not  separated  –  it  is  one
continuous file).  Each page starts with two lines containing the Job Title and other
information, with the page number at the far right.  

Page 20 of the output shows the initial design variables.  The flange breadth of the
frames and girders is set to the minimum value required to avoid lateral  buckling. 
Here again the aim is to make the initial design be a typical "good" rulebased design,
which fulfills the requirements but not to excess. 
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2.10.1 Initial Adequacy Parameters - Strake Level

After the finite element analysis, MAESTRO's next major task is  the evaluation of
all of the strakes  calculating the 33 strakebased limit values, combining these with
the actual values to obtain the adequacy parameters and then, for each limit state and
for  each  strake,  searching  through  all  bays  and  all  loadcases  to  find  the  worst
(lowest)  value  of  each  adequacy  parameter.   The program then  prints  these  lowest
values  in  four  tables,  which in  this  example  are  on  pages  2124 of  the  MAESTRO
output.   As  mentioned elsewhere,  before  commencing  any  MAESTRO "DESIGN"
job, an "ANALYSIS" job should always be performed first  because it  does several
data checking operations that are not done in a "DESIGN" job, because of the cyclic
nature  of  the  latter.   This  example  presupposes  such  an  "ANALYSIS"  job,  which,
among other things, would have established the adequacy of all of the strakes. 

As indicated in these four tables, all of the constraints are satisfied.  On page 21 it
can  be  seen  that  one  of  the  most  important  of  them   Panel  Collapse,  Stiffener
Flexure  is well satisfied, having an adequacy parameter of 0.194.  This means that
its  ratio  of  strength/load  (or  capability/demand)  is  above  the  minimum  required
value of 1.5 (if it was right at 1.5 then the adequacy parameter would be exactly 0). 
This again shows that the starting design is already as good or better than a typical
rulebased design.  Such design does not calculate the ultimate strength of each panel
because  this  would  require  a  computer,  even  with  the  simplest  algorithm  (the
algorithm used  by  MAESTRO for  panel  strength  is  given  in  Section  14.2  of  Ship
Structural  Design).   However,  through  a  combination  of  theory  and  accumulated
experience  with  a  given  type  of  structure,  rules  can  be  developed  such  that  the
design variables which they prescribe do give an ultimate strength that is close to the
target value.

Page 24 gives the adequacy parameter values for some nonfailure constraints.  The
"area" constraint is the requirement that the strake crosssectional area be at least as
large as the value that is determined by the module level optimization, in which the
design variables  are  the strake areas.   Since  module  level  optimization  has  not  yet
occurred this constraint is not yet relevant.

The other columns in that table are not used in this example.

2.10.2 Initial Adequacy Parameters  Module Level

After the strake evaluation the program then evaluates the limit states at the module
level.

(1) PCMY  Panel Collapse, Membrane Yield 

As  shown  earlier  (page  21  of  the  output)  the  initial  design  satisfies  the
PCMY constraint for both deck and bottom.  Since this constraint actually
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belongs  to  the  module  optimization  problem,  the  PCMY  adequacy
parameters are printed again on page 25 (including, in this case, the values
for the side strakes).  The value of 0.2706 for the deck and bottom shows
that  their  von  Mises  stress,  even  after  being  multiplied  by  1.5,  is  well
below the yield value. 

(2) Minimum Required Moment of Inertia

In this example the required value is 3.0x105 in4.  On page 19 of the output
the  actual  value  is  shown  to  be  1.209x106,  and  therefore  on  page  25  the
adequacy parameter is well above zero, being 0.602. 

(3) Minimum Required Section Modulus

In  this  example  the  required  value  is  15000  in3.    The  actual  value  is
1.209×106/72  =  16,792  and  so,  as  mentioned  earlier,  the  starting  design
satisfies this constraint almost exactly, with an adequacy parameter that is
close to zero (.056, on page 25).  This shows that,  as desired,  the starting
design  is  reasonably  efficient.   Because  of  the  symmetry  the  value  is  the
same for both deck and bottom.

2.10.3 Module Optimization

Page  26  of  the  output  gives  the  results  of  the  first  cycle  of  module  optimization
under  the  heading  “Values  at  start  of  module  opt’n.  cycle  2”.   Because  the  initial
design  had  slightly  more  than  the  required  section  modulus,  the  strake  areas  have
been decreased slightly.  The program performs two cycles of module optimization. 
The program obtains the new values of TPL, HSW, TSW, BSF and TSF by scaling
the  old  values  so  as  to  match  the  new strake  area.   The  scaling  is  applied  only  to
these  five variables;  the other  nine variables  remain the same,  including those  that
could  have  contributed  to  the  strake  area  increase:  the  number  of  stiffeners  (STF)
and the girder variables.  They are never changed at the module level because their
strongest influence is on the strakebased limit states.  The program then recalculates
the  adequacy  parameters  using  the  new  panel  scantlings,  and  using  the  same  load
effects as before (the finite element analysis is done only once in each overall cycle).

2.10.4 Strake Optimization

At this point the program performs the strake optimizations, in whatever sequence of
strakes was requested.  If none was requested (as here) the strakes are optimized in
numerical  order.   The  order  is  only  relevant  if  the  "LINK"  option  is  being  used,
whereby some design variables in some strakes can be required to match, or bear a
fixed  relationship  to,  the  (already  optimized)  variables  in  other  strakes,  in  a
"masterslave" manner.
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2.11 Results Of The First Design Cycle

If the Job Type data specified the normal level of output, as in this example, there is
no  output  during  the  entire  strake  optimization  process.   When  it  is  finished  the
results are presented in three tables: 

(1) the final set of active constraints for each strake (page 27) 

(2) the new values of the module flexural properties (page 28)

(3) the  new  values  of  the  design  variables  for  each  strake  and  the
corresponding value of the objective function (page 29).

This information can be very useful since it  indicates where the design is  heading,
precisely  which  constraints  are  "driving"  it,  and  how  much  benefit  has  been
achieved.   This  gives  the  designer  some  valuable  insight  and  a  better  grasp  of  the
situation in many ways, such as a better appreciation of what is important and what
is  not.   In many cases it  also gives ideas for  improving the design in more general
ways,  such as  by adding or  deleting members,  or  by  changing  the  geometry  of  the
structure.  (As will be shown later, this occurs in the present example).  Also, some
of  the  results  may  be  different  to  what  was  anticipated,  perhaps  leading  to  the
realization that a load has been forgotten,  or  that  another  constraint  is  needed.   As
will be shown, MAESTRO's "restart" feature makes it relatively easy to make such
changes, without having to start all over from the initial design. 

In the present case there are no unusual changes and the results are quite satisfactory.
  The  objective  function  and  its  ingredients  (cost  and  weight)  have  decreased.  
Compared with the original value (1.000 on page 20) the new value (0.830, on page
29) shows a 17% improvement.  Figure 1 (the numbered figures are at the end of the
text, just before Appendix A) gives a plot of the objective, cost and weight for all of
the cycles that we will be doing.

2.12 Subsequent Design Cycles And Evaluation Cycle 

The  program  now  begins  the  second  design  cycle,  first  performing  a  new  finite
element  analysis,  then  a  new  evaluation  at  both  strake  level  (pages  30  to  33)  and
module  level  (page  34),  then  a  module  level  optimization  (35),  and  finally  the
strakebystrake  re-evaluation  and  optimization  (which  is  not  printed).   The  active
constraints are given on page 36 and the results are given on page 38.  The objective
function is now 0.790.

As requested (in the Job Information data) the program next performs a third design
cycle  (pages  39  to  47.   The  objective  function  has  converged  to  a  final  value  of
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0.782 (page 47) a change of 21.8% from the original value of 1.000.

Finally,  as  requested  in  the  Job  Information  data,  MAESTRO  performs  an
"evaluation  cycle":   a  finite  element  analysis  followed  by  an  evaluation  at  both
levels.  This should normally be requested, because it is the only way of being sure
that the results  of  the last  design cycle  satisfy all  of  the constraints.   But  this  final
evaluation also has a broader purpose.  Since the specified number of design cycles
has now been completed,  the designer  would  usually  want  to  review the  results  in
more  detail  than  before,  to  see  whether  any  further  cycles  are  required  and  to
examine  aspects  of  special  interest.   For  example,  for  some  of  the  limit  states  
especially  those that  were the active  constraints   it  may be  of  interest  to  learn  just
where in the structure each limit state has its lowest margin, and for what loadcase. 
Are several of them clustered in one location?  Do they occur in the same loadcase? 
What  particular  combination  of  load  effects  is  involved  and  what  are  their
magnitudes?   As  with  the  optimization  results,  this  type  of  information  gives  the
designer a clearer and more complete view of the structure, and may generate ideas
for further improvements.

In  order  to  provide  this  information  the  output  of  the  evaluation  cycle  is  usually
more detailed than any previous evaluation.  The precise level of detail is specified
in the Job Information data.  In this example the output is on pages 49 to 67.  (Note
that  the  stress  values  and  other  results  on  these  pages  are  superseded  by
designerspecified alterations to the structure, to be described in Section 2.13).  The
output for the additional members is on pages 68-70, and the output for the module
evaluation is on page 71.

2.13 Review of the Design 

Besides  monitoring  the  cost  and  the  adequacy  of  the  design,  it  is  important  to
examine its  principal features  what are the main changes and what constraints are
directing  the  design?   Figure  2  compares  the  initial  design  and  the  current  design
(defined  on  page  47  of  the  output)  and  Figure  2(b)  shows  some  of  the  active
constraints.  Instead of four stiffeners there are now only two (1.7 at this stage;  it is
still too early to discretize) and the plating is thicker.

2.13.1 Sample Investigation Of An Active Constraint

This  section  shows  briefly  how to  obtain  information  about  the  active  constraints,
taking the FYCF2 constraint as an example.  

The  active  constraints  are  given  on  page  45.  For  strake  1  one  of  the  active
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constraints  arising  from  a  limit  state  (or  failure  mode)  is  FYCF2,  which  means
Frame  Yield,  Compression,  Flange  (the  R  prefix  simply  means  it  was  active
repeatedly).   For  a  frame  failure  mode  the  number  at  the  end  is  always  1,  2  or  3,
signifying the worst location: strake edge 1, strake edge 2, or the middle.  Therefore
FYCF2  means  that  the  relevant  location  (the  place  where  the  total  compressive
stress  (axial  +  bending)  in  the  frame  flange  has  reached  (approximately)  the
maximum permissible value of Y/1.25) is at strake edge 2. Since there is a bracket at
this edge, the precise location is at the toe of the bracket.

The required information can be obtained from the evaluation cycle output for strake
1: pages 49 to 52.  For example, the summary on page 52 shows that for the FYCF2
limit state the relevant section is section 2 and the relevant loadcase is  2.   Turning
back to this section and loadcase on page 50, the value of the bending moment at the
bracket toe at strake edge 2 (the second of the three values) is seen to be 3.778E05. 
The bending moment value at the far right, MFBKT2, is the value at the junction of
the  flexible  length  and  the  rigid  length  (see  Section  8.6  of  reference  1).   This  is
larger than the value at the bracket toe, but since it is within the bracket it is not used
in  optimizing  the  frame.   But  it  is  supplied  by  MAESTRO  so  that  it  can  be  used
later, in designing the bracket.  The output also gives the frame stresses.  The stress
in the frame flange (axial + bending) is ASIGFF2 = 11,230 psi and the shear stress
in the web is TAUF2 = 12,320 psi.  Together these cause the frame flange to be just
at  the maximum allowable  stress  condition,  which is  80% of yield (p.s.f.  = 1.25).  
For that reason the FYCF2 adequacy parameter is exactly zero (page 52).

2.13.2 Individual Influence of the Active Constraints

The  first  eight  active  constraints  (page  45)   two  “minimum”  and  six
“proportionality”  are all explicit functions of the design variables, and so they can
be  shown  directly  on  Figure  2(b)  as  the  "governing  dimensions"  of  those  design
variables.  The constraints relating to structural failure do not have any such explicit
relationship,  but  it  is  clear  from  the  nature  of  each  of  them  that  FYCF2  would
mainly control the frame web height, and PSPBL and AREA would mainly control
the number and height  of  the stiffeners  and the plate thickness.   The R in  front  of
PSPBL, FYCF2 and AREA indicates that  the constraint was “repeated” (i.e.  was a
strong influence).

2.14 Example Of Design Modification  Deletion Of Girders

Inspection of Figure 2(b) reveals an interesting fact: the girder is as small as it  can
possibly be.  The girder web is as small as it can be (10% higher than the frame web,
and a thickness that is 1/50 of the height) and the flange is at minimum breadth (the
9 inches required for flexuraltorsional buckling) and minimum thickness (limited by
the 1:25 proportion).  Also, none of the girder limit states was an active constraint,
and all of the girder adequacy parameters are well above zero (page 52 for strake 1).
 It therefore appears that the girders may not be needed.
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This possibility was investigated by deleting the girders.  However, it is important to
note that any change in the number of strakes or the number of girders requires that
the  optimization  job  be  performed  again,  from  the  beginning  (cycle  number  1)  in
order that the restart file has the correct number of strakes and girders.  The job can
be repeated for  the  same number  of  design  cycles,  or  if  the  convergence  had been
slow or rapid, for more or fewer cycles.

Another  important  consideration is  that  up to  now all  of  the  text  of  this  document
refers to the output of the original job (EX2.OUT) and so we certainly do not want
to overwrite that file.  Therefore we will now create a new  Modeler “mdl” file by
copying and modifying the model in the following steps:

(1) Create a new model by going to the Main Menu,  clicking on “File  /
Save  As”,  entering  ex2_no_girder  as  the  file  name  and  clicking  on
Save.  

(2) Delete the girders by going to the Strake Dialog Box and for strakes 1
and 4 uncheck the “Enable Girders” check box and click on Modify.

(3) To avoid confusion between the outputs of the original model and the
“no  girders”  model,  it  will  be  helpful  to  change  the  job  title  to
ex2_no_girder, because the title is printed at the top of each page.  Go
to  the  Job  Information  Dialog  Box  and  replace  the  existing  title  by
ex2_no_girder.

(4)
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(5) Also  in  the  Job  Information  Dialog  Box,  specify  that  a  restart  file
should  be  generated  by  checking  the  Save  Scantlings  check  box,  as
shown in  the  next  figure  it  is  probably  already  checked).   Keep  the
number  of  design  cycles  at  3  so  that  the  new  restart  file  has  all  3
cycles.  Click OK.

Now we must run MAESTRO in order to create the new restart file, consistent with
the deletion of the girders.  That is, we are repeating the first three cycles, but with
no girders.

(6) Click on the “execute” button at the far right of the upper toolbar (the
MAESTRO logo).  When asked about overwriting click Yes because
we have changed the model (no girders).
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2.15 Job No. 2  (Restart:  Cycles 4 And 5) - No Girders

A restart file is a file created by MAESTRO (if requested, as we just  did) for  each
module  that  is  currently  being  optimized.   Each  restart  file  contains  the  initial
scantlings and the new scantlings that are obtained in each design cycle. Each restart
file  has  the  name  jobname.sMN,  where  MN  is  the  cumulative  module  sequence
number,  numbering all  the modules  sequentially  among all  the  substructures.   The
new (and consistent) restart file that we just created is ex2_no_girder.s01.  

Once a (consistent) restart  file has been created,  the optimization can be continued
from  any  of  the  previous  cycles  that  have  been  performed.   The  user  specifies  a
restart run through the Job Information Dialog Box, and the modeler automatically
pulls the chosen scantlings from the restart file.  To make a restart run, open the Job
Information Dialog Box and check the “Scantlings Available” box, as shown in the
next figure.  This will cause the Restart box to be changed from gray to white, and
you can enter the starting cycle.  For example the next figure shows that the second
run will  started  from the  latest  (cycle  3)  design.   Enter  the  number  of  new  design
cycles  in  the  Design  Cycles  box.   In  the  next  figure  a  further  two  cycles  are
specified, plus an evaluation cycle.
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NOTE: After deleting the girders it would have been easier to simply rerun the job
from the beginning, for the full 5 cycles; i.e. ignore the Restart Cycles box
(leave it at zero) and in the Design Cycles box click the up arrow to obtain
the number 5.  Then there would be no need to create a new restart file for
the first three cycles; it  would have been created as part of the restart  file
for  the  5-cycle  job.   The  only  reason  for  restarting  from  cycle  3  was  to
demonstrate  how  to  restart  a  job  from  any  cycle,  rather  than  starting  all
over.   For  a  full  ship  model  this  can  save  a  considerable  amount  of
execution time.

Before making a restart run the designer can make further changes to the model, as
long  they  do  not  change  the  number  of  strakes  or  the  number  of  girders.   For
example changes could be made to  the loads,  the optimization constraints,  and the
objective function.

Run the restart job.  This starts with the results of cycle 3 and produces cycles 4 and
5.   You will  be  asked  about  overwriting  ex2_no_girder.DAT.   That  DAT file  was
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made when we repeated the first three cycles.  We now want to do cycles 4 and 5,
and so we do need to update the DAT file.  Click Yes.

We  will  now  look  through  the  output  of  this  second  job,  which  is  the  file
ex2_no_girder.OUT.

Open the output file by going to the Main Menu and clicking on Edit / MAESTRO
Out.  If necessary enlarge the Output pane by dragging its upper boundary upward. 
Right click and select Find.  Enter “objective function” and click on Find Next.  This
will take you to page 19 of the output which has a table of scantlings at the start of
cycle 4 (a restart job maintains the original cycle numbering).  The scantlings are all
the same as at the end of the third cycle of the first job, except that there are now no
girders.  Therefore  the  weight,  cost  and  objective  function  are  all  less  than  before.
For example the objective function is now 0.753 compared to 0.782 before, or about
3% less.

As  can  be  seen  in  Figure  1,  this  3%  savings  is  reflected  in  both  the  cost  and  the
weight,  because  they were given equal  importance.   Most  of  this  savings is  due to
the elimination of the girders.   (In reality the savings in  cost  would be still  greater
because of the elimination of the connections between frames and girders, which is
not considered in the simple cost function being used here).

The  results  of  design  cycle  5  are  given  on  pages  35-37.   There  are  now  only  10
active constraints (page 35) because there are only 10 design variables.   As shown
on page 37, the objective function is now 0.748, only slightly less than the starting
value, and so we conclude that the optimization has essentially converged.

The  Final  Evaluation  results  are  given  on  pages  38-54.   Page  55  is  the  histogram
from  the  evaluation  cycle,  showing  that  all  but  two  constraints  are  satisfied.   The
table on page 51 shows that they are PYCF in strakes 1 and 4, and that the adequacy
parameter is very small, being only -0.012.  This result verifes that the girders were
indeed not needed.  

Up  to  five  modules  can  be  optimized  at  once,  but  because  a  typical  module  is  in
itself  a  rather  large  structure,  with  many  design  variables  and  involving  a  large
amount  of  information,  it  is  recommended  that  only  one  or  two  modules  be
optimized at one time.  Once a module has been sufficiently optimized (usually in a
series  of  runs,  each  having  any  number  of  design  cycles  and  restarting  from  the
results of any previous cycle) two final steps are needed:

(1) the General Group for that module should be removed from the List Box on the
Structure page of the Optimization Dialog Box. 

(2) the final scantlings should be copied from the restart file of that module using a
text  editor  (as  explained  in  the  next  section)  and  pasted  into  the  job  data
(jobname.DAT) in place of the original scantlings.  

The  optimization  process  is  then  repeated  for  another  one  or  two  modules,  again
involving a series of runs.
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2.16 Job No. 3 (Restart:  Cycle 6) Discretize At End

From  the  plots  of  Figure  1,  it  can  be  seen  that  at  this  point  (end  of  cycle  5)  the
optimization  process  is  close  to  convergence  and  hence  it  is  time  to  discretize  the
design variables;  i.e. to convert them to standard sizes.  During most of the design
cycles, MAESTRO deliberately treats all design variables, including the number of
stiffeners, as continuous variables, in order to avoid the enormous computation and
complexity  of  discrete  variable  optimization.   This  also  has  the  advantage  of
allowing the designer to see what the idealized optimum is, and thus perhaps obtain
new ideas  regarding  the  degree  of  standardization  and  commonality,  or  at  least  be
better able to guide and direct the discretization process. 

In  the  DAT  file  the  input  data  for  discretization  consists  of  a  list  of  available
thicknesses,  the  roundoff  fractions  and  the  size  increments.   This  information  is
supplied in the DISCRETE data group, at the beginning of the optimization data. At
present the Modeler does not yet have a Dialog Box for the user to enter this data. 
Instead it  has just one box for entering a fixed increment in plate thickness,  and in
producing the DAT file it simply adopts the default values for all other items in the
discretization data. If you want to use other values you must edit the DAT file and
type them in.  Editing the DAT file is similar to editing the OUT file – in the Main
Menu click on Edit  /  MAESTRO Dat and the Modeler  will  bring up the DAT file
using the Notepad editor.  The format for typing the  discretization data is given in
Appendix A, taken from the Data Preparation Manual.

In a DESIGN job for which discretization is requested, it is performed as part of the
last design cycle, and the subsequent evaluation cycle then provides a check that the
resulting  scantlings  still  satisfy  all  of  the  constraints.   The  discretization  is  not
simply a rounding up all of the design variables to the next standard size.  Rather it
consists of six cycles, which are referred to as "rounds" in order to distinguish them
from  design  cycles.   Each  round  begins  with  the  rounding  off  (up  or  down,
according to the roundoff fractions specified by the designer) of a further one, two or
three  design  variables,  followed  by  a  full  optimization  of  the  remaining  free
(undiscretized)  variables.   In  this  way,  if  a  design  variables  is  rounded  down  the
remaining  free  variables  will  adjust  themselves  so  as  to  prevent  whatever  slight
degree of inadequacy might otherwise occur.

We now want to perform one more cycle of optimization, starting with the results of
cycle 5 and obtaining discretized results.  In Job No. 2 (labelled ex2_no_girder and
consisting of cycles 4 and 5) we did not make any changes to the structural model. 
Therefore we have a restart file (ex2_no_girder.s01) that is valid and complete, and
we could now perform a 6th cycle using the same Modeler file (ex2_no_girder.mdl). 
In the Job Information Dialog Box we would enter 5  in  the Restart  Cycle box and
enter 1 in the Design Cycles box (to do one more cycle).  
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However,  if  we  did  use  the  same  Modeler  file  then  the  previous  output  file
(ex2_no_girder.OUT) would be overwritten and the page numbering would change.
 We  don’t  want  that  because  this  tutorial  has  referred  to  some  of  those  pages.  
Therefore we will make a new  Modeler file and then enter the data for cycle 6, as
follows:

(1) Go to the Main Menu, click on “File /  Save As” and enter ex2_cycle6 as the
file name.  Click on Save. 

(2) Since the job title is printed at the top of each page we should also change it to
ex2_cycle6.   Go to  the Job Information Dialog Box and in  the  Job  Title  box
replace ex2_no_girder by ex2_cycle6.

(3) In that same Job Information Dialog go to the Restart Cycle box and click the
up arrow twice to change 3 to 5.  The go to the Design Cycles box and change
2 to 1 (to do just one more cycle).

(4) Click on OK.

(5) Bring up the Optimization Dialog Box (Model / Optimization) click on Group
Opt.  Settings.   In  that  Dialog  Box  the  ID  will  be  1  and  the  Group  will  be
STANDARD.

(6) In the Discretization section select On.  

(7) Let’s  say  that  plating  is  available  in  1/16  inch  increments.   Therefore  in  the
Plate Thickness Increment box enter 0.0625.

(8) Click on Modify.

(9) Steps  (6)  –  (8)  were  for  the  STANDARD  Group.   Click  the  ID  down-arrow
and select general group 1.  Then repeat steps (6) – (8).

(10) Save this new Modeler file – go to the Main Menu and click on File / Save.

(11) We  also  need  to  make  a  new  restart  file.   Recall  that  in  order  to  avoid
overwriting the output file ex2_no_girder.OUT (which would disturb the page
numbering)  we made a new Modeler  file  for  cycle  6  called  ex2_cycle6.mdl.  
Normally  this  would  not  be  necessary  –  it  was  only  done  because  of  the
Tutorial.  But since we did make a new Modeler file we must also make a new
restart  file  that  has  the  same  name.   We  cannot  do  this  by  “File  /  Save  As”
because the Modeler can only read mdl files.   We will  do it  by renaming the
current restart file.

In  the  Main  Menu  click  on  File  /  Open.   In  the  Open  dialog  box  go  to  the
bottom, click the down-arrow on Files of type, and select All Files.  Select the
file called ex2_no_girder.s01, right click and select Rename.  Rename the file
to ex2_cycle6.s01.  Close the Open dialog box.
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Now we  are  ready  to  perform the  sixth  cycle,  during  which  the  scantlings  will  be
discretized.

In the upper toolbar click on the Execute icon.  Select Yes to generate a new DAT
file.   After  the  job  has  completed  enlarge  the  Output  pane  by  dragging  its  upper
border.  Bring up the output file (Edit / MAESTRO Out).

The final scantlings,  all  of which are  now standard sizes,  are  given in  the table on
page 28 of the output.  Notice that the number of stiffeners is now an integer.  The
new design is illustrated in Figure 2.  As shown in Figure 1, the objective function
and the cost have increased (from 0.748 to 0.766 - about 2.4%) whereas the weight
has stayed essentially the same.  The reason for this is that most of the weight is in
the  plating,  which  stayed  the  same  thickness,  whereas  the  number  of  stiffeners
increased, which increased the welding cost and hence also the objective.

2.17 Active Constraints in the Final Design

After deleting the girders in strakes 1 and 4, these strakes have 10 design variables. 
Since MAESTRO uses (an improved version of) linear programming to perform the
optimization,  the  number  of  active  constraints  is  always  equal  to  the  number  of
design  variables.   For  the  Final  Design  these  constraints  are  listed  in  the  table  on
page  26  of  the  output.   There  is  one  minimum  constraint  and  four  proportionality
constraints.   For  min/max  and  proportionality  constraints  it  is  possible  to  show
graphically  how  these  constraints  govern  the  final  scantlings,  and  Figure  2  (c)
illustrates  this.    The  other  five  constraints  are  three  failure  modes  and  two  Area
constraints.   The  latter  are  minimum  values  of  the  strake  cross  sectional  area  to
satisfy the overall (hull girder) constraints (MIN.IMOD and MIN.ZMOD).  From the
nature of the failure modes it  is possible to make a logical connection between the
design  variables  and  the  constraints  that  most  influenced  them,  as  shown  in  the
following table.

Design Variables Governing Constraints

BFF MIN.BFF

TSW, BSF, TSF, TFW HFW/TFW, BFF/TFF, BSF/TSF, HSW/TSW

H S W PYCF (Panel Yield, Compression, Flange)

TPL AREA
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H F W RFYCF2 (Frame Yield, Compression, Flange)

T F W RAREA

STF RPSPBL (Panel Serviceability, Plate 
Bending, Longitudinal)

2.18 Updating the DAT file by Copying and Pasting from the Restart File

The restart files are text files, similar to the input data file (jobname.DAT). When a
module  has  been  sufficiently  optimized,  the  designer  should  transfer  its  final
optimum  scantlings  from  the  restart  file  into  the  appropriate  place  in  the  job  data
file.  This transfer is accomplished by copying and pasting using a text editor such as
NotePad.  For example, with the NotePad editor the procedure would be as follows
for Example 2:

(1) Within  the  “File”  option,  “Open”  the  restart  file,
ex2_no_girder.S01.

(2) Highlight  the  lines  containing  the  final  optimum  scantlings  (do
not  include  the  last  line  containing  the  objective  function,  cost
and weight).

(3) Within the “Edit” option, “Copy” these lines (to the Paste buffer).
(4) Go back to the “File” option and “Open” the original dataset file

EX2.DAT.
(5) Go  to  the  beginning  of  Data  Group  IX  of  the  module

corresponding to this restart file (in this example there is only one
module).

(6) Highlight the lines containing the old scantlings.
(7) Within  the  “Edit”  option,  “Paste”  the  lines  from  the  restart  file

into the data file.

The result is that data groups IX, X and XI of the job data file now contain the final
optimum scantlings.

2.19 Updating the Modeler file by Importing the DAT File

Finally, it is necessary to update the Modeler file (in this case ex2.mdl) because if MAESTRO
was run again and was allowed to write a new DAT file the above updates would be lost.  To
update the Modeler file go to the Main Menu, click on File / Import and select the newly
updated DAT file.  Since the new scantlings are not in the Properties lists, the Modeler will
create new properties for all of them.

NOTE: At the time of writing (July 2005) the Modeler’s Import option has not been
extended to include the optimization data.  It will be extended in a future update.
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16.6.3 References and Figures
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Figure 1- History of Objective Function, Cost and Weight
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(a) Initial Design 
 
 

(b) Scantlings and Constraints at End of Cycle 3 
 
 

(c) Scantlings and Constraints of Final Design 
 

Figure 2  Scantlings and Governing Constraints at 3 Stages 
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16.6.4 Appendix A

Appendix A

Format for Specifying the Discretization Data

(excerpt from the Data Preparation Manual)

9.1.3 DISCRETIZE Data Group

This  optional  group  allows  the  designer  to  specify  allowable  thicknesses  and  size
increments for the final values of the design variables. If this group is included, then
in the last  design cycle  the program will  round off  each of  the hitherto continuous
values of the design variables to one of the allowable discrete values. The evaluation
cycle is then performed on these discrete values.   Each rounding off  may be either
up or down, depending on the current structural adequacy of the affected structure,
and on "roundoff fractions" specified by the designer.

FIRST LINE:

ITEM 1 DISCRETIZE or NODISCRETIZE (keyword; the first four letters are
sufficient).

NODISCRETIZE  indicates  that  strake  design  variables  will  not  be
rounded  to  the  specified  allowable  values.   If  no  roundoff  of  strake
variables is  desired,  there is  no need for this  data  line.   But  once the
DISCRETIZE data has been created, adding the two-letter  prefix is  a
convenient  way  of  switching  off  the  roundoff  feature  and  avoids
having to remove or "comment out" the data for it.

ITEM 2 The  number  of  discrete  plate  thickness  values.  These  values  will  be
used  for  the  strake  plating  and  also  for  the  webs  and  flanges  of  the
stiffeners, girders, and frames.

ITEM 3 Type  of  roundoff.   Normally  the  roundoff  is  done  progressively,
modifying  only  a  few  design  variables  at  a  time,  in  order  that  a
decrease in a design variable can be compensated for, if necessary, by
an increase (rounding up) of a subsequent design variable.  This is the
default,  and  will  be  done  unless  it  is  overridden  by  entering  the
keyword  SIMPLE  for  this  item.   In  that  case  the  program  simply
rounds  off  all  design  variables  simultaneously,  according  to  the
roundoff  fractions.   A  null  or  any  other  entry  will  give  the  ordinary
(progressive) roundoff.
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ITEM 4 Debug  output  flag.  A  1  will  produce  additional  output  during  the
roundoff process.   This item should normally be null or zero.

SECOND LINE:

ITEMS 18 

The  first  eight  plate  thickness  values,  in  order  of  increasing  plate
thickness.

THIRD LINE:

ITEMS 18 The  next  group  of  eight  plate  thickness  values,  again  in  order  of
increasing plate thickness.

etc. As  many  lines  are  used  as  are  required  to  input  the  total  number  of
values  specified  by  Item  2  of  the  first  line.  (The  size  parameter
MPLTSZ defines the maximum number of allowable values.) All lines
except the last line (of plate thicknesses) must have eight values.

LAST LINE:

ITEM 1 Roundoff fraction for the number of panel  stiffeners,  STF.  When the
fractional  part  of  the  number  of  stiffeners  is  greater  than  this  value
(STFROF), the number of stiffeners is rounded up to the next integer
value. For values less than STFROF, the number is rounded down to
the next lower integer. The default value is 0.25. 

To switch off discretization of STF, specify a value of 1 for this item.

ITEM 2 Plate  roundoff  fraction  (PLTROF)  for  the  strake  plate  thickness  and
for  the  web  and  flange  thicknesses  of  the  stiffeners,  girders,  and
frames.  For a thickness value TPL between discrete values T(N) and
T(N+1)  the  value  of  TPL will  be  rounded  up  to  the  value  T(N+1)  if
the ratio

is greater than PLTROF, and rounded down to T(N) if the ratio is less.
  The default value is 0.25.

To switch off discretization for plate thickness, specify a value of 1 for
this item.
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ITEM 3 Panel  roundoff  fraction  (PANROF)  for  the  web  height  HSW  and
flange  breadth  BSF  of  the  panel  stiffeners.  This  item  is  used  in  a
similar  fashion  to  Item  2  except  that  the  appropriate  stiffener  values
are used instead of the plate thicknesses. The default is 0.25.

To switch off discretization for HSW and BSF, specify a value of 1 for
this item.

ITEM 4 Girder  roundoff  fraction  (GIRROF)  for  the  web  height  HGW  and
flange  breadth  BGF  of  the  girders.  This  item  is  identical  to  Item  3
except  that  this  value  is  applied  to  the  girders.  The  default  value  is
0.25.

To switch off discretization of HGW and BGF, specify a value of 1 for
this item.

ITEM 5 Frame  roundoff  fraction  (FRMROF)  for  the  web  height  HFW  and
flange breadth BFF of the frames. This item is identical to Items 3 and
4 except that this value is  applied to the frames. The default  value is
0.25.

To switch off discretization of HFW and BFF, specify a value of 1 for
this item.

ITEM 6 Dimensional increment (PNDELT) for the web heights and the flange
breadths  of  the  panel  stiffeners.  If  the  Nth  discrete  value  of  the  web
height  is  HW(N),  then  the  N+1st  value  is  defined  as  HW(N+1)  =
HW(N)  +  PNDELT.  Note  that  this  item  has  dimensions  so  the
appropriate  units  as  previously  defined  must  be  used.  The  default
value is 10.0 for mm, 0.010 for m and 0.25 for inches.

ITEM 7 Dimensional  increment  (GRDELT)  for  the  web  heights  and  flange
breadths of the girders. This item is similar to Item 6 except that this
value applies to girders. The default value is 20.0 for mm, 0.020 for m
and 0.5 for inches.

ITEM 8 Dimensional  increment  (FRDELT)  for  the  web  heights  and  flange
breadths  of  the  frames.  This  item  is  similar  to  Items  6  and  7  except
that it  applies to the frames. The default  value is  20.0 for  mm, 0.020
for m and 0.5 for inches.
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17 Verification and Validation

The topics in this section provide test results for MAESTRO element verification studies and
compare these results to theoretical and other FEA software results.

All data files referenced in the following sections can be found in the MAESTRO installation
directory under MAESTRO/Models & Samples/Verification Models.

17.1 CQUAD4R

The following sections provide various verification tests for MAESTRO's quad element.

17.1.1 Patch Test

For the patch tests, there are five files in all.   Three of them are set up for the constant in
plane strains, corresponding to tensions in X, Y direction and shear in X-Y plane.  The other
three  files  are  for  constant  bending  curvature,  corresponding  to  pure  bending  in  X,  Y
direction and pure twist.   Table  2  gives the boundary  conditions,  loads and the theoretical
strains  and  stresses  for  the  patch  elements  for  the  five  tests.   The  MAESTRO  recovered
stress  and  displacements  are  presented  along  with  the  results  from  MSC/Nastran  for
Windows V3.0 for comparison.

The  patch  test  model  geometry  is  presented  in  Figure  1.   The  location  of  the  nodes  are
presented in Table 1.

Figure 1 Patch Test Model, E = 1.0e06, v = 0.25

Node X Y
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1 0.00 0.00
2 0.24 0.00
3 0.24 0.12
4 0.00 0.12
5 0.04 0.02
6 0.18 0.03
7 0.16 0.08
8 0.08 0.08

Table 1 Patch Test Model Node Locations

BCs Loads Theoretica
l 

Strain

Theoretic
al 

Stress

MAESTRO 
Solver

MSC/Nastr
an for

Windows
V3.0

Input Data
Files

Constant
Strain in

X-Directio
n

1:
11100

1
2:

01100
0
4:

10100
0

2: Px = 0.06

Mz = -1.2e-03

3: Px = 0.06

Mz = 1.2e-03

ex = 10-03

ey = 0.25e
-03

exy = 0

sx = 1,000

sy = 0

sxy = 0

U2 =

0.00028997
8

U3 =

0.00028780
5

V3 =

-0.00012348
9

sx = 1013.8

U2 =

0.00028987
U3 =

0.00028765
V3 =

-0.0001232
2

sx =

1012.42

patchx.mdl
patchx.nas
patchx.mo

d
patchx.f06

Constant
Strain in

Y-Directio
n

1:
11100

1
2:

01100
0
4:

10100
0

3: Py = 0.12

Mz = -4.8e-03

4: Py = 0.12

Mz = 4.8e-03

2: Mz =

4.8e-03

ex = 0.25e
-03

ey = 10-03

exy = 0

sx = 0

sy = 1,000

sxy = 0

V3 = 0.00012

V4 = 0.00012

U3 = -6.0e-05

sVM = 1,000

V3 =

0.00012
V4 =

0.00012
U3 = -6.0e-05

sVM = 1,000

patchy.mdl
patchy.nas
patchy.mo

d
patchy.f06

Constant
Shear in

X-Y Plane

1:
11101

1
4:

10100
0

2: Px =

-0.048
Py = 0.024

3: Px = 0.048

Py = 0.024

4: Py =

-0.024

ex = 0

ey = 0

exy = 10-03

sx = 0

sy = 0

sxy = 400

V3 = 0.00024

sxy = 395.94

V3 =

0.000235
sxy = 399.72

patchs.mdl
patchs.nas
patchs.mo

d
patchs.f06
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BCs Loads Theoretica
l 

Strain

Theoretic
al 

Stress

MAESTRO 
Solver

MSC/Nastr
an for

Windows
V3.0

Input Data
Files

Constant
Bending

my=

8.889e-08

1:
11111

1
2:

00010
0
3:

00010
0
4:

10111
1

2: My =

5.33e-09
3: My =

5.33e-09

Curvature:
1.0e-03

Slopes:
2: qy = 2.4e

-03

3: qy = 2.4e
-03

Surface
Stress:

sx = 0.533

q3y:

0.00023985

q3y:

0.00023985

patchb.mdl
patchb.nas
patchb.mo

d
patchb.f06

Constant
Biaxial

Bending
mxy =

3.33e-08

1:
11111

1
2:

01101
0
4:

10110
1

2&3: Mx =
0.2e-08

3&4: My =
-0.4e-08

Twist: 0.5e
-03

Slopes:
2: qx = 1.2e

-03

qy = 0

3: qx = 1.2e
-04

qy = -6.0e-05

4: qy =

-6.0e-05

Surface
Stress:
sxy = 0.2

q3x: 0.00012

q3y: -6.0e-05

W3: 1.44e-05

q3x: 0.00012

q3y: -6.0e-05

W3: 1.44e-05

patchws.m
dl

patchws.na
s

patchws.m
od

patchws.f0
6

Table 2 Patch Test MAESTRO Quad Element vs. MSC/Nastran for Windows V3.0 QuadR Element Results

17.1.2 Cantilever Beam

The second test is a cantilever beam modeled with six trapezoidal (or parallelogram) shell
elements.  The dimensions and the material properties are given in Figure 1.  Three loads
are applied at the free end of the beam: a unit force in the Y direction (in the plane of the
element), a unit force in the Z direction (out of plane) and a unit twisting moment.  The in-
plane force causes in-plane shear.  The out of plane force causes shell bending.  The critical
part of this test is the in-plane shear.  The MSC/Nastran QUAD4 element completely failed
the in-plane test because of shear locking. The MAESTRO element is only 1.2% different
from the theoretical value.  For the out of plane bending, the errors are 2.3% and 1.6%
respectively.  For the twist the theoretical value is 0.0233 radians and not 0.0321 as given in
[2] and MAESTRO matches this value exactly.  Table 1 presents the results.   

Figure 1 Straight Cantilever Beam, Length = 6.0, Height = 0.2, Depth = 0.1, E = 1.0e07, v = 0.3,
mesh = 6 x 1
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BCs Loads MAESTRO
Solver

Theoretical Relative
Error

MSC/
Nastran

V3.0

Input Data
Files

In-Plane
Shear

Clamped
at one end
of beam

Unit force
in Y-

direction at
free end

v = 0.1068 v = 0.1081 1.20% 0.1068

trapz.mdl
trapz1.dat

trapz1.mod
trapz1.f06

Out-of-
Plane
Shear

Clamped
at one end
of beam

Unit force
in Z-

direction at
free end

w = 0.4252 w = 0.4321 1.62% w = 0.4264

trapz.mdl
trapz2.dat

trapz2.mod
trapz2.f06

Twist Clamped
at one end
of beam

Unit
twisting

moment at
free end

qx =

0.00233

qx =

0.00233

0% qx

= .00306

trapz.mdl
trapz3.dat

trapz3.mod
trapz3.f06

Table 1 Cantilever Beam Results

17.1.3 Curved Beam

The third test is the curved beam problem.  The geometry, dimensions, material properties,
and loading conditions are shown in Figure 1.  The element shape in this test is not exactly
rectangular and so this test includes the effect of a small irregularity in the element.  Table 1
presents the results of this test, which shows that the MAESTRO QUAD4 element has about
the same accuracy as the MSC QUAD4 element.  
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Figure 1 Curved Beam, Inner Radius = 4.12, Outer Radius = 4.12, arc = 90 degrees, thickness = 0.1, E = 1.0e07,
v = 0.25, mesh = 6 x 1

BCs Loads MAESTRO
Solver

Theoretical MAESTRO
Error

MSC
Quad4
Error

Input Data
Files

In Plane,
Shear

Clamped
at one end

of the
curved
beam

Unit force
in

Y-direction
at free end

v = 0.0880 v = 0.0873 0.8% 0.8%
curvedbea

m.mdl
curvbb.nas
curvbb.mo

d
curvbb.f06

Out of
Plane,

Bending

Clamped
at one end

of the
curved
beam

Unit force
in

X-direction
at free end

u = 0.4492 u = 0.5022 10.5% 4.9%
curvedbea

m.mdl
curvbs.nas
curvbs.mo

d
curvbs.f06

17.1.4 Twisted Beam

The  fourth  test  is  the  twisted  beam  problem.   The  size  of  the  beam,  element  mesh  and
material properties are given in Figure 1.  The purpose of this test is to study the ability of an



Verification and Validation 659

© 2014 Optimum Structural Design, Inc.

element  to  treat  the  coupling  of  in-plane  and  out-of-plane  strain  when  there  is  a  warped
element mesh.  In this test, the warp of each element is 7.5 degrees.  As shown in Table 1,
the MAESTRO QUAD4 gives results that are in good agreement with theoretical results.  

Figure 1 Twisted Beam, Length = 12.0, Width = 1.1, Depth = 0.32, Twist = 90 degrees, E = 2.9e07, v = 0.22,
mesh = 12 x 2

BCs Loads MAESTRO
Solver

Theoretical Relative
Error

MSC/Nastr
an

Input Data
Files

Out-of-Pla
ne Shear

Clamped
at one end

of the
beam

Unit Force
in

Y-direction
at free end

v = 1.728e
-03

v = 1.754e
-03

1.5% v = 1.727e
-03

twsb.mdl
twsb1.nas
twsb1.mod
twsb1.f06

In-Plane
Shear

Clamped
at one end

of the
beam

Unit Force
in

Z-direction
at free end

w = 5.382e
-03

w = 5.424e
-03

0.8% w = 5.388e
-03

twsb.mdl
twsb2.nas
twsb2.mod
twsb2.f06

Table 1 Twisted Beam Results

17.1.5 Rectangular Plate Under Lateral Load

The fifth test investigates the accuracy of the plate elements bending response for the case
of a rectangular plate.  A lateral load is applied to a rectangular plate of a given aspect ratio.
 The plate is tested separately for each of the two types of loads: a uniform pressure of 1.0e
-04  and  a  central  concentrated  load  of  4.0e-04.   It  is  tested  for  two  types  of  boundary
conditions:  simply  supported  edges  and  clamped  edges,  and  two  aspect  ratios,  yielding  a
total  of  eight  test  problems.   The  results  are  presented  in  Table  1,  showing  that  the
MAESTRO  QUAD4  element  gives  quite  good  results.   The  two  models  are  presented  in
Figures 1 and 2.  Because of symmetry, only one quarter of the plate is modeled for each
aspect ratio.
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Figure 1 Rectangular Plate, Aspect Ratio 1, a = 2.0, b = 2.0, t = 0.0001, E = 1.7472e07, v = 0.3

Figure 2 Rectangular Plate, Aspect Ratio 5, a = 2.0, b = 10.0, t = 0.0001, E = 1.7472e07, v = 0.3

BCs Aspect
Ratio

Loads Theoretic
al

Deflection

MAESTR
O Solver

MAESTR
O 

Error

MSC/Nas
tran

MSC/Nas
tran Error

Input
Data
Files
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Simply
Supporte

d All
Sides

1

Pressure 4.06 4.07 0.2 4.15 2.2
sp4.mdl

sp4pt.mo
d

sp4pt.nas
sp4pt.f06
sp4pres.

mod
sp4pre.f0

6
sp4pre.na

s

Point
Load

11.6 12.02 3.6 12.36 6.5

5

Pressure 12.97 12.98 0.1 13.08 0.8
rpl4.mdl   
rpl4pt.mo

d
rpl4pt.nas
rpl4pt.f06
rpl4pre.m

od
rpl4pre.n

as
rpl4pre.f0

6

Point
Load

16.96 16.22 4.4 16.11 5.0

Clamped
All Sides

1

Pressure 1.26 1.30 3.2 1.31 4.0
spl4cl.mdl
spl4clpr.

mod
spl4clpr.f

06
spl4clpr.n

as
spl4clpt.

mod
spl4clpt.f

06
spl4clpt.n

as

Point
Load

5.60 5.34 4.6 5.61 0.2

5

Pressure 2.56 2.86 11.7 3.41 33.2
rpl4cl.mdl
rpl4clpr.m

od
rpl4clpr.f0

6
rpl4clpr.n

as
rpl4clpt.m

od
rpl4clpt.n

as
rpl4clpt.f0

6

Point
Load

7.23 4.97 31.3 3.80 47.4

Table 1 Rectangular Plate Results
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17.1.6 Scordelis-Lo Roof

The sixth test is the Scordelis-Lo roof problem.  The structure is loaded by its own weight.
From the given conditions in Figure 1, the specific weight is 360/unit volume.  This problem
has the combination of in plane and out of plane loads.  This is the only slightly curved shell
problem in the test set.  It is required to correctly distribute the body force to four grid nodes.
 The results of this test are listed in Table 1.

Figure 1 Scordelis-Lo Roof, Radius = 25.0, Length = 50.0, t = 0.25, E = 4.32e08, v = 0, Loading =
90.0 per unit area in Z-direction
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BCs Load Mesh Size Theoretical
Max

Displacem
ent

MAESTRO
Max

Displacem
ent

MSC/
Nastran

Max
Displacem

ent

ABAQUS
Max

Displacem
ent

Input Data
Files

Simple
Support at

Both
Circular

Ends

Self-
Weight.

r = 360/
Unit

Volume

4 x 4

v = -0.3086v = -0.3197v = -0.3218v = -0.3880

scod.mdl

scod.mod

scod.nas

scod.f06

8 x 8 v = -0.3086 -- -- v = -0.3226 --

16 x 16 v = -0.3086 -- -- v = -0.3190 --

Table 1 Scordelis-Lo Roof Results

As shown in Figure 2, MAESTRO’s typical coarse mesh modeling (4 elements per side, for a
total of 16 elements) has an order of accuracy (3.6%) that ABAQUS only achieves with 16
elements per side, for a total of 256 elements (3.4%). 

Figure 2 Comparison of MAESTRO and ABAQUS Results with the Theoretical Solution

17.1.7 Hemispherical Shell

The final test is the hemispherical shell problem.  This test gives an opportunity to study the
solution accuracy of a doubly-curved shell.   The geometric size of the hemispherical shell
and the material properties are given in Figure 1.  The results are listed in the table below. 
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Figure 1 Sphere8 Model, Transverse Symmetry, Radius = 10.0, thickness = 0.04, E = 6.825e07, v
= 0.3
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Figure 2 Sphere8 Boundary Conditions

BCs Loads MAESTRO
Displacemen

t

Theoretical
Displacemen

t

% Error Input Data
Files

Refer to
Figure 2

Unit Forces
in Symmetric

Planes.

Pz = -1, Py =

2

v = 0.090 v = 0.094 4.3 %

sphere8.mdl

sphere8a.
mod

sphere8a.f06

sphere8a.
nas
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Refer to
Figure 2

Unit Forces
in Symmetric

Planes.

Pz = 1, Py = -

2

v = 0.090 v = 0.094 4.3%

sphere8.mdl

17.2 CROD

The rod test is a rod modeled with two solid rod elements of different cross sections.  The
rod is fixed at node 1.  The model and node locations are presented in Figure 1 and Table 1.
 The rod model is applied a vertical compressive force of 1,000 psi at node 3.

Figure 1 Rod Test, E = 1.0e07 psi
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Node X Y

1 0 0

2 0 10

3 0 20

The MAESTRO calculated axial stresses recovered in each element match exactly to the
theoretical values.

Element 1 axial stress = -500.00 psi

Element 2 axial stress = -666.67 psi

Model: rodtest.mdl

17.3 RBE3

RBE3 implementation was compared to NEi Nastran.  The results of the two multipoint
constraint coefficients are provided below.  The MAESTRO model, RBE3.mdl, and the
related NEi Nastran files can be found in the Program Files\MAESTRO\Models and Samples
\Verification Models\RBE3 directory.
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Figure 1 MPC Definition from NEi Nastrain
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Figure 2 MPC Definition from MAESTRO

17.4 Gap Element

The sample models shown below can be found under C:\Program Data\MAESTRO\Models
and Samples\Gap

The first example compares two beams separated by 0.1m with a GAP element connecting
the two ends and single vertical force applied at the top beam.  The results of the
displacement of the two nodes is compared to results from Nastran.
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The second example shows the same two beams and a single vertical force, but now with 3
gap elements modeled along the beam.  The force and nodal displacement results are
compared between MAESTRO and Nastran.
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17.5 Bracket

Bracket Element

1. Background

MAESTRO bracket element is used for a simplified coarse mesh analysis.  It can be attached
to an end of a beam element to get stress reduction. The technique involves separate modeling
of the axial and bending stiffness. The axial stiffness is modeled by a super-element method.
It is assembled with tapered axial elements for the bracketed portion and a standard axial
element for the rest of the beam. Internal nodes are eliminated by condensation of the stiffness
matrix.
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A=(A1+A2)/2

L1 L2

Cross Section Area=A1

Cross Section Area=A2

The bending stiffness of the assembly is obtained by matrix transformation. A portion of the
bracket is modeled as a rigid link element, and the remaining part of the beam is modeled as a
regular beam element.

R1 R2

Rigid Element (RBE2)

Bending Stress Location
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2. Verification
· Axial

Model Beam with Brackets  3 Rods

Beam_Brk_Tension.mdl Dz=-1.6413e-006 Dy=-1.6413e-006

· Bending
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Model Beam with Brackets  2 RBE2+ 1 Beam

Beam_Brk_Bending.mdl Dx=7.08468e-005 Dz=7.08469e-005
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3. Refinement

Coarse Mesh

Top-down auto-refinement

17.6 Second Flange

The following second flange examples demonstrate the three methods for modeling a
second flange: the second flange strake, defining a second flange on a beam, and creating
a T-beam with a rod element as the second flange.
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Example 1

This example compares the displacement of a beam with a second flange, a second flange
strake, a beam with a rod as the second flange, and a rod with equivalent cross sectional
area all subjected to a tensile force of 1,000 Newtons.  The intersection of all 4 elements is
fixed and the opposite end of the beams, frame, and rod are constrained such that only axial
motion is allowed.  This model, SecondFlangeTension.mdl, can be found in the Program
Files\MAESTRO\Models and Samples\Verification Models\Second Flange directory.

Element Force Displacement
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Beam with second flange
defined

Fx = 1000 N Dx = 1.08948e-6

Second flange strake Fy = 1000 N Dy = 1.08948e-6

Rod with equivalent cross
sectional area

Fx = -1000 N Dx = -1.08948e-6

Beam with rod defined as
second flange

Fy = -1000 N Dy = - 1.08948e-6

Example 2

This example compares the deformation of a beam with a second flange defined and a
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second flange strake under a lateral load.  The ends of both beams are fixed and a later
load of 1000 N is applied at each beam's center.  This model, SecondFlangeLateral.mdl, can
be found in the Program Files\MAESTRO\Models and Samples\Verification Models\Second
Flange directory.

Element Force Displacement

Beam with second flange
defined

Fy = 1000 N Dx = 5.70311e-7

Second flange strake Fz = 1000 N Dx = 5.70311e-7

17.7 Added Mass

Panel Method for Added Mass

1. Basic Theory
The  added  mass  can  be  expressed  as    

òò == )(3),(2),(1 HeaveSwaySurgekdsnm kk
s

k j
   (1)

Where 
),,( 321 nnnn =

r
 is the unit normal vector on the body surface

        
kj

 is the solution of the following problem

        
02 =Ñ kj

   in the field     (2)

k
k

k n
n

ngrad =
¶

¶
=×

j
j

r

  (3)

The solution to the Laplace equation (2) is obtained by covering the body surface with local

source strengths 
),,( zhxs

 at point 
),,( zhxq

, 

Thus, the velocity potential can be expressed as

3,2,1),,,,,(),,(),()(),,()( =òò ×=òò== kdszyxGdsqpGqzyxp
k

s
k

s
kkkk zhxzhxssjj

rrrr

    (3)
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 in which       
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==

 

Fig 1

According to boundary condition(3), the normal velocity of the fluid at the surface of the body
can be solved by 

3,2,1),()()()(
2

1)(
==òò Ñ·+-=

¶

¶
kndsqpGpnqp

n

p k
s

kkk
k rrrrrr

r

ss
j

   
(4)

2.  Panel Method

The problem to determine the continuous function 
),,( zyxs

 is replaced by the problem to 

determine a finite number N of value 
),4,3,2,1( Nii L=s

.  The integer equation become



MAESTRO 11.0.0680

© 2014 Optimum Structural Design, Inc.

     

å òò
=
=

=

Ñ·+-=
¶

¶

¹

=

N

ij

j jS ij
k

i
k
j

k
i

i

k
i

k
Nj

Ni

dsGn
n 1 3,2,1

,3,2,1

,3,2,1

2

1
L

L
r

ss
j

      (5)

Whereas this is a finite number of equations, only in a finite number of points this boundary
condition can be satisfied. 

After 
k
is

 are determined , the velocity potential can be obtained by
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The each panel added mass can be get by 
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The added mass of the body is
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3. Application

3.1 Sphere no free surface
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Figure 2
The sphere  can  be  expressed  by  panels  (See  Figure  2  above).  The theoretical  value[1]  of  the

added mass is 

3

3

2
r×× rp

(The surge,sway and heave are same).

The 
r

 and r  are the density of water and the radius of sphere respectively.

The numeric results are showed in the Table 1 below.

                         Table 1  
=r

1025(kg/m3)  
)(0.1 mr =

Panel Number          Theoretical           Numeric

Surge Sway Heave Surge  Sway Heave

50
2146.7594 2146.7594 2146.7594

2117.4725 2270.3245 2270.3245

800 2212.6462 2235.6909 2235.6911

1800 2195.8930 2209.7752 2209.7754

3.2 Half Sphere with free surface
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 Figure 3

The half sphere can be expressed by panels(See Figure 3 above). 

The Landweber value[2] of the added mass is 

3

3

1
r×× rp

 for heave and

3

3

2
)1

4
( r×××- rp
p  for surge and sway. 

The 
r

 and r  are the density of water and the radius of sphere respectively.

The numeric results are showed in the Table 2 below.

                         Table 2  
=r

1025(kg/m3) 
)(0.1 mr =

Panel Number          Theoretical           Numeric

Surge Sway Heave Surge  Sway Heave

100 586.5784 586.5784 1073.3775 622.825 646.769 1144.62

462 609 617 1115



Verification and Validation 683

© 2014 Optimum Structural Design, Inc.

1458 600 605 1099

3.3 Quad Sphere with free surface

Figure 4

The quad sphere can be expressed by panels(See Figure 4 above). 

The  Landweber  value[2]  of  the  added  mass  is  

3

6

1
r×× rp

 for  heave  and

3

3

1
)1

4
( r×××- rp
p  for surge and sway. 

The 
r

 and r  are the density of water and the radius of sphere respectively.

The numeric results are showed in the Table 3 below.

                         Tab 3  
=r

1025(kg/m3) 
)(0.1 mr =

Panel Number          Theoretical           Numeric

Surge Sway Heave Surge  Sway Heave

50 293.2892 293.2892 536.6887 311.3752 323.3339 572.2338

200 305.2384 309.8359 558.7456
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3.4 Cylinder no free surface

Figure 5

The Cylinder can be expressed by panels(See Figure 5 above). 

The theoretical value[1] of the added mass is 
Lr ××× 2rp

(for sway and heave). 

The 
r

, r  and L are the density of water , the radius of cylinder and the length of cylinder 
respectively.

The numeric results are showed in the Table 4 below.

                         Table 4  
=r

1025(kg/m3) 
)(2.4 mr = )(96 mL =

Panel Number Theoretical     Numerical

Sway Heave  Sway Heave

200 5453101.0369 5453101.0369 5630603.9968 5630603.5989

300 5599916.6043 5599917.0003

3.5 Half Cylinder with free surface
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Figure 6

The half cylinder can be expressed by panels(above Fig.6). 

The theoretical value[3] of the added mass is 

Lr ××× 2

2
r

p

(for heave), 

Lr ××× 22
r

p (for

sway) and

3

3

4
rk ×rp

(for surge 2.0=k ).

The 
r

, r  and L are the density of water , the radius of cylinder and the length of cylinder 
respectively.

The numeric results are showed in the Table 5 below.

                         Tab 5  
=r

1025(kg/m3) 
)(2.4 mr = )(96 mL =

Panel
Number

         Theoretical           Numeric

Surge Sway Heave Surge  Sway Heave

300 63619.5121 1105029.3409 2726550.5184 68414.6968 1173607.3222 2725225.6351

150 72652.9161 1252297.6302 2802519.8030

3.6 Quad Cylinder with free surface
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Figure 7

The quad cylinder can be expressed by panels (See Figure 7 above).

The theoretical value[3] of the added mass is 

Lr ××× 2

4
r

p

(for heave), 

Lr ××× 21
r

p (for

sway) and

3

3

2
rk ×rp

(for surge 2.0=k ).

The 
r

, r  and L are the density of water , the radius of cylinder and the length of cylinder 
respectively.

The numeric results are showed in the Table 6 below.

                         Tab 6  
=r

1025(kg/m3) 
)(2.4 mr = )(96 mL =

Panel
Number

         Theoretical           Numeric

Surge Sway Heave Surge  Sway Heave

100 31809.7560 552514.6704 1363275.2592 36799.7577 590738.4908 1369071.0764

150 34201.8993 587695.3912 1361613.3078
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3.7 Cube no free surface

Figure 8

The cube can be expressed by panels(See Figure 8 above).

The  theoretical  value[1]  of  the  added  mass  is  
37.0 a×× r

(The  surge,sway  and  heave  are
same). 

The 
r

 and a  are the density of water and the length of cube respectively.

The numeric results are showed in the Table 7.

                         Tab 7  
=r

1025(kg/m3) 
)(0.1 ma =

Panel Number          Theoretical           Numeric

Surge Sway Heave Surge  Sway Heave

54 717.5000 717.5000 717.5000 726.0585 726.0585 726.0585

References
1. Sarpkaya,  T.,  Isaacson,  M.,  Mechanics  of  Wave  Forces  on  Offshore  Structures,  Van

Nostrand Reinhold, New York, 1981
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17.8 Load Balance

This section provides verification data for MAESTRO two methods of balancing a model:

Hydrostatic Balance

Primitive Shapes Balance

S175 Hull Form Balance

Inertia Relief Balance

Hydrostatic Balance Validation

To validate MAESTRO’s hydrostatic balance, a simple box-shaped vessel 100 m long, 20 m beam and
12 m depth is built.  The Modeler file is called BalanceTest, located in “.../MAESTRO/Models and
Samples/Verification Models/Hydrostatic Balance” folder. For simplicity there is no wave, and the mass
(9.0E6 kg) gives a mean draft of 4.5 m.  The product ρg to convert from a volume to a force is taken
as 10,000 N/m3.  The mass is concentrated at the ¾ length position (X = 75 m) and at a height (KG) of
4 m, which causes a trim of -9.0903 degrees.  In this position the stern is out of the water and the bow
is immersed to exactly the full depth (12 m). The center of gravity and the center of buoyancy are
co-located at the same point (x=75, y=4, z=10).

Figure 1
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As shown in Figure 2 the model is very coarse mesh – much coarser than a normal ship model.  All
strakes are tapered, and strakes on the port side are tapered oppositely than those on the starboard.

Figure 2

The initial position of the model is horizontal, at a uniform draft of 4.5 m.  This corresponds to the
model’s displacement force of 90.E6 N, but it is incorrect since there is as yet no trim.  In this position
the LCF is at amidships.  As the model rotates about the initial LCF the stern rises out of the water,
and the model must sink a total of 1.5 m in order to maintain a vertical force balance.  In MAESTRO
terminology this sinkage is a negative “emergence”. 

Two other models, BalanceTest_Trans.mdl and BalanceTest_rot45.mdl, which were rotated 90
degrees and 45 degrees from model BalanceTest.mdl, were also tested. The result is shown in table
1.

Model Item MAESTRO Theory (exact)
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BalanceTest.
mdl

 
Emergence

(m)

-1.500 -1.500

 Heel (deg.) 0 0
 Trim (deg.) -9.09 -9.0903

BalanceTest_
Trans.mdl

 
Emergence

(m)

-1.500 -1.500

 Heel (deg.) -9.09 -9.0903
 Trim (deg.) 0 0

BalanceTest_
Rot45.mdl

 
Emergence

(m)

-1.500 -1.500

 Heel (deg.) -6.455 Visual
 Trim (deg.) -6.414 Visual

Table 1

Exact solution derivation in the global (earth) coordinate system

To further validate MAESTRO’s balance tool, an exact solution of BalanceTest is presented below.
Since the model is hydrostatic balanced, the following equilibrium or balance conditions in earth
coordinate system should be fulfilled,
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Free Body Diagram
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Moment with respect to CG: vertical pressure load contribution on bottom, part 1.
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Moment with respect to CG: vertical pressure load contribution on bottom, part 2.
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( ) ( ) ( ) ( ) ( ) 0127512tan425tan450)( 2321 =+++-++=å xxqyyyz MMMMMCGM qq

Vertical Bending Moment Distribution
 
While the static equilibrium equations are formulated with respect to the center of gravity, naval
architects often prefer to check vertical bending moment and shear force distribution. The closure of
bending moment and shear force distribution is an alternative way to validate equilibrium.

Vertical Bending Moment Distribution: vertical pressure load contribution on bottom, part 1.

6
cossin

cos)(cossin

cos)(cos

cos)(

)(

3
2

0

0

0

1

0

211

L
gw

dxxLgwx

dxxLgwh

dxxLf

dxLfLM

L

L

L

y

L

yy

qqr

qqqr

qqr

q

=

-=

-=

-=

==

ò

ò

ò

ò

where



Verification and Validation 697

© 2014 Optimum Structural Design, Inc.

qtan1275

0

2

2

+=

<<

L

LL

Vertical Bending Moment Distribution: vertical pressure load contribution on bottom, part 2.
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Vertical Bending Moment Distribution: vertical pressure load contribution on bow.
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Exact solution derivation in the local (structural) coordinate system

The above derivation is based on the global coordinate system. The static equilibrium should also be
fulfilled in the local coordinate system. MAESTRO’s graphical display and tabulate data are based on
the local coordinate system.
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Bending Moment at the end
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-1.E+08

0.E+00

1.E+08

2.E+08

3.E+08

4.E+08

5.E+08

6.E+08

7.E+08

0 20 40 60 80 100 120

MAESTRO

Exact

X MAESTRO Exact X MAESTRO Exact

0 0 71 5.16E+08 512604607.2

25 0 72 5.51E+08 546767363.9

26 131658 5266.341407 73 5.87E+08 582415228.9

27 263316 42130.73126 74 6.23E+08 619579800.2

28 394973 142191.218 75 6.58E+08 658292675.9

29 526631 337045.8501 76 6.13E+08 609716945.1

30 658289 658292.6759 77 5.68E+08 562751635.3

31 1.58E+06 1137529.744 78 5.22E+08 517429426.6

32 2.50E+06 1806355.103 79 4.77E+08 473781917.3
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33 3.42E+06 2696366.8 80 4.32E+08 431840705.3

34 4.34E+06 3839162.886 81 3.95E+08 391637388.9

35 5.27E+06 5266341.407 82 3.59E+08 353203566.2

36 7.77E+06 7009500.413 83 3.22E+08 316570835.1

37 1.03E+07 9100237.951 84 2.85E+08 281770793.9

38 1.28E+07 11570152.07 85 2.49E+08 248835040.6

39 1.53E+07 14450840.82 86 2.22E+08 217795173.3

40 1.78E+07 17773902.25 87 1.95E+08 188682790.1

41 2.26E+07 21570934.4 88 1.67E+08 161529489.2

42 2.75E+07 25873535.33 89 1.40E+08 136366868.6

43 3.24E+07 30713303.09 90 1.13E+08 113226526.4

44 3.73E+07 36121835.71 91 9.64E+07 92140060.74

45 4.21E+07 42130731.26 92 7.95E+07 73139069.7

46 5.02E+07 48771587.77 93 6.27E+07 56255151.4

47 5.82E+07 56076003.3 94 4.58E+07 41519903.91

48 6.62E+07 64075575.9 95 2.90E+07 28964925.36

49 7.43E+07 72801903.61 96 2.32E+07 18621813.83

50 8.23E+07 82286584.49 97 1.74E+07 10522167.43

51 9.43E+07 92561216.57 98 1.16E+07 4697584.258

52 1.06E+08 103657397.9 99 5.79E+06 1179662.415

53 1.18E+08 115606726.6 100 -389.622 0

54 1.30E+08 128440800.6

55 1.42E+08 142191218

56 1.59E+08 156889576.9

57 1.76E+08 172567475.2

58 1.92E+08 189256511.1

59 2.09E+08 206988282.7

60 2.26E+08 225794387.8

61 2.48E+08 245706424.7

62 2.70E+08 266755991.3
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63 2.93E+08 288974685.7

64 3.15E+08 312394105.9

65 3.37E+08 337045850.1

66 3.66E+08 362961516.1

67 3.94E+08 390172702.2

68 4.23E+08 418711006.3

69 4.51E+08 448608026.4

70 4.80E+08 479895360.7

Primitive Shapes Balance

The following presents the hydrostatic verification results for a cube, cylinder, and sphere.  These
problems demonstrate the hydrostatic balance capabilities of MAESTRO by applying them to a
polygon cube, cylinder, and sphere with geometric centers placed at the origin.  Rhino was used to
create these primitives by using the Mesh>Polygonal Mesh Primitives>Box.  The number of panels per
side were created by using the Rhino Command Line.  Next, the geometry was selected in Rhino and
the File>Export Selected was chosen, which allows a *.ply file to be exported for consumption into
MAESTRO.  An upright unstable condition and a heeled stable condition were tested and the results
presented below.

Cube

See the ...\MAESTRO\Models and Samples\Verification Models\Hydrostatic Balance directory for
model data and results.
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Cylinder

See the ...\MAESTRO\Models and Samples\Verification Models\Hydrostatic Balance directory for
model data and results.
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Sphere

See the ...\MAESTRO\Models and Samples\Verification Models\Hydrostatic Balance directory for
model data and results.
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S175 Hull Form Balance

The following presents the hydrostatic verification results for the S175 hull form.  This hull was
generated in Rhino and then exported using the Export Selected command in Rhino to generate a *.ply
file, which was then consumed by MAESTRO.  An upright and heeled condition was tested and the
results presented below.

See the ...\MAESTRO\Models and Samples\Verification Models\Hydrostatic Balance directory for
model data and results.
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Inertia Relief Balance Validation

To validate MAESTRO’s inertia relief balance, a variation of the above model is used. The Modeler file
is called BalanceTest-acc.mdl.  A point mass of 4E6 kg is located at the 1/4 length position (X = 25 m)
on bottom shell, a point mass of 2E6 kg is located at the 1/2 length position (X = 50 m) on deck shell,
and a point mass of 4E6 kg is located at the 3/4 length position (X = 75 m) on bottom shell. The bow is
subjected to 20E5N uniform slamming pressure.

Because the model is a floating structure, hydrostatic balance is performed first, which results a small
trim (0.594 degrees). The model now has equilibrium in heave, roll and pitch. Note that the slamming
force (x-direction, surge) can not be balanced by the hydrostatic balance. Next, an inertia relief
balance is performed, which automatically generates a -4.9 surge acceleration to balance the
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slamming load. The model is now fully balanced in 6 degrees of freedom.

Exact solution derivation in the local (structural) coordinate system
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Where

1000 << L

Bending moment distribution due to gravity contribution in y direction

)25(cos64)(2 --= LgELM q
Where

10025 << L

)50(cos62)(3 --= LgELM q

Where

10050 << L

)75(cos64)(4 --= LgELM q
Where

10075 << L

Bending moment distribution due to gravity and additional acceleration contribution in x direction

( ) 4.2sin64)(6 ×--= qgaELM

Where

10025 << L

( ) )4.212(sin62)(7 -×-= qgaELM

Where

10050 << L

( ) 4.2sin64)(7 ×--= qgaELM

Where

10050 << L

Bending moment distribution due to end bulkhead pressure load

( )4.26201252)100(8 -×××-= EM
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Vertical Bending Moment Distribution
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Exact

17.9 ULSAP

The following model has been created in MAESTRO using user-defined evaluation patches.
The *.mdl files can be found in the Models and Samples/Verification Models/ULSAP
directory.  The model properties are shown below and he two tables describe the input data
and results for the 15 load cases.

 Model properties

• Yield stress of plate, σYp = 313.6 N/mm2

• Yield stress of stiffener, σYs = 313.6 N/mm2

• Elastic modulus, E = 205800 N/mm2

• Poisson’s ratio, ν  = 0.3
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• Density, ? = 7.850e-06 kg/mm3

• Plate length, a = 4750 mm
• Plate breath, b = 950 mm
• Panel breath, B = 8550 mm
• Number of stiffeners, ns = 8

Initial deflections (ISO formula)

• wopl = 0.1ß2tp

• wos = 0.0015a

Input data

Case

Latera
l

Pressu
re

(MPa)

Load
type
sx : s

y

Plate
Thickne

ss,
tp (mm)

Stiffen
er

type

hw

(mm)
tw

(mm)
bf

(mm)
bt

(mm)
wopl

(mm)
wos

(mm)

01 0.0 1:0 15 Flat 250 25 - - 9.168 7.125

02 0.0 1:0 15 Angle 235 10 90 15 9.168 7.125

03 0.0 1:0 15 Tee 235 10 90 15 9.168 7.125

04 0.0 1:0 15 Flat 350 35 - - 9.168 7.125

05 0.0 1:0 15 Angle 383 12 100 17 9.168 7.125

06 0.0 1:0 15 Tee 383 12 100 17 9.168 7.125

07 0.0 1:0 18.5 Flat 250 25 - - 7.434 7.125

08 0.0 1:0 18.5 Angle 235 10 90 15 7.434 7.125

09 0.0 1:0 18.5 Tee 235 10 90 15 7.434 7.125

10 0.0 1:1 15 Flat 250 25 - - 9.168 7.125

11 0.0 1:1 15 Angle 235 10 90 15 9.168 7.125

12 0.0 1:7 15 Tee 235 10 90 15 9.168 7.125
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13 0.1 1:0 15 Flat 250 25 - - 9.168 7.125

14 0.1 1:0 15 Angle 235 10 90 15 9.168 7.125

15 0.1 1:0 15 Tee 235 10 90 15 9.168 7.125

* sx and sy are longitudinal and transverse compression. There are no residual stress

Ultimate limit strength using ALPS/ULSAP

Case
ALPS/ULSAP FEA (ANSYS) ULSAP/FEA

sxu/sYeq syu/sYeq Mode sxu/sYeq syu/sYeq sxu/sYeq syu/sYeq

01 0.642 0.000 III 0.640 0.000 1.003 -

02 0.625 0.000 V 0.594 0.000 1.052 -

03 0.624 0.000 V 0.585 0.000 1.067 -

04 0.734 0.000 IV 0.794 0.000 0.924 -

05 0.684 0.000 V 0.702 0.000 0.974 -

06 0.673 0.000 V 0.655 0.000 1.027 -

07 0.616 0.000 III 0.647 0.000 0.952 -

08 0.651 0.000 III 0.640 0.000 1.017 -

09 0.651 0.000 III 0.605 0.000 1.076 -

10 0.250 0.250 III 0.224 0.224 1.116 1.116

11 0.253 0.253 III 0.217 0.217 1.164 1.164

12 0.253 0.253 III 0.215 0.215 1.174 1.174

13 0.268 0.000 III - - - -

14 0.332 0.000 III - - - -

15 0.332 0.000 III
0.436*

0.371**
-

0.762*

0.894**
-

* is plate sided pressure, ** is stiffener sided pressure.
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18 Frequently Asked Questions

This section covers some problems that are frequently encountered by users of MAESTRO.
The questions are organized by category and where necessary, links are provided to
relevant sections of the help file.

18.1 General Questions

· What are the recommended graphics card settings?

The recommend settings in the View Options dialog are:

Rendering Options: Hardware Z-buffer

Video Driver: OpenGL Driver

Driver Options: Double Buffering

· If the MAESTRO auto-recovery functionality fails, can I still try to recover my model?

Open the location where the original model was saved.  You will see a filename.mdl and
filename.bck.  The filename.bck file can be opened directly by MAESTRO; this is your
recovered modeler file.

· How can I download the latest version of MAESTRO?

The latest version of MAESTRO and the security driver can be downloaded from http://www.
maestromarine.com/download.php. Note, you must have a valid maintenance and support
expiration date to run the newest release of MAESTRO.

· Where can I find additional support for MAESTRO?

In addition to contacting technical support at support@maestromarine.com, you may visit
the MAESTRO forum at MAESTRO Forum to add and review posts from MAESTRO users
and technical support personnel.

· Why aren't MAESTRO folders removed from Start > All Programs when MAESTRO is
uninstalled?

This is due to the autosave files that are added to the directory.  These folders and menu
items can be manually deleted after the uninstall process. 

http://www.maestromarine.com/download.php
http://www.maestromarine.com/download.php
mailto:support@maestromarine.com
http://www.maestromarine.com/forum/
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18.2 Pre-Processing

· How do the stiffeners in a stiffener layout differ from a beam element?

Stiffeners are defined as beam elements, but they are not actual finite elements in a coarse
mesh model.  Instead, they are treated as additional stiffness in the defined direction for the
panel element they are defined on, thus converting the material to orthotropic.  In a coarse
mesh model, all stiffeners are treated as "internal" regardless of their defined location.  The
number of stiffeners, whether defined as internal or edge, is the key to how the mechanical
properties of the panel element are changed.  However, the location is relevant when
creating a fine mesh model from the coarse mesh model.  At this point, an actual beam
element will be created representing the properties of the stiffener at the defined location

· When two end points coincide at the reference or opposite end, is there a difference
between using a strake triangle or an additional triangle element?

No, in the case of a strake element with coinciding reference of opposite end points, the
triangular element is degenerated to a simple triangle.

       `               

· Do I need to define the "second strake" for girders when running the sparse solver?

No.  The second strake is used to identify the girder's effective breadth for the hybrid beam
formulation in the scalable solver.
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· How is the additional stiffness treated when a quad or strake has a stiffener layout?

The axial and bending stiffness of the stiffener(s) defined on that plate element are
"smeared" into the panel's property.  If an edge stiffener is defined, MAESTRO adds the
axial and bending stiffness of the whole stiffener to the panel on which the stiffener is
defined.

· Can I sort the plate and beam properties in the strake definition dialog or the
additional elements dialogs?

Yes, element properties can be sorted in the properties dialog by name, thickness, etc.

· How is a model balanced in MAESTRO?  How does this compare to Orca3D, for
example?

MAESTRO is a force based balance.  The equivalent forces are calculated for each panel
element.  Orca3D, however uses a volume/buoyancy based balance.

· Can I hide particular substructures and modules?

Using a right-mouse-click on a particular Part (via the Parts Tree), the user has the ability to
make particular parts visible or invisible.  This works well when you are turning the visibility
of a few parts off, but is a little inconvenient when turning many parts off.  When you are
interested in turning the visibility off/on of many parts (substructures or modules), use the
Visibility List command, which allows you to toggle the visibility on/off of Parts quickly.

1. Right-click on any part in the Parts Tree

2. Choose Visibility List, which opens a separate Parts Tree list

3. Left-click on a part to toggle the visibility on or off.

This is especially useful when the model becomes sufficiently large and many parts exist.

· How do I model an I-beam element?

MAESTRO can create an equivalent I-beam element by adding a second flange to an
existing T-beam element.  This second flange is defined in the Beams tab of the Finite
Elements dialog, the Beam tab of the Compounds dialog, or a "second flange" strake can be
created.  The second flange is defined by a width and thickness.  Please see the Second
Flange section under Verification and Validation for further demonstration of this.

· How do I reset zCF?
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1.  Navigate to the balance tab in the load dialog

2.  Click "Specify" under the Center of Flotation section.

3.  In the Define Floating Center dialog, select "Do not Change Wave Emergence".

4.  Change the CF Structure Coord and Click OK.

5.  On the balance tab, set Center of Floatioan back to "Default" and click Modify.

· Can I modify the property of more than one element at a time?

Yes.  You can create a general group of all the elements desired and modify the entire
group's element's properties at once.  For example, if you would like to change the hull
thickness you can create a general group of all the hull plate elements.  Right-click on the
group in the groups tree and select Modify.  In the Properties dialog that opens, select a new
plate property from the drop-down list to change all plate elements to this property.

18.3 Post-Processing

· With respect to stiffener tripping calculations, are the stiffeners defined in the
stiffener layouts taken to be normal to the strake?

Yes, MAESTRO's stiffeners are normal to the plate.

· How does Yield Stress (as defined in the Materials dialog) affect the analysis?

Yield stress only affects the analysis when using the limit state analysis.

· What is the "Master Elements" option used for in the View Options dialog?

Master elements are the parent elements of fine mesh elements.  This can be used when a
user wants to view the fine mesh results in the context of the global model by clicking View >
All Modules.  Turning "off" Master Elements allows the fine mesh elements to be more
clearly seen.

· When performing a natural frequency analysis, how do you view the participation
factors and what do they indicate?

A summary of the analysis can be seen in the output tab at the bottom of the screen.  "ACU-
%" is the accumulated modal participation factor.  Modal effective mass and participation
factor are relative measurement to the total vibration.  For example, if the "ACU-%" is 99% in
the first five modes, it implies the first five modes are dominant modes, and the rest of the
modes can often be ignored.  Modal effective mass and participation factors are often used
in constraint vibration such as Dynamic Design Analysis Method (DDAM).

· How do I eliminate local distortion of boundary modules when applying end
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moments?

End moments applied in MAESTRO  are simply a combination of end nodal forces that
collectively sum to the user defined moments.  Unless additional local structure, for example
a transverse bulkhead, is applied, we would expect to see local deformation.

· How do I copy the data from the MAESTRO grid into a program such as Microsoft
Excel?

1.  Right-click inside the grid and select "Change to Fixed Rows."

2.  Change fixed row number from 1 to 0.

3.  Highlight the desired data and right-click and select Copy.

4.  Paste the data into the desired program.

18.4 Licensing and Security Device

· How do I reprogram my hardware lock with new passwords?

To reprogram a lock, please execute the following steps:

· Remove all other hardware locks from your computer.  The MAESTRO hardware
lock should be the only device attached to your computer for this operation.  

· Run the MAESTRO Fast Lock program from your MAESTRO program group.  

· Select:  Edit/Set Passwords. 

· Enter the new passwords and click OK

· The new support date should be shown 

· How do I transfer my license to another computer?

MAESTRO licenses can be easily transferred between computers with the USB security
device.  Before plugging the security device into the new computer, verify that MAESTRO
has been installed.  After this, the security device can be plugged into the new computer and
MAESTRO can be launched.  Security drivers and network servers are integrated into the
MAESTRO installation process.  Therefore, if MAESTRO version 9.0 or newer is installed,
licenses can be moved between computers by simply moving the security device. 

· How do I renew my maintenance and support contract or add modules to my
license?

To renew your maintenance and support contract, or to add additional modules to your
license, please send an email to support@maestromarine.com with your contact
information, license number and request for update or addition and you will receive a quote
for these services.

mailto:support@maestromarine.com
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· I have installed MAESTRO 9.0 or newer; why doesn't my Sentinel System Driver and
Protection Server show in the Add/Remove Programs dialog box?

The Sentinel Driver and Protection Server are now part of the MAESTRO installation and
therefore it is no longer a separate product.  

· Where can I get more information for troubleshooting issues with a Network lock?

Please see the ReadMe.pdf file located in the MAESTRO installation directory under System
> Sentinel for more information regarding MAESTRO network locks.
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19 Appendices

Enter topic text here.
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19.2 B: Data Prep Manual

For the legacy Data Preparation Manual, click here.

19.3 C: IDF Specification

INTERNATIONAL MARINE SOFTWARE ASSOCIATES

INTERFACE DEFINITION FILE (.IDF)

REVISION 3.03

5 May, 1997

The IMSA IDF is intended to be a neutral file format for exchange of hull description data
between marine programs, without the generality or complexity of standards such as IGES
and DXF, and without the specific traits of a particular program's native format.

The file is designed to be easily human-readable. Compactness is sometimes sacrificed for
this goal.

3.01 NOTES

1. Revision 3.01 includes a new sectional AREA entity, at the request of the US Navy and
other users.

2. All data tags (items preceded with $) must exist in the header, in the order and format
given.

3. Following the $UNITS data tag must be a line that reads either SI or User Defined.

4. The HYDRO entity has been reduced to a subset of the ITTC computer symbols, called the
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Interim Standard Transfer Set (ISTS). The list of supported terms is included in the
description of the HYDRO entity. At their own risk, programs may output other ITTC values;
however these are not strictly supported, and may or may not be read by other programs.

5. It is suggested that IDF interfaces be tested by trading files with other programmers who
have IDF interfaces. Please contact the IMSA Technical coordinator above to arrange this.

3.02 NOTES

1. The General Form showed $COORDINATE SYSTEM preceeding $COMMENTS, while
the specific entity defintions had these reversed. The specific entity definitions have been
revised to be the same as the General Form.

3.03 NOTES

1. Added the PROPSECTS entity, for describing propeller geometry.

GENERAL FORM

$IDF

3.01 (or greater)

$ENTITY

entity type

$VESSEL NAME

identifier for this vessel

$DATA SOURCE

name of program that wrote the file

$DATE

date

$TIME

time

$UNITS

units

$COORDINATE SYSTEM
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coordinates of a point one unit forward,starboard,down ("coordinate gnomon")

e.g. for FAST SHIP 1,1,1

$COMMENTS

comments

comments

$GEOMETRY

(data format specific to geometry type from here down)

$END ENTITY

Current Entity Types:

Entity Type Description

SECTIONS Sectional Data (Stations, Buttocks, Wls, 3d curves)

MESH Surface Mesh data

NURBS NURBS Surface data

HYDRO Hull Parameter data

AREA Sectional Area Data

PROPSECTS Propeller Geometry Data

General Comments

This standard contains only one interface file. This file can contain one or more entities,
where each entity is a specific data type (e.g. hull sectional data, NURBS surface data, etc.).
This avoids having many different files, and allows new entities to be added as necessary. It
also means that one file can contain different types of data for a single ship (sectional data,
surface data, etc.), thus avoiding many files describing the same ship.

The file will be a simple ASCII file, so that it will be transportable across different hardware
platforms, as well as being easily human-readable. While this does not result in the most
compact format, it does result in a format that is easy to produce, read, add to, and modify.

Data for each line item are to be separated by commas. Comments may be added on any line
following an exclamation mark (!). End of line sequence is to be appropriate to the operating
system. Text strings may be up to 79 characters long, and are limited to ASCII characters 1
through 127.
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Units

Units must be specified as either: SI or User Defined. If User Defined, then the following
lines must be given:

# of user units/meter

# of user units/square meter

# of user units/cubic meter

# of user units/kg

Some entities may not require all of the conversion factors, and the entity's definition will
specify which should be included.

Coordinate System

Since different programs use different coordinate systems (e.g. some have positive X aft,
some have positive X forward, some use Z for the longitudinal coordinate, etc.), the
coordinates of a fixed point in space is required. This point is one unit forward of the origin,
one unit to starboard, and one unit down from the origin. Then, as data is read in from the file,
by multiplying the data by the given vector and by your own vector, the sign will be correct.
All data in the formats is given in the order longitudinal, athwartships, and height. Not all
entities will have a coordinate system associated with them. If not, the entity definition will
leave this section out.

Data Tags

Data tags (e.g. $ENTITY), while not absolutely required in a fixed format file, make the file
easily human-readable, and can simplify the computer-reading process. Import programs that
are searching for a particular ENTITY type, can search the file for the string "$ENTITY", and
then read the next line to see if the type is correct, and go on from there.

Data tags (items preceeded with $) must have the $ in column 1, i.e. no white space is allowed
before a data tag. Leading white space (tabs, spaces) is allowed on lines containing data.
Blank lines are allowed between data and the next data tag.

Any data that is shown in the entity definitions is required; if not known, dummy data should
be substituted.

Where entities allow for more than one body or surface, it is subdivided into parts (each part
may represent a body or surface, or a group of bodies).

Entity #1: Sectional Data (SECTIONS)

Note: Indenting is for clarity only; not used in actual data file.
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$IDF

3.01 (or greater)

$ENTITY

SECTIONS

$VESSEL NAME

Identifier for this vessel

$DATA SOURCE

program that wrote the file

$DATE

mm/dd/yy

$TIME

hh:mm:ss

$UNITS

This line must be either SI or User Defined

If User Defined, then the following line(s) must be specified:

# of user units/meter

$COORDINATE SYSTEM

coordinates of a point one unit forward,starboard,down ("coordinate gnomon")

e.g. for FAST SHIP 1,1,1

$COMMENTS

This is a comment about the ship about to be described. Can be any # of 79 character lines.

$GEOMETRY

n (number of parts or bodies)

part 1
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.

.

part n

where each part format is:

$PART

part name

m (number of curves)

curve 1

.

. 

curve m

where each curve format is:

$CURVE

curve name

Curve type (station, buttock, waterline, cant, incline,diagonal) diagonal, general plane,
three-d)

j=integer number of points on curve

point 1

.

. 

point j

where points are coordinate triplets (long'l, trans ,vert), breakpoint indicator (unknown, fair,
knuckle)

for example: 10.15, 3.25, 1.50, fair 

$END ENTITY
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Entity #2: Surface Mesh Data (MESH)

Note: Indenting is used for clarity only; does not exist in actual file

$IDF

3.01 (or greater)

$ENTITY

MESH

$VESSEL NAME

Identifier for this vessel

$DATA SOURCE

program that wrote the file

$DATE

mm/dd/yy

$TIME

hh:mm:ss

$UNITS

This line must be either SI or User Defined

If User Defined, then the following line(s) must be specified:

# of user units/meter

$COORDINATE SYSTEM

coordinates of a point one unit forward,starboard,down ("coordinate gnomon")

e.g. for FAST SHIP 1,1,1

$COMMENTS

This is a comment about the ship about to be described. Can be any # of 79 character lines.
$COORDINATE

$GEOMETRY
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n (number of parts or surfaces)

part 1

.

.

part n

where each part is

$PART

part name

#rows,#columns in surface mesh

long'l,trans,vert coords of mesh points: B(row,col) where col varies fastest

.

.

long'l,trans,vert coords

$END ENTITY

Entity #3: NURBS Surface Data (NURBS)

Note: Indenting is used for clarity only; not used in actual file.

$IDF

3.01 (or greater)

$ENTITY

NURBS

$VESSEL NAME

Identifier for this vessel

$DATA SOURCE

program that wrote the file
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$DATE

mm/dd/yy

$TIME

hh:mm:ss

$UNITS

This line must be either SI or User Defined

If User Defined, then the following line(s) must be specified:

# of user units/meter

$COORDINATE SYSTEM

coordinates of a point one unit forward,starboard,down ("coordinate gnomon")

e.g. for FAST SHIP 1,1,1

$COMMENTS

This is a comment about the ship about to be described. Can be any # of 79 character lines.

$GEOMETRY

n (number of parts or surfaces)

part 1

.

.

part n

where each part is

$PART

part name

nonrational or rational

basis function in u,w directions (e.g. open or periodic)
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order in u,w directions (integers)

i,j (#rows,#columns in defining polygon net, integers)

knot vector in u direction (floating point)

knot vector in v direction (floating point)

long'l, trans, vert coords, weight of net points: B(i,j) where j varies fastest

.

.

long'l, trans, vert coords, weight (floating point)

$END ENTITY

Entity #4: Hull Parameter Data (HYDRO)

Note: Indenting is used for clarity only; not used in actual file.

$IDF

3.01 (or greater)

$ENTITY

HYDRO

$VESSEL NAME

Identifier for this vessel

$DATA SOURCE

program that wrote the file

$DATE

mm/dd/yy

$TIME

hh:mm:ss

$UNITS
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This line must be either SI or User Defined

If User Defined, then the following line(s) must be specified:

# of user units/meter

# of user units/square meter

# of user units/cubic meter

# of user units/kg

$COORDINATE SYSTEM

coordinates of a point one unit forward,starboard,down ("coordinate gnomon")

e.g. for FAST SHIP 1,1,1

$COMMENTS

This is a comment about the ship about to be described. Can be any # of 79 character lines.

$GEOMETRY

n (number of parts or surfaces)

part 1

.

.

part n

where each part is

$PART

part name

entry 1

.

.

entry n
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$END ENTITY

Each entry is an ITTC computer symbol from the Interim Standard Transfer Set (ISTS), a
subset of the ITTC list of Standard Symbols and Terminology entered in the following form:

computer symbol=value

For example, the ITTC computer symbol for length of waterline is LWL. For a ship with a
waterline length of 451.5, the data would be entered in the file as:

LWL=451.5

As many entries as desired may be made in this form using the ITTC ISTS standard computer
symbols.

NOTES ON THE IDF HYDRO ENTITY

The 'HYDRO' entity of the IDF file is used to pass parametric information about hull
geometry between programs. This information - length on waterline, displacement volume
and trim, for example - is representative of a single vessel load condition.

The symbols are derived from ITTC computer symbols and terminology. In January 1993, the
ITTC Symbols and Terminology Group identified the need for an Interim Standard Transfer
Set (ISTS) as a subset to their comprehensive database-oriented collection of computer
symbols. Dr. Bruce Johnson, Chairman, has asked IMSA to prepare and define the ISTS. The
symbols used in the IDF HYDRO entity will form the ISTS.

To eliminate redundancy and potential confusion, the ISTS philosophy will be to use only
those symbols based on geometric items (displaced volume, for example), rather than
parameters (such as Cb). Also, a number of geometric and conversion references are defined.

Abbreviations used in this document:

FP - forward perpendicular.

Reference datum for the forward point of the length between perpendiculars (LPP).

AP - after perpendiculars.

Reference datum for the aft point of the length between perpendiculars (LPP).

MIDP - midship.

Located midway between FP and AP.

References:

International nautical mile = 6076.1155 feet, 1852.00 meters.
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Gravitational constant, G = 32.1740 feet/sec^2, 9.80665 meters/sec^2.

Supported Symbols and Definitions:

ABT - total area of transverse cross-section of a bulbous bow. Full (port and starboard) cross
sectional area at the FP.

AM - midship section area.

Immersed transverse sectional area located at MIDP.

APB - planing bottom area.

Horizontally projected planing bottom area (at rest), excluding area of external spray strips.
(Area outlined by the chine as projected onto a horizontal plane.)

ATR - total area of immersed transom.

Full (port and starboard) cross-sectional area of a transom stern below the waterline.

AVL - longitudinal area exposed to wind.

Area of portion of ship above waterline projected onto a longitudinal plane (as viewed from
the side).

AVT - transverse area exposed to wind.

Area of portion of ship above waterline projected onto a transverse plane (as viewed from
ahead).

AW - area of the waterplane.

Area enclosed by the outline of the waterplane.

AX - maximum transverse section area.

Maximum immersed transverse sectional area.

BETD - principal deadrise angle of planing bottom.

Angle of the tangent slope of the planing bottom. (For a temporary solution, the tangent slope
of the planing bottom at a point BPX/4 off the centerline, located at the mid-point of LPRC, is
recommended.)

BETTR - deadrise angle of planing bottom at transom. Angle of the tangent slope of the
planing bottom at the transom. (For a temporary solution, the tangent slope of the planing
bottom at a point BTR/4 off the centerline, located at the aft-most point of LPRC, is
recommended.)
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BM - midship breadth on waterline.

Molded breadth on the waterline located at MIDP.

BPX - maximum breadth over chines.

Maximum breadth of the outside of the chine (excluding external spray strips).

BTR - breadth of the chine at the transom.

Breadth of the outside of the chine (excluding external spray strips) at the transom (aftmost
point of LPRC).

BX - maximum breadth on waterline.

Maximum breadth of the waterplane.

DISV - displacement volume.

Immersed volume of the hull, neglecting appendages. (Large added volumes such as skegs
may have a contribution to hull volume and there should be data agreement between SWH
and DISV.)

ENTA - half angle of entrance.

Angle of waterline at the bow with reference to centerplane, neglecting local shape at stem.
(For a temporary solution, the tangent slope of the waterplane at a point BX/10 off the
centerline is recommended.)

LOS - overall submerged length.

Entire length of the submerged portion of the vessel, including items such as bulbs that extend
beyond the limits of LWL.

LPP - length between perpendiculars.

Reference length that defines the distance between FP and AP.

LPRC - projected chine length.

Overall longitudinal length of chine projected onto a horizontal plane. (Longitudinal limit of
APB.)

LWL - length of waterline.

Overall longitudinal length of the waterplane.

RHOW - mass density of water.
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Standard ITTC values at 15 deg C, 59 deg F are:

Fresh: 1.9384 lb-sec^2/ft^4, 101.87 kg-sec^2/m^4

(specific gravity of 0.9990)

Salt: 1.9905 lb-sec^2/ft^4, 104.61 kg-sec^2/m^4

(specific gravity of 1.0259, 3.5% salinity)

Note: specific gravity uses international convention of distilled

water at 3.98 deg C (1.9403 lb-sec^2/ft^4, 101.97 kg-sec^2/m4).

SWH - wetted surface of the hull.

Entire immersed surface of the hull, neglecting appendages. (Large added volumes such as
skegs may have a contribution to hull wetted surface and there should be data agreement
between SWH and DISV.)

TM - draft at midship.

Molded hull draft on centerline, located at MIDP. Value reflects the principal hull volume and
should not be confused with a keel draft that includes the effect of appendages or skegs.

TR - trim.

Vessel trim by the stern. Equals the draft at AP less the draft at FP.

XFB - longitudinal center of buoyancy from FP.

Longitudinal distance of the center of buoyancy aft of the FP.

XFG - Longitudinal center of gravity from FP.

Longitudinal distance of the center of gravity aft of the FP.

XLWL - location of length on waterline

Distance of the forward-most point of LWL aft of FP. (Registers location of LWL with
respect to FP.)

XLPRC - location of projected chine length.

Distance of the forward-most point of LPRC aft of FP. (Registers location of LPRC with
respect to FP.)

Entity #5: Sectional Area Data (AREA)
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Note: Indenting is used for clarity only; not used in actual file.

$IDF

3.01 (or greater)

$ENTITY

AREA

$VESSEL NAME

Identifier for this vessel

$DATA SOURCE

program that wrote the file

$DATE

mm/dd/yy

$TIME

hh:mm:ss

$UNITS

This line must be either SI or User Defined

If User Defined, then the following line(s) must be specified:

# of user units/meter

# of user units/square meter

$COORDINATE SYSTEM

coordinates of a point one unit forward,starboard,down ("coordinate gnomon")

e.g. for FAST SHIP 1,1,1

$COMMENTS

This is a comment about the ship about to be described. Can be any # of 79 character lines.

$GEOMETRY
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n (number of parts or surfaces)

part 1

.

.

part n

where each part is

$PART

part name

nsta

x1, a1

x2, a2

.

.

xnsta, ansta

where nsta is the number of stations cutting the part, xi is the ith station's longitudinal
coordinate, and ai is it's immersed area.

$END ENTITY

Entity #6: Propeller Sectional Data (PROPSECTS)

Note: Indenting is for clarity only; not used in actual data file.

$IDF

3.03 (or greater)

$ENTITY

PROPSECTS

$VESSEL NAME

Identifier for this vessel (or job)
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$DATA SOURCE

Program that wrote the file

$DATE

mm/dd/yy

$TIME

hh:mm:ss

$UNITS

This line must be either SI (meters) or User Defined

If User Defined, then the following line(s) must be specified:

# of user units/meter

$COMMENTS

This is a comment about the propeller about to be described. Can be any # of 79 character
lines.

$GEOMETRY

rotation = Right or Left hand

number of blades , expanded blade area ratio , propeller diameter [dim], nominal pitch [dim],
hub diameter [dim]

blade thickness ratio (may be zero), rake at tip (positive downstream) [dim]

n = number of sections

type = XY Offsets or Camber Thickness

section 1

.

section n

where each expanded section format is:

$SECTION
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section name (e.g., 0.7R), radial position [dim], chord length [dim], maximum thickness
[dim], location of max.

thickness from leading edge [dim]

local pitch [dim], distance of generator line to mid-chord (positive in the direction of the
leading edge) [dim], rake

(positive downstream) [dim]

maximum camber [dim], location of max. camber from leading edge [dim]

j = number of radial sections

point 1 where points are ordered triplets of

. XY: chord position, ordinate suction side, ordinate press side [dim], or

. CT: chord position, ordinate of camber, thickness (normal to camber line) [dim]

point j

$END ENTITY

Comments

These files may contain any number of these entities. However, when writing to files, entities
are typically appended to existing files. Therefore, only the last found entity is typically used
when reading entities from files.

Example of PROPSECTS entity in units of meters (SI):

$IDF

3.03

$ENTITY

PROPSECTS

$VESSEL NAME

Sample propeller

$DATA SOURCE

PropCad 2.00
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$DATE

03/25/97

$TIME

08:22:46

$UNITS

SI

$COMMENTS

Example of the PROPSECTS entity.

$GEOMETRY

Right

4, 0.65, 1.0, 0.9, 0.18

0.0702704, 0

10

XY Offsets

$SECTION

0.2R, 0.1, 0.253418, 0.0406, 0.0794288

0.72, 0.233917, 0.0140541

0.0203, 0.0794288

15

0.0, 0.0142046, 0.0142046

0.00633546, 0.0219650, 0.00923921

0.0126709, 0.0256052, 0.00684665

...

0.228076, 0.0102679, 0.0



Appendices 741

© 2014 Optimum Structural Design, Inc.

0.240747, 0.00608771, 0.0

0.253418, 0.00182631, 0.0

$SECTION

0.3R

...

0.4R

...

...

$END ENTITY
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20 License & Copyright

Information included herein is categorized as ECCN 8D992 under the Export Administration
Regulations  (15  CFR  §  730-774)  issued  by  the  U.S.  Department  of  Commerce.  An  export
license  issued by the U.S.  Department  of  Commerce or  an EAR exception  may be  required
prior to export or transfer of this information to certain parties or end uses.  Public release of
this document is not authorized. Diversion contrary to U.S. law is prohibited.

MAESTRO Software License Agreement

NOTICE:  PLEASE READ THIS LICENSE AGREEMENT CAREFULLY BEFORE
INSTALLING OR USING THE SOFTWARE. BY INSTALLING OR USING THE
SOFTWARE, YOU ARE AGREEING TO BE BOUND BY THE TERMS AND
CONDITIONS OF THIS LICENSE AGREEMENT. IF YOU DO NOT AGREE WITH
THESE TERMS AND CONDITIONS, PROMPTLY RETURN THE UNUSED
SOFTWARE.

1. RESTRICTED LICENSE.  This License Agreement grants you (whether an entity or
a person, hereinafter referred to as the “Customer”) the non-exclusive,
non-transferable, perpetual right to use MAESTRO (hereinafter referred to as the
“SOFTWARE”) for the stipulated License Fee.   

2. LICENSE RESTRICTIONS.  The SOFTWARE, along with all security features,
shall be used only as stated herein.  Customer may not transfer or assign to another
party or location the rights under this License Agreement, the SOFTWARE, or any
accompanying Documentation without Licensor’s prior written consent.  This
license includes the right to use one copy of the SOFTWARE on any single
computer, provided the SOFTWARE is only used on one computer at a time.  The
SOFTWARE is “in use” on a computer when it is loaded into temporary memory
(RAM) or installed into the permanent memory of a computer (e.g., a hard disk,
CD-ROM, or other storage device). Customer may not use the SOFTWARE for
commercial time-sharing or rental use. Customer may make one (1) copy of the
SOFTWARE solely for backup, archival or disaster recovery purposes. Customer
may not modify, decompile, disassemble, reverse engineer, reverse translate or
prepare derivative works of the SOFTWARE in whole or in part at any time for any
reason.

3. COPYRIGHT.  The SOFTWARE is owned by Optimum Structural Design, Inc.
(hereinafter referred to as “Licensor”) and is protected by U.S. copyright laws and
international treaty provisions.  This License Agreement does not transfer any
ownership in the SOFTWARE, Documentation, trademarks or other Licensor
proprietary property rights.

4. WARRANTY.  Licensor warrants that it is the owner of the SOFTWARE and
Documentation and that the SOFTWARE and Documentation do not infringe any
U.S. patent, copyright or trade secret rights of any third party.  Licensor further
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warrants for a period of thirty (30) calendar days from the date of shipment that (i)
the media on which a copy of the SOFTWARE is provided to Customer will be free
from defects in material and workmanship under normal use, and (ii) the
SOFTWARE will perform substantially in accordance with the Documentation.  

5. CUSTOMER REMEDIES.  Licensor’s entire liability for breach of warranty and the
Customer’s exclusive remedy for breach of warranty shall be, at Licensor’s option
and expense, either (a) repair or replacement of the SOFTWARE or media that does
not meet the warranty or (b) return of the price paid.  This warranty is void if failure
of the SOFTWARE has resulted from accident, abuse or misapplication from any
party other than Licensor.  EXCEPT AS EXPRESSLY STATED IN ARTICLE 4,
LICENSOR DISCLAIMS ALL OTHER WARRANTIES, WHETHER
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE.    NO AGENT, DEALER OR DISTRIBUTOR IS
AUTHORIZED TO MODIFY OR REVISE THIS WARRANTY.

6. LIMITATION OF LIABILITY.  IN NO EVENT SHALL LICENSOR BE
LIABLE FOR ANY INDIRECT, INCIDENTAL, SPECIAL, PUNITIVE OR
CONSEQUENTIAL DAMAGES, DAMAGES FOR LOSS OF BUSINESS
PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS
INFORMATION, LOSS OF DATA, OR LOSS OF GOODWILL ARISING
OUT OF THE USE OF OR INABILITY TO USE THE SOFTWARE.
NOTWITHSTANDING ANYTHING HEREIN TO THE CONTRARY,
LICENSOR’S TOTAL LIABILITY TO CUSTOMER AND ANY THIRD
PARTIES SHALL NOT EXCEED THE AMOUNTS PAID BY CUSTOMER
FOR THE LICENSED SOFTWARE HEREUNDER.

7. INDEMNITY. In the event that a claim is brought against Customer alleging that the
SOFTWARE or Documentation infringes a U.S. patent, copyright or trade secret,
Licensor agrees to defend such claim and to indemnify and hold Customer harmless
for any damages or costs awarded against Customer.  Customer shall give Licensor
prompt written notice of any such claim, shall allow Licensor to control the defense
and settlement of such claim, and shall reasonably cooperate with Licensor in the
defense and settlement thereof. If an injunction or order is obtained against
Customer’s use of the SOFTWARE, or if, in Licensor’s reasonable opinion, the
SOFTWARE is likely to become the subject of a claim of infringement or violation
of a U. S. patent, copyright, or trade secret, then Licensor will, at its option and
expense: (i) procure for Customer the right to continue using the SOFTWARE; (ii)
replace or modify the SOFTWARE so that it becomes noninfringing; or (iii) return
the unamortized cost of the SOFTWARE to Customer based on a thirty-six (36)
month pro rata schedule.

8. TECHNICAL SUPPORT/SOFTWARE MAINTENANCE.  User Support and
Upgrades are available through the MAESTRO Maintenance and Support
Agreement, which can be purchased from Licensor or one of its designated
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Support/Sales Dealers in accordance with the terms and conditions provided.

9. TERMINATION OF LICENSE.  This License Agreement may only be terminated
by Licensor upon providing at least ten (10) calendar days prior written notice to
Customer of any violation or default of the terms of this License Agreement by
Customer.  Customer shall be allowed to remedy any such violation or default
within the 10-day period to Licensor’s reasonable satisfaction. Upon termination for
Customer’s default, all copies of the SOFTWARE and Documentation shall be
immediately returned to Licensor or destroyed.  If Customer destroys all
SOFTWARE and Documentation, it will notify Licensor in writing that such
destruction has taken place and that the SOFTWARE will not be used or reactivated
by Customer in the future.  Customer may terminate this License Agreement at any
time by returning all SOFTWARE and Documentation to Licensor or destroying all
SOFTWARE and Documentation and notifying Licensor as above. Any termination
under this provision (whether by Licensor or Customer) shall be without rebate or
any reduction in the amount owed or paid. Any cause of action or claim accrued or
to accrue because of any breach or default shall survive termination of this License
Agreement.  Articles 2, 3, 4, 5, 6, 7, 12, 14, 15, and 16 shall survive any expiration
or termination of this License Agreement.

10. TAXES.  Any prices and fees for SOFTWARE or services exclude any applicable
sales, use, excise, value added or other taxes or assessments which are or may
hereinafter be levied or imposed by any federal, state, local or other public taxing
authority, howsoever designated. Any such taxes or assessments (except for
Licensor income taxes) levied or imposed as a result of this License Agreement shall
be the Customer’s obligation solely, and the Customer shall be responsible for all
such payments.

11. FORCE MAJEURE.  Except for any payment obligations, neither party shall be in
default for any delay or failure to perform hereunder due to causes beyond its
reasonable control and without its fault or negligence.

12. GOVERNING LAW/ARBITRATION.  This License Agreement shall be governed
by and construed under the laws of the State of New York, U.S.A., excluding its
conflict of laws principles. Any dispute, controversy or claim, arising out of or
relating to this License Agreement or a breach thereof, shall be finally resolved by
arbitration. Such arbitration shall be the parties’ exclusive remedy (except for cases
of urgent equitable relief). The arbitration shall be in accordance with the rules of
the American Arbitration Association (AAA) then in effect on the date of this
Agreement by one arbitrator appointed in accordance with such rules.  In the event
of any conflict between the rules and this clause, the provisions of this clause shall
govern.  Unless the parties otherwise mutually agree in writing, the place of
arbitration shall be New York, New York, U.S.A.  The arbitration shall be
conducted in the English language. The parties shall pay their own arbitration
expenses and shall equally share the arbitrator’s costs and fees and the arbitrator
shall allocate such costs equally between the parties as part of the award.
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13. LIMITED LICENSE FOR TRIAL RELEASE.  Licensor hereby grants Customer a
limited, non-exclusive, non-transferable right to use the SOFTWARE at no-charge
for the limited purpose of evaluating whether to purchase the SOFTWARE.  This
trial release license contains the following requirements/restrictions: The
SOFTWARE will run for fifteen (15) calendar days after installation.  Upon the
expiration of this 15-day period, the Customer shall either (i) purchase an ongoing
license by paying the stipulated License Fee, which shall be subject to the terms and
conditions of this License Agreement, or (ii) promptly remove or uninstall the
SOFTWARE and return it to Licensor, or, at the Licensor’s option, destroy the
SOFTWARE and certify to such destruction.

14. EXPORT COMPLIANCE.  The SOFTWARE is subject to the United States Export
Regulations, as administered by the Department of Commerce, Bureau of Industry
Security. The SOFTWARE may not be used in or exported/re-exported to Cuba,
Libya, North Korea, Sudan, Syria, or any country to which the United States
embargoes goods. The same restriction applies to persons, no matter where they are
located, that appear on the Table of Denial Orders, the Entity List, or the List of
Specially Designated Nationals.

15.  NOTICE TO U.S. GOVERNMENT END USERS. The SOFTWARE and
Documentation are "commercial items," as that term is defined at 48 C.F.R. Part
2.101, consisting of "Commercial Computer Software" and "Computer Software
Documentation," as such terms are defined in 48 C.F.R. Part 252.227-7014(a)(1) and
48 C.F.R. Part 252.227-7014(a)(5), and used in 48 C.F.R. Part 12.212 and 48 C.F.R.
Part 227.7202, as applicable. Consistent with 48 C.F.R. Part 12.212, 48 C.F.R. Part
252.227-7015, 48 C.F.R. Part 227.7202-1 through 227.7202-4, 48 C.F.R. Part
52.227-19, and other relevant sections of the Code of Federal Regulations, as
applicable, the Commercial Computer Software and Computer Software
Documentation are distributed and licensed to U.S. Government end users (a) only
as commercial items and (b) with only those rights as are granted to all other end
users pursuant to the terms and conditions herein. 

16. MISCELLANEOUS. If any portion of this License Agreement shall be held to be
illegal or otherwise void and invalid, the remaining portion of the License
Agreement shall not be affected and it shall remain in full force and effect. This
License Agreement constitutes the exclusive and entire understanding between
Licensor and Customer with respect to the SOFTWARE. This License Agreement
supersedes any prior proposals, bids, quotes, representations, agreements, or any
other understandings, whether oral or written, regarding the SOFTWARE or the
relationship between Licensor and Customer, and may only be modified by a written
agreement executed by authorized representatives of both parties.  Licensor hereby
rejects any additional or inconsistent terms and conditions offered by Customer at
any time and irrespective of Licensor’s commencement of performance or shipment,
or the acceptance of payment, hereunder. Purchase orders or other similar unilateral
documents issued by the Customer shall be for the Customer’s internal use only and
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shall not be binding on Licensor or otherwise affect or amend this License
Agreement whatsoever.

09/24/12
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